4.2. Account Tab Display

Figure 4.2. The Account Tree Display.

Account Tree screen

This is an image of the Accounts tab.

4.2.1. Account Tree - Menus

The Menubar for the Accounts Tree window contains the following options. Account Tree - File Menu

The following table describes the options in the File Menu.

Clicking on the File option of the Menubar will pull down a menu of options described in Table 4.1, “Account Tree - File Menu - Access to file, account operations and printing.”.

Table 4.1. Account Tree - File Menu - Access to file, account operations and printing.

Menu Item


New File (Ctrl+N)

Creates a new data file (starts with new accounts and data.)

Open... (Ctrl+O)

Opens an already existing GnuCash data file.


Opens the Import sub-menu to import files from other financial programs.


Import QIF ...

Starts the QIF file Import process.


Import OFX/QFX ...

Starts the OFX/QFX file Import process.


Import CSV/Fixed-Width ...

Starts the CSV/Fixed-Width file Import process.


Replay GnuCash .log file...

Starts the replaying of a GnuCash log file. Used for data recovery from "crashes".


Import MT940



Import MT942



Import DTAUS



Import DTAUS and send


Save (Ctrl+S)

Saves the currently open file.

Save As... (Shift+Ctrl+S)

Saves the currently opened file with a different name.


Do NOT store your data file in ~/.gnucash/books.

Page Setup... (Shift+Ctrl+P)

Let you choose the paper size, layout and margins for printing.


Opens the Export sub-menu.


Export Accounts

Exports your account hierarchy to a new file. Does not export data.

Properties (Alt+Enter)

Sets options for this GnuCash data file.

Recently opened files

Numbered list of most recently opened GnuCash data files.

Quit (Ctrl+Q)

Exits GnuCash. Account Tree - Edit Menu

Table 4.2. Account Tree - Edit Menu - Access to file and account editing operations and preferences.

Menu Item


Edit Account (Ctrl+E)

Modify name or characteristic of selected account. Section 5.5, “Editing an Account”

Delete Account... (Delete)

Remove an account. See Section 5.7, “Deleting an Account”

Renumber Subaccounts...

Starts the Renumber Account assistant. See Section 5.6, “Renumbering Subaccounts”.


This item is selectable only if you have highlighted an account with at least one subaccount in the accounts tree.

Open Account

Opens the register window for the currently selected account.

Open Subaccount

Opens a register window that displays all the transactions for the selected account and for all its subbaccounts.

Find... (Ctrl+F)

Set criteria for a search for a specific transaction. See Section 7.1, “Find” for specifics on searches.

Preferences (GnuCashPreferences on Mac OS X).

Customize GnuCash for location, style, and numerous other preferences. See Section 9.2, “Setting Preferences”.

Style Sheets

Modify/customize Style Sheets. See Section 9.3, “Changing Style Sheets”.

Tax Report Options

Set tax characteristics on account(s) (US). Assign tax form and line to account. See Section 9.4, “Setting Tax Report Options” Account Tree - View Menu

Table 4.3. Account Tree - View Menu - Changes display window view.

Menu Item



Check-box to enable/disable display of Toolbar.


Check-box to enable/disable display of Summarybar .


Check-box to enable/disable display of Statusbar.

Filter by ...

Set filter for accounts displayed in the Account Tree display.

Refresh (Ctrl+R)

Repaint the display screen.

New Accounts Page

Open a new tab that display the account tree. Account Tree - Actions Menu

Table 4.4. Account Tree - Actions Menu - Setup scheduled transactions, repair accounts, perform stock splits, transfer and reconcile transactions.

Menu Item


Online Actions

This menu item (and sub-menu) is shown only if Online Banking was enabled for GnuCash

Get Balance


Get Transactions

Download transactions from online accounts


Issue Transaction...

Upload transaction(s) to online account ??


Internal Transaction...


Direct Debit...

Scheduled Transactions

Scheduled Transactions sub-menus

Scheduled Transaction Editor

Invoke tool to edit scheduled transactions. See Section 6.13, “Edit Scheduled Transaction Window”


Since Last Run...

Display Scheduled transactions since last running of GnuCash. Section 7.2, “Since Last Run Assistant”


Mortgage & Loan Repayment...

Starts the Mortgage & Loan Repayment assistant for setting up repayments. Section 7.3, “Mortgage & Loan Repayment Assistant”


Budget sub-menus

New Budget

Opens the window to create a new budget.


Open Budget

Opens an existing budget.

New Account...

Creates a new account and opens the account properties window.

New Account Hierarchy...

Starts the New Account Hierarchy Setup assistant.

Transfer... (Ctrl+T)

Starts the Transfer assistant for transfer between accounts.


Open the Reconcile window. Section 5.8, “Reconciling an Account to a Statement”

Stock Split...

Starts the Stock Split assistant. Additional details Section 7.4, “Recording a Stock Split”

View Lots...

Opens the Lots in Account form.

Auto clear...

Opens the auto-clear screen where you can fill up the automatic clear information.

Check & Repair

Check & Repair Submenus


Check & Repair Account

Check for and repair unbalanced transactions and orphan splits in this account.


Check & Repair Subaccounts

Check for and repair unbalanced transactions and orphan splits in this account and its subaccounts.


Check & Repair All

Check for and repair unbalanced transactions and orphan splits in all accounts.

Reset Warnings...

GnuCash gives warnings when certain operations are attempted, such as removing a transaction or removing the splits of a transaction. The warning message gives you the option to not give you these warnings when attempting the operation. Check-boxes labeled Remember and don’t ask me again and Remember and don’t ask me again this session allow disabling the warnings. This option resets the warnings to the default, This option resets the warnings to the default, i.e. display all warnings.


Warnings may be selectivly enabled.

Rename Page

Open the form to rename the current page/tab. Account Tree - Business Menu

Table 4.5. Account Tree - Business Menu - Access small business features of GnuCash.

Menu Item



Select customer related activities.


New Customer...

Start the form to create a new customer.


Find Customer...

Start the assistant to search for a customer.


New Invoice...

Start the form to create a new invoice.


Find Invoice...

Start the assistant to search for a invoice.


New Job...

Start the form to create a new job.


Find Job...

Start the assistant to search for a job.


Process Payment...

Starts the Process Payment assistant. Requires an account of type "A/Payable" before running assistant.


Select vendor related activities.


New Vendor...

Start the form to create a new vendor.


Find Vendor...

Start the assistant to search for a vendor.


New Bill...

Start the form to create a new bill.


Find Bill...

Start the assistant to search for a bill.


New Job...

Start the form to create a new job.


Find Job...

Start the assistant to search for a job.


Process Payment...

Starts the Process Payment assistant. Requires an account of type "A/Payable" before running assistant.


Select employee related activities.


New Employee...

Start the form to create a new employee.


Find Employee...

Start the assistant to search for a employee.


New Expense Voucher...

Start the form to create a new expense voucher.


Find Expense Voucher...

Start the assistant to search for a expense voucher.


Process Payment...

Starts the Process Payment assistant. Requires an account of type "A/Payable" before running assistant.

Sales Tax Table

View and edit the list of tax tables.

Billing Terms Editor

View and edit the list of Billing Terms.

Bills Due Reminder

View and edit the list of Bills Due Reminder. Account Tree - Reports Menu

This is only a brief listing of each of the available reports and graphs. Each report or graph may be customized by selecting a different Stylesheet or by pressing the Options button in the Toolbar.

Table 4.6. Account Tree - Reports Menu - Access GnuCash Reports and Charts.

Menu Item


Assets & Liabilities


Advanced Portfolio


Asset Barchart


Asset Piechart


Average Balance


Balance Sheet


Balance Sheet using eguile-gnc


General Journal


General Ledger


Investment Portfolio


Liability Barchart


Liability Piechart


Net Worth Barchart


Price Scatterplot

Business Reports


Customer Report


Easy Invoice


Employee Report


Fancy Invoice


Job Report


Payable Aging


Printable Invoice


Receivable Aging


Tax Report


Vendor Report

Income & Expense


Cash Flow


Equity Statement


Expense Barchart


Expense Piechart


Expenses vs Day of Week


Income & Expense Chart


Income Barchart


Income Piechart


Income Statement


Income vs Day of Week


Trial Balance


Profit & loss

Sample & Custom


Welcome Sample Report


Custom Multicolumn Report


Sample Report With Examples

Account Summary

Report showing the balance of selected accounts.

Custom Reports

Open the screen to manage the user created reports.

Tax Schedule Report & TXF Export

Create a Tax report (US) and/or export data for tax preparation software. (TXF)

Transaction Report Account Tree - Tools Menu

Table 4.7. Account Tree - Tools Menu - Access to miscellaneous tools and editors

Menu Item


Online Banking Setup ...

Starts the Online banking setup assistant, if GnuCash was built to support on-line banking. Section 7.5, “HBCI (Online Banking) Setup Assistant”

Price Editor

Tool to enter or modify Stock/Fund prices. Details at Section 7.6, “Price Editor”

Security Editor

Tool to enter or modify Stock or commodities. Details at Section 7.7, “Security Editor”

Loan Repayment Calculator

Details at Section 7.8, “Loan Repayment Calculator”

Close Book

Open a screen where you can enter the required information to close the current accounting book.

General Ledger

See Section 6.16, “General Ledger” Account Tree - Windows Menu

Table 4.8. Account Tree - Windows Menu

Menu Item


New Window

Opens a new GnuCash empty window.

New Window with Page

Moves the current tab into a new window. Account Tree - Help Menu

Table 4.9. Account Tree - Help Menu - Access to this help and the Tutorial and Concepts Guide.

Menu Item


Tutorial & Concepts Guide

Explanation of accounting principles and how to apply them in GnuCash

Tips Of The Day

Shows short notes about features you might otherwise miss.


Open this document.


Show the information screen with GnuCash version, license and credits

4.2.2. Account Tree - Toolbar Icons/Buttons

The GnuCash main Window has a number of buttons in the Toolbar to quickly access some common functions used with the specific active tab. The Toolbar can be hidden or shown by selecting ViewToolbar. The specific options displayed in the Toolbar vary with the functions available to the "active tab".

A brief description of the function of a Toolbar button is displayed when the mouse pointer is placed over the icon for a couple of seconds.

Table 4.10. Account Tree - Window Toolbar

Toolbar Buttons


Save (Ctrl+S)

Perform a save on the data file, commit all transactions to the data file.

Close (Ctrl+W)

Close the currently active account page


This icon is not available for the first accounts tab. It is available for additional account tree displays.


Open a transaction register of the selected account.


Edit the characteristics for the selected account. Section 5.5, “Editing an Account”


Start the assistant for creating a new account. Section 5.4, “Creating a New Account”


Remove the selected account. Section 5.7, “Deleting an Account”

4.2.3. Tab bar

The Tab bar displays file/notebook folder style tabs for open transaction registers, reports and the account tree.

4.2.4. Main pane - Account tree

The account tree displays the list of your accounts in hierarchical format. This enables you to organize your accounts by type.


The triangle shape (or plus sign) beside the account name is used to open and close the account tree. When you click on the triangle (plus sign), it changes from a rightward-pointing into a downward-pointing sign (minus sign) to indicate that the tree is opened. You will then see offset below the account name either a list of the sub account(s) or another triangle (plus sign) to the left of an account. This indicates another lower level of the account tree.

In the main pane are also shown, by default, four columns: Account Name, Type, Description and Total. For each account, this informations, if available, is displayed in the same row of the account.


The columns shown for each account in the Account Tree can be customized to suit your needs. Click on the arrow icon on the far right of the Account Tree window to display a drop down list of column options. Click on a column description to add it to the Account Tree window. Click again on the column description to hide it.

The default display for the account tree window is in Notebook mode. This is indicated by the tab in the tab row of the main window. Other tabs will appear beside this one when you open reports, account registers or additional account trees.

4.2.5. Summarybar

The Summarybar displays balances appropriate for the opened account type at a glance. Usually accounts display today’s account balance, any balance for future dates, a balance for cleared items and a reconciled balance. Stock accounts, however, display shares totals and their value. The Summarybar can be hidden or shown by selecting ViewSummarybar.

4.2.6. Statusbar

The Statusbar displays informations about the currently highlighted menu item. It also shows a progress bar when opening or saving a GnuCash data file or generating reports. The Statusbar can be hidden or shown by selecting the Statusbar item on the View menu.