4.4. Report Window

4.4.1. Report Display Window

This window is shown whenever a report or chart is selected from the Reports menu.

To open the report window, select a report from the Reports item in the Menubar. This will open a new window with the report displayed. It provides a web browser type display with active links to account data.


Depending on the report there may be a delay while the report is generated. An approximation of the progress to completion is displayed in the Statusbar, if has not been opted out of displaying.

Figure 4.4. The Report Window

Report screen

This is an image of the Income/Expense Chart.

4.4.2. Report Menus

The Menubar for the report window contains the following options. Reports - File Menu

The following table describes the options in the File Menu.

Clicking on the File option of the Menubar will pull down a menu of options described in Table 4.17, “Report - File Menu - Access to file and account operations and printing.”.

Table 4.17. Report - File Menu - Access to file and account operations and printing.

Menu Item


New File (Ctrl+N)

Creates a new data file (starts with new accounts and data.)

Open... (Ctrl+O)

Opens an already existing GnuCash data file.


Opens the Import sub-menu to import files from other financial programs.


Import QIF ...

Starts the QIF file Import process.


Import OFX/QFX ...

Starts the OFX/QFX file Import process.


Import CSV/Fixed-Width ...

Starts the CSV/Fixed-Width file Import process.


Replay GnuCash .log file...

Starts the replaying of a GnuCash log file. Used for data recovery from "crashes".


Import MT940



Import MT942



Import DTAUS



Import DTAUS and send


Save (Ctrl+S)

Saves the currently open file.

Save As... (Shift+Ctrl+S)

Saves the currently opened file with a different name.


Do NOT store your data file in ~/.gnucash/books.

Add Report

Saves the displayed report in a configuration file. In this way you will be able to run the exact same report again by using the ReportsCustom Report menu item.


In order to make the Add Report item selectable, you first need to change the report’s default name through the report options or by selecting ActionsRename Page when displaying the report.

Print Report... (Ctrl+P)

Print the selected report.

Page Setup... (Shift+Ctrl+P)

Let you choose the paper size, layout and margins for printing.


Exports ...


Export Report

Export the current report in an HTML formatted file.


Export Accounts

Exports your account hierarchy to a new file. Does not export data.

Properties (Alt+Enter)

Sets options for this GnuCash data file.

Recently opened files

Numbered list of most recently opened GnuCash data files.

Close (Ctrl+W)

Closes the current report.

Quit (Ctrl+Q)

Exits GnuCash. Report - Edit Menu

Table 4.18. Reports - Edit Menu - Access to file and account editing operations and preferences.

Menu Item


Copy (Ctrl+C)

Performs a standard Copy operation.

Find... (Ctrl+F)

Set criteria for a search for a specific transaction. See Section 7.1, “Find” for specifics on searches.

Preferences (GnuCashPreferences on Mac OS X).

Customize GnuCash for location, style, and numerous other preferences. See Section 9.2, “Setting Preferences”.

Style Sheets

Modify/customize Style Sheets.

Report Options

Open form to edit/modify report selection criteria, stylesheets, date ranges, and other parameters.

Tax Report Options

Set tax characteristics on account(s) (US). Assign tax form and line to account. See Section 9.4, “Setting Tax Report Options”. Report - View Menu

Except Filter By..., the items shown in the View menu are the same listed in Table 4.3, “Account Tree - View Menu - Changes display window view.” Report - Actions Menu

Table 4.19. Reports - Actions Menu - Setup scheduled transactions.

Menu Item


Online Actions

This menu item (and sub-menu) is shown only if Online Banking was enabled for GnuCash

Get Balance


Get Transactions

Download transactions from online accounts


Issue Transaction...

Upload transaction(s) to online account ??


Internal Transaction...


Direct Debit...

Scheduled Transactions

Scheduled Transactions sub-menus

Scheduled Transaction Editor

Invoke tool to edit scheduled transactions. See Section 6.13, “Edit Scheduled Transaction Window”


Since Last Run...

Display Scheduled transactions since last running of GnuCash. Section 7.2, “Since Last Run Assistant”


Mortgage & Loan Repayment...

Starts the Mortgage & Loan Repayment assistant for setting up repayments. Section 7.3, “Mortgage & Loan Repayment Assistant”


Budget sub-menus

New Budget

Opens the window to create a new budget.


Open Budget

Opens an existing budget.

Reset Warnings...

GnuCash gives warnings when certain operations are attempted, such as removing a transaction or removing the splits of a transaction. The warning message gives you the option to not give you these warnings when attempting the operation. Check-boxes labeled Remember and don’t ask me again and Remember and don’t ask me again this session allow disabling the warnings. This option resets the warnings to the default, This option resets the warnings to the default, i.e. display all warnings.


Warnings may be selectivly enabled.

Rename Page

Lets you type a new name for the current page or tab. Report - Business Menu

The items shown in the Business menu are the same listed in Table 4.5, “Account Tree - Business Menu - Access small business features of GnuCash.”. Report - Reports Menu

The items shown in the Reports menu are the same listed in Table 4.6, “Account Tree - Reports Menu - Access GnuCash Reports and Charts.”. Report - Tools Menu

The items shown in the Tools menu are the same listed in Table 4.7, “Account Tree - Tools Menu - Access to miscellaneous tools and editors”. Report - Windows Menu

The items shown in the Windows menu are the same listed in Table 4.8, “Account Tree - Windows Menu”. Report - Help Menu

The items shown in the Help menu are the same listed in Table 4.9, “Account Tree - Help Menu - Access to this help and the Tutorial and Concepts Guide.”.

4.4.3. Reports - Toolbar Icons/Buttons

The Report Window has a Toolbar to quickly access the functions used with reports. The Toolbar can be hidden or shown by selecting ViewToolbar.

Table 4.20. Reports - Toolbar Buttons

Toolbar Button


Save (Ctrl+S)

Close (Ctrl+W)

Closes the displayed report.


Move back one step in the history.


Move forward one step in the history.


Reload (rerun) current report.


Stops the


Exports HTML formatted report to a file.


Edit options specific to selected report.

Print (Ctrl+P)

Queues the current report for printing.

4.4.4. Tab Bar

The Tab bar displays notebook/file folder-style tabs for open transaction registers, account trees and reports.

4.4.5. Report Main Display

This is where the report or chart you have selected is shown. The properties of this window are editable in two ways. Selecting the Options button on the Toolbar lets you edit what the report is showing and which accounts the information is drawn from. Selecting EditStyle Sheets... lets you select the properties of the page that displays your report.

The report is able to act like a web browser if your report contains links to external web pages. The Toolbar buttons allow you to move Back and Forward through web pages. It will also open account registers when you click on links to accounts contained in the report.

You can also Export your report to a file and Print the report through the Toolbar buttons.

4.4.6. Summarybar

The Summarybar is not displayed when viewing a report window.

4.4.7. Statusbar

The Statusbar works the same as described in Section 4.2.6, “Statusbar”.