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Chapter 1. Introduction to GnuCash
What is GnuCash?

GnuCash is a personal and small business finance application. It’s designed to be easy to use, yet powerful
and flexible. GnuCash allows you to track your income and expenses, reconcile bank accounts, monitor
stock portfolios and manage your small business finances. It is based on professional accounting principles
to ensure balanced books and accurate reports.

1



Chapter 2. Using This Document &
Getting Help

This document is organized in two dimensions:

• From the GUI (Graphical User Interface) explaining the available options and their functions, with links
to deeper descriptions and usage. Chapter 4, GnuCash Windows & Menus

• By classifying Operations, Tasks, or Functions based on whether it is an Account, Transaction, Report-
ing or other oriented operation. Examples are:

• Account Actions - Chapter 5, Setting Up, Editing & Working with Accounts

• Transaction/Register Actions - Chapter 6, Common Transaction Operations

• Tools and Assistants - Chapter 8, Tools & Assistants

• Reporting & Charting - Chapter 9, Reports And Charts

• Customization - Chapter 10, Customizing GnuCash

Accessing Help
When GnuCash is running and this documentation is installed 1 ,

• this window is accessed by

• pressing the F1 key or

• selecting from the menu Help → Contents .

• Help → Tutorial and Concepts Guide (Ctrl+H) will open the other part of this documentation.

• In most dialogs the Help button will lead you directly to the page which describes that dialog.

The complete help menu is explained in the section called “Account Tree - Help Menu”.

Operating System and Help Viewer

Depending on your operating system we use different programs to display this help document:

Linux

Gnome Yelp

macOS

default web browser

Windows

Windows help viewer

1Our bundles for FlatPak, macOS, and Windows contain it, but under Linux it is usually shipped as separate package gnucash-docs .
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Using This Document & Getting Help

See their respective manuals to get help about help.

GnuCash Tutorial and Concepts Guide
The guide is the counterpart to this help. It explains the concepts used in GnuCash and has a tutorial that
takes you through using GnuCash to manage your accounts. It will appear if you choose Open the new
user tutorial in the Welcome to GnuCash! menu.

To open this Guide manually go to Help → Tutorial and Concepts Guide or press Ctrl+H .

Important

It is strongly recommended to read this guide if you are new to GnuCash or unfamiliar with
accounting concepts.

GnuCash Wiki
An immense amount of less-formal, but often more recent documentation about as well usage as develop-
ment of GnuCash is collected by the community in the GnuCash Wiki [https://wiki.gnucash.org/wiki/] ;
the Frequently Asked Questions [https://wiki.gnucash.org/wiki/FAQ] page should be a first stop whenever
you encounter difficulty using GnuCash.

Tip

You should also try its search page [https://wiki.gnucash.org/wiki/Special:Search] or browse cat-
egories [https://wiki.gnucash.org/wiki/Special:Categories].

GnuCash Website
The multilingual GnuCash website [https://www.gnucash.org/] contains:

Announcements

of new releases or server maintenance – usually only in English;

Downloads

of the program or the documentation in several flavours;

Links

to file bugs or suggest enhancements and more.

GnuCash On-line Assistance

Mailing Lists

The primary source of user support is the user mailing list [mailto:gnucash-user@gnucash.org]. If Eng-
lish is not your primary language, see wiki:user mailing lists [https://wiki.gnucash.org/wiki/Mailing_List-
s#User_Lists] for local lists. That page has also other useful sections like Netiquette [https://wiki.gnu-
cash.org/wiki/Mailing_Lists#Netiquette] or your individual Mailing List Management [https://wiki.gnu-
cash.org/wiki/Mailing_Lists#Mailing_List_Management].

In case you are old school there are 3rd party services which convert some of the lists into other formats:
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Using This Document & Getting Help

Web Forum

Nabble [http://gnucash.1415818.n4.nabble.com/GnuCash-f1415818.subapps.html];

NNTP News Feed

Gmane [nntp://news.gmane.org/gmane.comp.gnome.apps.gnucash.user].

One must subscribe [https://lists.gnucash.org/mailman/listinfo/gnucash-user] before posting, even if using
Nabble or Gmane.

Chat

Several of the developers and experienced users monitor the #gnucash channel at irc.gimp.net [irc://ir-
c.gimp.net/gnucash]. They are usually busy with other tasks and of course are not always at their com-
puters. Log in, ask your question, and stay logged in; it may take several hours before your question is
noticed and responded.

• If you got disconnected check the IRC logs [https://lists.gnucash.org/logs/] to verify that you missed
nothing related.

• Requirements, netiquette, and other details are explained in the IRC wiki page [https://wiki.gnu-
cash.org/wiki/IRC].

Mouse Buttons
This document refers to mouse buttons as Button1, Button2 etc.

• Button1 is typically the left mouse button or the right button in a left-handed setup

• Button2 is typically the right mouse button or the left button in a left-handed setup
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Chapter 3. Getting Started
The “Welcome to GnuCash!” Screen
Figure 3.1. “Welcome to GnuCash!” Screen

This screen is intended for you to use to get up and running quickly. The Cancel button is used to exit the
screen. It will then prompt you with Display Welcome Dialog Again?.

Figure 3.2. Display Welcome Dialog Again?

If you do not want to see the Welcome to GnuCash! menu again click the No button. Click the Yes button or
press the keyboard Enter key for the default which is to have the Welcome to GnuCash! screen run again.

Note

Selecting either of these options will leave you with a minimal GnuCash main window. Opera-
tions in this window are described in Chapter 4, GnuCash Windows & Menus.
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Figure 3.3. Minimal GnuCash main window

New Account Hierarchy Setup
This assistant helps you to create a set of GnuCash accounts. It will appear if you choose Create a new set
of accounts in the Welcome to GnuCash! menu, or if you select File → New .

Import QIF Files
This Assistant helps you import Quicken QIF files. It will appear if you choose Import my QIF files in
the Welcome to GnuCash! menu.

To start this assistant manually go to File → Import ... → Import QIF... .

In the following all the screens that you can see in this assistant are described in order of appearance.

1. The Import QIF files assistant opens with a screen that briefly describes what this assistant does and
requests the file(s) to import. The three buttons at the very bottom of the screen will not change while
using the assistant.

• Cancel: exit the process and cancel importing QIF files.

Warning

If you click this button, any selections you have made up to this point will be lost.

• Back: brings up the previous screen so that you can change a previous selection until the first screen.

• Forward: brings up the next screen so you can continue through the assistant.

2. The next screen allows you to Select a QIF file to load. The Select... button on this screen is used to
access the list of files. The Select... button brings up the Select QIF File dialog.

Navigate to where you have stored your QIF files and select the first one then click Import. The next
screen will display it in the Select a QIF File to Load field.

Note

If the file you are loading does not have an QIF date listed in it you will see the Set a date
format for this QIF file screen. Select the proper format from the pull down list and continue.
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Note

If the file you are loading does not have an account name listed in it you will see the Set the
default QIF account name screen. Otherwise you will skip this screen and go on to the screen
in the next section that shows loaded QIF files.

• The Account name: field is used to set an account name for this QIF file.

3. The next screen shows you the QIF files you have loaded. You can use this screen to return to the
previous screen and load more QIF files. It will also let you unload any files you have loaded by mistake.

• The top panel shows the list of QIF Files you have loaded.

• The Load another file button takes you back to the previous screen to load another QIF file.

• The Unload selected file button allows you to select a file from the top panel and remove it from
the list.

When you have selected all the QIF files to be imported, click the Forward button.

4. Depending on the type of data contained in the QIF files to be imported, you may see only one or all
of the following screens:

Accounts and stock holdings

This screen gives a description of the Accounts and stock holdings matching process on the fol-
lowing Match QIF accounts with GnuCash accounts screen.

Tip

This and other informational screens in the Import QIF files assistant can be turned off in
the Online Banking tab (see the section called “Online Banking”) under GnuCash Pref-
erences.

The next screen lets you Match QIF accounts with GnuCash accounts. You will see a list of QIF
account names on the left and suggested GnuCash account names on the right. The New? column
indicates if the GnuCash account name will be created by the QIF Import.

To change the GnuCash account to a different one select the QIF account. A screen will pop up
to select another account or create a new one.

• Select an account from the list to choose a already existing account.

• The New Account button allows you to add a new account name as a sub-account (child of
selected) of the selected account.

• The OK button is used to confirm your selection.

• The Cancel button is used to exit the dialog without using any changes you have made.

Income and Expense categories

This screen gives a description of the Income and Expense categories matching process on the
following Match QIF categories with GnuCash accounts screen.
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Tip

This and other informational screens in the Import QIF files assistant can be turned off in
the Online Banking tab (see the section called “Online Banking”) under GnuCash Pref-
erences.

The next screen lets you Match QIF categories with GnuCash accounts. You will see a list of QIF
category names on the left and suggested GnuCash account names on the right. The New? column
indicates if the GnuCash account name will be created by the QIF Import.

To change the GnuCash account to a different one select the QIF category. A dialog will pop up
to select another account or create a new one.

• Select an account from the list to choose a already existing account.

• The New Account button allows you to add a new account name as a sub-account (child of
selected) of the selected account.

• The OK button is used to confirm your selection.

• The Cancel button is used to exit the dialog without using any changes you have made.

Payees and memos

This screen gives a description of the Payees and memos matching process on the following Match
payees/memos to GnuCash accounts screen.

Tip

This and other informational screens in the Import QIF files assistant can be turned off in
the Online Banking tab (see the section called “Online Banking”) under GnuCash Pref-
erences.

The next screen lets you Match payees/memos to GnuCash accounts. You will see a list of QIF
payee/memo names on the left and suggested GnuCash account names on the right. The default
GnuCash account used is called Unspecified. The New? column indicates if the GnuCash account
name will be created by the QIF Import.

To change the GnuCash account to a different one select the QIF payee/memo. A dialog will pop
up to select another account or create a new one.

• Select an account from the list to choose a already existing account.

• The New Account button allows you to add a new account name as a sub-account of the selected
account.

• The OK button is used to confirm your selection.

• The Cancel button is used to exit the dialog without using any changes you have made.

5. The next screen allows you to Enter the QIF file currency. The drop down list defaults to the currency
configured in the Accounts tab (see the section called “Accounts”) under GnuCash Preferences. If you
wish the new accounts to use a different currency, select one from the list.

When you have selected the currency, click the Forward button.
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6. Depending on the type of data contained in the QIF files to be imported, you may or may not see one
or more of the following screens:

Tradable Commodities

This screen gives a description of the Tradable Commodities process on the screen.

Tip

This and other informational screens in the Import QIF files assistant can be turned off in
the Online Banking tab (see the section called “Online Banking”) under GnuCash Pref-
erences.

A series of screens, one for each of the stock, mutual fund, or commodity, displays the exchange,
full name, and symbol for each of the commodities listed in the QIF file you are importing so that
you can check them before proceeding.

Match duplicate transactions

This screen gives a description of the Match duplicate transactions process on the following Select
possible duplicates screen.

Tip

This and other informational screens in the Import QIF files assistant can be turned off in
the Online Banking tab (see the section called “Online Banking”) under GnuCash Pref-
erences.

The next screen lets you Select possible duplicate transactions. Imported transactions are shown
on the left panel and possible matches to each selected transaction are shown on the right.

• The left panel shows the list of Imported transactions to select from for matching duplicates

• The right panel shows the list of possible duplicates for the selected imported transaction. Select
the one that most closely matches

7. The last screen, Update your GnuCash accounts, gives you a list of three choices to finish the assistant.

• Cancel: exit the process and cancel importing QIF files.

Warning

If you click this button, any selections you have made up to this point will be lost.

• Back: brings up the previous screen so that you can change a previous selection until the first screen.

• Forward: imports the data and creates the accounts you have specified.

You should now have successfully imported your accounts.

Tip

Imported transactions might need to be reconciled. This process is described in the GnuCash
Tutorial and Concepts guide.
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The “Tip of The Day” Screen
Figure 3.4. “Tip of The Day” Screen

The Tip of the Day screen starts whenever you start GnuCash unless it has been disabled in the GnuCash
Preferences. It gives tips on features and using GnuCash. You can use the three buttons at the bottom of
the screen to look through the tips:

Previous 1

Shows the previous tip

Next 2

Shows the next tip

Close

Dismiss the Tip of the Day screen

The checkbox Show tips at startup can be used to enable or disable the Tip of the Day from running at
GnuCash start-up.

It is also possible to configure the Tip of the Day to run at start-up by the checkbox Display "tip of the
day" dialog on the General tab of Edit → Preferences , see the section called “General”.

The Tip of the Day can also be run manually by going to Help → Tip of the Day .

1Before GnuCash version 3.0 it was labeled Prev.
2Before GnuCash version 3.0 it was labeled Forward.
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Chapter 4. GnuCash Windows & Menus
The main GnuCash window displays the accounts, reports, menu selections and tools you may use to
process your financial data. This section gives you an overview of the different windows and sections of
windows that you will see in GnuCash.

Links in the various tables will lead to additional details on the topic.

GnuCash Main Windows Areas
You can access commonly used sub-windows and tools through this window.

Figure 4.1. The Main GnuCash Window

The parts in which the main GnuCash window is divided.

When you start GnuCash, after a couple of windows (Splash screen, Tip of the Day) the main window
will be displayed. This window is divided into the following sections (see Figure 4.1, “The Main GnuCash
Window” for reference):

Titlebar

Displays the name of the currently opened file and the active tab’s name

Menubar

Displays the available menu entries

Toolbar

Displays the available Toolbar buttons

Tab bar

Lists the open reports, registers and tree of accounts

Main pane

The major display space showing the content of the currently selected tab
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Summarybar

Displays a financial summary

Statusbar

Gives a description of the active menu item and shows a progress bar

Note

The contents and options within the various sub-menus of the different sections of the main Gnu-
Cash window will vary upon the active display window.

The tree of accounts is labeled Accounts in the Tab bar, and displays all your accounts and their balances,
grouped according to standard accounting practice.

Tip

To open an additional view of the tree of accounts go to View → New Accounts Page . This will
open the account tree in the existing window.

Tip

To open a new window with a tree of accounts view, go to Windows → New Window with Page .

Account Tree Display
Figure 4.2. The Account Tree Display.

This is an image of the Accounts tab.

Account Tree - Menus
The Menubar for the Accounts Tree window contains the following options.
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Account Tree - File Menu

The following table describes the options in the File Menu.

Clicking on the File option of the Menubar will “pull down” a menu of options described in Table 4.1,
“Account Tree - File-Menu - Access to file, account operations and printing.”.

Table 4.1. Account Tree - File-Menu - Access to file, account operations and
printing.

Menu Item Description

New File (Ctrl+N) Creates a new data file (starts with new accounts and data.)

Open... (Ctrl+O) Opens an already existing GnuCash data file.

Import → Opens the Import sub-menu to im-
port files from other financial programs.

Import Bills & Invoices... Open the Import Transactions
from text file window.

Import Accounts from CSV... Starts the CSV Account file im-
port process. The file to import
must be in the same format as the
one exported by GnuCash.

Import Transactions from CSV... Starts the CSV Transactions file
import process. The file to import
must be a delimited file.

Import Prices from a CSV file... This assistant will help you im-
port Prices from a CSV file. The
file to import must be a delimited
file.

Import Customers and Ven-
dors ...

Open the Import Customers and
Vendors from text file window.

Import QIF... Starts the QIF file Import
process.

Replay GnuCash .log file... Starts the replaying of a GnuCash
log file. Used for data recovery
from "crashes".

Import OFX/QFX... Starts the OFX/QFX file Import
process.

Import MT940 Import an end-of-day account
statement in SWIFT MT940 for-
mat into GnuCash.

Import MT942 Import an interim account state-
ment in SWIFT MT942 format
into GnuCash.

Import DTAUS Import a traditional german
DTAUS file into GnuCash.

Import DTAUS and send Import a DTAUS file into Gnu-
Cash and transmit its orders by
Online Banking.
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Menu Item Description

Save (Ctrl+S) Saves the currently open file.

Save As... (Shift+Ctrl+S) Saves the currently opened file with a different name.

Warning

Do NOT store your data file in ~/.gnucash/books.

Revert Reload the last saved version of the currently opened file. Useful if
you need to discard changes made to the data and not yet saved.

Print This entry is only activated if a printable item like a report or an in-
voice is selected..

Page Setup... (Shift+Ctrl+P) Lets you choose the paper size, layout and margins for printing.

Export → Opens the Export sub-menu.

Export Account Tree to CSV Exports your account hierarchy
to a delimited CSV file. Does not
export data.

Export Transactions to CSV Exports transactions to a delimit-
ed CSV file.

Export Active Register to CSV... Export the active Register to a
CSV file.

Export Accounts Exports your account hierarchy
to a new GnuCashfile. Does not
export data.

Properties (Alt+Enter) Sets options for this GnuCash data file.

Recently opened files Numbered list of most recently opened GnuCash data files.

Close (Ctrl+W) Close the current tab.

Note

In the initial Account tree this item is not available - it will
be grayed out.

Quit (Ctrl+Q) Exits GnuCash.

Account Tree - Edit Menu

Table 4.2. Account Tree - Edit-Menu - Access to file and account editing operations
and preferences.

Menu Item Description

Cut (Ctrl+X) Performs a standard Cut operation.

Copy (Ctrl+C) Performs a standard Copy operation.

Paste (Ctrl+V) Performs a standard Paste operation.

Edit Account (Ctrl+E) Modify name or characteristic of selected account.
the section called “Editing an Account”

Delete Account... (Delete) Remove an account. See the section called “Delet-
ing an Account”
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Menu Item Description

Find Account (Ctrl+I) Opens the Find Account wizard. This can be used
to search the account structure to open the desired
account.

Cascade Account Properties... Opens the Cascade Account Properties dialogue.
Transfers the selected account properties to the
subordinate accounts.

Note

This item can only be selected if you have
marked an account with at least one sub-
account in the account structure.

Renumber Subaccounts... Starts the Renumber Account assistant. See the
section called “Renumbering Subaccounts”.

Note

This item is selectable only if you have
highlighted an account with at least one
subaccount in the accounts tree.

Open Account Opens the register window for the currently select-
ed account.

Open Subaccount Opens a register window that displays all the trans-
actions for the selected account and for all its sub-
accounts.

Find... (Ctrl+F) Set criteria for a search for a specific transac-
tion. See the section called “Find” for specifics on
searches.

Preferences ( GnuCash → Preferences on macOS). Customize GnuCash for location, style, and nu-
merous other preferences. See the section called
“Setting Preferences”.

Style Sheets Modify/customize Style Sheets. See the section
called “Changing Style Sheets”.

Tax Report Options Set tax characteristics on account(s) (US). Assign
tax form and line to account. See the section called
“Setting Tax Report Options”

Account Tree - View Menu

Table 4.3. Account Tree - View-Menu - Changes display window view.

Menu Item Description

Toolbar Check-box to enable/disable display of Toolbar.

Summarybar Check-box to enable/disable display of Summary-
bar .

Statusbar Check-box to enable/disable display of Statusbar.
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Menu Item Description

Filter by ... Set filter for accounts displayed in the Account
Tree display.

Refresh (Ctrl+R) Repaint the display screen.

New Accounts Page Open a new tab that displays the account tree.

Account Tree - Actions Menu

Table 4.4. Account Tree - Actions-Menu - Setup scheduled transactions, repair
accounts, perform stock splits, transfer and reconcile transactions.

Menu Item Description

Online Actions → Online Banking Submenu

Note

This is shown only if WITH_AQBANKING was set while
building GnuCash.

Important

The menu entries will be enabled by the successful comple-
tion of Tools → Online Banking Setup... .

Note

Not all options are for all institutions available.

Get Balance Get the balance for the selected
account.

Get Transactions... Get the transactions online
through Online Banking.

Note

Sending orders to the bank is only available for EBICS and
FinTS.

Issue SEPA Transaction... Issue a new international Euro-
pean (SEPA) transaction online
through Online Banking.

Internal Transaction... Issue a new bank-internal trans-
action online through Online
Banking.

Issue SEPA Direct Debit... Note

Issue a new internation-
al European (SEPA) di-
rect debit note online
through Online Banking.
With the changeover to
SEPA, this menu entry
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Menu Item Description

has disappeared, but is
still possible. See the
German https://wik-
i.gnucash.org/wiki/De/
SEPA-Lastschrift.

Show log window... Open the Online Banking Con-
nection Window

Scheduled Transactions → Scheduled Transactions sub-menus

Scheduled Transaction Editor Invoke tool to edit scheduled
transactions. See the section
called “Edit Scheduled Transac-
tion Window”

Since Last Run... Display Scheduled transactions
since last running of GnuCash.
the section called “Since Last
Run Assistant”

Mortgage & Loan Repayment... Starts the Mortgage & Loan Re-
payment assistant for setting up
repayments. the section called
“Mortgage & Loan Repayment
Assistant”

Budget → Budget sub-menus

New Budget Opens the window to create a
new budget.

Open Budget If no budget exists, create a new
budget and open it. If only one
budget exists, open it; otherwise
user selects one to open.

Copy Budget If no budgets exist yet, just open
a new budget. If only one budget
exists, create a copy of it; other-
wise user selects one to copy. If
a copy is made, then the copy is
opened in a new tab.

Delete Budget If the active tab is a budget view,
the open budget is deleted. Other-
wise, a list of existing budgets to
delete is displayed in the Select
Budget dialogue.

New Account... Creates a new account and opens the account properties window.

New Account Hierarchy... Starts the New Account Hierarchy Setup assistant.

Transfer... (Ctrl+T) Starts the Transfer assistant for transfer between accounts.

Reconcile... Open the Reconcile window. the section called “Reconciling an Ac-
count to a Statement”

Auto clear... Opens the auto-clear screen where you can fill up the automatic
clear information.
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Menu Item Description

Stock Split... Starts the Stock Transaction assistant. Additional details the section
called “Recording a Stock Transaction”

View Lots... Opens the Lots in Account form.

Check & Repair → Check & Repair Submenus

Check & Repair Account Check for and repair unbalanced
transactions and orphan splits in
this account.

Check & Repair Subaccounts Check for and repair unbalanced
transactions and orphan splits in
this account and its subaccounts.

Check & Repair All Check for and repair unbalanced
transactions and orphan splits in
all accounts.

Reset Warnings... GnuCash gives warnings when certain operations are attempted,
such as removing a transaction or removing the splits of a trans-
action. The warning message gives you the option to not give you
these warnings when attempting the operation. Check-boxes labeled
Remember and don’t ask me again and Remember and don’t ask me
again this session allow disabling the warnings. This option resets
the warnings to the default, i.e. display all warnings.

Tip

Warnings may be selectively enabled.

Rename Page Open the form to rename the current page/tab.

Account Tree - Business Menu

Table 4.5. Account Tree - Business-Menu - Access small business features of
GnuCash.

Menu Item Description

Customer → Select customer related activities.

Customers Overview Open a customers overview page.

New Customer... Start the form to create a new
customer.

Find Customer... Start the assistant to search for a
customer.

New Invoice... Start the form to create a new in-
voice.

Find Invoice... Start the assistant to search for an
invoice.

New Job... Start the form to create a new
job.

Find Job... Start the assistant to search for a
job.
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Menu Item Description

Process Payment... Starts the Process Payment assis-
tant. Requires an account of type
"A/Payable" before running as-
sistant.

Invoices Due Reminder Open the Invoices Due Reminder
dialog.

Vendor → Select vendor related activities.

Vendors Overview Open a vendors overview page.

New Vendor... Start the form to create a new
vendor.

Find Vendor... Start the assistant to search for a
vendor.

New Bill... Start the form to create a new
bill.

Find Bill... Start the assistant to search for a
bill.

New Job... Start the form to create a new
job.

Find Job... Start the assistant to search for a
job.

Process Payment... Starts the Process Payment assis-
tant. Requires an account of type
"A/Payable" before running as-
sistant.

Bills Due Reminder View and edit the list of Bills
Due Reminder.

Employee → Select employee related activities.

Employees Overview Open an employees overview
page.

New Employee... Start the form to create a new
employee.

Find Employee... Start the assistant to search for an
employee.

New Expense Voucher... Start the form to create a new ex-
pense voucher.

Find Expense Voucher... Start the assistant to search for an
expense voucher.

Process Payment... Starts the Process Payment assis-
tant. Requires an account of type
"A/Payable" before running as-
sistant.

Business Linked Documents View all Linked Business Documents.

Sales Tax Table View and edit the list of tax tables.

Billing Terms Editor View and edit the list of Billing Terms.
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Account Tree - Reports Menu

This is a brief listing of each of the available reports and graphs. See the section called “Reports Listed
By Class” for specific report details. Each report or graph may be customized by selecting a different
Stylesheet or by pressing the Options button in the Toolbar.

Table 4.6. Account Tree - Reports-Menu - Access GnuCash Reports and Charts.

Menu Item Description

Budget →

Budget Balance Sheet

Budget Chart

Budget Flow This report includes informa-
tion from one budget period at a
time. The left column of numbers
shows the budgeted amounts,
and the right column of numbers
shows the actual amounts. It on-
ly shows certain accounts, those
that have no sub-accounts.

Budget Income Statement

Budget Profit & Loss This report is identical to the
Budget Income Statement report.

Budget Report The budget report shows all ac-
counts and all periods. For each
period it gives the budgeted
amount and the actual amount.
There is an option to add anoth-
er column showing the difference
(budgeted - actual).

Examples →

Average Balance

Expenses vs. Day of Week

Income vs. Day of Week

Sample Graphs

Sample Report With Examples

Welcome to GnuCash

Assets & Liabilities →

Advanced Portfolio

Asset Chart

Asset Piechart

Balance Forecast

Balance Sheet

Balance Sheet using eguile-gnc

General Journal
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Menu Item Description

General Ledger

Investment Portfolio

Liability Chart

Liability Piechart

Net Worth Barchart

Net Worth Linechart

Price Scatterplot

Security Piechart

Business →

Australien Tax Invoice

Customer Report

Customer Summary

Easy Invoice

Employee Report

Fancy Invoice

Job Report

Payable Aging

Printable Invoice

Receipt

Receivable Aging

Tax Invoice

Vendor Report

Experimental →

Balance Sheet (Multicolumn)

Income Statement (Multicolumn)

Income & Expense →

Cash Flow

Cash Flow Barchart

Equity Statement

Expense Chart

Expense Piechart

Income & Expense Barchart

Income & Expense Linechart

Income Chart

Incme Piechart

Income Statement

Income and GST Statement

Profit & loss
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Menu Item Description

Trial Balance

Multicolumn →

Custom Multicolumn Report

Dashboard

Account Summary Report showing the balance of selected accounts.

Future Scheduled Transactions
Summary

Report showing a summary of future transactions.

Reconciliation Report

Tax Schedule Report & TXF Ex-
port

Create a Tax report (US) and/or export data for tax preparation soft-
ware. (TXF)

Transaction Report

Saved Report Configurations Open the screen to manage saved user configured reports.

Account Report Open a register report for this account.

Account Report - Single Transac-
tion

Open a register report for the selected Transaction.

Account Tree - Tools Menu

Table 4.7. Account Tree - Tools-Menu - Access to miscellaneous tools and editors

Menu Item Description

Online Banking Setup... Performs the initial setup of an account for Online
Banking access (FinTs, OFX DirectConnect, ...) by
AqBanking, if GnuCash was built with the option
WITH_AQBANKING. the section called “The On-
line Banking Setup Assistant”

Price Database Tool to enter or modify Stock/Fund prices. Details
at the section called “Price Editor”

Security Editor Tool to enter or modify Stock or commodities. De-
tails at the section called “Security Editor”

Loan Repayment Calculator Details at the section called “Loan Repayment Cal-
culator”

Close Book Open a screen where you can enter the required in-
formation to close the current accounting period.
See the section called “Close Book”.

Import Map Editor Opens the Import Map Editor tool to view, edit or
delete import mappings (e.g. Bayes algorithm).

Transaction Linked Documents With the Transactions Linked Documents dialogue,
documents can be linked to a transaction.

General Journal See the section called “General Journal”
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Account Tree - Windows Menu

Table 4.8. Account Tree - Windows-Menu

Menu Item Description

New Window Opens a new GnuCash empty window.

New Window with Page Moves the current tab into a new window.

Opened windows A numbered list of open windows.

Account Tree - Help Menu

Table 4.9. Account Tree - Help-Menu - Access to this help and the Tutorial and
Concepts Guide.

Menu Item Description

Tutorial & Concepts Guide Explanation of accounting principles and how to ap-
ply them in GnuCash

Tips Of The Day Shows short notes about features you might other-
wise miss.

Contents Open this document.

About Show the information screen with GnuCash version,
license and credits

Account Tree - Toolbar Icons/Buttons

The GnuCash main Window has a number of buttons in the Toolbar to quickly access some common
functions used with the specific active tab. The Toolbar can be hidden or shown by selecting View →
Toolbar .

Note

The specific options displayed in the Toolbar vary with the functions available to the "active tab".

Tip

A brief description of the function of a Toolbar button is displayed when the mouse pointer is
placed over the icon for a couple of seconds.

Table 4.10. Account Tree - Window Toolbar

Toolbar Buttons Description

Save (Ctrl+S) Perform a save on the data file, commit all transac-
tions to the data file.

Note

Only active if changed data has not yet
been saved.
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Toolbar Buttons Description

Close (Ctrl+W) Close the currently active account page

Note

This icon is not available for the first ac-
counts tab. It is available for additional ac-
count tree displays.

Open Open a transaction register of the selected account.

Edit Edit the characteristics for the selected account. the
section called “Editing an Account”

New Start the assistant for creating a new account. the
section called “Creating a New Account”

Delete Remove the selected account. the section called
“Deleting an Account”

Tab bar
The Tab bar displays “file/notebook folder” style tabs for open transaction registers, reports and the ac-
count tree.

Main pane - Account tree
The account tree displays the list of your accounts in hierarchical format. This enables you to organize
your accounts by type.

Tip

The triangle shape (or plus sign) beside the account name is used to open and close the account
tree. When you click on the triangle (plus sign), it changes from a rightward-pointing into a
downward-pointing sign (minus sign) to indicate that the tree is opened. You will then see offset
below the account name either a list of the sub account(s) or another triangle (plus sign) to the
left of an account. This indicates another lower level of the account tree.

In the main pane are also shown, by default, four columns: Account Name, Type, Description and Total.
For each account, this informations, if available, is displayed in the same row of the account.

Tip

The columns shown for each account in the Account Tree can be customized to suit your needs.
Click on the arrow icon on the far right of the Account Tree window to display a drop down list
of column options. Click on a column description to add it to the Account Tree window. Click
again on the column description to hide it.

The default display for the account tree window is in Notebook mode. This is indicated by the tab in the tab
row of the main window. Other tabs will appear beside this one when you open reports, account registers
or additional account trees.

Summarybar
The Summarybar displays balances appropriate for the opened account type at a glance. Usually accounts
display today’s account balance, any balance for future dates, a balance for cleared items and a reconciled
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balance. Stock accounts, however, display shares totals and their value. The Summarybar can be hidden
or shown by selecting View → Summarybar .

Statusbar
The Statusbar displays informations about the currently highlighted menu item. It also shows a progress
bar when opening or saving a GnuCash data file or generating reports. The Statusbar can be hidden or
shown by selecting the Statusbar item on the View menu.

Account Register/General Journal

Account Register & General Journal Window
This window is used to enter and edit your account data. It also provides tools for scheduling future trans-
actions, finding and reporting on transactions and printing checks.

To open the Account Register Window for an account, select the account in the Account Tree then go to
File → Open Account or press Ctrl+O . This will open a new window with the Account Register. Pressing
the Open button on the Toolbar in the Account Tree Window or the Jump button in the Account Register
Window are alternate methods.

Figure 4.3. The Account Register Display.

This is an image of the Account Register tab.

Tip

Appearance of the Account Register Display is highly customizable (see  Tutorial and Con-
cepts Guide, Choosing a Register Style [https://www.gnucash.org/docs/vnone/C/gnucash-guide/
chapter_txns.html#txns-regstyle1]) and Setting Column Widths [https://www.gnucash.org/docs/
vnone/C/gnucash-guide/chapter_txns.html#txns-columnwidths1]).

Note

The methods to enter transactions are described in detail in Chapter 6, Common Transaction
Operations.
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Account Register Menus
The Menubar for the Transaction Register window contains the following options.

Account Register - File Menu

Clicking on File in the Menubar will “pull down” a menu of choices described in Table 4.1, “Account
Tree - File-Menu - Access to file, account operations and printing.”.

The following table describes the additional options in the File Menu.

Table 4.11. Account Register - File-Menu - Access to file and account operations
and printing.

Menu Item Description

Print Checks... (Ctrl+P) Starts the Print Checks assistant. See the section called “Printing
Checks”.

Close (Ctrl+W) Closes the currently opened transaction register.

Account Register - Edit Menu

The Menubar in the Edit menu includes, in addition to the items described in Table 4.2, “Account Tree -
Edit-Menu - Access to file and account editing operations and preferences.” the following menu items.

Table 4.12. Account Register - Edit Menu - Access to file and account editing
operations and preferences.

Menu Item Description

Assign as payment... Assign as payment the selected transaction.

Account Register - View Menu

The View menu in the Menubar. Table 4.3, “Account Tree - View-Menu - Changes display window view.”
is supplemented for the transaction view by the following entries.

Table 4.13. Account Register - View-Menu - Changes GnuCash display window
characteristics.

Menu Item Description

Basic Ledger Radio button to select register display mode. See  Tutorial and
Concepts Guide, Choosing a Register Style [https://www.gnu-
cash.org/docs/vnone/C/gnucash-guide/chapter_txns.htm-
l#txns-regstyle1].

Auto-Split Ledger Radio button to select register display mode.

Transaction Journal Radio button to select register display mode.

Double Line Check-box to enable/disable display of Double Line display.

Sort by... Set the sort order of the transactions display. Requires a click to start
options form. Option form requires Cancel/OK to close.
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Menu Item Description

Standard Order Keep normal order: date posted
[day], number, date entered [sec-
ond] a , description.

Date Sort by date.

Date of Entry Sort by date of entry.

Statement Date Sort by the statement date (unrec-
onciled items last).

Number Sort by number.

Amount Sort by amount.

Memo Sort by memo.

Description Sort by Description.

Action Sort by action field.

Notes Sort by notes field.

Reverse Order Reverse the sort order.

Save Sort Order Save the sort order between ses-
sions.

aThe “date entered” is usually invisible. Use a report to display it.

Account Register - Transaction Menu

Table 4.14. Account Register - Transaction-Menu - access to transaction tools.

Menu Item Description

Cut Transaction Cut the selected transaction into the clipboard.

Copy Transaction Copy the selected transaction into the clipboard.

Paste Transaction Paste the selected transaction from the clipboard.

Duplicate Transaction Insert in the register a copy of the selected transac-
tion.

Delete Transaction Delete the selected transaction.

Remove Other Splits Remove all splits from the selected transaction.

Enter Transaction Enter in the register the transaction you are cur-
rently working on.

Cancel Transaction Blanks all fields in the selected transaction if it has
not yet been recorded.

Void Transaction Void the selected transaction.

Unvoid Transaction Unvoid the selected transaction.

Note

This menu item is only displayed if the
selected transaction is marked as void.

Add Reversing Transaction Add a copy of the selected transaction with an in-
verted amount.
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Menu Item Description

Manage Document Link... Add, change or unlink the document linked with
the selected transaction.

Open Linked Document Open the linked document for the current transac-
tion.

Note

Only available if a file or location was as-
sociated with the currently selected trans-
action.

Jump to Invoice Opens the invoice for the current transaction.

Note

Only available if a invoice was associated
with the currently selected transaction.

Account Register - Actions Menu

The basic scope of the Actions menu in the Menubar is described in Table 4.4, “Account Tree - Ac-
tions-Menu - Setup scheduled transactions, repair accounts, perform stock splits, transfer and reconcile
transactions.”. In addition, the following menu items are available.

Table 4.15. Account Register - Actions-Menu - Setup scheduled transactions, repair
accounts, perform stock splits, transfer and reconcile transactions.

Menu Item Description

Blank Transaction (Ctrl+Page
Down)

Move to the blank transaction at the bottom of the register

Go to Date (Ctrl+G) Move to the split at the specified date.

Split Transaction Expand the currently selected transaction to show splits.

Edit Exchange Rate Edit the exchange rate for the current transaction.

Schedule... Create a Scheduled Transaction with the current transaction as a
template.

Jump to the other account Jump to the corresponding transaction in the other account.

Account Register - Busines Menu

The items shown in the Business menu are the same as listed in Table 4.5, “Account Tree - Business-Menu
- Access small business features of GnuCash.”.

Account Register - Reports Menu

The items shown in the Reports menu are the same as listed in Table 4.6, “Account Tree - Reports-Menu
- Access GnuCash Reports and Charts.” plus the two types of report listed in the following.
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Table 4.16. Account Register - Reports-Menu - Access GnuCash Reports and
Charts.

Menu Item Description

Account report Open a register report for this Account.

Account Transaction Report Open a register report for the selected Account.

Account Register - Tools Menu

The items shown in the Tools menu are the same as listed in Table 4.7, “Account Tree - Tools-Menu -
Access to miscellaneous tools and editors”.

Account Register - Windows Menu

The items shown in the Windows menu are the same as listed in Table 4.8, “Account Tree - Win-
dows-Menu”.

Account Register - Help Menu

The items shown in the Help menu are the same as listed in Table 4.9, “Account Tree - Help-Menu -
Access to this help and the Tutorial and Concepts Guide.”.

Account Register - Toolbar Icons/Buttons
The GnuCash main Window has a number of icons/buttons in the Toolbar to quickly access some common
functions used with the specific active tab. The Toolbar can be hidden or shown by selecting the Toolbar
item on the View menu.

Note

The specific options displayed in the Toolbar varies by the functions available to the active tab.

Tip

A brief description of the function of a button is displayed when the mouse pointer is placed over
the button for a couple of seconds.

Table 4.17. Account Register (Transaction Register) Window Toolbar

Toolbar Buttons Description

Save Perform a save on the data file, commit all transac-
tions to the data file.

Note

This item is only active if changed data has
not yet been saved.

Close Close this register.

Note

In the initial Account tree this item is not
available - it will be grayed out.
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Toolbar Buttons Description

Duplicate Make a copy of the current transaction.

Delete Delete the current transaction in this register.

Enter Record the current transaction.

Cancel Cancel the current transaction.

Blank Move to a blank transaction at bottom of register.

Split Show all splits in the current transaction. Not high-
lighted if View → Auto-Split Ledger is enabled.

Jump Jump to the corresponding transaction in the other
account

Schedule Create a Scheduled Transaction with the current
transaction as a template.

Transfer Start the transfer assistant to transfer funds from one
account to another.

Reconcile Start the Reconcile process for the selected account.
the section called “Reconciling an Account to a
Statement”

Tab Bar
The Tab bar displays “notebook/file folder” style tabs for open transaction registers, account trees and
reports.

List of Transactions
The List of Transactions displays transactions you have entered and a running balance. It also provides a
blank transaction to enter new transactions. The column headings vary according to what type of account
you have opened. Common headings are Date, Description, Transfer and Balance.

The View menu can be used to alter the appearance of the List of Transactions. Possible changes are
limiting the number of transactions shown, using a different sort order and changing the style to more
easily see transactions. The Split button also provides quick access to view all the parts of a transaction.

Summarybar
The Summarybar displays balances appropriate for the opened account type at a glance. Usually accounts
display Present (today’s) account balance, any balance for Future dates, a balance for Cleared items, a
Reconciled balance and a Projected Minimum balance. Stock accounts, however, display shares totals and
their value. The Summarybar can be hidden or shown by selecting the View → Summarybar item.

Statusbar
The Statusbar works the same as described in the section called “Statusbar”.

Report Window
Report Display Window

This window is shown whenever a report or chart is selected from the Reports menu.
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To open the report window, select a report from the Reports item in the Menubar. This will open a new
window with the report displayed. It provides a web browser type display with active links to account data.

Note

Depending on the report there may be a delay while the report is generated. An approximation of
the progress to completion is displayed in the Statusbar, if has not been opted out of displaying.

Figure 4.4. The Report Window

This is an image of the Income/Expense Chart.

Report Menus
The Menubar for the report window contains the following options.

Reports - File Menu

Clicking on the File option of the Menubar will “pull down” a menu of options described in Table 4.1,
“Account Tree - File-Menu - Access to file, account operations and printing.”.

In addition, these menu items are available.

Table 4.18. Report - File-Menu - Access to file and account operations and printing.

Menu Item Description

Print Report... (Ctrl+P) Print the selected report.
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Menu Item Description

Export → Opens the Export sub-menu.

Export Report Export the current report in an
HTML formatted file.

Close (Ctrl+W) Closes the current report.

Report - Edit Menu

The items shown in the Edit menu are the same as listed in Table 4.2, “Account Tree - Edit-Menu - Access
to file and account editing operations and preferences.” plus the items listed in the following.

Table 4.19. Reports - Edit-Menu - Access to file and account editing operations and
preferences.

Menu Item Description

Report Options Open form to edit/modify report selection criteria,
stylesheets, date ranges, and many other parame-
ters.

Report - View Menu

Except Filter By..., the items shown in the View menu are the same as listed in Table 4.3, “Account Tree
- View-Menu - Changes display window view.”

Report - Actions Menu

The items shown in the Actions menu are the same as listed in Table 4.4, “Account Tree - Actions-Menu
- Setup scheduled transactions, repair accounts, perform stock splits, transfer and reconcile transactions.”.

However, the number of menu items is considerably reduced.

Report - Business Menu

The items shown in the Business menu are the same as listed in Table 4.5, “Account Tree - Business-Menu
- Access small business features of GnuCash.”.

Report - Reports Menu

The items shown in the Reports menu are the same as listed in Table 4.6, “Account Tree - Reports-Menu
- Access GnuCash Reports and Charts.” with the addition of:

Table 4.20. Report - Reports-Menu - Access GnuCash Reports and Charts.

Menu Item Description

Save Report Configuration (Ctr-
l+Alt+S)

Save the current report configuration. If you are not working with a
saved report configuration, you will be asked to give it a name. You
will be able to run the exact same report again by using the Reports 
→ Saved Report Configurations menu item.

Save Report Configuration As...
(Shift+Ctrl+Alt+S)

Add the current report's configuration to the Reports → Saved Report
Configurations menu.
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Report - Tools Menu

The items shown in the Tools menu are the same as listed in Table 4.7, “Account Tree - Tools-Menu -
Access to miscellaneous tools and editors”.

Report - Windows Menu

The items shown in the Windows menu are the same as listed in Table 4.8, “Account Tree - Win-
dows-Menu”.

Report - Help Menu

The items shown in the Help menu are the same as listed in Table 4.9, “Account Tree - Help-Menu -
Access to this help and the Tutorial and Concepts Guide.”.

Reports - Toolbar Icons/Buttons
The Report Window has a Toolbar to quickly access the functions used with reports. The Toolbar can be
hidden or shown by selecting View → Toolbar .

Note

The specific options displayed in the Toolbar vary with the functions available to the “active tab”.

Tip

A brief description of the function of a Toolbar button is displayed when the mouse pointer is
placed over the icon for a couple of seconds.

Table 4.21. Reports - Toolbar Buttons

Toolbar Button Description

Save Perform a save on the data file, commit all transac-
tions to the data file.

Note

Only active if changed data has not yet
been saved.

Close Closes the displayed report.

Note

This icon is not available for the first ac-
counts tab. It is available for additional ac-
count tree displays.

Back Move back one step in the history.

Forward Move forward one step in the history.

Reload Reload (rerun) current report.

Stop Stops the HTML requests.

33



GnuCash Windows & Menus

Toolbar Button Description

Options Edit options specific to selected report.

Save Report Configuration Saves the displayed report. You will be able to run
the exact same report again by using the Reports →
Saved Report Configurations menu item.

Save Report Configuration As... Saves the displayed report in a configuration file
with a given name. You will then be able to run
the exact same report again by using the Reports →
Saved Report Configurations menu item.

Export Exports HTML formatted report to a file.

Print Queues the current report for printing.

Tab Bar
The Tab bar displays “notebook/file folder”-style tabs for open transaction registers, account trees and
reports.

Report Main Display
This is where the report or chart you have selected is shown. The properties of this window are editable in
two ways. Selecting the Options button on the Toolbar lets you edit what the report is showing and which
accounts the information is drawn from. Selecting Edit → Style Sheets... lets you select the properties of
the page that displays your report.

The report is able to act like a web browser if your report contains links to external web pages. The Toolbar
buttons allow you to move Back and Forward through web pages. It will also open account registers when
you click on links to accounts contained in the report.

You can also Export your report to a file and Print the report through the Toolbar buttons.

Summarybar
The Summarybar is not displayed when viewing a report window.

Statusbar
The Statusbar works the same as described in the section called “Statusbar”.

Reconcile Window

Reconcile Display Window

Tip

The detailed explanation of reconciling an account is described in the section called “Reconciling
an Account to a Statement”.

To open the Reconcile window, click Actions → Reconcile... from the Menubar or the Reconcile button
from the Toolbar in a register window. This will open a Reconcile screen in which you need to enter the
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Statement Date and the Ending Balance. If you select the Include subaccounts option, all transactions in
the subaccounts of the selected account will also be counted for the reconcile operation. Pressing the OK
button will open a Reconcile window allowing you to compare deposit and withdrawal transactions to
your statement.

Reconcile - Window

Table 4.22. Reconcile - Components of the Reconcile Window.

Component Description

Menubar Contains the Menus used in the Reconcile Window.

Toolbar (Icons and/or Text) Contains buttons used to access common Reconcile
Account Window tasks.

Funds In This pane in the left contains a list of funds deposited
in the account.

Funds Out This pane in the right contains a list of funds with-
drawn from the account.

Balance Pane This pane in the lower right contains a list of bal-
ances useful for reconciling.

Reconcile - Menus
The following tables describe Menubar in the Reconcile Window.

Reconcile - Reconcile menu

Table 4.23. Reconcile Menu - Access to Reconcile Information and finishing or
postponing.

Menu Item Description

Reconcile Information... Opens the Reconciling Information Window.

Finish (Ctrl+W) Complete the reconciliation of this account.

Postpone (Ctrl+P) Postpone the reconciliation of this account.

Cancel Cancel the reconciliation of this account.

Reconcile - Account Menu

Table 4.24. Reconcile - Account Menu - Access to account operations

Menu Item Description

Open Account Opens a transaction register for the accounts

Edit Account Modify name or characteristic of selected account.
the section called “Editing an Account”

Transfer... (Ctrl+T) Opens a Transfer assistant for entering a transfer
transaction between any two accounts.

Check & Repair Verify and repair this account if necessary.
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Reconcile - Transaction Menu

Table 4.25. Reconcile - Transaction Menu - Access to transaction editing operations

Menu Item Description

Balance (Ctrl+B) Opens the account‘s register window with a pre-
compiled balancing transaction.

Edit (Ctrl+E) Edit the currently selected transaction.

Reconcile Transaction (Strg+R) Reconcile the selected transactions.

Unreconcile Transaction (Strg+U) Do not reconcile the selected transaction.

Delete (Ctrl+D) Remove the currently selected transaction.

Reconcile - Help Menu

Table 4.26. Reconcile - Help Menu - Access to help.

Menu Item Description

Help Open this Help text file.

Reconcile - Toolbar Icons/Buttons
The Reconcile window has a Toolbar to quickly access some common functions used with reconciliation.

Note

The specific options displayed in the Toolbar varies by the functions available to the active tab.

Note

Some buttons in the Toolbar only become active as soon as a transaction has been selected in
the “Reconcile window”.

Tip

A brief description of the function of a button is displayed when the mouse pointer is placed over
the button for a couple of seconds.

Table 4.27. Reconcile - Toolbar buttons

Toolbar Button Description

Balance Opens the account‘s register window with a pre-
compiled balancing transaction.

Edit Edit the currently selected transaction.

Reconcile Selection Reconcile the selected transactions.

Unreconcile Selection Do not reconcile the selected transaction.

Delete Remove the currently selected transaction.

Open Open an Account transaction window.

Finish Complete the reconciliation of this account.
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Toolbar Button Description

Note

This button is not active (grayed out) un-
til the Difference value in the balance pane
(lower right) is 0.

Postpone Postpone the reconciliation of this account.

Cancel Cancel the reconciliation of this account.

Schedule Transaction Window

Scheduled Transactions Main Display Window

Note

The detailed explanation of scheduling transactions is described in the section called “Scheduling
Transactions”.

This window is shown when Actions → Scheduled Transactions → Scheduled Transactions Editor is se-
lected from the Menubar. This will open a new tab window with the Scheduled Transactions displayed.

Scheduled Transaction Main Window Components

Table 4.28. Components of the Schedule Transactions Window.

Component Description

Menubar Contains the Menus used in the Schedule Trans-
actions Window. It provides the standard list of
Menubar options and an additional option, Sched-
uled, which presents options; New, Edit or Delete.
If no transaction is highlighted Edit and Delete will
be "grayed out".

Note

Some buttons in the Toolbar only become
active as soon as a transaction has been se-
lected in the “Schedule Transactions win-
dow”.

Toolbar, Icons/Buttons Contains buttons used to access Schedule Transi-
tions tasks.

Tabs Tabs to switch between open displays.

Transactions The Transactions pane contains a list of transactions
scheduled and related characteristics.

Upcoming The Upcoming pane contains a calendar of the next
months In this calendar the days in which one or
more transactions are scheduled, are highlighted
with a circle.
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Component Description

You can change the time interval displayed in the
calendar by selecting a different period from the
View: drop down list on the right.

Tip

Click on a date in the pane and the details
about the scheduled transactions on that
date will be displayed.

Scheduled Transactions Menu
The following table describe the Scheduled menu options available in the Menubar when you are in the
Scheduled Transaction window.

Scheduled Transactions - Scheduled Menu

Table 4.29. Scheduled Transactions Menu - Access to scheduled transaction editing
operations.

Menu Item Description

New Add a new scheduled transaction.

Edit Edit the currently selected transaction.

Delete Remove the currently selected transaction.

Scheduled Transactions - Toolbar Icons/Buttons
The Scheduled Transactions window has a Toolbar to quickly access some common functions used with
scheduling.

Tip

A brief description of the function of a Toolbar button is displayed when the mouse pointer is
placed over the icon for a couple of seconds.

Table 4.30. Scheduled Transactions Window Toolbar

Toolbar Button Description

Save Save the current schedule of transactions.

Note

Only active if changed data has not yet
been saved.

Close Close the Scheduled Transactions window.

New Add a new scheduled transaction.

Edit Edit the currently selected transaction.
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Toolbar Button Description

Delete Remove the currently selected transaction.

Budget Window

Budget Window Menus
Actions → Budget → Open Budget will open the default budget or offer you a choice if there is more than
one budget. A new tab will open with the budget displayed.

Here are some menu items that are particularly useful to working with budgets.

Budget Window - Edit menu

Table 4.31. Budget - Edit Menu - Special items for the budget window.

Menu Item Description

Estimate Budget Estimate a budget value for the selected accounts
from past transactions.

All Periods... Edit budget for all periods for the selected accounts.

Delete Budget Delete this budget.

Edit Note Edit note for the selected account and period.

Budget Options Edit this budget’s options.

Budget Window - Actions menu

Table 4.32. Budget - Actions Menu - Items in the standard menu that relate to
budgets.

Menu Item Description

Budget → Opens the Budget sub-
menu to select budget actions.

Tip

The menu items needed to plan bud-
gets are described in detail in Ta-

ble 4.4, “Account Tree - Actions-Menu
- Setup scheduled transactions, re-
pair accounts, perform stock splits,

transfer and reconcile transactions.”.

Budget Window - Reports menu

Using more than one budget

When there is more than one budget, the reports will use the budget selected in book options by
default. See the section called “Book Options” and the section called “Budgeting Book Options
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Tab” for more details. After the report is displayed, the budget it uses can be changed in the Edit
→ Report Options General tab.

Table 4.33. Budget - Reports Menu - Items in the standard menu that relate to
budgets.

Menu Item Description

Budget → Opens the Budget sub-menu
to select a budget report.

Tip

The menu items available to display bud-
get reports are described in detail in Ta-
ble 4.6, “Account Tree - Reports-Menu

- Access GnuCash Reports and Charts.”.

Budget Window Toolbar, Icons/Buttons
The Budget window has a Toolbar to quickly access common functions used with budgeting.

Tip

A brief description of the function of a Toolbar button is displayed when the mouse pointer is
placed over the icon for a couple of seconds.

Table 4.34. Budget Window Toolbar

Toolbar Button Description

Save Save the current file.

Note

Only active if changed data has not yet
been saved.

Close Close the Budget window.

Open Open a transaction register of the selected account.

Options Edit this budget’s options.

Estimate Estimate a budget value for the selected accounts
from past transactions.

All Periods... Edit budget for all periods for the selected accounts.

Delete Delete this budget.

Note Edit note for the selected account and period.

Budget Window Main Display
The budget window contains a list of accounts down the left hand side, and a set of columns down the
right hand side that represent budget values. Each column corresponds to a budget period. The number of
periods for a budget can be changed using the Budget Options dialog.
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Procedure 4.1. Entering a budget value

1. Click the row corresponding to the account you wish to budget

2. Choose the period this value is for, and click in the cell corresponding to that period

3. Type the value in the cell

4. Press Enter to finish editing the value.

Budget Options

Table 4.35. Budget options

Option Description

Budget Name The budget name is used in the tab’s name and also
in any reports you create with the budget.

Notes A description of the budget.

Budget Period The budget period includes when the budget starts
(start date) and how long each budget period lasts.

Number of Periods The number of periods in the budget.

Business Windows

Customers Overview
To open the Customers Overview window, click Business → Customer → Customers Overview .

Table 4.36. Customers Overview - Toolbar, Icons/Buttons

Toolbar Buttons Description

New Create a new customer.

Edit Edit the selected customer.

New Invoice Create a new invoice (by default it is for the selected
customer).

Customer Listing Show customer aging overview for all customers.

Process Payment Starts the Process Payment assistant.

Table 4.37. Customer context menu

Context menu item Description

Rename Page Rename the current page/tab.

Edit Customer Edit the selected customer.

New Invoice Create a new invoice.

Customer Report Show customer report.

Process Payment Starts the Process Payment assistant.
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Note

The customer context menu appears if you right click on a customer in the list.

Vendors Overview
To open the Vendors Overview window, click Business → Vendor → Vendors Overview .

Table 4.38. Vendors Overview - Toolbar, Icons/ Buttons

Toolbar Buttons Description

New Create a new vendor.

Edit Edit the selected vendor.

New Bill Create a new bill (by default it is for the selected
vendor).

Vendor Listing Show vendor aging overview for all vendors.

Process Payment Starts the Process Payment assistant.

Table 4.39. Vendor context menu

Context menu item Description

Rename Page Rename the current page/tab.

Edit Vendor Edit the selected vendor.

New Bill Create a new bill.

Vendor Report Show vendor report.

Process Payment Starts the Process Payment assistant.

Note

The vendor context menu appears if you right click on a vendor in the list.

Employees Overview
To open the Employees Overview window, click Business → Employee → Employees Overview .

Table 4.40. Employees Overview - Toolbar, Icons/Buttons

Toolbar Buttons Description

New Create a new employee.

Edit Edit the selected employee.

New Voucher Create a new voucher (by default it is for the selected
employee).

Process Payment Starts the Process Payment assistant.

Table 4.41. Employee context menu

Context menu item Description

Rename Page Rename the current page/tab.
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Context menu item Description

Edit Employee Edit the selected employee.

New Voucher Create a new expense voucher.

Employee Report Show employee report.

Process Payment Starts the Process Payment assistant.

Note

The employee context menu appears if you right click on an employee in the list.
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Chapter 5. Setting Up, Editing &
Working with Accounts

This section describes the process of setting up, editing and working with GnuCash Accounts. In GnuCash
an Account is used as the basic tool to organize the recording of where money comes from and goes
to. GnuCash also extends the concept of real world accounts such as a bank account or loan account to
grouping income and expense accounts. This allows you to quickly see where you spent your money and
what your major income and expenses are. GnuCash sets Account Types (as described in the next section)
to help in organizing and grouping accounts. Account Types can be used to create a Chart of Accounts.

Types of GnuCash Accounts
GnuCash supports a number of different account types. It is recommended to choose an appropriate account
type based on the list of account types described below.

Warning

The Accounts Payable and Accounts Receivable types are used internally by GnuCash’s business
features. Transactions involving these accounts should not be added, changed or deleted in any
way other than by using

• post/unpost bill/invoice/voucher or

• process payment

Table 5.1. Types of GnuCash Accounts.

Account Type Description

Accounts Payable Accounts Payable are used by businesses to record
amounts that must be paid. Example: The business
has bought something, but the business has not paid
the bill until later.

Accounts Receivable Accounts Receivable records amounts for which
money has not yet been received. Example: A busi-
ness has sold something and issued a bill, but the
client has not payed until later.

Asset Asset accounts are used for tracking things that are
of value and can be used or sold to pay debts. (Nor-
mally a placeholder account)

Bank The Bank account type denotes savings or check-
ing accounts held at a bank or other financial institu-
tion. Some of these accounts may bear interest. This
is also the appropriate account type for check (deb-
it) cards, which directly withdraw payments from a
checking account.

Cash The Cash account type is used to denote the cash
that you store in your wallet, shoe box, piggyback,
or mattress.

Credit Card The Credit Card account type is used to denote cred-
it card accounts, both for cards that allow floating
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Account Type Description

lines of credit (e.g. VISA, MasterCard, or Discov-
er) and with cards that do not permit continuing bal-
ances (e.g. American Express)

Currency Currency Accounts were used for trading curren-
cies, but have been replaced by the Currency Trans-
fer pane on the Transfer Funds Window (the section
called “Transfer Funds Dialog Box”).

Equity Equity accounts are used to store the opening bal-
ances when you first start using GnuCash or start a
new accounting period.

Expense Any expense such as food, clothing, taxes, etc. This
type is called a category in Quicken.

Income Any income received from sources such as salary,
interest, dividends, etc. This type is called a category
in Quicken.

Liability Liability accounts are used for tracking debts or
financial obligations. (Normally a placeholder ac-
count)

Mutual Fund A professionally managed portfolio of stocks and
bonds or other investments divided up into shares.

Stock A share of ownership in a corporation, which enti-
tles its owner to all the risks and rewards that go with
it.

The New Account Hierarchy Setup assistant described in the first section of this help is a convenient
way of setting up a set of accounts to use as a framework of account types.

When new accounts are created the available choices of account types are grayed out according to what
type the parent account is. The following list contains the possible choices.

• Accounts Payable: All accounts except Equity, Expense and Income can be child accounts.

• Accounts Receivable: All accounts except Equity, Expense and Income can be child accounts.

• Asset: All accounts except Equity, Expense and Income can be child accounts.

• Bank: All accounts except Equity, Expense and Income can be child accounts.

• Cash: All accounts except Equity, Expense and Income can be child accounts.

• Credit Card: All accounts except Equity, Expense and Income can be child accounts.

• Currency: All accounts except Equity, Expense and Income can be child accounts.

• Equity: Only Equity accounts can be child accounts.

• Expense: Only Expense or Income accounts can be child accounts.

• Income: Only Expense or Income accounts can be child accounts.

• Liability: All accounts except Equity, Expense and Income can be child accounts.

• Mutual Fund: All accounts except Equity, Expense and Income can be child accounts.
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• Stock: All accounts except Equity, Expense and Income can be child accounts.

Creating a Chart of Accounts
The Chart of Accounts is like a table of contents for your finances. The best way to conceptualize a chart
of accounts is as a tree. The main branches represent entire categories or groups, while the leaves of the
tree denote individual bank accounts or expense categories. When a summary report is requested, typically
only the main branches are shown in the report, rather than the individual accounts. For example, a chart
of accounts might look like the following:

300             Expenses
 |
 +--310         Living Expenses
 |   |
 |   +--311     Beer
 |   |
 |   +--312     Cable
 |
 +--320         Business Expenses
 |   |
 |   +--321     8-inch Floppies
 |   |
 |   +--322     Blue Ray RW DVDs
 |   |
 :   :

Accounts codes

Note that accounts not only have names; they may have codes, to order the accounts. When a
report is generated, the sort order is determined by the numbering. It’s customary to have the leaf
accounts end in non-zero digits, while parent nodes have increasing numbers of zeros.

Warning

GnuCash does not prevent duplicate numbering, although we would encourage you to avoid this.
Account codes are treated as numbers in base-36, thus, if you run out of numbers, you can use
the letters, a through z.

Editing a Chart of Accounts
Editing the Chart of Accounts is done within the Parent Account pane of the Edit Account dialog. It is
possible to move an account to any part of the Chart of Accounts. It is recommended to keep accounts
generally under the related types of accounts as described in the section called “Types of GnuCash Ac-
counts”. This helps to preserve the Chart of Accounts structure.

To move the selected account to a different parent account just select the account in the Parent Account
pane. If New top level account is selected then the account will be moved to the top level.

Creating a New Account
To create a new account go to Actions → New Account... or click the New Toolbar icon in the Account
Tree Window. The New Account dialog will be opened.

The New Account properties dialog consists of two tabs, the General tab and the Opening Balance tab.
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Creating a New Account involves planning in advance several details that are used in the New Account
dialog.

• What type of account is needed.

• Where it fits in the structure of the Chart of Accounts.

• If there is an Opening Balance.

• If there is a Commodity (security/currency) needed for the account.

• If online updating of the commodity price is needed.

These details are described below.

General Information Tab
The General tab is used to access the basic information about the account. It provides a way of connecting
the account to stock information if it is one of the currency, mutual fund or stock account types. It can
also be flagged as a Placeholder account. It displays if it is flagged as a Tax Related account (which is set
through the Edit → Tax Report Options dialog).

There are seven fields in the Identification section of this tab.

1. Account Name: The name for the account such as First Bank Checking.

2. Account Code: The optional number code as described in Accounts codes.

3. Description: Optional description for the account.

4. Security/Currency:

Note

The Type field in the Select Security is determined by the selection of Account Type panel
in the New Account screen.

• For accounts other than Stock or Mutual Fund this should be the default currency, USD (US Dollar)
or your local currency symbol. If this account is for a foreign currency then use the Select... button
to choose a different currency from the currencies pull-down list.

• For Accounts containing a Stock and Mutual Fund; first select stock or mutual fund in the Account
Type panel, then the Parent Account, then use the Select... button, to choose the Type (usually the
exchange the security is traded on) and security from the Select Security window.

If the required security/fund is not on the list, and you have the correct Type you will need to create
the security/fund. To create a commodity for mutual fund and stock accounts select the New... button
in the Select Security screen, to bring up the New Security: screen. The options are described in detail
in the Security Editor the section called “Security Editor” section. Fill in a name, symbol and type
and Close to create the security. After the security is created select the Type: (usually the exchange
the security is traded on) and the name in the Currency/security: drop down list and Close the screen.

5. Smallest Fraction: The smallest fraction that will be tracked.

6. Account Color: The color to assign to the account’s register tab. Click on the color button to open the
Pick a Color screen. To reset the account color click the Default button.

7. Notes: This is a free form text box that can be used for any additional notes about the account.
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Below the panes are 3 check-boxes: one to show if the account is Tax Related, one to mark the account
as a Placeholder, and one to mark an account Hidden.

The Tax Related check-box means that an account has been flagged to be included in the Tax Schedule
Report. This flag is only displayed on the Edit Account dialog and is set in the Income Tax Information
dialog ( Edit → Tax Report Options ). For related reports see the examples like Tax Schedule Report and
TXF Export in (the section called “Country Specific Reports”).

The Placeholder check-box sets an account to read-only status and prevents the addition of transaction
data to the account.

Note

Setting an account to Placeholder will also hide that account in the pop-up account list in a register.
Sub-accounts to the placeholder account will still display in the pop-up, however.

The Hidden check box hides an account (and any sub-accounts) in the account tree. To reset this option,
you will first need to open the View → Filter By... dialog for the account tree and check the Show hidden
accounts option. Doing so will allow you to select the account and reopen this dialog.

Note

Hidden accounts still appear in the pop-up account list in a register. To remove an account from
this pop-up account list as well, check the Placeholder check box.

Below these checkboxes is a pane that contains a list of Account Types. Select a type from the descriptions
in the section called “Types of GnuCash Accounts”.

The next pane contains an account tree to choose a Parent Account. To create a new account tree select
New top level account.

Note

The available choices in the Account Type pane depends on the selected account in the Parent
Account pane. For example if the Parent Account is Assets you will see only Equity in the Account
Type pane. This is to help maintain a proper account structure for the Chart of Accounts.

Steps to enable Online Quotes updating
1. GnuCash uses an external tool to retrieve online courses. This tool is a Perl module called Fi-

nance::Quote and must be installed independently of GnuCash on your computer.

Tip

The installation of Finance::Quote is described under the section called “Installing Fi-
nance::Quote”.

2. Create the Account for the mutual fund or stock with it listed in the Security/Currency field, as described
above.

Tip

When creating these accounts it is a good time to create income accounts to track dividends,
capital gains (long and short) and expense account(s) for tracking commissions and losses (if
you track losses as expenses).
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3. Create the mutual fund or stock with either the Security Editor for existing stock/funds or the New
Security/Currency dialog for a new stock/fund.

Select Get Online Quotes, Type of Quote Source and Timezone.

Online currency quotes require that the check-box for Online quotes and the timezone be selected in the
Security screen and the Security Editor check-box for "get quote" box is checked for those currencies
that are to be downloaded.

• Get Online Quotes This check-box is to enable this security/fund to have quotes downloaded from
an online source.

• Type of Quote Source use the radio buttons to select the type of source for the Online quotes. Mul-
tiple: quote sources like “Europe” should be used if fail-over to multiple sites are desirable. Single:
selections will only return information from the specified source.

After selecting the type of source for price quotes, select a quote source from the pull-down menu.
For details on currently supported sources see the section called “Finance::Quote Sources”.

Note

Note that Yahoo will provide price quotes for many mutual funds including Fidelity,
T.Rowe Price and Vanguard, and that the quoted prices at Yahoo should be identical to
those that may be found at the source sites.

If you are outside the US and use one of the different Yahoo sources or multiple sources containing
Yahoo, you should append the market code for the security such as PA for Paris, BE for Berlin,
etc. Example: 12150.PA (a Peugeot security in the Paris market). Table A.4, “Yahoo Codes for
Exchanges and Markets” below lists suffixes for various markets around the world.

Pseudo-symbols for TIAA-CREF funds are listed in table Table A.5, “Pseudo-symbols that can be
used for TIAA-CREF quotes”.

• Timezone for these quotes: Select the timezone for the source of the online quotes you are receiving.
For example, Yahoo normally quotes Eastern timezone, so choose America/New York if you use
that quote source.

4. Select a commodity to the Price Editor.

5. Select Get Quotes in the Price Editor.

6. Check the latest price for the selected security.

Remember that Mutual Fund “prices” are really “Net Asset Value” and require several hours after the
exchange closes before being available. If NAVs are downloaded before the current days NAVs are de-
termined, yesterday’s NAVs are retrieved.

Opening Balance tab
The Opening Balance tab is visible only when creating a new account, and is disabled for Stock and Mutual
Fund accounts. In the latter case, opening balances must be created by hand. Please see Section 8.5.1 in
the Tutorial and Concepts Guide for instructions if you need to create an opening balance in a Stock or
Mutual Fund account. It is used to record the beginning balance for an account. This allows it to be used
for two different scenarios. If using GnuCash for the first time to record transactions, it can be used as a
beginning balance. If the accounts in use are closed at the end of a period and new accounts are created,
it is used to close and carry balances forward.
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There are three panes in this tab. The top pane contains the Balance Information.

• Balance: The balance to start the account with.

• Date: The date the opening balance should be recorded.

The next pane is the Transfer Type pane.

• Use Opening Balances Equity account: This transfers the opening balance for the account from a stan-
dard Equity account called Opening Balances.

• Select Transfer Account: This enables the pane below so a different account can be used to transfer
the opening balance.

The last pane is the Transfer Account pane. Select the account to use for opening balances from the list
of accounts in this pane.

Editing an Account
The Edit Account dialog consists of just the General tab. This tab has the same information that was
described in the section called “Creating a New Account”. To access the Edit Account dialog go to Edit
→ Edit Account (Ctrl+E) or click the Edit Toolbar icon in the Account Tree Window.

Renumbering Subaccounts
Use Renumber Subaccounts to rewrite the account codes for all children of the current account. For ex-
ample, you have the following account structure:

Table 5.2. Starting account numbers.

Code Name

10 Colors

10-1 Red

10-2 Orange

10-3 Yellow.

10-4 Blue

10-5 Violet

You now need to add the “Green” account, but you want it to sort between the Yellow and Blue accounts.
Instead of having to manually renumber all the accounts starting with Blue, you can use the Renumber
subaccount command on the Colors account. In the pop-up dialog the prefix value should default to “10”,
the account code for the colors account. If you set an interval value of “5” and click Renumber you will
end up with the following account structure:

Table 5.3. Renumbered account numbers

Code Name

10 Colors

10-05 Red

10-10 Orange

10-15 Yellow.
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Code Name

10-20 Blue

10-25 Violet

Now you have room in the account code numbering space to add the Green account with an account code
to force the proper ordering.

Table 5.4. Final account numbers.

Code Name

10 Colors

10-05 Red

10-10 Orange

10-15 Yellow.

10-18 Green

10-20 Blue

10-25 Violet

Deleting an Account

Deleting an Account means removing all transaction information and information about this account from
the file. This cannot be undone. You will be prompted to verify that you wish to remove the account. If the
account still contains transaction information you will be warned that this account contains transactions.

A side effect of removing an account that contains transactions is that you will end up with unbalanced
accounts. This will be indicated in the account by a gray check-box next to the debit and credit amounts.
You can automatically repair these unbalanced accounts by using the Actions → Check & Repair menu.
This will automatically assign the unbalanced amounts to a new account named Imbalance.

Reconciling an Account to a Statement
Reconciliation of Accounts in GnuCash with statements from a bank or other institution is a way of double
checking the accuracy of your (and your banks) transactions and the balance of your accounts. It also is
useful to track uncleared checks and other outstanding transactions.

The reconciling process in GnuCash involves two dialogs: the the section called “Reconciling Information”
dialog followed by the the section called “Reconcile” window. They provide access to various GnuCash
functions to make it easy to enter and update account information during the reconciliation.

Tip

The Reconcile window is accessed from the account tree window or the account register window
by selecting Actions → Reconcile… .

Note

If you are reconciling an Liability Account of type credit card using a credit card statement you
have the option of using the Transfer Funds dialogue that opens automatically and enter a credit
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card payment. You can change this behaviour in the GnuCash Preferences from the menu Edit →
Preferences in the Register tab by activating the checkbox Automatic credit card payment. (see
the section called “Register”)

The Summary Bar at the bottom of the Account Register Window indicates the amounts of Present (Bal-
ance), Future (Balance), Cleared (Transactions), Reconciled (Transactions) and Projected Minimum. On-
line account information can be used to mark which transactions the bank has processed by changing the
R (reconciliation status) column in the register from n (new) to c (cleared). The bank statement is then
used with the Reconcile window to reconcile the account which changes the R field to y (reconciled).

Reconciling Information
The Reconcile Information dialog is used to indicate the closing Statement Date and the Starting Balance
(fixed from last reconciliation) and Ending Balance from the statement. The Include Sub-accounts check-
box is used if one or more subaccounts are used to track the account you are reconciling. The Enter Interest
Payment button is used to add a transfer to the accounts for an interest payment. If selected a dialog will
be displayed to add the the section called “Interest Payment” to the account.

Note

The Enter Interest Payment button is shown only if you are reconciling an account of Bank type.

When you have entered all relevant data, press Ok to proceed to the the section called “Reconcile” dialog
or Cancel to discard the reconciliation process.

Interest Payment

There are three panes in the Interest Payment dialog. At the bottom is a button called No Auto Interest
Payments for this Account which will cancel the dialog. The top pane contains the Payment Information.

• Amount: Enter the amount of the interest payment.

• Date: Select the date for the interest payment.

• Num: Enter a number for the transaction (optional).

• Description: Enter an informational description for the transaction.

• Memo: Enter a note about the transaction (optional).

The Reconcile Account pane highlights in the tree the account that the interest payment will be transferred
to or from.

The Payment From pane contains a list of accounts where you can select the source account.

Note

If the payment is for a credit or loan account then usually the payment would be from an Expense
account. If the payment is for a checking or savings account then usually this would be from an
Income account.

Tip

The Show Income/Expense check-box shows or hides the Income and Expense accounts.
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Select OK to enter the interest transaction (or Cancel the payment) and return to the initial reconciliation
screen.

Reconcile

Note

For a detailed description of menu items and buttons on the reconcile window, see the section
called “Reconcile Window”.

The Reconcile dialog is where the actual process of matching your statement to GnuCash data takes place
on a per transaction basis.

The Reconcile dialog is composed of a toolbar and three panes; Funds In on the left, Funds out on the
right and a balance pane.

Note

If you enabled the option Use formal accounting labels in the Accounts section of the GnuCash
preferences, you will see Debits and Credits panes instead of Funds In and Funds Out panes.

The Funds In and Funds Out pane shows all unreconciled deposits to the account. Both panes are composed
of five columns.

Tip

To order the listed transactions with a preferred criteria, click on the relevant column header. To
reverse the selected order click a second time on the column header.

Date

The date of the unreconciled transaction.

Num

The number of the unreconciled transaction.

Description

The Description of the unreconciled transaction.

Amount

The Amount of the unreconciled transaction.

R

Shows a check if the transaction will be reconciled when done.

To mark a transaction as reconciled just click on it and a checkmark will appear on the relevant R column.

Tip

You can check or uncheck the reconcile status of all transactions in either pane by clicking on
a transaction in the required pane then clicking Ctrl-A followed by space. This will toggle the
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reconcile status of all transactions in the pane to either checked or unchecked state. This procedure
can be repeated to achieve the desired status for the transactions in the pane.

Note

Under each pane a Total for reconciled transactions is shown.

The balance pane shows a summary of the balances used in reconciliation.

Statement Date

The date on the statement set on the the section called “Reconciling Information”.

Starting Balance

The balance at the end of the last reconciliation.

Ending Balance

The balance entered from the statement.

Reconciled Balance

The balance of selected transactions.

Difference

The difference between the Reconciled and Ending balances.

The set of unreconciled transactions in the Funds In and Funds Out panes can be changed by using the
menus and Toolbar to access the account and transaction information. You can create a New transaction,
Edit a selected transaction, add a Balance transaction (of the same amount as listed under Difference in
the balance pane), and delete the selected transaction.

Tip

To modify a listed transaction, double click on it.

By pressing the Open icon the register of the account to reconcile will be opened.

If you wish to postpone the reconciliation until later use the Reconcile → Postpone (Ctrl+P) menu item
or pressing the Postpone icon. If you wish to cancel the reconciliation use the Reconcile → Cancel menu
item or press the Cancel icon.

All previous commands are also available in the Reconcile dialog menu.

Select each unreconciled transaction matching a transaction on the statement so a green tick appears in the
R column. The Balance pane changes to reflect each selected transaction until the Ending Balance equals
the Reconciled Balance and the Difference is zero. Once this is done select the Finish button or Reconcile
→ Finish (Ctrl+W) to finish the reconcile process.
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A transaction represents the movement of money from one account to another account. Whenever you
spend or receive money, or transfer money between accounts, that is a transaction. In GnuCash transactions
always involve at least two accounts.

GnuCash uses accounts as a way of grouping or organizing the recording of transactions. This section
describes the methods GnuCash has to help enter transactions quickly into the register.

GnuCash has several methods available for entering transactions.

• Entering directly into the register window is the most common way of entering transactions.

• Using the Transfer Funds window .

• Importing transactions either from a file or via on-line banking.

Transfer Funds Dialog Box
The Transfer Funds Dialog Box, accessed via Actions → Transfer... (Ctrl+T) or by pressing the Transfer
icon from the account register tab, serves two purposes in GnuCash:

• A way to create a simple (i.e. two-split) transaction between arbitrary accounts.

• Collect exchange rate or amount information in a multi-currency transaction (see the section called
“Multiple Currency/Commodity Transactions”).

Note

The Basic Information and Transfer Accounts panes will be disabled in the Transfer Funds dialog
when it is being used only to collect exchange rate or amount information.

Basic Information

The Basic Information section collects the entries for constructing a transaction: Date, description, amount,
etc.

• Amount: The amount of the transaction in the Transfer Fromaccount's commodity.

• Date: The posting date for the transaction, i.e. the date that you want to record it in your book.

• Num: A reference number for the transaction, often a check number.

• Description: The description of the transaction, often the payer or payee.

• Memo: Additional information you might want to note about the transaction. Anything entered here
will be added to the Memo fields of both splits.
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Transfer Accounts
The Transfer From and Transfer To tree views are used to select the accounts which will participate in
the transaction. They normally show only Asset and Liability accounts. If you need to use an Income or
Expense account in one of them, check the Show Income/Expense checkbox below the appropriate view.

• Choose the Transfer From account.

• Choose the Transfer To account.

Currency Transfer
The Currency Transfer pane is used to collect the needed information to enter the amount of the Transfer
To split. You may enter either a price or an amount and GnuCash will compute the other. If you have
Online Price Retrieval installed (see the section called “Installing Finance::Quote”) you can use the Fetch
Rate button to retrieve a current quote.

The Currency Transfer pane is enabled only if the selected accounts use different commodities or the
Transfer Funds dialog was launched to collect price or amount information from editing a transaction in
the register.

The Currency Transfer pane is organized as a radio group with two selections, Exchange Rate and To
Amount. Each consists of a radio button and a numeric entry.

If a relevant price is available in the price database (see the section called “Adding a stock price manually”)
the Exchange Rate will have that as a default entry.

• Select the Exchange Rate radio button if you want to enter a price or use the Fetch Rate button.

• Select the To Amount radio button if you want to enter the amount of the To Account split.

• Enter the price/exchange rate or the amount in the numeric entry corresponding to radio button you
selected. GnuCash will calculate the other amount for you when you exit the field. If it's enabled you
can use the Fetch Rate button to retrieve a current quote.

Note

If you have created a price in the Price Editor (see the section called “Adding a stock price man-
ually”) for the current date quote retrieval will not update that price. You must first delete the
manually-created price in the Price Editor before you Button1 on the Fetch Rate button.

Note

The Fetch Rate button will immediately create or replace a price in the Price Editor unless there
is an existing manually-created price for today.

Finishing Up
Select OK to commit the transaction (or confirm the price/amount) or Cancel to dismiss the dialog without
entering the transaction.

Note

When committing a transaction or confirming an exchange rate the price on the transaction date
in the Price Editor may be updated. See the section called “Price Editor” for details.
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Enter Transaction via register
When the Account Register Window for an account is opened the list of transactions for that account is
shown. This window has the name of the account on its tab. The menus contain several functions that alter
the display of transactions. The Toolbar also contains several functions that are often used when entering
or manipulating transactions. These are described in the the section called “Account Register & General
Journal Window” section of this document.

Entering Directly in the Register Window

The register window will look slightly different depending on the style options you have chosen. The
following describes entering simple transactions in the basic ledger style. The cursor is placed in the date
field by default when the register window is opened.

Note

When working on transactions in GnuCash, be aware that the Enter key and the Tab key behave
differently, and perform different actions.

The Enter key moves to the first field of the next split, regardless of which field you are in. If there
is no next split, proceeds to the next transaction. In any case, Enter finishes the transaction edit,
and any imbalance is posted to Imbalance-CUR, where CUR is the currency of the transaction.

The Tab key moves to the next field in the current split. If it's the last field, moves to the next
split, creating a new one if there isn't one. If the split is blank, the Tab key finishes the transaction
and posts any imbalance to Imbalance-CUR, as above.

1. Selecting the small icon on the right of the date field drops down a date selection calendar. Use the
arrows to select the correct month and year for the transaction then select the date. Selecting the icon
once more will close the date selection calendar. It is also possible to type in the date or part of the
date and let GnuCash fill the rest.

2. Press Tab to move to or select the Num field. Here you can enter a check or transaction number. Pressing
+ (plus) will automatically advance the number by one from the last transaction to have a number.

3. Press Tab to move or select the Description field. This field is used to enter either a payee or other
description for the transaction. It will automatically attempt to fill the payee name as you type.

4. At this stage one of two things will happen if tab is pressed. If GnuCash matches an existing transaction
the cursor will jump to one of the amount fields, automatically filling in the transfer account. Selecting
any field with the mouse instead of tabbing will not automatically fill the transferring account field.
If there is no matching (existing) transaction, GnuCash will move the cursor to the Transfer field with
only one line of the transaction supplied.

5. Accounts may be selected either by typing them in or by pressing the small button on the right of the
Transfer field, which will display a pick list of all non-placeholder accounts. Note that this pick list will
still display hidden accounts. If you have hidden an account in your chart of accounts, you may want
to set the account also to be a placeholder account so that it doesn't display here.

When typing, GnuCash will fill in available accounts as you type. For example, if you have Equity
and Expenses top-level accounts, typing E will fill in Equity because it sorts before Expenses. Con-
tinuing to type x will present Expenses the account separator (: by default, see the section called “Ac-
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counts”Account Preferences about changing it) will accept the currently offered account so that you
can start typing the name of a child account.

6. The next field R is used for reconciliation. This is described in the Reconcile an Account to a Statement
section. the section called “Reconciling an Account to a Statement”

7. Press the Tab key to move to the first of the amount fields. The names of the next two columns are
different according to what type of account is opened. For example, Bank accounts show Deposit and
Withdrawal here, Credit Card accounts show Payment and Charge, and Stock accounts show Shares,
Price, Buy and Sell.

8. Enter an amount for the transaction in the correct fields. When the transaction is "balanced" pressing
the Enter key, selecting the Enter icon or going to Transaction → Enter Transaction will finish the
transaction. Selecting the Cancel icon or going to Transaction → Cancel Transaction will erase the
transaction.

9. Transactions with just one transfer account will show the name of that account in the Transfer field in
completed transactions. (The Transfer field is the fourth (4) from the left in the register display.)

10.To move to the blank transaction at the bottom of the register, press the Blank Toolbar icon or go to
Actions → Blank Transaction .

Associating an External File with a Transac-
tion.

Some users find it helpful to associate external files or URLs, perhaps images of store receipts, cancelled
checks, or vendor invoices, with their transactions. GnuCash provides a facility for doing just that.

Select a transaction in the Register and Button2 click it to present the Context Menu and select Update
Association for Transaction. You will be presented with the Change a Transaction Association dialog.

Figure 6.1. Change a Transaction Association Dialog

At the top is a radio button with two choices File Association and Location Association. If there's an item
associated then the radio button will have the appropriate selection. At the bottom, 3 buttons: Remove,
Cancel, and OK. Remove will remove the current association and close the dialog box; the other two do
the usual actions.

If the File Association radio button is selected the control beneath it is a file chooser button. It will display
the name of the selected file if there is one or None if there isn't. Clicking the button will bring up a file
chooser dialog from which one may select the file to associate.

If the Location Association radio button is selected there is a text entry beneath it in which you may type
a URL.
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When you have finished click the OK button to confirm your choice or the Cancel button to dismiss the
dialog without making a change.

Open Association for Transaction is enabled if there is a file or URL associated with the selected trans-
action. Selecting it will open a file in the operating system's default viewer for the file type and a URL
in the default browser

Remove Association from Transaction is enabled if there is a file or URL associated with the selected
transaction and does exactly what you'd expect.
Figure 6.2. Chain and PaperclipWhen the Register is in Double Line mode the cell underneath the Reconciliation cell is the Association
cell and displays

• a paperclip symbol if there is a file associated with the transaction and

• a chain-link symbol if there is a URL associated with it

as long as those symbols are supported by the current font for the cell. Hovering over the cell will display
the file path or URL in a tooltip and clicking in it will open the file or URL as the Open Transaction
context menu item would.

Multiple Split Transactions
The register window will look slightly different depending on the style options you have chosen. The
following describes entering transactions with multiple splits in the basic ledger style. GnuCash describes
as a “Split” when money is transferred to or from more than two accounts in a transaction. The cursor is
placed in the date field by default when the register window is opened.

The multiple account lines will not be displayed in the Basic Ledger unless the Split icon or the Action
→ Split Transaction option have been selected.

1. Selecting the triangle icon on the right of the date field drops down a date selection dialog. Use the
arrows to select the correct month and year for the transaction then select the date. Selecting the icon
once more will close the date selection calendar. It is also possible to type in the date or part of the
date and let GnuCash fill the rest.

2. Press Tab to move to or select the Num field. Here you can enter a check or transaction number. Pressing
+ (plus) will automatically advance the number by one from the last transaction to have a number.

3. Press Tab to move to or select the Description field. This field is used to enter either a payee or other
description for the transaction. It will automatically attempt to fill the payee name as you type.

4. At this stage one of two things will happen if tab is pressed. If GnuCash matches an existing transaction
the cursor will jump to one of the amount fields, automatically filling in the transfer account. Selecting
any field with the mouse instead of tabbing will not automatically fill the transferring account field.
If there is no matching (existing) transaction, GnuCash will move the cursor to the Transfer field with
only one line of the transaction supplied.

5. When typing in the Transfer field GnuCash will also attempt to automatically match the account. It
does this alphabetically, so typing Ex will match the Expenses section of the account list. When the
section is matched, it is possible to move to a child account by pressing : (colon). If after typing Ex you
press : then the cursor will move to the first child account in the list. Typing combinations of letters and
: will allow movement down the tree of accounts quickly. The small icon on the right of the Transfer
field can be used as an alternate way of selecting accounts.

6. The next field is used for reconciliation. This is described in the section called “Reconciling an Account
to a Statement”

59



Common Transaction Operations

7. Press Tab to move to the first of the amount fields. The names of the next two columns are different
according to what type of account is opened. For example, Bank accounts show Deposit and Withdrawal
here, Credit Card accounts show Payment and Charge, and Stock accounts show Shares, Price, Buy
and Sell.

8. Enter the total amount for the transaction in the correct field. Before pressing Tab or Enter read next
step.

9. To enter the additional splits, press the Split button on the Toolbar or select Actions → Split Transaction .
Transactions with more than one split show the text --Split Transaction-- and the Split button will need
to be used to show the details.

10.The display will expand, the titles of the amount columns will be renamed and the Transfer column
name will be blank. The first line contains the description and the amount of the transaction. The second
line contains the currently opened account name in the Account field and the amount of the transaction.
The third line contains the transfer account name in the Account field. If the amount is not balanced,
GnuCash will indicate this by placing gray check-boxes in the amount columns with the unbalanced
amount in a blank last row.

11.When one of the short lines is selected, the column titles will change. The very first and last (Date
and Balance) columns will have blank titles. Num will change to Action, Description to Memo, the
now blank Transfer column will change to Account. The last two amount columns will show the name
described in step seven.

12.The Action and Memo columns are optional to fill out at this stage. Action is used to describe what
kind of account transfer is involved. Memo is an additional description of the transfer.

13.Move to the missing amount field on the third line and fill in the amount. Pressing the Enter key,
selecting the Enter icon or going to Actions → Enter will now move the cursor to the next line.

14.The Account column contains the list of transfer accounts. This column is the one that is used to add
splits. The method described in step five can be used to select another account on a blank line. Add
as many additional splits as needed.

15.When the transaction is balanced the gray check-boxes will disappear and the last blank line will not
have an amount.

16.Pressing Enter as described above will jump to the next transaction. Selecting the next transaction
will close the split or it can be manually closed by pressing the Split icon or selecting Actions → Split
Transaction .

Multiple Currency/Commodity Transactions
Any transaction that has splits whose accounts are denominated in different commodities (currencies are a
subset of commodities) requires an exchange rate to convert between the two. For more information please
see Chapter 10 of the Tutorial and Concepts Guide.

Registers for accounts of type STOCK or FUND display four columns, Shares, Price, Buy, and Sell (the last
two will be Credit and Debit respectively if you've enabled Use formal accounting labels in the Accounts
tab of Preferences). Enter any two and GnuCash will calculate the other for you; if you enter 3 and the
result doesn't balance GnuCash will ask which one to change to make the split balance.

Registers of other types have only Credit and Debit (the names will be different depending on the account
type if you haven't enabled Use formal accounting labels) and so use the Transfer Dialog with most of the
fields disabled to collect either an Exchange Rate or a To Amount (the amount in the other currency/co-
modity). Please see (the section called “Currency Transfer”) for details of using this dialog.
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Note

When committing a transaction or confirming an exchange rate the price on the transaction date
in the Price Editor may be updated. See the section called “Price Editor” for details.

Editing a Transaction
Editing a transaction involves just selecting the part of the transaction that needs to be changed. Once the
changes are complete pressing the Enter key, selecting the Enter icon or going to Transaction → Enter
Transaction will now move the cursor to the next line or transaction.

To see a more detailed view of a transaction for editing in Basic Ledger, press the Split button on the
Toolbar or select Actions → Split Transaction .

Deleting a Transaction
If a transaction needs to be removed from the register, select the transaction and press either the Delete
icon on the Toolbar or go to Transaction → Delete Transaction . A window will appear to confirm the
delete, unless the preference has been changed. The window presents two options; "Remember and don’t
ask again", and "Remember and don’t ask again this session". The response will be set according to the
selected checkbox. The preference can also be reset via Actions → Reset Warnings . the section called
“Reset Warnings...”.

Parts of a transaction can also be removed by pressing the Split button on the Toolbar or selecting Actions
→ Split Transaction . The part of the transaction that needs to be deleted can be then selected for deletion.

Add Reversing Transaction
In formal accounting, transactions should never be deleted or altered. Instead, when a mistake is made, the
original transaction remains in the ledger, and a reversing transaction is added to the ledger. This reversing
transaction restores the ledger to its state before the error, allowing the user to enter the transaction again
correctly.

While a user can certainly enter reversing transactions manually, GnuCash includes a menu option ( Trans-
action → Add Reversing Transaction ) that can quickly create the reversing transaction for you. This op-
tion only appears when you are in an account register. When you are in the transaction that needs to be
reversed, all you need to do is select this menu item, and a duplicate transaction that reverses the active
transaction is immediately created.

Note

Once you choose the menu item, a reversing transaction is immediately created in the account
using the current date. You may wish to locate the new transaction at the end of the register, and
add explanatory notes to it.

Removing Transaction Splits
Removing Transaction Splits involves erasing all splits except the one for the account that is opened. This
is a useful way of reusing a previous transaction that has multiple splits that need to be changed. (Note
this can be done without opening the split, but doing so makes the effect more visible)
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1. If in Basic Ledger, press the Split button on the Toolbar or select Actions → Split Transaction to open
the transaction. If in other modes select transaction.

2. Select Transaction → Remove Transaction Splits .

A window will appear to confirm the delete, unless the preference has been changed. The window
presents two options; "Remember and don’t ask again", and "Remember and don’t ask again this ses-
sion". The response will be set according to the selected checkbox. The preference can also be reset via
Actions → Reset Warnings . the section called “Reset Warnings...”.

3. All Accounts and their related details will be removed except for the currently opened account.

4. The amount is not balanced and GnuCash will indicate this by placing gray check-boxes in the amount
columns with the unbalanced amount in the blank last row.

5. Edit the transaction to fill in the new details.

Copying a Transaction
Copying Transactions is available from the Transaction menu. The Transaction menu has Cut Transaction,
Copy Transaction and Paste Transaction which allows a whole transaction to be cut or copied and pasted to
a new transaction line. This way of copying a transaction will use the date showing in the new transaction
blank line.

The Transaction → Duplicate Transaction... or the Toolbar Duplicate which, unlike the Copy method,
allows for choosing a different date.

• Select the transaction to duplicate.

• Go to Transaction → Duplicate Transaction...

• A dialog called Duplicate Transaction will prompt for a new Date and Num for the transaction.

• Press OK to add the transaction to the register.

Setting the reconcile status (R field) of a trans-
action

In the GnuCash register there is a column labeled R. This field indicates the status of a transaction. Possible
values are:

n

No. This is the default status when a transaction is created.

c

Cleared. Status may be assigned either manually or by an import process. Indicates the transaction
is included in the bank's record of the account transactions but has not yet been reconciled to a bank
statement in GnuCash.

y

Yes, reconciled. This status is solely assigned by the reconciliation process (see the section called
“Reconciling an Account to a Statement”). Places limits optionally requiring confirmation on editing
fields in that line of a transaction.
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f

Frozen. Not implemented at this time

v

Voided. Status is assigned or released manually through the transaction menu (the section called “Ac-
count Register - Transaction Menu”) to a transaction and applies to every line in the transaction. It
hides most of the transaction details but does not delete them. When a transaction is voided a reason
entry is required that appears to the right of the transaction notes. The notes and void reason will only
be visible when you have enabled View → Double Line .

Jump to another Account Register
When using the Account Register Window it is frequently useful to be able to view another account and
also the transfer account at the same time. GnuCash allows you to do this quickly by using the Jump button
available in the Toolbar or the Actions → Jump menu item in the Account Register Window.

Select the transaction in the Account Register Window and either click the Jump icon or select Actions
→ Jump to open the Account Register Window target. If the transaction is split between more than one
transfer account then you will need to show all the split transfer accounts first and select the transfer
account to jump to.

Scheduling Transactions
Scheduled Transactions provide the ability to have reminders scheduled or transactions scheduled to be
entered at a specified date. This is combined with the Since Last Run assistant (the section called “Since
Last Run Assistant”) to review and enter the transactions. The Mortgage & Loan Repayment assistant
(the section called “Mortgage & Loan Repayment Assistant”) is used to setup a scheduled transaction to
repay a compounding interest loan. The Scheduled Transaction Editor (the section called “Edit Scheduled
Transaction Window”) is used to create and edit transactions that are to be added to the register in an
automated way.

The easiest way to setup a scheduled transaction is to use an existing transaction in an account register as
a template. Select the transaction you wish to use as a template and then either select the Schedule icon on
the Toolbar or go to Actions → Schedule... . This will bring up the Make Scheduled Transaction dialog.

• Name: Enter a name to use for the scheduled transaction. This will be used in the Description field of
the transaction.

• Frequency: Choose the time period you want between scheduled entries. The dates that the transactions
will be entered will show in the mini calendar pane to the right.

• Start Date: Choose a date for the scheduled transaction to start.

• Never End: This scheduled transaction has no finish date.

• End Date: Choose a date for the scheduled transaction to end.

• Number of Occurrences: Enter the number of times you wish the scheduled transaction to be added to
the register.

The Advanced... button brings up the Scheduled Transaction Editor’s dialog to Edit the Scheduled Trans-
action. This is described in the section Scheduled Transaction Editor. the section called “Edit Scheduled
Transaction Window”
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Scheduled Transactions Window
The Scheduled Transactions Window is used to access the list of scheduled transactions and create, edit
or remove them. It also provides a calendar which displays upcoming scheduled transactions. Clicking
on the calendar view and hovering over any date will pop up a small dialog that shows the transactions
scheduled for that day. The blue highlight in the calendar indicates which days have scheduled transactions.
To dismiss the hover dialog click once more.

The top pane of the Scheduled Transaction Window contains the list of scheduled transactions that are
currently setup. This window lists the Name of the transaction, if the transaction is enabled for scheduling,
the Frequency (month and day) that the transaction is to be entered, the last time the transaction was entered
and the next time the transaction will be entered.

The right side of this pane contains a down arrow button that when clicked will pull-down a window to
allow selection of the characteristics displayed in the list. Unchecking the appropriate box will remove
the characteristic from the display.

The Toolbar of this window contains three buttons to create, delete and edit scheduled transactions. New
and Edit buttons opens the Edit Scheduled Transaction dialog. Delete removes the selected scheduled
transaction. The same options are available thru Schedule → New/Edit/Delete , from the Scheduled Trans-
action Tab.

Below the list of scheduled transactions is the Upcoming calendar. This calendar displays up to the next
year and highlights the dates that the scheduled transactions are scheduled to occur so it is easy to see when
the transactions are scheduled. Clicking on a date in the calendar brings up a list of scheduled transactions
for that date. Moving the mouse over other dates changes to the list of transactions on those dates. Clicking
once more on the calendar removes the transaction list.

The Scheduled Transaction Window is activated from the Account tab or the Transaction Register via
Actions → Scheduled Transaction → Scheduled Transaction Editor... .

Edit Scheduled Transaction Window
The Edit Scheduled Transaction Window is divided into a Name area, Options area, Occurrences area,
Recurrence Frequency area, mini calendar and Template Transaction pane.

The Name field is used to enter the name for the scheduled transaction. This will be used in the Description
of the transaction.

The Options area contains check-boxes to set if the transaction is automatically created and how many
days in advance the transaction is created and/or a reminder posted.

The Occurrences area contains selections to set for dates limits on transactions to be entered or the number
of transactions to be entered.

The Recurrence Frequency area contains selections to set how often the transaction is scheduled to be
added and on what dates this occurs.

The mini calendar provides a visual indication of what transactions are already scheduled.

The Template Transaction pane allows you to setup the transaction as you would like it to be entered into
the register.

These options are described in more detail in the section called “Scheduling Transactions”
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• From the Scheduled Transaction tab selecting a transaction from the list and pressing the Edit or New
buttons will bring up the Edit Scheduled Transaction Editor.

Printing Checks
Checks are printed in GnuCash from the account register. GnuCash provides the ability to print to several
standard Quicken Checks (including US Letter) or to make a custom check format. Check position and
Date formats are also customizable.

To print a single check in GnuCash, select the transaction to print a check for and go to File → Print Checks .
This will open the Print Checks properties dialog to print the selected transaction.

To print multiple checks in GnuCash execute a search to find the transactions you wish to print. With the
search results window as the front window go to File → Print Checks . This will open the Print Checks
properties dialog to print all the transactions in the search results window.

The Print Checks dialog has two tabs. The first tab, Options, is used to setup the most common options to
print a check. The second tab, Custom format, is used to setup the position of various fields on the check.
It is useful to print a test check to a plain piece of paper first and use that to make any adjustments needed.

The default selection in Options is for Quicken/Quickbooks (tm) US-Letter checks.

• Check format: Test with Quicken first then use custom if the position is incorrect.

• Check position: This sets if the Top, Middle or Bottom check is printed. Custom is used if the position
of the checks on the page is incorrect.

• Date format: The default here is set in the Preferences International section. Choose a date format. This
can also be adjusted by the Use of the Months: and Years: lines. Custom allows the date format to be
set in the Format: box (%m means month, %d means day, %Y means year) A Sample of the format
chosen is displayed below.

• Address: This sets the address of the Payee, if the check format includes a space for it and you are
printing a single check.

The Custom format tab has two sections. The top half of the window (above the dividing line) allows you
to position the fields in each check. It contains two columns to enter in the X and Y co-ordinates of the
field position on the check. Positions in the Custom Check Format entry area are specified with x = 0 at
the left edge of the check with x increasing to the right, and y = 0 at the top edge of the check with y
increasing as you travel down. (If you are using a version of GTK prior to 2.10, then y = 0 is at the bottom
of the page and y increases as you travel up.)

• Payee:

• Date:

• Amount (words):

• Amount (numbers):

• Address:

• Notes:

• Memo:

• Splits Amount:
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• Splits Memo:

• Splits Account:

The part of the custom format tab below the dividing line contains fields to position the entire check
correctly on the page. The Translation field is the distance from the top left corner and the Rotation field
rotates the check clockwise by the indicated amount.

The Units field in the bottom half of the window specifies the units used in all the fields in both halves
of the window.

Once OK is pressed on the Print Check dialog the Print GnuCash Document dialog is presented. Press
OK to print the check.

Importing Transactions from Files
Imported transactions will generally be to a specific account in your account tree. In the following this will
be referred to as the import or base account. It may or may not be specified in the data being imported
depending on the import format. It is usually the first split of a transaction being imported.

All transactions will also need to have a destination account for any other splits associated with the tans-
action. These may or may not be supplied in the imported data, depending upon the data source and the
format of the data. If it is not, GnuCash may be able to assign an account on the basis of the previous import
history by matching infomation in the imported data to data associated with previous account assignments
in the importer. The user may always over-ride this automatic assignment or where no assignment can be
made automatically assign an account manually.

Multi-split data exported from GnuCash in CSV format will normally have both the import and destination
accountsfor transaction splits specified in the data file.

Import Formats
GnuCash allows transactions to be imported in a number of structured formats for the exchange of financial
data as well as in the unstructured CSV format, a plain text tabular format commonly used for the import
and export of data to and from spreadsheets:

• QIF (.qif) Quicken Interchange format - import data from Quicken financial software;

• OFX/QFX (.ofx,.qfx) Open Financial eXchange format (QXF is an Intuit/Quicken proprietary version
of OFX);

• CSV (.csv) Comma Separated Values;

• Others Import with AQBanking supports importing several European and International file formats
including:

• CAMT 052Daily Bank Statements

• OLYMPIC Banking System ERI

• Spanish Q45

• SWIFT MT535, MT940, MT942.Bank Statements

• Swiss YellowNet XML
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Note

Files using these formats do not necessarily use the file extensions shown above.

These import methods can be accessed from the File → Import sub-menu entry, along with methods for
importing other types of data. Select the appropriate entry from the File → Import sub-menu to initiate
importing transactions.

Import Preference
User preferences set in the Import tab or the Online Banking tab of the user preferences accessed by Edit
→ Preferences from the menu will affect the importing of transactions from the files described below.

Import QIF
To import data from Quicken®, MS Money®, or other programs that use QIF(Quicken® Interchange
Format), you must first export your data to a QIF file. One way to do this is to export each account as a
separate QIF file. An easier way, available in Quicken® 98 and beyond, is to export all accounts at once
into a single QIF file. Check your program's manual to determine if this option is available.

To import QIF files:

Select File → Import → Import QIF... from the menu to open the QIF Import dialog box illustrated below.

Figure 6.3. The Import QIF Files Assistent

Dialog Navigation. The right hand pane will display some or all of the following navigation buttons:

• Cancel: Exit the dialog;

• Back: Go back to the previous step;

67



Common Transaction Operations

• Next: Proceed to the next step.

The buttons displayed are determined by whether navigation to the destination step is valid from the current
step.

Import Dialog Steps. The left hand pane lists the steps in the import dialog process. The right hand pane
contains instructions and/or controls for performing the operations in the step selected and highlighted in
the left hand pane. The import process steps are:

• Import of QIF files: Initial informational panel. Click Next to proceed;

• Select a QIF file to load: Open a file selection dialog. Navigate to and select the file you wish to import
and click Import. Then click Next;

• Load QIF files: Click the Start button to load the file. The file will be parsed and loaded. If errors or
warnings occur you may have to remove the file, edit it and reimport it. If there are no errors click Next;

• Set a date format for the file: Select a date format (m-d-y or d-m-y) appropriate to the locale of the
source of your QIF file. In the US this is generally m-d-y and in Europe d-m-y;

• Set the default QIF account name: If the QIF file does not specify an account name, enter an account
name. If importing data from another accounting program you should use the name used in that program;

• QIF files you have loaded: This step allows you to edit the list of files to be imported and to load
additional files. To remove a file, click on the row and then click on Unload selected file. To load another
file click the Load another file. When you have all the files you wish to import loaded, click Next;

• Accounts and stock holdings: Information panel. Click Next to proceed;

• Match QIF accounts with GnuCash accounts: QIF account names are matched to GnuCash accounts
if possible. New GnuCash accounts are created if no matching accounts are found. For stock, the required
account structures are also created. Created accounts are indicated by checking the checkbox in the
New column. Assigned accounts may be edited by selecting the appropriate the row and clicking on the
Change GnuCash Account button to to run the account selection dialog;

• Income and Expense categories: Information panel. Click Next to proceed;

• Match QIF categories to GnuCash accounts: QIF categories are matched to GnuCash accounts where
possible. New GnuCash accounts are created where no matching GnuCash account is found. Created
accounts are indicated by the checkbox in the New column being checked. If you are not sure what
changes are needed, it is safe to accept the GnuCash account names. These may be changed later in
GnuCash. Assigned accounts may be edited by selecting the appropriate row and clicking on the Change
GnuCash Account button to run the account selection dialog;

• Payees and Memos: Information page. Click Next to proceed;

• Match payees/memos to GnuCash accounts: QIF payees and memos are matched to GnuCash ac-
counts where possible and new accounts are created where this is not possible again indicated by the
checkbox in the New column. The assigned account may be changed by selecting a row and clicking
on the Change GnuCash Account button to to run the account selection dialog;

• Choose the QIF file currency: Select the required currency from the dropdown list and click on Next
to continue;

• Tradable commodities: Not yet implemented;

• QIF Import: Click on Start to begin the import. GnuCash currently proceeds to the Update your Gnu-
Cash accounts tab if the import is successful;
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• Match existing transactions: Not yet implemented;

• Select possible duplicates: Not yet implemented;

• Update your GnuCash accounts: Click Apply to complete the import. Depending upon the size of
your file, the import might take a few minutes to complete, so a progress bar displays the percentage
finished. When the import process is complete, GnuCash will return you to the main window, which
should now display the names of the accounts you imported.

Other features are not currently implemented;

• QIF Import Summary: Click on Close to exit the wizard.

Import OFX/QFX

File->Import->Import OFX/QFX transactions opens a file selection dialog. Navigate to the file you wish
to import, select a file with the appropriate extension (.ofx or .qfx), then press the Import button.

GnuCash then opens an Account Selection dialog to select an account in your CoA to match to an account
name in the import file. Select the appropriate account from the account tree and press the OK button. On
subsequent import of files from the same source account, the mapped GnuCash account is remembered
and the account selection dialog is not displayed.

The generic import transaction matcher dialog is opened next. See the  Import Matcher section (common
to both OFX/QFX and CSV import formats) following the Import CSV section to continue the import
process.

Import CSV

Clicking on File->Import->Import Transactions from CSV will bring up the CSV Transaction Import
Assistant dialog illustrated below.

The CSV Transaction import Assistant is largely self explanatory with information panes which describe
the functionality.

Dialog Navigation. Each pane displays a selction of the following navigation buttons at the bottom
right:

• Cancel Exit the CSV Transaction Import Assistant;

• Back Return to the previous step in the assistant;

• Next Proceed to the next step in the assistant.

The buttons displayed are determined by the validity of the traget step from the current step.

Procedure 6.1. CSV Import Process Steps

The steps in the CSV import process are listed in the left hand pane with the current step highlighted.
Explanatory text and the widgets to setup and carry out the step are displayed in the right hand pane. The
function of the controls in each step is explained below, in the explanatory information in the panes or in
tooltips on some controls. The steps in the CSV import process are:
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1. Introductory information panel

Figure 6.4. The CSV Transaction Import Assistant - Introduction

Click Next to continue;

2. Select File for Import: Display the File selection dialog. Navigate to the file you wish to import
then click the Next button;

3. Import Preview: The Import Preview pane controls set options for the import of CSV data and
provides a preview of the data to be imported.

Figure 6.5. The CSV Import Preview Pane

The CSV Import Preview Pane with settings to import the shown data.
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Import preview Controls

• Load and Save Settings

The settings group GnuCash Export Settings defines a setting group for used for the export and reimport of GnuCash
transaction data - use this if importing data previously exported from GnuCash.

Save

Once you have set all the import parameters, you can save these settings by typing a unique
name in the Load and Save Settings Entry combo box and clicking the Save icon just to the
right of the box.

Load

A previously defined settings group can be retrieved by selecting the appropriate setting group
name from the dropdown list activated by the down arrow at the right end of the text box. This
will set all other settings to the stored values.

Delete

The delete/trashcan icon to the right of the Save icon can be used to remove the saved settings
group selected from the drop down list for the box.

• Account: If the data you are importing does not specify the source account for the transaction an
account can be selected from the drop down list will import all transactions to the selected account.
Leave blank if your imported data specifies a source account;

• File Format:

• Separators: Selecting this radio button will allow you to define characters which will be used
to distinguish columns in the input file. The default is comma separated. In countries using the
comma as decimal separator the semicolon is common as column separator. However spaces,
tabs, colons or semicolons or any combination of them may be used to separate columns in the
input file by selecting the appropriate check boxes. You may also define custom separators by
typing the required characters into the text box and selecting the Custom checkbox. This may
be used in combination with any of the predefined separators;

• Fixed-Width: Selecting this radio button will allow you to define column boundaries by double
clicking at the appropriate positions in the sample records displayed in the panel below. Single
clicking in a column will narrow, widen or merge the column.

• Multi-split: Selecting this check box allows the splits for a single transaction to be defined on
consecutive lines within the file with each line defining a single split. If not selected each line is
assumed to contain the information for a single transaction including one or two splits;

Multi-split is a gnucash specific variant of a csv file to support easier data preparation.

Each line should define one split by

transaction-specific fields

date and description as bare minimum and
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split specific fields

account and deposit/withdrawal as bare minimum.

Tip

There is a convenience feature built-in so you don't have to repeat the transaction fields if
the split belongs to the same transaction as the previous one (though you can repeat them
if that makes csv preparation easier).

Example 6.1. Sample Multi-split.csv

Date,Description,Deposit,Account
05/03/2006,Grocery Store,-45.21,Assets:Checking
,,45.21,Expenses:Groceries
14/03/2006,Employers R Us,670.00,Assets:Checking
,,180.00,Expenses:Taxes:Federal
,,90.00,Expenses:Taxes:Medicare
,,60.00,Expenses:Taxes:Social Security
,,-1000.00,Income:Salary

• Miscellaneous: The miscellaneous settings allow you to set:

• Encoding: This is usually UTF-8, but may differ for files from other sources;

• Date Format: This does not default to the Locale setting so check it matches the data you are
importing;

• Currency Format: Select the format of the decimal separator (full stop or comma or other) for
the currency if the correct value is not supplied by Locale;

• Leading Lines to Skip: Select the number of header lines to skip in the imported file; 1

• Trailing Lines to Skip: Select the number of trailing lines to skip in the import file;1

• Skip alternate lines: Use to skip every second line in the import file.
to match the settings for the file you are importing. Tooltips may also contain information on the
setting and options.

The import panel shows the data being imported as it is interpreted using the settings chosen to define
columns and formats. The dropdown lists in the headers for each column of the import allow you to
associate a specific column in the imported data with a specific field in the display of a transaction
in an account register. At a minimum to import data, columns in the imported data containing the
following information must be specified:

• Date: of transaction;

• Account: into which transaction is to be imported (or alternatively set the base account as above);

• Description: of the transaction;

• Deposit or Withdrawal: column.1While we only want to import transactions, some banks send additional informations like a fieldname header or account status information as
header or footer.
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The dropdown list of GnuCash transaction data fields which may be associated with a column of the
imported data contains the following:

• None: The column is not assigned to a transaction data field and is not imported;

• Date: Ensure the date format in the column matches the Miscellaneous date Format Setting;

• Num: Transaction Num field - Use for check numbers etc.;

• Description;

• Notes;

• Transaction Commodity;

• Void Reason;

• Action;

• Account: This header should be matched to a column specifying the source account for a transac-
tion if it is present. Otherwise, set the source account in the Account combo box;

• Deposit: Apply this header to a column containing the amount of the transaction. Positive amounts
in the column generally represent an increase in the account balance and negative amounts a de-
crease in the balance (asset accounts: Checking, Savings). In external statements supplied by a
bank for a check or savings account, a credit (Cr) is normally an increase in the account balance
and a debit (Dr) a decrease in the account balance. In the banks eyes, your savings or checking
account is a Liability to them;

If the amount data is in separate columns for debits and credits you will have to apply both this
heading and the Withdrawal heading.

• Withdrawal: Apply this header to a column with the amount of the transaction where positive
amounts in the column represent a decrease in the account balance and negative amounts an in-
crease in the balance (e.g. Liability account: credit card).

Where separate columns are used for debits and credit to the account apply it to the opposite to
the column to which Deposits is applied;

Note

Some experimentation may be necessary to determine the correct allocation of the Deposit
and Withdrawal headings.

• Price: The price for commodity transactions and/or transactions involving currency exchange;

• Memo: Additional column containing descriptive information relevant to one split of a transaction.
If in the first line of a multi-split import it will apply to the source account. In subsequent lines/
splits it is applied to the transfer account defined in that line or allocated to it in the matcher;

• Reconciled: Apply to a column indicating the reconciliation status of the transaction. This gener-
ally only applies to data exported from GnuCash;

• Reconcile Date: Apply to a column which specifies the date of reconciliation, generally only for
GnuCash exported data;
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• Transfer Action;

• Transfer Account: This header should be applied to a column which specifies the transfer account
for the second split of a single line import and/or for subsequent splits in multiline exported trans-
actions;

• Transfer Memo: Apply to a column with descriptive information relevant to a split to a transfer
account specified by Transfer Account;

• Transfer Reconciled: Apply to a column with reconciliation status information relevant to a split
to a transfer account specified by  Transfer Account;

• Transfer Reconcile Date: Apply to a column containing a reconciliation date relevant to a split
to a transfer account previously specified in Transfer Account.

The Skip Errors check box will skip trying to import any rows with errors in matching the columns.

When you are happy with all the import settings, save them if you will use the same settings again,
then press the Next button.

4. Match Import and GnuCash accounts: This window allows you to map the accounts identified
in the account columns (Account and Transfer Account) with accounts in the GnuCash account tree
(Account name). Double click on a row to bring up a dialog to select the matching GnuCash account.
If you have previously imported transactions to this account and account mappings can be matched
automatically, this window will not be displayed. When you have selected a match for all accounts,
click on the Next button;

5. Transaction Information: The Transaction Information panel allows review of data entry settings
so far. Clicking Next will perform checks on the data. If there are errors you will be returned to the
Import Preview pane to edit the settings. For no errors you proceed to the next step;

6. Match Transactions: Clicking on Match Transactions will then bring up the main Import Matcher
window. The Import Matcher is described in a separate section;

7. Import Summary: GnuCash displays a summary of the imported data. Click on the Close to exit
the wizard.

Caution

Multi-split imports of multicurrency transactions and commodity transactions are experimental
and may currently experience some errors. Please experiment and report any bugs encountered.

Import several file formats with AQBanking
If GnuCash was built with AqBanking support and you have AqBanking installed on your computer you
may use Import using AQBanking to import files in several formats.

You will first be presented with a dialog box having two lists. The left one lists importer plugins and the
right one lists file format profiles available for that importer. In some cases, for example swift, the profiles
include specialized formats for particular bank: Continuing the example the swift importer can import both
generic MT940 and MT942 statements and those specialized for the Netherlands's AMRO Bank.

Select an importer and a profile from the lists. GnuCash will remember your selection for the next time
you do an import.

74



Common Transaction Operations

Click OK to proceed to the filechooser. Select a file to import and click the Import button to proceed.

GnuCash will process the selected file and map the account description in the import file onto the selected
account and use it for future imports from the same account. The imported transactions will then be dis-
played in the Generic Import Transaction Matcher for review.

Generic Transaction Import Matcher

Introduction

Figure 6.6. The Generic Transaction Import Matcher Window

This is an image of the import transaction matcher window after opening a file to import.

The Import Matcher checks whether an imported transaction matches an existing transaction already
recorded in GnuCash within a predefined time window (~+_42 days) for the account into which the trans-
actions are being imported. A match probablity is calculated based on the Date, Amount, Transaction ID's
(if present), Check numbers (if present) and the Description and split Memo fields. Exact matches will
generate a high match probability and flag a transaction as matching an existing transaction and therefore
not to be imported. If there is a lower quality match to an existing transaction, the imported transaction may
be flagged for updating of non-matching information in the GnuCash record of the matching transaction.
These decisions can be overridden by the user.

If no matching transaction can be identified the transaction will be flagged for import. The matcher will at-
tempt to assign a transfer account based on matches between tokenized information for previously import-
ed transactions stored in lists associated with the transfer accounts which were assigned to them on import.

• If a good match is obtained, the transfer account is assigned and the transaction is flagged as ready to
import.

• If a transfer account cannot be assigned, the transaction will be flagged for import and manual assign-
ment of the transfer account by the user. By default, if no transfer account is assigned, transactions will
be assigned to an Imbalance account on import. This is to indicate that they need an appropriate account
assigned to them.

Import Formats

The generic import transaction matcher is invoked when transaction data is imported using any of the
following import formats:

• QIF;
• OFX/QXF;
• CSV;
• MT940;
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• MT942;
• DTAUS.

Controls

List of Controls

This window has the following

Controls:

• List of downloaded transactions: Table containing information from the imported transactions.

• Show Account column: Checkbox to display the account into which the transactions are being import-
ed. This is the second column labelled Account in the screenshot;

• Show Memo column: Checkbox to display the Memo from the imported transactions after the column
labelled Description;

• Show matched information: Checkbox to display the matched transaction which has been already
imported or entered into GnuCash. If there is one, this will be a line with a white background (by default)
after the imported transaction. This is either the manually selected match if one has been selected or
the best possible match otherwise;

• Append: Checkbox to indicate that when updating and clearing a matched transaction, the imported
Description and Notes are to be appended to the matched transaction Description and Notes respectively,
rather than overwriting them. When the  OK button is clicked, the state of the checkbox is saved so the
next import for that account will automatically default it to the saved state;

• Reconcile after match: Checkbox to automatically start the reconciliation process after transactions
have been matched and imported;

• Help: Display a popup help window;

• Cancel: Close this window without importing transaction data;

• OK: Close this window importing transaction data;

List of downloaded transactions

The List of downloaded transactions has the following columns which display the following information
for each of the downloaded transactions:

Columns in “List of Downloaded Transactions”

• Date - The date supplied with the downloaded transaction;

• Account - The import or base account to which the transactions will be imported (optional see above);

• Amount - The amount of the transaction (split to the import or base account);

• Description - The description of the transaction;

• Memo - The memo for the split to the import or base account of the transaction (optional see above);
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• A - Add - Checkbox which indicates that the transaction is to be imported as a new transaction;

• U+C - Update and Clear - Checkbox which indicates that the transaction matches an existing transaction
but has some differences and the existing transaction will be updated with the different information;

• C - Clear - Checkbox which indicates that the transaction matches an existing transaction and will not
be imported;

• Info - For transactions which have been matched to an existing transaction, this column displays a bar
indicating the quality of the match;

• Additional Comments - Shows what is to happen to the transaction and the transfer account if known;

Import Status

In addition to the checkboxes, the import status of each transaction is indicated by the background color of
the transaction row. The checkbox state, background colors and their meaning are described in Table 6.1,
“Import Status of Transactions”.

Table 6.1. Import Status of Transactions

Checked
Box

Background Meaning

Gold
No matches, flagged for input and no transfer account
matched – Import as a new transaction. Intervention re-
quired to select a transfer account.

A

DarkSeaGreen1

No matches detected, flagged for input and a transfer ac-
count is matched – Import as a new transaction. Reconcil-
iation status will be set as cleared (c) on import. Interven-
tion is not required.

U+C DarkSeaGreen1

Matches an existing transaction but not exactly on date
and/or amount – Intervention not required, import and up-
date. Reconciliation status will be set as cleared (c) on im-
port.

C DarkSeaGreen1
Matches an existing transaction: – Not to be imported. The
existing transaction reconciliation status will be as cleared
(c) on import. Intervention is not required

 Brown1
Transaction has poor matches and no action was set: – Not
to be imported. Intervention required.

 Cornflower Blue Row is selected

Note

The colors illustrated here are the defaults for GnuCash specified in gnucash-fallback.css
[https://github.com/Gnucash/gnucash/tree/stable/gnucash/gnucash-fallback.css]. You may expe-
rience different colors if the gtk-3.0 CSS files have been modified

You may always intervene manually to

• change the import action by selecting another checkbox (or none) and/or

• manually assign a different transfer account
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after reviewing the matched transactions and accounts and the automatically selected actions.

Multi row selection is enabled for the list of downloaded transactions. The following operations can be
performed on the list of downloaded transactions:

• Click Button1 (see Mouse Buttons) on a row: Select this row (row is displayed with a blue back-
ground);

• Double-click Button1 on a row: If the transactions is flagged for import (see below) this will open
an account selection dialog to select a destination/transfer account to be used in the second split of the
imported transaction. You may create a new account if necessary in this dialog using the New Account
button. If the transaction is flagged as matching an existing transaction either for import or updating,
the match picker dialog is opened to allow the matched transactions to be examined and a correct match
selected;

• Ctrl+Button1 on a row: Add the row to a selection of rows (displayed with a blue background) to
which a single destination/transfer account may be applied;

• Shift+Button1 on a row: Select all rows between the last selected row and this row and add them to
the current selection of rows;

• Click Button2 in the window: Display a popup menu which when clicked in turn opens a dialog to
select a single destination/transfer account which will be applied to all rows currently selected.

Important

It is important to assign a transfer account to each transaction prior to import of the transactions.
Otherwise the tokenized information from the imported transaction will not be appended to the list
of tokens for an assigned account for use in future matching of transactions to transfer accounts.

Note

Note that "reconciled" in this context does not mean the same as "reconciled" in the process of
reconciling an account to an external statement. The reconciliation status of an imported transac-
tion is set to cleared (c) on import of a new transaction. See Setting the reconcile status (R field)
of a transaction for details of the values of reconciliation status.

Where a row has been matched to an existing transaction or is to update an existing transaction it will
have a DarkSeaGreen background. Double-clicking Button1 on the row will bring up the Match Picker
dialog which displays detail of the imported. If you, feel the wrong transfer account has been assigned or
the matcher has not produced a valid result, you may change the checkbox selection if you disagree with
the matcher decisions and you may reassign an assigned transfer account (see below).

Double-clicking Button1 on a row marked as New with a DarkSeaGreen1 background and a transfer
account assigned to it will bring up the account selection dialog to allow you to choose a different transfer
account for the second split.

Double-clicking Button1 on a row marked New with no transfer account matched with a Gold background
will also bring up the account selection dialog to allow you to assign a suitable transfer account to the
transaction.

Assign a Destination Account to a Single Transaction

Select the required row by clicking Button1 on it. It is displayed with a  Cornflower Blue background color.
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Double clicking Button1 on a row will select it and open an Account Selection dialog to allow you to
assign a transfer account. Select the desired transfer account in the dialog and click OK. The dialog has
a New Account button which will allow you to create a suitable account if there is no existing account
which can be applied as the transfer account.The row background will change to a  DarkSeaGreen1 and
the assigned destination account will be displayed in the Info column.

or alternatively, Button1 click on a row to select it followed by a Button2 click to bring up a popup menu
then select Assign a transfer account to display the Account Selection dialog, select the destination account
and click the OK button.

Assign a Destination Account to Multiple Transactions

Sometimes you will have several transactions which can have the same destination account. GnuCash
allows you to select multiple transactions and apply the same destination account to all transactions in
the selection.

Rows in a selection are displayed with a  Cornflower Blue background.

Only rows which have the A checkbox checked and either a  DarkSeaGreen1 or  Gold background colour
can be selected for inclusion in a multiple selection. Rows with a  Brown1 background or with the U+C
or C checkboxes checked cannot be selected in a multiple selection.

To select rows and add rows to a selection either:

• Click Button1 on first row and then  Ctrl+Button1  on other rows to add to the selection; or

• Click Button1 on first row and then  Shift+Button1  on another row to select all rows between them.

• Rubber banding is also enabled so you may also  hold Button1 and drag over rows to create a selection.
To add more rows,  Ctrl-Button1 and drag over more rows.

then  Button2  to display a popup menu and then select Assign a transfer account to open the Account
Selection dialog. Select the desired destination account (create a new account if necessary) and click the
OK button in the Account Selection dialog.

Completing the Import

Once you have assigned destination accounts for all the imported transactions using the above methods (all
row backgrounds will be a light green colour), check that the assigned destination acounts are correct and
then press the OK button at the bottom of Figure 6.6, “The Generic Transaction Import Matcher Window”.
The transactions selected for import will have their splits added to the selected source and destination
accounts.

The tokenized data from the transactions assigned to a given transfer account is stored on exiting from the
matcher and is used to match transactions to the appropriate transfer account in future imports.

Match Picker

The Match Picker allows you to review and edit existing GnuCash transactions which have been matched
to a transaction being imported. Button1 on a row with the C checkbox checked to bring this dialog up.
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Figure 6.7. The Match Picker Dialog

The Match Picker dialog window showing existing GnuCash transactions matching an imported transaction.

The top pane of the Match Picker displays details of the first split of the transaction to be imported. The
column labels:

• Account

• Date

• Amount

• Description

• Memo

• Balanced

are the same and have the same meaning as in the section called “List of downloaded transactions” with
the exception of the Balanced column which gives the amount of the balancing split for the transaction.

The lower pane displays the details of existing GnuCash transactions which match this transaction. If no
transactions are displayed check the Show Reconciled checkbox at the bottom of the panel. The first row
in this pane will normally be the auto-matched transaction with the best match score. Other rows will
display other existing transactions which might also be matches for the transaction being imported. The
columns in this pane are:

• Confidence: This column indicateds the confidence of the individual match as both a bar chart and a
numerical value. Where the bar extends into the green, the match is good. If the bar only extend to the
red or yellow setions the quality of match is more doubtful.

• Date

• Amount: If this does not match exactly the amount of the transaction being imported but otherwise
the match is good, the amount of the imported transactions is used to update the existing transaction
matching it.

• Description

• Memo
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• Reconciled: Indicates the reconciliation status of a matching existing transaction.

• Pending Action

If you are not happy with the existing transaction that was auto-matched, Button1 on your preferred match
to select it and then Button1 the OK. The transaction will then be marked as a (manual) match in the Info
column of the Import Matcher. To exit the dialog without changing the auto-match Button1 on the Cancel.

Import Match Editor
The Import Match Editor allows you to edit the data used by GnuCash to automatically assign a transfer
account in the Import Matcher. It can be used to edit the data used by the Bayesian matcher, the Non-
Bayesian matcher and online ID's. To open it select  Tools->Import Map Editor from the menu.

Figure 6.8. The Import Map Editor

The Import Map Editor illustrating typical entries for the Bayesian matcher.

The three radio buttons at the top of the dialog select the type of data being displayed and edited:

• Bayesian: The Bayesian matcher matches a transfer or destination account using the frequency of as-
sociation of a token string with an assigned transfer/destination account in the Import matcher for a
specific source account (the account that the first split of the imported transactionis directed to);

• Non-Bayesian: The Non Bayesian matcher matches the transfer account on the basis of the occurrence
of a token string in transactions assigned to a transfer/destination account and does not record the fre-
quency of association. This was the original GnuCash matching process and has now been superceeded
by the Bayesian matcher in more recent versions;

• OnlineiD: Online ids are specific strings which identify specific accounts in information downloaded
from online sources. they may include account numbers and specific instiution identifiers.
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The Bayesian matcher data columns are:

• Source Account: This is the account into which a transaction has been imported and is normally the
first split in an imported record. It may either be specified in the record itself or during the import setup
for all transactions to be imported. The arrow control at the left of each entry in this column may be
used to display all the data used in matching a transfer or destination account for transactions which
have this account as their source split;

• Match String: This column displays a specific token string that has been associated with the allocation
of the account in the Mapped to Account Name column as a transfer/destination account for transfers
to the Source Account;

• Mapped to Account Name: The account name in this column is a GnuCash account name which has
been allocated as a transfer/destination account in association with the token string in the Match String
column;

• Count of Match String Usage: This is the number of times the token string in the Match String column
has occurred in association with the transfer/destination account specified in the Mapped to Account
Name column for transactions imported to GnuCash.

The Non-Bayesian matcher displays the same first three columns as the Bayesian matcher having the
same usage. It does not store data on the frequency with which a particular token is associated with the
assignement of a given transfer/destination account. It has an additional column which specifies the type
of the imported data process in which the assignment occurred.It has the following columns:

• Source Account;

• Based on: This identifies the import process in which the Match String was associated with the transfer
destination account in the Mapped to Account Name column;

• Match String;

• Mapped to Account Name.

Online ID displays the same columns with the same data as the Non-Bayesian matcher.

The Filter textbox at the bottom of the dialog allows filtering of the displayed data matching the entered
string in either the Match String column or the Mapped to Account Name column.

The Expand All and Collapse All buttons expand or collapse the data in the other columns for the accounts
in the Source Account column.

The Delete button will delete any selected rows in the displayed matcher data.

The Close button closes the Import Match Editor dialog.

Exporting Transactions
GnuCash allows transaction data to be exported in CSV format with the optional use of alternative column
separators. Transactions can be exported in either a single line format (simple layout) which can only be
used for transactions with two splits and may not allow all the data associated with a transaction to be
exported or in a multiline format where two or more lines are used for transactions with two or more splits
with each splits information on separate lines. Transaction data can be exported either from the currently
selected active register or from selected accounts. The menu commands to export transactions are:

• File->Export->Export Transactions to CSV;
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• File->Export->Export Active Register to CSV.

These commands start the wizard illustrated in to setup the export. They differ only in that in the latter
case the Account Selection step is not available in the left hand pane.

Figure 6.9. The Export Transactions Wizard.

The Export transaction wizard opens at the first step and performs the steps listed in the left hand pane:

• Choose Export Settings;

• Account Selection;

• Choose File Name for export;

• Export Now...;

• Export Summary.

Navigation between the steps uses the buttons displayed in the right hand lower corner of the wizard.
Which of the following buttons are displayed will depend on what is permissible from the step:

• Cancel: Exit the wizard without exporting any transactions;

• Back: Return to the previous step in the wizard;

• Next: Proceed to the next step.

Choose Export Settings
This step allows you to choose various options in the formattig of the transactions being exported.

The Options checkboxes may be selected singly or both may be selected together:

• Quotes: Surround each data field in quotes;

• Simple layout: If checked, the ouput transaction data will be as displayed in the single row register
view option and some of the transfer detail may be lost.

The column headers for data exported in Simple layout format are:

1. Date
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2. Account Name: name of the source account;

3. Number

4. Description

5. Full Category Path: full account name for transfer/destination account;

6. Reconcile

7. Amount with Sym

8. Amount NUm

9. Rate/Price

If Simple layout is not checked the transaction data will be exported in a multi-line format.

The column headers for a multiline output for a transaction are:

1. Date: first line only;

2. Transaction ID: first line only;

3. Number: first line only;

4. Description: first line only

5. Notes: first line only;

6. Commodity/Currency: first line only;

7. Void Reason: first line only;

8. Action: first line and subsequent lines;

9. Memo: first line and subsequent lines;

10.Full Account Name: first line and subsequent lines;

11.Account Name: first line and subsequent lines;

12.Amount with SYm: first line and subsequent lines;

13.Amount Num: first line and subsequent lines;

14.Reconcile: first line and subsequent lines;

15.Reconcile Date: first line and subsequent lines;

16.Rate/Price: first line and subsequent lines;

Each line contains the data relevant to a single split with the first line also having transaction data
relevant to all splits in the first 7 columns.

The Separators radio buttons allow the choice of an alternative column separator:

• Comma(,): This is the default separator;
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• Colon(:): Use a colon to separate the columns;

• Semicolon(;): Use a semicolon to separate the columns;

• Custom: Define a custom character to separate the columns by entering it in the textbox.

Button1 on Next to go to the next step.

Account Selection
This step allows selection of one or more accounts and the specification of the date range containing the
transactions to be exported.

The Accounts panel displays an account tree which allows one or more accounts to be selected for export.
( Ctrl-Button1> and Shift-Button1 may be used to select accounts). The Select Subaccounts button will
select all subaccounts of a selected account. The Select All button will select all accounts in the account
tree for export. The number of accounts which have been selected is indicated.

The Dates panel allows selection of either all transactions or only those within a selected date range in
the selected accounts to be exported.

Choose File Name for export
A file selection dialog is presented allowing specification of a file name and a path to the directory/folder
in which it is to be stored.

Export Now...
The filename and path of the file to be exported and the number of accounts to be exported is displayed.
To continue with the export Button1 the Apply button.

Export Summary
Displays a message if the file is successfully exported or an error message and debugging suggections
if not.

Online Actions ...
Important

For each account on which you want to execute this actions you will have to run the the section
called “The Online Banking Setup Assistant” once.

Note

This section is "under construction - any input will be welcome !!".

Get Balance

Get Transactions ...
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Issue Transaction

Direct Debit

General Journal
The General Journal is an advanced register used to enter transactions without needing to open individual
accounts. The General Journal shows the transaction entries for all accounts on one register.

Entering transactions in the General Journal is more complicated than entering them in the individual ac-
count registers. The advantage is the General Journal provides a more comprehensive view of the trans-
actions you have entered in all your accounts.

The General Journal defaults to showing only the previous month of transactions. This is changeable by
using the "Filter By..." on the View menu.
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Chapter 7. Business Features
The accounting needs of a business are quite different from that of a person. Businesses have customers
that owe money, vendors which are owed money, employee payroll, more complex tax laws, etc. GnuCash
offers business oriented features to facilitate these needs.

Accounts Receivable (A/R) are used by businesses to record sales for which they are not immediately paid.
Accounts Payable (A/P) record bills that they have received, but might not pay until later. These types of
accounts are used primarily when you have a lot of bills and receipts flowing in and out, and do not want
to lose track of them just because you do not pay or get paid right away. For most home users, A/R and
A/P are too complicated to be worth the effort.

Accounts Receivable (or A/R) refers to products or services provided by your company for which payment
has not yet been received. This is represented on the balance sheet as an asset, because the expectation is
that you will receive payment soon.

Accounts Payable (or A/P) refers to products or services bought by your company for which payment has
not yet been sent. This is represented on the balance sheet as a liability because you will have to pay for
them.

Initial Setup
To set up GnuCash to handle accounts receivable and accounts payable for a company the following
preliminary steps must be done.

Account Setup
There are many different ways to set up a business account hierarchy. You can start with the Business
Accounts setup which is available from the New Account Hierarchy assistant, or you could build one
manually. To access the prebuilt Business Accounts, start GnuCash and click on File → New File and
proceed until you see the list of available accounts, select Business Accounts.

Note

The prebuilt Business Account hierarchy will not meet your needs exactly. You will need to make
adjustments for the hierarchy to function well with your particular situation. It should be close
enough that it is recommended you begin with it.

Tax Tables
Tax Tables can used to determine the tax for customer invoices (or vendor bills).

A tax table can be assigned to an invoice line or bill line.

The default invoice line tax table can be assigned to each customer and the default bill line tax table can
be assigned to each vendor.

The default tax table for new customers or new vendors can be specified in the Book Options  window
which can be accessed by File → Properties → Business tab.

Tax Tables are maintained using the Sales Tax Table editor which is accessed via menu Business → Sales
Tax Table . The following fields should be entered:

• Name This is the tax table name.
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• Type Either Percent % or Value $.

• ValueThis is the percentage or value depending on Type.

• Account This is the account to which tax will be posted. For tax collected from customers, this should
probably be a Liability account as it must be payed to the government. For tax paid to vendors, if tax
laws allow tax paid to vendors to offset tax collected from customers, this should probably also be
a Liability account (even though it will usually have a debit balance) so that the net tax owed to the
government can be easily observed.

If you set up Tax on Purchases and Tax on Sales as subaccounts of Liabilities:Tax then the net tax will
be rolled up and can be seen in the GnuCash Accounts tab.

If unsure about tax law requirements, get professional advice.

Company Registration
After you have built the account structure and defined your tax tables, register the GnuCash file as belong-
ing to your company by filling in the data requested in the the section called “Business Book Options Tab”
accessible from the File → Properties menu item.

Counters
Define the format and last used numbers of codes such as customer, invoice, vendor, bill, employee, ex-
pense voucher, job number and order. See the section called “Counters Book Options Tab”.

Business Preferences
Set options on the Business tab of the GnuCash preferences, which is accessed via Edit → Preferences
( GnuCash → Preferences on macOS). See the section called “Business”.

Billing Terms
Billing Terms can be used to determine the payment due date and be a guide for determining discount for
early payment of invoices (or vendor bills).

Caution

As of GnuCash 2.6.7, Billing terms are only partially supported. Date due is calculated but dis-
count amount is not.

Discount for early invoice payment is not implemented. There are 2 ways this may be done, al-
though neither is recommended, and professional advice should be used to confirm that regula-
tions are being complied with:

• After creating and posting a payment which pays the invoice in full, manually edit the payment
transaction (usually strongly discouraged) and split the payment to reduce it by the amount of
the discount and a create a compensating split in an income (discount) account.

• Alternatively, after creating and posting a payment for the discounted amount, create a credit
note for the discount using a specific negative sales income (discount) account for the transfer
account.

You can specify the billing terms on each invoice/bill. Invoice billing terms will default from the customer
billing terms. Bill billing terms will default from the vendor billing terms.
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Billing Terms are maintained using the Billing Terms Editor which is accessed via menu Business →
Billing Terms Editor . The following fields should be entered:

• Name The internal name of the billing term. For some examples of billing term names and descriptions
see https://wiki.gnucash.org/wiki/Payment_Terms

• Description The description of the billing term, printed on invoices

• There are 2 types of billing terms, with different information to be entered

• Type Days

• Due Days The invoice or bill is due to be paid within this number of days after the post date

• Discount Days The number of days after the post date during which a discount will be applied for
early payment

• Discount % The percentage discount applied for early payment

• Type Proximo

• Due Day The day of the month bills are due

• Discount Day The last day of the month for the early payment discount

• Discount % The discount percentage applied if paid early

• Cutoff Day The cutoff day for applying bills to the next month. After the cutoff, bills are applied
to the following month. Negative values count backwards from the end of the month.

Accounts Receivable
GnuCash has an integrated accounts receivable system.

To use GnuCash’s integrated accounts receivable system, you must first set up Accounts Receivable ac-
counts of type A/Receivable under Assets to accrue income you're owed. It is within this account that the
integrated A/R system will place transactions, debiting it when you post bills and crediting it when you
receive payments.

Example 7.1. Basic A/R Account Hierarchy

-Assets
  -Accounts Receivable
  -Checking
-Income
  -Sales
-Liabilities
  -Tax
    -Tax on Purchases
    -Tax on Sales

Important

If you deal with customers in more than one currency you will need a separate Accounts Receiv-
able account for each currency:
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-Assets
  -Accounts Receivable
    -CHF
    -EUR
    :

Note

You need to add additional asset, expense, and income accounts to this hierarchy for it to be
useful. The important aspects of this hierarchy are the use of an income account and the Accounts
Receivable asset account, with account type set to A/Receivable.

The transactions generated by the A/R system are recorded within the Accounts Receivable account. You
generally do not work directly with this account. You generally work with the four integrated GnuCash A/
R application components available through the Business → Customer sub-menu. These four components
are:

the section called “Customers”

People or companies to whom you sell products or services on credit.

the section called “Invoices”

The physical invoice you send to a customer to request payment. This invoice contains an itemized
list of things you sold.

the section called “Customer Jobs”

Is where you register Customer Jobs. Jobs are a mechanism by which you can group multiple invoices
to a particular customer.

the section called “Process Invoice Payment”

Used to register payments you received from a customer.

The following sections introduce the individual components in more detail.

Customers
Customers are people or companies to whom you sell goods or services. They must be registered within
the A/R system.

New
To register a new customer, enter the menu Business → Customer → New Customer . Fill in customer
information, such as Company Name, Address, Phone, Fax, etc. Below is a list of the other options:

• Identification - Customer Number - can be any number by which you would like to refer to this customer.
You may leave it blank and a number will be chosen automatically. See the section called “Counters
Book Options Tab” for more info.

• Identification - Active - differentiates active customers from inactive ones. This is useful when you have
many past customers, and you want to see only those marked active.

• Billing Address - Name - is the contact name of the person to receive the invoices.
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• Notes - records any additional comments about the customer.

• Billing Information - Currency - specifies the billing currency for this customer. It will default to the
default currency set in Preferences

Important

All invoices will be denominated in this currency and GnuCash will require an Accounts Re-
ceivable account in this currency.

• Billing Information - Terms - specifies the default billing terms for this customer. Billing terms must
be preregistered using Business → Billing Terms Editor .

• Billing Information - Discount - gives the customer a default percentage based discount at the time of
invoice creation. Enter a value from 0 to 100. You can override the default discount when you create
an invoice.

• Billing Information - Credit Limit - stores the maximum credit you are willing to extend to the customer.
This field is for your reference purposes only. GnuCash does not use the value.

• Billing Information - Tax Included - this specifies whether nor not tax is included in invoice amounts
by default. You can choose Yes, No, or Use Global.

• Yes means that the tax is already included in amounts on invoices.

• No means tax is not included.

• Use Global means to use the setting made in the global preferences accessible through Edit → Pref-
erences ( Gnucash → Preferences on macOS).

• Billing Information - Tax Table - specifies a default tax table to apply to invoice line items. Tax tables
must be registered from the Business → Tax Table Editor menu item.

• Shipping Address - records the customer’s shipping address if it is different from the billing address.
The shipping address is for your reference. GnuCash does not use the value.

Find and Edit
To search for an existing customer, use the Business → Customer → Find Customer window. You select a
customer to View/Edit from the results of the search. This window is also used to look up customers when
creating invoices and processing payments.

If many customers match the search criteria you provide, the search can be refined by running an additional
search within the current results. The current result set is searched when the Refine Current Search radio
button is selected. In fact, GnuCash selects this option for you after you run the initial search.

If the customer you are searching for does not match the supplied search criteria, change the search criteria,
click the New Search radio button and then the Find button. The relevant step is the New Search selection.
If the customer is not in the result of the original search, and you only search within this set, the customer
cannot be found, regardless of new search criteria.

Tip

To return a list of all registered active customers, set the search criterion to matches regex, and
place a single dot "." in the text field area. Make sure Search only active data is checked, then
click Find. The regular expression "." means to match anything.
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Invoices
An invoice is the paperwork you send to a customer to request payment for products or services rendered.
GnuCash can generate and track invoices.

A credit note is the paperwork you send to a customer to correct products or services rendered that were
incorrectly invoiced. GnuCash can generate and track credit notes via the same menu entries as invoices.

Note

This section applies to both invoices and credit notes. In order to avoid repeating everything
twice and to keep the text easier to read it will refer only to invoices. You can apply it equally to
credit notes. Only where the behaviour of credit notes differs from invoices this will be explicitly
mentioned. Credit notes were introduced starting with GnuCash stable release 2.6.0.

New

To send an invoice to a customer you must first create a new invoice. To create an invoice use Business
→ Customer → New Invoice . The New Invoice window must be filled in appropriately:

• Invoice Information - Type: the type of customer document to create - either an invoice or a credit note.

• Invoice Information - Invoice ID (optional): the formated identification number of this invoice. This
is your internal number for this invoice. If you leave it blank, an invoice number will be generated
automatically. See the section called “Counters Book Options Tab” for more info.

• Invoice Information - Date Opened: the date this invoice was created.

• Billing Information - Customer: the customer who is to receive this invoice. If you remember the com-
pany name you entered in the New Customer window for this customer, start to type it in this field and
GnuCash will try auto complete it for you. Else, press the Select... button to access the Find Customer
window described in the section called “Find and Edit”. Highlight the customer you are looking for with
a click in the search results, then press the Select button.

• Billing Information - Job (optional): associates the new invoice with a customer job (see the section
called “Customer Jobs”). If you remember the job name you entered in the New Job window for this
job, start to type it in this field and GnuCash will try auto complete it for you. Else, press the Select...
button to access the Find Job window. This window is the same to the one described in the section
called “Find and Edit”. Highlight the job you are looking for with a click in the search results, then
press the Select button.

• Billing Information - Billing ID: this is the customer’s PO Number or other “customer reference num-
ber”. You should use it to identify your invoices to this customer (and job, if you have one).

• Billing Information - Terms: the payback terms agreement for this invoice. A list of registered terms is
available within the pop up menu. If you specified a default value for the selected customer, this field
is initialized with the default.

• Notes: Here you can enter internal notes.

When you click the OK button, the Edit Invoice window opens.
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Edit
From the Edit Invoice window you can enter an itemized list of goods and services you sold on this invoice
in a manner similar to how the account register works. For credit notes you enter an itemized list of goods
and services you refunded instead.

Tip

Saved column layout works a bit differently in invoices from the account registers: Layouts are
not saved for each invoice; instead a layout can be saved as a default for invoices to override the
calculated widths using the View>Use as Default Layout for Customer Documents and the cal-
culated widths restored as the default with View>Reset Default Layout for Customer Documents.

There are 15 columns in the Invoice Entries area:

• Date - The date this item was sold.

• Invoiced? - X means the item is attached to this invoice, an empty box means the item is not attached
to this invoice. The item is attached for you when you proceed to the next line item.

• Description (optional) - is what the item or service is called.

• Action (optional) - is a user defined field. You can place Cost Center information here, or use one of
the 3 predefined actions, Hours, Material, or Project.

• Income Account - selects which income account is credited with this income.

• Quantity - tracks how many of the items you sold.

• Unit Price - is the unit price of the item.

• Discount Type - is the type of discount:

• $ means Discount is a monetary value

• % means Discount is a percentage.

You can click the field to toggle between the discount types.

• Discount How - the discount can be computed as follows:

• > means the discount applies after tax.

• < means the discount applies before tax.

• = means both discount and tax are applied to the pretax value.

You can click the field to change the setting.

• Discount (optional) - is the total discount, in monetary units or percentage, depending on Discount Type.
You can leave it blank for no discount. Any default discount you specified for the customer will be
automatically entered for each new item.

• Taxable? - is this item taxable? X means yes, a blank field means no. You can click the field to toggle
the setting.

• Tax Included? - has the tax already been included in the unit price? X means yes, a blank field means
no. For example, if there is 1 item of $100 with a tax of 5% then:
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• If Tax Included is empty, then subtotal = $100 and tax = $5.

• If Tax included is set (X), then subtotal = $95.23 and tax = $4.77. The computation is: Subtotal =
Total / (1+taxrate) and Tax = Total - Subtotal = Total - (Total / (1+taxrate)).

• Tax Table (optional) - this is a pop up menu of all the available tax tables. If you make the item taxable,
then this table is used to compute the amount of tax. The tax table determines tax percentages and the
accounts to which tax is charged.

• Subtotal (uneditable) - is the computed subtotal for this item (less tax).

• Tax (uneditable) - is the computed tax for this item.

When you have finished entering all the items, you can Post and print the invoice.

Post
When you finish editing an invoice and are ready to print, you must Post the invoice. The invoice does
not have to be posted immediately. In fact, you should only post an invoice when you are ready to print it.
Posting an invoice places the transactions in an accounts receivable account.

The Post Invoice window appears and asks you to enter the following information:

• Post Date - specifies the date for the transactions entered into the accounts receivable account. By default
this is the invoice’s Date Opened (see the section called “New” for information about that date).

• Due Date - is the date on which payment for the invoice is expected.

• If you specified payment terms when you created the invoice, the date is calculated according to
selected terms, and the entry field is insensitive.

• If you did not specify payment terms, enter the expected payment due date here.

• Description - is an arbitrary description. When invoice transactions are placed in the accounts receivable
account, this description is entered in the memo field of those transactions.

• Post To Account - selects the accounts receivable account in which invoice transactions are posted. You
can select the account from a list of existing A/Receivable accounts.

• Accumulate Splits - determines if invoice items which transfer to the same account are combined into
a single split for that account or entered individually. For the sample invoice which sold Nails and a
Hammer, the setting affects post results as follows:

• Checked (splits are accumulated) - a single transfer of $575.00 from the Income:Sales account is
recorded.

• Not checked - the transaction created in the A/Receivable account, shows two transfers from In-
come:Sales account $100.00 and $475.00. The memo fields in the splits indicate the sale of Nails and
the Hammer (the item descriptions entered on the invoice) respectively.

Find

To find an existing invoice, use the Business → Customer → Find Invoice menu item. From the results of
the search, you can select an invoice to edit or view.
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Important

Before you can edit a posted invoice, you will need to Unpost it.

One of the design goals in GnuCash’s Account Receivable system was to allow different processes to get
to the same state, so you can reach an invoice from different directions based on the way you think about
the problem:

• You can search for the customer first, then list their invoices.

• You can search for invoices by number or by company name.

• You can list invoices associated with a customer job.

Print
After you post an invoice, you should print it and send it to your customer. To print an invoice use File
→ Print Invoice menu item.

Tip

You can modify the appearance of the invoice, IE: add a company logo, etc. To do so, see the the
section called “Changing the Invoice Appearance”.

Invoices can also be printed from the main window by selecting Reports → Business Reports → Printable
Invoice from the main menu. The resulting report window states that no valid invoice is selected. To select
the invoice to print:

1. Use the Options Toolbar button or select Edit → Report Options from the main menu.

2. Select the General tab of the report options dialog.

3. Click the Select button next to the Invoice Number field.

4. Search for the invoice as usual.

You can also print invoices from within the Process Payment dialog. See the the section called “Process
Invoice Payment” for instructions on how to do so.

Assign Starting Invoice Number
By default, GnuCash starts with invoice number 1 and increments from there. You can manually type an
invoice number into the text box each time you create an invoice, but this gets tiring and sooner or later
leads to duplicate numbers.

You can change the starting invoice number if it is important you. Use File → Properties , access the
Counters tab, change the Invoice number value to be one less than your desired starting invoice number
and click the OK button or the Apply button.

Customer Jobs
Customer Jobs are used to group multiple invoices and credit notes to the same customer. Use of the
Customer Jobs feature is optional. The feature is useful when you have multiple jobs for the same customer,
and would like to view all the invoices and credit notes related to a single job.
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To use customer jobs, you must create them using the Business → Customer → New Job menu item. You
will see the New Job window. The editable fields are:

• Job Info - Job Number (optional) - enter the number for this job. If left blank, a number will be chosen
for you. See the section called “Counters Book Options Tab” for more info.

• Job Info - Job Name - the name you want to assign to the new job.

• Owner Info - Customer - the customer for whom the job is created. If you remember the company name
you entered in the New Customer window for this customer, start to type it in this field and GnuCash
will try auto complete it for you. Else, press the Select... button to access the Find Customer window
described in the section called “Find and Edit”. Highlight the customer you are looking for with a click
in the search results, then press the Select button.

• Owner Info - Billing ID - the customer’s reference to this job (e.g. their PO Number). This is the "Billing
Identification" that they require to correlated your invoices with their order. The Billing ID you enter is
used to set the billing id for new invoices associated with this job.

• Job Active - toggles this job being active or not. This is useful when you have many inactive jobs, since
it is easier to search only among jobs that are marked active.

To edit an existing customer job, use the Business → Customer → Find Job menu item. Select the desired
job in the search results, and click the View/Edit Job button.

To select from the invoices and credit notes associated with a given job, use Business → Customer → Find
Job menu item. Select the desired job in the search results and click the View Invoices button. A window
listing invoices and credit notes associated with this job appears. Select an invoice or credit note and click
the View Invoice button to open an invoice editor in the main application window.

Process Invoice Payment
Eventually, you will receive payment from your customers for outstanding invoices. To register these
payments, use the Process Payment application found in Business → Customer → Process Payment .

Tip

There is an alternative way of assigning a payment to (one or more) invoices where the payment
transaction already exists, say in the case where transactions have been imported from a bank.
There is no way to assign a payment to an invoice during the import process, so this must be done
after transactions have been imported.

This can best be done starting from the asset account register holding the imported payment
transaction (like your bank account). In that account, select the payment, right-click (control-click
for macOS) and choose Assign as payment.... The payment window will pop-up, partly filled in
with the information from the transaction. Fill in the missing information like the proper customer
and invoice to complete the payment.

One caveat: the logic behind Assign as payment... won't properly detect credit note reimburse-
ments and will wrongfully interpret such a transaction as a vendor bill.

The Process Payment application consists of:

• Payment Information - Customer - the customer who paid you. If you remember the company name
you entered in the New Customer window for this customer, start to type it in this field and GnuCash
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will try auto complete it for you. Else, press the Select... button to access the Find Customer window
described in the section called “Find and Edit”. Highlight the customer you are looking for with a click
in the search results, then press the Select button.

• Payment Information - Invoice - the invoice for which payment was received. If you remember the
invoice ID, start to type it in this field and GnuCash will try auto complete it for you. Else, press the
Select... button to access the Find Invoice window described in the section called “Find”. Highlight the
invoice you are looking for with a click in the search results, then press the Select button.

• Payment Information - Date - the date you you received payment.

• Payment Information - Amount - the amount of money received.

• Payment Information - Num - the check number.

• Payment Information - Memo - any comments about this payment.

• Post To - the A/Receivable account to which to post this transaction.

• Transfer Account - the account where the money will be deposited (a checking account for example).

Over Payments or Pre-Payments
If a customer overpays an invoice or pays for goods or services before they have been invoiced, Process
Payment for the total amount received. GnuCash will then keep track of the over-payment (or pre-payment)
in the A/R account and you can use the residual when paying the next invoice.

Partial Payments
Partial payments are possible too. Select the invoice to pay. GnuCash will automatically suggest that
invoice's remaining balance as payment amount. Simply adjust that amount to what you want to pay.

Writing Off a Bad Debt

Important

Please check with your accountant to ensure the following is acceptable in your region.

The usual way to do this is to process a payment for the invoice to a BadDebt account. Such an account
would be an expense account. However, in GnuCash, you can't process a payment for an invoice directly
to an expense account, so it takes two steps:

1. Pay the invoice to an asset or liability account, such as your checking account.

2. Change the asset or liability account, in the  non Accounts Receivable split of the payment transaction,
to the BadDebt expense account.

Specifically

• Remove all transactions from the A/R account related to the invoice, except for the invoice's transaction
itself. This includes any payment transactions, and transactions between your BadDebt and A/R account.

In case the payment has associated lot link transactionsa, remove those as well.
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If all is well, your Process Payment window for this customer should list the invoice the customer won't
pay, and no prepayments.

• Pay your invoice to an arbitrary asset or liability account. It can be your checking account. We will fix
that in the next step.

• Open the account register for your A/R account. For this invoice there should now be one payment
transaction. If you are using GnuCash 2.6.0 - 2.6.4 there will also be one lot link transactiona.

• Select the payment transaction and change the transfer account to your BadDebt account. Make sure to
leave the transaction (eg by clicking on another transaction) to save the changes.

If all is well, your Process Payment window should still be clean: no pre-payments, and the bad debt
invoice gone.

Caution
a GnuCash version

2.6.0 to 2.6.4

created lot link transactions which show in the A/R account register. This came with its own
set of subtle issues.

2.6.5

had a flaw in the logic cleaning up the lot links.

It is recommended to upgrade to the latest (or at least 2.6.6) version, which fixes a lot of small
problems. Once upgraded, please run Actions → Check & Repair to clean up most of the lot link
legacy. Don't forget to make a backup first just in case.

Distinction between Lot and Lot link

Lots

are used internally for relating payments to invoices. Lots themselves are invisible in the
account registers. To see them you need to open the lot viewer, which can be found in Actions
→ View Lots… while in any A/R or A/P account register. Select a lot to see the Splits in lot.

Lot links

are transactions which you can see in your A/R and A/P accounts. They are unusual in the
sense that all their splits are in one account (A/R or A/P). Each split in a lot link transaction
is linked (hence the name) to an invoice or payment transaction by means of a lot.

See https://wiki.gnucash.org/wiki/Business_Features_Issues for more information.

Changing the Invoice Appearance
The default Invoice style, as shown in the section called “Print”, is fairly barren. The default invoice style
leaves the top part of the form blank, so you can print on company letterhead paper. There are some things
you can do to change invoice appearance.

Use File → Properties to enter your Company information in the Business tab of the Book Options window.
Some of the entered information is printed on the right side of invoices.
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To add a customized background, heading banner or logo to invoices, modify the invoice style sheets.
To do this, go to Edit → Style Sheets and select the New button in the Select HTML Style Sheet window
that will appear.

Give a Name to the new style sheet (e.g. Custom Invoice) and select the Fancy Template. When you click
the OK button, the HTML Style Sheet Properties window is displayed. This window presents you five
sections listed in the left pane: Colors, Fonts, General, Images, and Tables. The Colors section allows you
to change the colors of various items of the invoice. The Fonts section lets you set font type and dimensions.
The General section allows you to set the Preparer and Prepared for information, and to Enable Links. The
Images section allows you to import graphics into the style sheet. The Tables section allows you to adjust
the spacing around the tables which make up the invoice.

To include a company logo, banner heading and background image, use your favorite graphics application
such as The Gimp or OpenOffice Draw to save the images in either GIF or PNG format. Then import them
into the style sheet using the Images section described above.

Note

The images are placed in the invoice as follows. The Background Tile is tiled to become the
background image, the Heading Banner goes above the invoice text, and the Logo is placed in the
upper left corner of the invoice to the left of the Heading Banner. You will probably have to try
a few different sized images until you get the invoices to print nicely. Some sizing suggestions
are that the Logo should be 1 square cm (~0.5 inch), and the Heading Banner should be 15 cm
(~6 inches) wide and 1 cm (~0.5 inch) tall.

With the style sheet configured, when you print the invoice, you select the style sheet to use from the
Options menu.

Accounts Payable
GnuCash has an integrated accounts payable system. As with Accounts Receivable you must have an
Accounts Payable account set up under Liabilities for each currency in which you will issue invoices.
The Accounts Payable accounts accrue the amounts you owe to others, so bills credit these accounts and
payments and credit memos debit these accounts. Generally you do not directly work with this account
but use the four integrated GnuCash A/P application components. The A/P components are available from
the Business → Vendor sub-menu.

These A/P components are:

• Vendors are people or companies from which you buy products or services on credit.

• Bills represent the physical bills vendors send to request payment from you. A bill contains an itemized
list of things you purchased.

• Jobs (optional) is where you register Vendor Jobs. Jobs are a mechanism by which you can group
multiple bills from a particular vendor.

• Process Payments is where you register payments to a vendor to whom you owe money.

The following sections introduce the individual Accounts Payable application components.

Vendors
A vendor is a company or person from whom you purchase goods or services. Vendors must be registered
within the A/P system.
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New
To register a new vendor, select the Business → Vendor → New Vendor menu item. Fill in general infor-
mation about the vendor, such as Company Name, Address, Phone, Fax, etc. Below is a list of the other
options:

• Identification - Vendor Number - can be any number by which you would like to refer to this vendor.
You may leave it blank and a number will be chosen automatically. See the section called “Counters
Book Options Tab” for more info

• Identification - Active - differentiates active vendors from inactive ones. This is useful when you have
many past vendors, and you want to see only those marked active.

• Payment Address - Name - is the contact name of the person to receive payments you make.

• Notes - records any additional comments about the vendor. Use it to track names of contact people
within the vendor’s company, for example.

• Payment Information - Currency - specifies the payment currency for this vendor. It will default to the
default currency set in Preferences

Note

All Bills and Credit Notes will be denominated in this currency and GnuCash will require an
Accounts Payable account in this currency.

• Payment Information - Terms - specifies the default payment terms for this vendor. Payment terms must
be preregistered using Business → Billing Terms .

• Payment Information - Tax Included - specifies if tax is included in bills from this vendor. You can
choose Yes, No, or Use Global.

• Yes means that tax is already included in amounts on bills.

• No means tax is not included.

• Use Global means to use the setting made in the global preferences accessible through Edit → Pref-
erences ( Gnucash → Preferences on macOS).

• Payment Information - Tax Table - specifies a default tax table to apply to bills from this vendor. Tax
tables must be registered using the Business → Tax Table menu item.

Find and Edit
To search for an existing vendor, use the Business → Vendor → Find Vendor window. You select a vendor
to View/Edit from the results of the search. This window is also used to look up a vendor when entering
bills and processing payments.

If many vendors match the search criteria you provide, the search can be refined by running an additional
search within the current results. The current result set is searched when the Refine Current Search radio
button is selected. In fact, GnuCash selects this option for you after you run the initial search.

If the vendor you are searching for does not match the supplied search criteria, change the search criteria,
click the New Search radio button and then the Find button. The relevant step is the New Search selection.
If the vendor is not in the result of the original search, and you only search within this set, the vendor
cannot be found, regardless of new search criteria.
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Tip

To return a list of all registered active vendors, set the search criterion to matches regex, and place
a single dot “.” in the text field area. Make sure Search only active data is checked, then click
Find. The regular expression “.” means to match anything.

Bills
A bill is a request for payment you receive from a vendor. GnuCash can track bills.

A credit note is the document you receive from a vendor to correct products or services rendered that you
were incorrectly charged for on a bill. GnuCash can generate and track credit notes via the same menu
entries as bills.

Note

This section applies to both bills and credit notes. In order to avoid repeating everything twice and
to keep the text easier to read it will refer only to bills. You can apply it equally to credit notes.
Only where the behaviour of credit notes differs from bills this will be explicitly mentioned.

New
When you receive a bill from a vendor and want to enter it into GnuCash, you must create a new bill.
To create a new bill use the Business → Vendor → New Bill menu item, and fill in the resulting window
appropriately.

• Bill Information - Type - the type of vendor document to create - either a bill or a credit note.

• Bill Information - Bill ID (optional) - the identification number of the invoice as emitted by the vendor
(IE: the vendor’s internal number for this invoice).

• Bill Information - Date Opened - the date the Invoice was emitted by the vendor.

• Billing Information - Vendor - the issuing vendor. If you remember the company name you entered in
the New Vendor window for this vendor, start to type it in this field and GnuCash will try auto complete
it for you. Else, press the Select... button to access the Find Vendor window described in the section
called “Find and Edit”. Highlight the vendor you are looking for with a click in the search results, then
press the Select button.

• Billing Information - Job (optional) - associates a vendor job (see the section called “Vendor Jobs”) with
this bill. If you remember the job name you entered in the New Job window for this job, start to type it
in this field and GnuCash will try auto complete it for you. Else, press the Select... button to access the
Find Job window. This window is very similar to the one described in the section called “Find and Edit”.
Highlight the job you are looking for with a click in the search results, then press the Select button.

• Billing Information - Billing ID (optional) - the vendor’s ID for the bill (e.g.: their invoice #).

• Billing Information - Terms - the pay back terms agreement for this bill. A list of registered terms is
available within the pop up menu. If you specified a default value for the selected vendor, this field is
initialized with the default.

• Default Chargeback Project - Customer (optional) - the customer to associate with this bill. This is used
to charge your customer later.
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• Default Chargeback Project - Job (optional) - the customer job to associate with this bill.

When you click the OK the Edit Bill window opens.

Edit
From the Edit Bill window you can enter an itemized list of goods and services you purchased, in a manner
similar to how the account register works. For credit notes you enter an itemized list of goods and services
the vendor refunded instead.

Note

Saved column layout works a bit differently in invoices from the account registers: Layouts are
not saved for each invoice; instead a layout can be saved as a default for invoices to override
the calculated widths using the View>Use as Default Layout for Vendor Documents and the
calculated widths restored as the default with View>Reset Default Layout for Vendor Documents.

There are 12 columns in the Invoice Entries area:

• Date - The date this item was sold.

• Invoiced? - X means the item is attached to this invoice, an empty box means the item is not attached
to this invoice. If the box is empty you can attach the item to the invoice by first selecting the item row
and then clicking in this box.

• Description (optional) - is what the item or service is called.

• Action (optional) - is a user defined field. You can place Cost Center information here, or use one of
the 3 predefined actions, Hours, Material, or Project.

• Expense Account - selects the expense account to charge for this item.

• Quantity - tracks how many of the items you bought.

• Unit Price - is the unit price of the item.

• Taxable? - is this item taxable? X means yes, a blank field means no. You can click the field to toggle
the setting.

• Tax Included? - has the tax already been included in the unit price? X means yes, a blank field means no.

• Tax Table (optional) - this is a pop up menu of all the available tax tables. If the item is taxable and tax
has not been included in the unit price, then this tax table is used to compute the amount of tax.

• Subtotal (uneditable) - computed subtotal for this item (less tax)

• Billable - is this item billable to the chargeback customer/job?

When you have finished entering all the items, Post the bill.

Post
When you finish editing a bill, you should Post the bill. You do not have to post the bill, you can close
it and return to it later. You have to post the bill eventually. Posting a bill places its transactions into an
accounts payable account. The Post Bill window appears and asks you to enter information:
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• Post Date - specifies the date for the transactions entered into the accounts payable account.

• Due Date - is the date on which payment for the bill is expected.

• If you specified payment terms when you created the bill, the date is calculated according to selected
terms, and the entry field is insensitive.

• If you did not specify payment terms, enter the expected payment due date here.

• Description - is an arbitrary description. When bill transactions are placed in the accounts payable ac-
count, this description is entered in the memo field of those transactions.

• Post To Account - selects the accounts payable account in which bill transactions are posted. You can
select the account from a list of existing A/Payable accounts.

• Accumulate Splits - determines if bill items which transfer to the same account are combined into a
single split for that account or entered individually. For the sample bill for Letterhead and Envelopes,
the setting affects post results as follows:

• Checked (splits are accumulated) - a single transfer of $100.00 to the Expenses:Office Supplies ac-
count is recorded.

• Not checked - the transaction created in the A/Payable account, shows two transfers to Expenses:Of-
fice Supplies account $75.00 and $25.00. The memo fields in the splits indicate the purchase of Let-
terhead and Envelopes (the item descriptions entered on the bill) respectively.

Find

To find an existing bill, use the Business → Vendor → Find Bill menu item. From the results of the search,
you can select a bill to edit, or view.

Note

Before you can edit a posted bill, you will need to Unpost it.

Note

There are other ways to access an existing bill. These are similar to accessing invoices for your
customers. See the section called “Find” for more information.

Vendor Jobs
Vendor Jobs are used to group multiple bills and credit notes from a single vendor. Use of the vendor jobs
feature is optional. The feature is useful when you have multiple jobs for the same vendor, and would like
to view all the bills and credit notes for a single job.

To use vendor jobs, you must create them using the Business → Vendor → New Job menu item. You will
see the New Job window. The editable fields are:

• Job Info - Job Number (optional) - enter the number for this job. If left blank, a number will be chosen
for you.

• Job Info - Job Name - the name you want to assign to the new job.
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• Owner Info - Vendor - the vendor for whom the job is created.

• Owner Info - Billing ID - the vendor’s reference to this job (e.g. their PO Number).

• Job Active - toggles this job being active or not. This is useful when you have many inactive jobs, since
it is easier to search only among jobs that are marked active.

To edit an existing vendor job, use the Business → Vendor → Find Job menu item. Select the desired job
in the search results, and click the View/Edit Job button.

To select from the bills and credit notes associated with a given job, use the Business → Vendor → Find
Job menu item. Select the desired job in the search results and click the View Invoices button. A window
listing bills and credit notes associated with this job appears. Select a bill or credit note and click the View
Invoice button to open a bill editor in the main application window.

Process Bill Payment
Eventually, you need to pay your bills. To do so, use the Process Payment application found in Business
→ Vendor → Process Payment .

Tip

There is an alternative way of assigning a payment to (one or more) bills where the payment
transaction already exists, say in the case where transactions are imported from a bank.

This can best be done starting from the asset account register holding the imported payment
transaction (like your bank account). In that account, select the payment, right-click (control-click
for macOS) and choose Assign as payment.... The payment window will pop-up, partly filled in
with the information from the transaction. Fill in the missing information like the proper vendor
and bill to complete the payment.

One caveat: the logic behind Assign as payment... won't properly detect credit note reimburse-
ments and will wrongfully interpret such a transaction as a customer invoice.

The Process Payment application consists of:

• Payment Information - Vendor - the vendor you wish to pay. If you remember the company name you
entered in the New Vendor window for this vendor, start to type it in this field and GnuCash will try
auto complete it for you. Else, press the Select... button to access the Find Vendor window described in
the section called “Find and Edit”. Highlight the vendor you are looking for with a click in the search
results, then press the Select button.

• Payment Information - Bill - the bill you wish to pay. If you remember the bill ID, start to type it in this
field and GnuCash will try auto complete it for you. Else, press the Select... button to access the Find
Bill window described in the section called “Find”. Highlight the bill you are looking for with a click
in the search results, then press the Select button in the search window.

• Payment Information - Date - the date you wish to make the payment, normally the current date.

• Payment Information - Amount - the amount of money to transfer in this payment.

• Payment Information - Num - the check number.

• Payment Information - Memo - any comments about this payment.
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• Post To - the A/Payable account to post this transaction.

• Transfer Account - the account from which money for the payments comes from, such as a checking
account.

Over Payments or Pre-Payments
If you wish to overpay an invoice or pay for goods or services before they have been invoiced, Process
Payment for the total amount payed. GnuCash will then keep track of the over-payment (or pre-payment)
in the A/P account and you can use the residual in the future.

Partial Payments
You may wish to partially pay a bill. Select the bill to pay. GnuCash will automatically suggest that bill's
remaining balance as payment amount. Simply adjust that amount to what you want to pay.

Employees
GnuCash can help your company by tracking employees. You can register a the section called “New
Employee”, the section called “Find and Edit” existing employees, create the section called “New Expense
Voucher/Credit Note” and the section called “Find Expense Voucher/Credit Note”.

Expense vouchers are used to reimburse employees for authorized expenses (f.e. travel, parking, food
etc...). Employee credit notes are the opposite of expense vouchers.

New Employee

To register a new employee, select the Business → Employee → New Employee menu item. The New
Employee window will open with two tabs:

• Employee tab

• Access Control tab

Employee tab

• Identification - Employee Number - can be any number by which you would like to refer to this employ-
ee. You may leave it blank and a number will be chosen automatically. See the section called “Counters
Book Options Tab” for more info.

• Identification - Username (Mandatory) - a unique username to identify the employee.

• Identification - Active (Optional) - differentiates active employees from inactive ones. This is useful
when you have many past employees, and you want to see only those marked Active.

• Payment Address - Name (Mandatory) - the full name of the employee.

• Payment Address - Address (Mandatory) - the address of the employee.

• Payment Address - Phone, Fax, Email (Optional)- other optional contact information for the employee.

• Interface - Language (Optional) -
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• Payment Information - Terms (Optional) - specifies the default payment terms for this employee. Pay-
ment terms must be preregistered using Business → Billing Terms .

• Billing - Default Hours per Day (Optional) -

• Billing - Default Rate (Optional) -

• Billing - Currency - specifies the billing currency for this employee. It will default to the default currency
set in Preferences

Note

All expense vouchers and credit notes for this employee will be denominated in this currency
and GnuCash will require an Accounts Payable account in this currency.

• Billing - Credit Account (Optional) -

Access Control tab

• Access Control List

Find and Edit
To search for an existing employee, use the Business → Employee → Find Employee... menu. You select
an employee to View/Edit from the results of the search. This window is also used to look up an employee
when entering voucher and processing payments.

If many employees match the search criteria you provide, the search can be refined by running an additional
search within the current results. The current result set is searched when the Refine Current Search radio
button is selected. In fact, GnuCash selects this option for you after you run the initial search.

Note

If the employee you are searching for does not match the supplied search criteria, change the
search criteria, click the New Search radio button and then the Find button. The relevant step is
the New Search selection. If the employee is not in the result of the original search, and you only
search within this set, the employee cannot be found, regardless of new search criteria.

Tip

To return a list of all registered active employees, set the search criterion to matches regex, and
place a single dot “.” in the text field area. Make sure Search only active data is checked, then
click Find. The regular expression “.” means to match anything.

New Expense Voucher/Credit Note
To register a new expense voucher/ Credit Note, select the Business → Employee → New Expense Vouch-
er... menu item. The New Expense Voucher window will open. You can enter the following data:

• Voucher information - Type (Optional) - select if you are entering a Voucher or a credit note.

• Voucher information - Voucher ID (Optional) - can be any number by which you would like to refer to
this voucher. You may leave it blank and a number will be chosen automatically. See the section called
“Counters Book Options Tab” for more info.
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• Voucher information - Date opened - the date of the voucher. Click on the button on the right of the
date to open a calendar.

• Billing information - Employee (Mandatory) - the employee to which the voucher refers.

Tip

The field supports auto-completion so if you start typing GnuCash will try to complete the text
automatically using existing employees name. You can also press the button Select... to open
the Find Employee window.

• Billing information - Billing ID (Optional) - the identification number of the document (f.e. the bill
number for a dinner).

• Billing information - Terms (Optional) - the pay back terms agreement for this bill. A list of registered
terms is available within the pop up menu.

• Default chargeback project - Customer (Optional) - the Customer to which the voucher refers.

Tip

The field supports auto-completion so if you start typing GnuCash will try to complete the text
automatically using an existing Customer name. You can also press the button Select... to open
the Find Customer window.

• Default chargeback project - Job (Optional) - the Customer Job to which the voucher refers.

Note

you can type in this field only if there are one or more jobs registered in GnuCash belonging
to the selected Customer.

Tip

The field supports auto-completion so if you start typing GnuCash will try to complete the text
automatically using an existing Customer name. You can also press the button Select... to open
the Find Customer window.

• Notes - records any additional comments about the voucher/credit note.

Find Expense Voucher/Credit Note
To search for an existing Expense Voucher, use the Business → Employee → Find Expense Voucher...
menu item. You select an Expense Voucher to View/Edit from the results of the search. This window is
also used to look up an expense voucher when entering vouchers and processing payments.

If many expense vouchers match the search criteria you provide, the search can be refined by running an
additional search within the current results. The current result set is searched when the Refine Current
Search radio button is selected. In fact, GnuCash selects this option for you after you run the initial search.

Note

If the expense voucher you are searching for does not match the supplied search criteria, change
the search criteria, click the New Search radio button and then the Find button. The relevant step
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is the New Search selection. If the expense voucher is not in the result of the original search, and
you only search within this set, the voucher cannot be found, regardless of new search criteria.

Tip

To return a list of all expense vouchers, set the search criterion to matches regex, and place a
single dot “.” in the text field area. Make sure Search only active data is checked, then click Find.
The regular expression “.” means to match anything.

Edit
From the Edit Expense Voucher window you can enter an itemized list of goods and services the employee
bought or performed for the job, in a manner similar to how the account register works. For credit notes
you enter an itemized list of goods and services charged back to the employee instead.

Note

Saved column layout works a bit differently in invoices from the account registers: Layouts are
not saved for each invoice; instead a layout can be saved as a default for invoices to override the
calculated widths using the View>Use as Default Layout for Employee Documents and the cal-
culated widths restored as the default with View>Reset Default Layout for Employee Documents.

There are 10 columns in the Entries area:

• Date - The date this item was sold.

• Invoiced? - X means the item is attached to this invoice, an empty box means the item is not attached
to this invoice. If the box is empty you can attach the item to the invoice by first selecting the item row
and then clicking in this box.

• Description (optional) - is what the item or service is called.

• Action (optional) - is a user defined field. You can place Cost Center information here, or use one of
the 3 predefined actions, Hours, Material, or Project.

• Expense Account - selects the expense account to charge for this item.

• Quantity - tracks how many of the items you bought.

• Unit Price - is the unit price of the item.

• Subtotal (uneditable) - computed subtotal for this item (less tax)

• Billable - is this item billable to the chargeback customer/job?

• Payment - How the employee was reimbursed. You might enter a check or petty cash voucher number
here.

When you have finished entering all the items, Post the voucher.
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GnuCash offers many specialized Tools. These tools enable access to the enhanced functionality of GnuCash. They
are accessed via the Tools menu from any window that displays the GnuCash standard menu. Some of these tools may
be deactivated for several reasons:

• the tools is not appropriate for the current window,
• the required software is not found on your system,
• the package maintainer disabled it in the build process.

Find
The GnuCash Find dialog can be used to find transactions or to perform business related research on your
data file.

Find Transaction
Find Transaction is used to search for transactions in GnuCash and display the results in a General Journal
type tab. To open the Find Transaction dialog in you can type the keyboard shortcut Ctrl+F or from the
main menu use Edit → Find... .

Search results differ depending on the tab from which you open it. Aside from the transaction fields De-
scription, Number, Notes, and Date Posted, all of the searchable fields are part of individual splits, and
splits are associated with a single account. When you open the Find Transactions dialog from an account
register tab only the splits associated with that register will be searched. There is one exception, the All
Accounts item, see the footnote about it in table Table 8.1, “Search criteria buttons - Split Search” below.
For the transactions fields only transactions linked to a split in that register are inspecected and for the rest
only the split attached to that account is, with one exception, All Accounts. If you filter the transactions in
a register using View  →  Filter By... , then only transactions in that account and shown by the filter will be
searched. If you start from the Accounts page or a General Journal register then all splits in all applicable
transactions (in the latter case those included in the register) are inspected.

Note

The first row of the Find Transaction dialog indicates that you are performing a Split Search.

There are two panes in the Find Transaction dialog. The top pane contains the Search Criteria buttons and
the bottom pane contains the Type of Search selection.

There are two buttons in the top of the Search Criteria pane. The left button allows you to Add another
criteria row to search for multiple criteria. The existing criteria row needs to be completed before adding a
new row. The right button is used to Search for items where all criteria are met or Search for items where
any criteria are met. The all criteria are met search requires all of the criteria rows to have at least one
match. The any criteria are met search requires only one of the criteria rows to be matched.

The criteria row in the Search Criteria pane is used to combine different criteria buttons (see table Table 8.1,
“Search criteria buttons - Split Search” for a comprehensive list of combinations)

In the Type of Search pane there are five selections. The first option is always enabled, the following
three are available when you invoke the Find... option from a register window or after performing the first
Find if the Find... command was invoked from any other window. The last option is available only for
Business search.
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New Search

Perform a new transaction search

Refine current search

Search within the results of the previous search

Add results to current search

Search based on the first set of criteria or the new criteria

Delete results from current search

Discard any results that match the previous search results

Search only active data

Search only if data are marked as active. This selector is greyed out for the Split Search as it is
meaningful only for business related search

Note

When selecting search criteria keep in mind that criteria are applied to individual splits or fields in
transactions, and that the entire transaction is included in the results. There is no visual indication
in the results to indicate which split or field met the search criteria.

Once you've set the search criteria, you can press the Find button. You will be presented with the search
results in a new register tab. A report of the search results may created and printed using Reports → Account
Report . The Account Report has limited formatting options but, like all GnuCash reports, being in html
format, can be copied and pasted into a spreadsheet for further formatting. Alternatively, the Account
Report can be exported to an html file, and the html file may be opened in a spreadsheet.

Note

Press the Close button to close the Find Transaction dialog.

Table 8.1. Search criteria buttons - Split Search

Button 1 Button 2 Button 3 Button 4 Button 5 Button 6 Button 7 Button 8

contains

matches
regex bDescription

a
does not
match
regexb

Criteria en-
try field

Is entry
Case Insen-
sitive?

Remove
row

contains

matches
regexb

Notesa

does not
match
regexb

Criteria en-
try field

Is entry
Case Insen-
sitive?

Remove
row

contains

Memo matches
regexb

Criteria en-
try field

Is entry
Case Insen-
sitive?

Remove
row
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Button 1 Button 2 Button 3 Button 4 Button 5 Button 6 Button 7 Button 8

does not
match
regexb

contains

matches
regexbDescrip-

tion, Notes,
or Memo c does not

match
regexb

Criteria en-
try field

Is entry
Case Insen-
sitive?

Remove
row

contains

matches
regexb

Numbera

does not
match
regexb

Criteria en-
try field

Is entry
Case Insen-
sitive?

Remove
row

contains

matches
regexb

Action
does not
match
regexb

Criteria en-
try field

Is entry
Case Insen-
sitive?

Remove
row

is before

is before or
on

is on

is not on

is after

Reconciled
Date

is on or af-
ter

Date selec-
tion field

Remove
row

is before

is before or
on

is on

is not on

is after

Date Poste-
da

is on or af-
ter

Date selec-
tion field

Remove
row

less than

less than or
equal to

equal to
Value

has credits
or debits

not equal to

Amount en-
try field

Remove
row
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Button 1 Button 2 Button 3 Button 4 Button 5 Button 6 Button 7 Button 8

greater than

greater than
or equal to

less than

less than or
equal to

equal to

not equal to

greater than

has credits

greater than
or equal to

less than

less than or
equal to

equal to

not equal to

greater than

has debits

greater than
or equal to

is less than

is less than
or equal to

equals

does not
equal to

is greater
than

Shares

is greater
than or
equal to

Amount en-
try field

Remove
row

is less than

is less than
or equal to

equals

is not equal
to

is greater
than

Share Price

is greater
than or
equal to

Amount en-
try field

Remove
row
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Button 1 Button 2 Button 3 Button 4 Button 5 Button 6 Button 7 Button 8

is
Reconcile d

is not
Not Cleared Cleared Reconciled Frozen Voided

Remove
row

Closing En-
tries e

Check for
true

Remove
row

Balanced f
Check for
true

Remove
row

matches
any account

Account g
matches no
accounts

Choose Ac-
counts

Remove
row

All Ac-
counts h

matches all
accounts

Choose Ac-
counts

Remove
row

aThe Description, Number, Notes, and Date Posted fields belong to the transaction, all other searchable fields are part of individual
splits.
bregex means regular expression text search as used in various computer programs such as Perl
cSearches for a term in the transaction's Description and Notes fields and the Split's Memo field.
dThe Reconcile option applies the selected criteria to each line of a transaction individually. Each transaction line may have only
one of the indicated values, but there is often a mix of values within a complete transaction, so companion lines may not meet the
selected criteria. See separate note defining status values. For a detailed description of transaction statuses see the section called
“Setting the reconcile status (R field) of a transaction”
eThe Closing Entries selection will find transactions whose split is marked as a closing entry by Tools → Close Book .
fBalanced finds transactions that are or are not balanced. Since GnuCash nearly always succeeds in balancing transactions this will
almost always return all possible transactions. However it is possible to create a transaction containing multiple commodities that
cannot be balanced and unchecking the box will find those transactions.
gWhen the Find Transactions dialog is started from the Accounts tab or a General Journal register the Account option performs a
search where the accounts selected in the Choose Accounts dialog will both be searched individually for results. This means that
a match in any of the selected accounts will either be displayed (matches any account) or discarded (matches no account). If the
FindTransactions dialog is started in a regular account register and the current account is selected return all of the transactions or
if it is not, no transactions.
hThe All Accounts option performs a search where accounts selected in the Choose Accounts dialog will return transactions contain-
ing at least one split in every one of the accounts chosen. When run from a regular account register this is the only criterion that will
inspect splits from other accounts so if you start the Find Transactions dialog from your Assets:Current Assets:Checking register
and want to find all of the transactions in that account with a split in Expenses:Groceries, this is the criterion to use. Keep in mind,
though, that it's an "and" search: If you also include Expenses:Misc it will find only those transactions with a split in each of the
two, not transactions with a single split in either of them.

Explanations of the Criteria

The Reconcile criterion deserves some more explanation. Think of the selected reconciliation status but-
tons (Not Cleared, Cleared, and so on) as a single group, joined with a logical “or”. In other words, the
selection “is ” or “is not” applies to the “or” of the selected status buttons. The buttons which are left uns-
elected are simply ignored. (It’s not the same as saying the reconciliation status must not be one of these.)

For example: if you select Reconcile is Cleared Reconciled, that means you’re saying “I want all trans-
actions which contain cleared splits OR reconciled splits” (imagine an invisible “OR” between all the
selected status buttons). It’s the same as selecting Reconcile is Cleared, then adding another search crite-
rion with the Add button, then on the new line selecting Reconcile is Reconciled, and finally selecting
Search for items where any criteria are met. In either case, GnuCash will show you exactly the same set
of transactions.
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Find Customer, Invoice, Job, Vendor, Bill, Employee, Ex-
pense Voucher

The business find assistant is used to search for business related items (Customer, Invoice, Job, Vendor,
Bill, Employee, Expense Voucher). To open the business search dialog select the desired item to Find
from the Business → Customer/Vendor/Employee submenus.

Tip

The titlebar and the first row of the assistant dialog reports the item type you are searching for:
Customer, Invoice, Job, Vendor, Bill, Employee, Expense Voucher.

There are two panes in the Find dialog. The top pane contains the Search Criteria buttons and the bottom
pane contains the Type of Search selection.

Search Criteria section

There are two buttons in the top of the Search Criteria pane. The left button allows you to Add another
criteria row to search for multiple criteria.

Note

The existing criteria row needs to be completed before adding a new row.

The right button is used to Search for items where all criteria are met or Search for items where any criteria
are met. The all criteria are met search requires all of the criteria rows to have at least one match. The any
criteria are met search requires only one of the criteria rows to be matched.

The criteria row in the Search Criteria pane is used to combine different criteria buttons (see tables Ta-
ble 8.2, “Search criteria buttons - Customer Search”, Table 8.3, “Search criteria buttons - Invoice Search”,
Table 8.4, “Search criteria buttons - Job Search”, Table 8.5, “Search criteria buttons - Vendor Search”,
Table 8.6, “Search criteria buttons - Bill Search”, Table 8.7, “Search criteria buttons - Employee Search”
Table 8.8, “Search criteria buttons - Expense Voucher Search” for a comprehensive list of combinations)

Type of Search section

In the Type of Search pane there are five selections. The first and alst options are always selectable while
the following three are available only when you perform the first search by setting some search criteria
and pressing the Find button.

New Search

Perform a new search

Refine current search

Search within the results of the previous search

Add results to current search

Search based on the first set of criteria or the new criteria

Delete results from current search

Discard any results that match the previous search results
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Search only active data

Search only if data are marked as active.

The rest of the search dialog

When search criteria are selected, you can press the Find button. You will be presented with the list of
search results in the same Find dialog.

Tip

Aside from the results, GnuCash gives you some buttons to manage the highlighted result.

Tip

In the bottom right of the Find dialog there is a button that allows you to create a New business
item.

Note

Press the Close button to close the Find assistant dialog.

List of search criteria buttons

Table 8.2. Search criteria buttons - Customer Search

Button 1 Button 2 Button 3 Button 4 Button 5 Button 6 Button 7 Button 8

contains

matches
regexbCompany

Name does not
match
regexb

Criteria en-
try field

Is entry
Case Insen-
sitive?

Remove
row

contains

matches
regexbCustomer

ID does not
match
regexb

Criteria en-
try field

Is entry
Case Insen-
sitive?

Remove
row

contains

matches
regexbBilling

Contact does not
match
regexb

Criteria en-
try field

Is entry
Case Insen-
sitive?

Remove
row

Shipping
Contact

contains Criteria en-
try field

Is entry
Case Insen-
sitive?

Remove
row
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Button 1 Button 2 Button 3 Button 4 Button 5 Button 6 Button 7 Button 8

matches
regexb

does not
match
regexb

Table 8.3. Search criteria buttons - Invoice Search

Button 1 Button 2 Button 3 Button 4 Button 5 Button 6 Button 7 Button 8

contains

matches
regexb

Invoice ID
does not
match
regexb

Criteria en-
try field

Is entry
Case Insen-
sitive?

Remove
row

contains

matches
regexbCompany

Name does not
match
regexb

Criteria en-
try field

Is entry
Case Insen-
sitive?

Remove
row

is before

is before or
on

is on

is not on

is after

Date
Opened

is on or af-
ter

Date selec-
tion field

Remove
row

is
Is Posted?

is not
set true

Remove
row

is before

is before or
on

is on

is not on

is after

Date Posted

is on or af-
ter

Date selec-
tion field

Remove
row

is
Is Paid?

is not
set true

Remove
row

Billing ID contains Criteria en-
try field

Remove
row
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Button 1 Button 2 Button 3 Button 4 Button 5 Button 6 Button 7 Button 8

matches
regexb

does not
match
regexb

Is entry
Case Insen-
sitive?

contains

matches
regexbInvoice

Notes does not
match
regexb

Criteria en-
try field

Is entry
Case Insen-
sitive?

Remove
row

Customer

Vendor

Employee
is

Job

Customer

Vendor

Employee

Invoice
Owner

is not

Job

Criteria en-
try field

Select...
Remove
row

Table 8.4. Search criteria buttons - Job Search

Button 1 Button 2 Button 3 Button 4 Button 5 Button 6 Button 7 Button 8

contains

matches
regexb

Job Name
does not
match
regexb

Criteria en-
try field

Is entry
Case Insen-
sitive?

Remove
row

contains

matches
regexbJob Num-

ber does not
match
regexb

Criteria en-
try field

Is entry
Case Insen-
sitive?

Remove
row

contains

matches
regexb

Billing ID
does not
match
regexb

Criteria en-
try field

Is entry
Case Insen-
sitive?

Remove
row

isOnly Ac-
tive? is not

set true
Remove
row
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Button 1 Button 2 Button 3 Button 4 Button 5 Button 6 Button 7 Button 8

contains

matches
regexbOwner's

Name does not
match
regexb

Criteria en-
try field

Is entry
Case Insen-
sitive?

Remove
row

Table 8.5. Search criteria buttons - Vendor Search

Button 1 Button 2 Button 3 Button 4 Button 5 Button 6 Button 7 Button 8

contains

matches
regexbCompany

Name does not
match
regexb

Criteria en-
try field

Is entry
Case Insen-
sitive?

Remove
row

contains

matches
regexb

Vendor ID
does not
match
regexb

Criteria en-
try field

Is entry
Case Insen-
sitive?

Remove
row

contains

matches
regexbBilling

Contact does not
match
regexb

Criteria en-
try field

Is entry
Case Insen-
sitive?

Remove
row

Table 8.6. Search criteria buttons - Bill Search

Button 1 Button 2 Button 3 Button 4 Button 5 Button 6 Button 7 Button 8

contains

matches
regexb

Bill ID
does not
match
regexb

Criteria en-
try field

Is entry
Case Insen-
sitive?

Remove
row

contains

matches
regexbCompany

Name does not
match
regexb

Criteria en-
try field

Is entry
Case Insen-
sitive?

Remove
row

Due Date is before Date selec-
tion field

Remove
row
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Button 1 Button 2 Button 3 Button 4 Button 5 Button 6 Button 7 Button 8

is before or
on

is on

is not on

is after

is on or af-
ter

is before

is before or
on

is on

is not on

is after

Date
Opened

is on or af-
ter

Date selec-
tion field

Remove
row

is
Is Posted?

is not
set true

Remove
row

is before

is before or
on

is on

is not on

is after

Date Posted

is on or af-
ter

Date selec-
tion field

Remove
row

is
Is Paid?

is not
set true

Remove
row

contains

matches
regexb

Billing ID
does not
match
regexb

Criteria en-
try field

Is entry
Case Insen-
sitive?

Remove
row

contains

matches
regexb

Bill Notes
does not
match
regexb

Criteria en-
try field

Is entry
Case Insen-
sitive?

Remove
row

Customer
Bill Owner is

Vendor
Criteria en-
try field

Select...
Remove
row
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Button 1 Button 2 Button 3 Button 4 Button 5 Button 6 Button 7 Button 8

Employee

Job

Customer

Vendor

Employee
is not

Job

Table 8.7. Search criteria buttons - Employee Search

Button 1 Button 2 Button 3 Button 4 Button 5 Button 6 Button 7 Button 8

contains

matches
regexbEmployee

Name does not
match
regexb

Criteria en-
try field

Is entry
Case Insen-
sitive?

Remove
row

contains

matches
regexbEmployee

Username does not
match
regexb

Criteria en-
try field

Is entry
Case Insen-
sitive?

Remove
row

contains

matches
regexbEmployee

ID does not
match
regexb

Criteria en-
try field

Is entry
Case Insen-
sitive?

Remove
row

Table 8.8. Search criteria buttons - Expense Voucher Search

Button 1 Button 2 Button 3 Button 4 Button 5 Button 6 Button 7 Button 8

contains

matches
regexb

Voucher ID
does not
match
regexb

Criteria en-
try field

Is entry
Case Insen-
sitive?

Remove
row

contains

matches
regexbEmployee

Name does not
match
regexb

Criteria en-
try field

Is entry
Case Insen-
sitive?

Remove
row
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Button 1 Button 2 Button 3 Button 4 Button 5 Button 6 Button 7 Button 8

is before

is before or
on

is on

is not on

is after

Due Date

is on or af-
ter

Date selec-
tion field

Remove
row

is before

is before or
on

is on

is not on

is after

Date
Opened

is on or af-
ter

Date selec-
tion field

Remove
row

is
Is Posted?

is not
set true

Remove
row

is before

is before or
on

is on

is not on

is after

Date Posted

is on or af-
ter

Date selec-
tion field

Remove
row

is
Is Paid?

is not
set true

Remove
row

contains

matches
regexb

Billing ID
does not
match
regexb

Criteria en-
try field

Is entry
Case Insen-
sitive?

Remove
row

contains

matches
regexbVoucher

Notes does not
match
regexb

Criteria en-
try field

Is entry
Case Insen-
sitive?

Remove
row
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Button 1 Button 2 Button 3 Button 4 Button 5 Button 6 Button 7 Button 8

Customer

Vendor

Employee
is

Job

Customer

Vendor

Employee

Voucher
Owner

is not

Job

Criteria en-
try field

Select...
Remove
row

Since Last Run Assistant
The Since Last Run assistant is run automatically when GnuCash is started. It is used to enter into the reg-
ister any transactions that are due to be automatically entered (see the section called “Scheduling Trans-
actions”). The run on GnuCash start can be altered in the Scheduled Transactions tab of the GnuCash
Preferences. To run the Since Last Run assistant manually, go to Actions → Scheduled Transactions →
Since Last Run...

In the Since Last Run assistant window you can see three columns:

Transaction

The name assigned in the Scheduled Transaction Editor that identifies the scheduled transaction.

State

The state column of the scheduled transaction can be one of the following:

Tip

Click on the state field in the row of a transaction to change its state (this option is available
only if the state field is not empty)

Ignored

If a scheduled transaction is being displayed, either to be created or as a reminder, the user can
set the status to Ignored to skip this event. The scheduled transaction will not be entered in the
register and the next reminder for this scheduled transaction will be the next occurrence. For
instance, if you have a scheduled transaction set up with a reminder to transfer $500 at the end
of the month to your savings account but you bought yourself a computer this month and don’t
have the money for this month’s transfer then you would set the status to Ignored.

Postponed

If a scheduled transaction has been listed with a status To-create but you want to hold it and not
have it entered to your register yet, then you can set it to Postponed. When at some later time you
change it back to To-create it will be created with the original posted-date. If you want to change
that you must edit the transaction after it's created.

Reminder

You are n days from the scheduled transaction due date. The number of days n to remind in
advance, is set either in the GnuCash Preferences Scheduled Transactions tab or in the Overview
tab of the Scheduled Transaction Editor.
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To-create

This scheduled transaction will be automatically created when you press OK.

Empty

An empty field means that no operations are pending for the scheduled transaction.

At the bottom of the window there are two buttons:

• The Cancel button is used to exit the Since Last Run window without creating the transactions scheduled
to be entered.

• The Ok button closes the Since Last Run window and applies the pending operations.

At the bottom right of the Since Last Run window there is also an option that allows to Review created
transactions. If this option is enabled when there are one or more transactions To-create, pressing OK
will open a register window in which are shown the details of the scheduled transactions splits entered
automatically by GnuCash.

Mortgage & Loan Repayment Assistant
This assistant creates a loan repayment scheduled transaction. When used to setup a scheduled transaction,
the assistant creates a variable formula so that the compounding interest is correctly calculated. To start
this assistant manually go to Actions → Scheduled Transactions → Mortgage and Loan Repayment... .

It does not support zero-interest loans, but one doesn't really need an assistant for that: Just create a sched-
uled transaction for the principal divided by the number of payments that lasts for the number of payments.
For example, if one has borrowed $1200 for a year at no interest and promised to pay it back in monthly
installments, the repayment schedule is $100 monthly for twelve months.

The Mortgage and Loan Repayment assistant opens with a screen that briefly describes what this assistant
does. The three buttons at the very bottom of the screen will not change while using the assistant.

• The Cancel button is used to exit the assistant and cancel creating the scheduled transaction. Any selec-
tions you have made in this assistant up to this point will be lost.

• The Back button will bring up the previous screen so you can change a selection made on that screen.

• The Forward button will bring up the next screen so you can continue though the assistant.

The next screen allows you to enter the basic loan information. This is usually the information provided
by the bank when loan and disclosure documents are given to the borrower. Here you can also setup an
account that the scheduled transaction will use to enter the payment transaction.

• Loan Account: Choose an account for the loan payment transactions or use New... to setup a new account
for the transactions.

• Loan Amount: Enter the amount of the loan.

• Interest Rate: Enter the loan interest rate in percent per compounding period. The Assistant supports
rates between .001% and 100%.

• Type: Choose the type of loan. If an adjustable rate is used the frequency screen is enabled.

• Interest Rate Change Frequency: Choose the frequency for the rate change and the start date of the rate
change.
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• Start Date: Choose the date the loan is starting on.

• Length: Enter the length of the loan with the number and period, e.g. 60 months or 5 years.

• Months Remaining: This tells the Assistant how many months remain on the loan. The default value
assumes that the loan is paid up through today. For example, if a 5-year loan started on 1 January 2012
and today is 12 July 2015, the default months remaining is 18. If you want to create past payment
transactions you'll set the months remaining accordingly: In our example, if you wanted to create all of
the payments you'd set "months remaining" to 60; if you wanted to start tracking the payments at the
beginning of 2015 you'd enter 24.

The next screen is used to set escrow, insurance and tax options for the loan. It is mainly used for mortgage
payments. When each of the options here is set, this enables additional pages in the assistant to setup those
portions of the payments. All of the pages will be described here, even though some may not show if that
option is not chosen.

• ... utilize an escrow account for payments?: This selection enables the use of an account setup for track-
ing escrow payments. If the mortgage or loan uses an escrow account to pay taxes, insurance, etc then
setup an account here.

• ... pay "Taxes"?: adds an additional page to setup a scheduled transaction to pay taxes.

• ... pay "Insurance"?: adds an additional page to setup a scheduled transaction to pay insurance payments.

• ... pay "PMI"?: adds an additional page to setup a scheduled transaction to pay PMI payments.

• ... pay "Other Expense"?: adds an additional page to setup a scheduled transaction to pay other expenses.

The next screen is used to setup the details of the scheduled transaction for the Loan Repayment.

• Transaction Memo: The name entered here will be used as the name for the scheduled transaction, the
description of the scheduled transaction and the memo.

• Payment Amount: Shows the variable used to calculate the payment amount.

• Payment From: Choose an account to pay the loan amount from.

• Principal To: Choose an account to transfer the principal part of the loan to.

• Interest To: Choose an account to transfer the interest part of the loan to.

• Repayment Frequency: Select the Frequency and start date for loan repayments. Note that the start date
will be the posted date of the first scheduled transaction. This is not taken into account for calculating
the remaining duration of the loan, see Months Remaining:. Make sure that you set both to reflect your
intentions or you may get surprising results.

The next screen is used to setup the details of the scheduled transaction for the Tax payment.

• Transaction Memo: The name entered here will be used as the name for the scheduled transaction, the
description of the scheduled transaction and the memo.

• Amount: Enter the payment amount.

• Payment From: Choose an account to pay the tax amount from.

• Payment To: Choose an account to transfer the tax payment to.

• Repayment Frequency: Select the Frequency and start date for tax payments.
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The next screen is used to setup the details of the scheduled transaction for the Insurance payment.

• Transaction Memo: The name entered here will be used as the name for the scheduled transaction, the
description of the scheduled transaction and the memo.

• Amount: Enter the payment amount.

• Payment From: Choose an account to pay the insurance amount from.

• Payment To: Choose an account to transfer the insurance payment to.

• Repayment Frequency: Select the Frequency and start date for insurance payments.

The next screen is used to setup the details of the scheduled transaction for the PMI payment.

• Transaction Memo: The name entered here will be used as the name for the scheduled transaction, the
description of the scheduled transaction and the memo.

• Amount: Enter the payment amount.

• Payment From: Choose an account to pay the PMI amount from.

• Payment To: Choose an account to transfer the PMI payment to.

• Repayment Frequency: Select the Frequency and start date for PMI payments.

The next screen is used to setup the details of the scheduled transaction for the Other Expense payment.

• Transaction Memo: The name entered here will be used as the name for the scheduled transaction, the
description of the scheduled transaction and the memo.

• Amount: Enter the payment amount.

• Payment From: Choose an account to pay the other expense amount from.

• Payment To: Choose an account to transfer the other expense payment to.

• Repayment Frequency: Select the Frequency and start date for other expense payments.

The last screen gives you a list of three choices to finish the assistant.

• The Cancel button is used to exit the assistant and cancel creating a new loan scheduled transaction.
Any selections you have made in this assistant up to this point will be lost.

• The Back button will bring up the previous screen so you can change a selection made on that screen.

• The Finish button creates the scheduled transaction.

You should now have the Mortgage or Loan Repayment scheduled transaction setup.

Recording a Stock Transaction
While with practice you can quickly enter any stock transaction directly in the register as explained in the
“Investments” chapter in the guide, GnuCash provides an assistant that can help walk you through most
common transactions and several less common ones that you might encounter.

The assistant is accessed from the Action menu when the current register is for a Stock or Mutual Fund
account.
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Types of stock transactions supported by the Stock Transaction Assistant

• Buy

• Sell

• Dividend

Note

This is for cash dividends; use Stock Split for share dividends.

Note

The assistant does not support recording reinvested dividends in a single transaction. If you
reinvest dividends, even if it's done automatically by your broker, mutual fund company, or
the issuer of the shares, you must record the share purchase with a second pass through the
assistant.

• Return of Capital

• Notional Distribution

• Stock Split

• Reverse Split

The assistant recognizes long and short positions in the account and adjusts pages it presents to you de-
pending on the transaction type and whether the position is long or short. It optionally capitalizes com-
missions and fees.

Transaction Details Page
Enter the transaction post date and description on this page.

Transaction Type Page
Select the type of transaction from the list. The assistant will display a description of what it will do when
you make a selection.

Stock Amount Page
This page is displayed for Buy, Sell, Stock Split, and Reverse Split transactions to collect the new share
information. For a Buy or Sell it will display the current share balance, ask for the number of shares traded,
and once that's entered it will display the new share balance. For a Stock Split or Reverse Split it will ask
for the new balance after the split and display the split ratio.

Stock Value Page
Displayed for Buy and Sell to collect the value of the shares bought or sold net of commissions and fees,
which are collected on another page. For example if you sell 100 shares of stock for $10.00 per share with
a 2% commission and a $10.00 SEC fee the net value for this page is $1000.00.
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Cash Page
Displayed for all transaction types.

Enter the asset account to or from which the money for the transaction will go.

Note

Only asset accounts denominated in the stock account's currency—that of the nearest parent ac-
count denominated in currency—will be offered. The stock assistant does not support multi-cur-
rency stock trading.

Note

For a stock split or reverse split this entry is only to balance any fees entered on the following page.
Any cash in lieu of fractional units must be recorded as a separate sell or cover-buy transaction.

Enter the gross amount of the transaction including commissions and fees. In the example from the Stock
Value Page that would be $970.00: $1000.00 for the stock less $20 for the 2% commission and the $10.00
fee. Had it been buy you would have added the commission and fees to the amount.

There is a field for you to enter a memo on the cash split. It defaults to Cash.

Fees Page
Displayed for all transactions. There is a checkbox to select whether the fees will be incorporated into the
value of the stock split (capitalized) or separately credited to an expense account.

If the amount is to be expensed select the account. Expense acconts will be offered and there's a button
to create a new one.

Amount: Enter the total of any commissions, fees, or taxes on the transaction.

Note

There's only one amount and one account. If you want separate accounts for say commissions
and taxes, enter the total and one of the accounts here and then edit the transaction afterwards
to create the extra splits.

As with the Cash Page there's a memo field for this split's memo.

Dividend Page
Displayed only for Dividend transactions. Select or create an income account and enter the gross amount
of the dividend. There's a memo field as usual.

Capital Gains Page
Displayed only for Sell of a long position or Buy of a short position. As with the Dividend Page select an
income account for the capital gain or create a new one, enter the amount of the gain—losses should be
entered as a negative amount—and optionally edit the memo for the capital gain split.
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Note

The assistant doesn't do any calculating for you: It's up to you to determine the basis by whatever
strategy you choose subject to the tax laws in your jurisdiction and to compute the difference
between the basis and the proceeds.

Note

If you prefer to use the View Lots dialog to compute capital gains/losses you should leave the
Amount field in this page blank.

Finish Page
The final page displays a list of the splits the assistant will create along with errors that would prevent the
transaction from being complete. If there are errors the Apply button will be disabled. You must use the
Back button to navigate to the appropriate page and correct the error. Once all of the errors are resolved
click the Apply button to create the transaction.

Note

The assistant provides a Finish button to move to the Finish Page from any other.

The Online Banking Setup Assistant
The Online Banking Setup Assistant is used to create or edit the configuration to enable interaction with
your bank. For this purpose the package AqBanking is used. It contains several modules with different
abilities. Their availability depends on the region. But all can fetch the current balance and recent trans-
actions.

Table 8.9. AqBanking Supported Protocols

Module Send Orders Region Notes

EBICS AT, CH, DE, FR
Usually available for
business customers.

FinTS

Yes

DE
Submodules: HBCI,
PIN/TAN.

OFX DirectConnect US a
Not to confuse with
“OFX WebConnect”!

PayPal

No

intl.
aIf you know about banks in other countries, update the wiki table [https://wiki.gnucash.org/wiki/OFX_Direct_Connect_Bank_Set-
tings].

Tip

If Online Banking Setup does not appear in your Tools menu, verify that you are in an Account
Tree or Register tab.

The currently available instructions are still kept in the GnuCash wiki and depend on the used module:

EBICS

No users shared their experience util now.
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FinTS

This module is only documented in German. Overview https://wiki.gnucash.org/wiki/De/On-
line-Banking, usage of the https://wiki.gnucash.org/wiki/De/Onlinebanking-Einrichtungsassistent,
and details of the different https://wiki.gnucash.org/wiki/De/PIN/TAN methods.

OFX DirectConnect

Instruction for this process are in English at https://wiki.gnucash.org/wiki/Setting_up_OFXDirect-
Connect.

PayPal

This module is only documented in German https://wiki.gnucash.org/wiki/De/Paypal einrichten.

Price Editor
Note

GnuCash uses the term commodity to mean anything that it counts: Currencies, securities (i.e
intangible assets like stock or mutual fund shares and bonds), or tangible assets like trucks and
computers. When valuing one commodity in terms of another it uses the term Exchange Rate be-
tween two currencies and Price between a non-currency commodity and a currency commodity.
For the rest of this section we'll use "price" to mean both price and exchange rate and "commod-
ity" to mean any sort of commodity except where currency behavior is different.

The Price Editor is used to list and edit the price of one commodity in another commodity. New prices
can be added, existing prices can be edited, and prices can be retrieved from a variety of sources on the
World-Wide Web when the commodity is properly configured.

Each commodity pair can have one price per day. An existing price will be overwritten by a newer one if the
newer one has the same or a more preferred source. The order of source preference (1 is most preferred) is:

1. user:price-editor: Prices created manually in the Price Editor

2. Finance::Quote: Online quotes

3. user:price: Prices entered explicitly in the Exchange Rateentry of the Transfer Funds dialog box or in
the Price column of a register for an account of types STOCK or MUTUAL

4. user:xfer-dialog: Prices calculated from an entry in the To Amount entry of the Transfer Funds dialog
box.

5. user:split-register: Prices calculated from the Shares and Debit or Credit columns of a register for an
account of types STOCK or MUTUAL

6. user:stock-split: Prices entered in the Stock Split Assistant

Note

Prices created manually in the Price Editor are preferred over prices retrieved via Finance::Quote
so Finance::Quote will fail to update such manually-created prices.

The Price Editor displays existing prices as follows:

• Security: The Security/commodity being priced. The display is sorted by the Namespace that the indi-
vidual securities are listed on. The list is expanded by clicking on the caret on the left of the name.
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• Currency: The currency the price is recorded in.

• Date: The date the price was recorded.

• Source: The source of the commodities price quote, listed above.

• Type: There are several different types of stock price quotes.

• Bid: Indicates what a specialist dealer is prepared to pay for a stock.

• Ask: Indicates at what price the dealers are prepared to sell a stock.

• Last: Indicate the price at which the last trade in that stock/security occurred at. This is the price
most commonly quoted in the media.

• Net Asset Value: Are typically used for mutual funds. They are calculated on the net value of the
fund’s assets each day around the time of the market close and are in effect until the next recalculation.

• Unknown: Use this if the type of price quoted is not known.

• Price: The actual price of the commodity.

Adding a stock price manually
To add a new price, click on Add, and enter the details of the security and price into the dialog box. To
edit an existing price, select the price in the price list, click the Edit button, and edit the figures.

To remove just one price, select the price and click the Remove button. If you want to remove all prices
older than a certain date, click on the Remove Old button and enter the details in the dialog box.

A pop-up will display with the message "Delete all stock prices based upon the criteria below:". Enter
the date of the last price you wish to delete.

Two check-boxes are below the date field;

• Delete manually entered prices - If checked, delete manually entered stock prices dated earlier than the
specified date. Otherwise only stock prices added by Finance::Quote will be deleted.

• Delete last price for a stock - If checked, delete all prices before the specified date. Otherwise the last
stock price dated before the date will be kept and all earlier quotes deleted.

Configuring for use of the Get Quotes button
To support on-line quotations for a particular stock or mutual fund account, you must first enable on-line
price quoting and select a price source in the Security. This is described in detail in the section called
“Configuring Securities/Currencies for On-Line Retrieval of Prices”. Once on-line quotes are enabled, and
Finance::Quote is installed, you can update prices for your stocks and mutual funds manually by clicking
the Get Quotes button.

Security Editor
The Security Editor is used to create and edit commodities that are used by mutual fund and stock type
accounts. It also shows the details of National Currencies that are used by GnuCash.

To show the details for National Currencies click the Show National Currencies check-box at the bottom
of the screen.
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Each entry in the editor shows the details used by the security/currency:

• Type: Categories for organizing securities. GnuCash has the following built in:

• CURRENCY or ISO4317: These are used for national currencies and are not editable with the Se-
curity Editor.

• FUND: Ordinarily used for open-ended mutual funds, i.e., those that one purchases from and sells to
only the issuing company and that are priced daily at their net asset value.

• AMEX, ASX, EUREX, NASDAQ, and NYSE: These represent a few of the exchanges on which
stocks, closed-end mutual funds, and exchange-traded funds are traded.

• Template: This is a reserved word. It will not normally appear in the Security Editor unless you type
it in, and if you do it will cause problems. Don't use it.

If your investment doesn't fit into one of these categories, for example if you trade stocks on the DAX
or LSE, you can easily create your own type simply by typing it into the field. The type of security has
no meaning to Gnucash (except Template, don't use that!), it's there only to make it easier for you to
find the security from the selection lists.

• Symbol: Indicates the symbol or abbreviation for the commodity. This is usually the ticker symbol
(for stocks) or other unique abbreviation for the commodity. If the commodity is traded on any public
exchange, it is important to use the same identifier used on that exchange. For national currencies the
symbol is the ISO-4217 currency code.

• Name: The full name of the commodity is a recognizable name such as US Dollars or IBM Common
Stock.

• Code: This is any numeric or alphanumeric code that is used to identify the commodity. The ISIN code
is an international unique identifying numeric string that is associated with every stock, bond or mutual
fund, and most kinds of traded options, futures and commodities. There are also regional valid codes
available like CUSIP in the North America, WKN in DE, … This code is not required.

• Fraction: This is the smallest traded unit of the commodity, expressed as a fraction of a single nominal
unit. This unit is used by GnuCash accounts as the default fraction for trades in the commodity.

Adding or Editing a Commodity
To add a new commodity (stock, or mutual fund), click on Add, and enter the details of the commodity into
the New Security dialog box. To edit an existing commodity, select the commodity from the Commodities
list, click the Edit button, and edit the Edit Security dialog box. To remove a commodity, select the
commodity and click the Remove button.

The fields in the New/Edit Security screens are the same as defined for the Security Editor the section
called “Security Editor”. Below these fields are the options for Online Quotes.

Configuring Securities/Currencies for On-Line Retrieval
of Prices

To support on-line quotations for a particular stock or mutual fund account, you must first enable on-line
price quoting and select a price source in the Security Editor. Online currency quotes require only that
the check-box for Online quotes and the timezone be selected, and that the “Get Quotes” box be checked
in the Security Editor.
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Detailed instructions are in the section on Creating New Accounts. the section called “Steps to enable
Online Quotes updating”

Loan Repayment Calculator
The Loan Repayment Calculator is used to calculate compound interest. It provides a way of entering four
of the five parameters of a compound interest calculation and then calculating the remaining figure.

The calculator is split into two panes. The left pane has five fields with a Calculate button and a Clear
button. The Calculate button is used to select the figure to calculate. The Clear button is used to clear any
amount in the field.

• Payment Periods: This field is used to select the number of payments you wish to use in the calculation.

• Interest Rate: This field is used for the interest rate percentage.

• Present Value: This field usually contains the amount you have borrowed. It is the base amount you
wish to compound.

• Periodic Payment: This field contains the amount that is the payment for the period selected (IE month-
ly, weekly, etc). If it is for repaying a loan it should be a negative number.

• Future Value: This field contains the final value at the end of the periods above. If we are repaying
a loan in full it would be 0.

The right pane contains buttons to select what sort of payments and compounding is used for the left pane
calculations.

• Compounding: This button allows you to select the interval used if the Discrete Compounding button
is selected.

• Payments: This button allows you to select the interval used for the Payment Periods field.

• End of Period Payments: Use this button if the payment is at the end of the period.

• Beginning of Period Payments: Use this button if the payment is at the beginning of the period.

• Discrete Compounding: This button is used where interest is charged at a discrete interval defined by
the Compounding button above.

• Continuous Compounding: This button is used when the interest is charged continuously.

• Payment Total: This field shows the total amount paid.

Examples of using the Loan Repayment Calculator are given in the Tutorial and Concepts Guide.  GnuCash
Tutorial and Concepts Guide’s Chapter on Loans [https://www.gnucash.org/docs/vnone/C/gnucash-guide/
loans_calcs1.html]

Close Book
The Close Book dialog box is used for “closing the books,”--an accounting process that resets the balances
of the income and expense accounts. In this process, income account balances are transferred into an
income equity account, while expense account balances are transferred into an expense equity account.
You must specify both these accounts, which may be the same. You must also specify the date for the
closing transfer.

132

https://www.gnucash.org/docs/vnone/C/gnucash-guide/loans_calcs1.html
https://www.gnucash.org/docs/vnone/C/gnucash-guide/loans_calcs1.html
https://www.gnucash.org/docs/vnone/C/gnucash-guide/loans_calcs1.html
https://www.gnucash.org/docs/vnone/C/gnucash-guide/loans_calcs1.html


Tools & Assistants

Dialog Box Details
The dialog box has the following parts:

• Closing Date: Specify the date for the closing transfer. You can type in a date or choose one from the
drop-down.

• Income Total: Specify the account into which the total balance of all income accounts will be transferred.
Optionally you can create a new account to receive the transfer using the New button.

• Expense Total: Specify the account into which the total balance of all expense accounts will be trans-
ferred. Again, you can optionally create a new account to receive the transfer using the New button.

• Description: Specify the description that will be entered in the closing entry.

How It Works
GnuCash closes books by creating one transaction per currency for income accounts, and one transaction
per currency for expense accounts. The transactions all use the date selected by the user, and each transac-
tion may contain any number of splits. Each split moves the balance out of one income or expense account.
The last split in each closing transaction moves the total offsetting debit/credit balance into the specified
equity account.

Each transaction will use the description provided by the user in the Description: entry.

The fact that GnuCash just uses transactions to close the books makes it very simple to undo a book closing:
just delete the closing transactions.

What It Doesn’t Do
The book closing tool does not delete any accounts or transactions; create any new files; or hide any
accounts.

Necessity
Note that closing the books in GnuCash is unnecessary. You do not need to zero out your income and
expense accounts at the end of each financial period. GnuCash’s built-in reports automatically handle
concepts like retained earnings between two different financial periods.

In fact, closing the books reduces the usefulness of the standard reports because the reports don’t currently
understand closing transactions. So from their point of view it simply looks like the net income or expense
in each account for a given period was simply zero.

Conclusion
If you close your books, be prepared to see inaccuracies in the standard reports. On the other hand, you
will see current-period income and expense figures in the chart of accounts.

Lots in Account
GnuCash uses lots in 2 ways:
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• To link security buy transactions to sell transactions so the real cost of the sold securities can be used
to calculate capital gain or loss. See the section called “Lots for Security Capital Gains”.

• To link payments or credit notes to the invoices to which they apply in the Business Features. See the
section called “Lots for Business Features”.

Lots for Security Capital Gains
The Lots in Account SSSS window, where SSSS is the security account, is used to manually or automat-
ically link security transaction splits to lots and create capital gain/loss transactions to account for the
difference between the costs of buying a security and the value received by selling it.

To open the Lots in Account window, open the security account register, then select Actions → View Lots .

Figure 8.1. Lots in Account window for Security Capital Gains

An image of the Lots in Account  window for a security account.

Screen Elements

Adjusting the Size of Screen Elements

As well as adjusting the size of the whole window, it is possible to adjust the proportions of the window
elements both horizontally and vertically.

There are 2 bars for adjusting the window horizontally. One between the Title and the Lots in This Account
panel, and the other between the Splits free panel and the >> and << buttons.

The window proportions may be adjusted vertically by dragging the vertical bar located to the right of
Show only open lots.

These resizing bars can be hard to see, so move the mouse pointer until it changes to the resize pointer then
click and drag the bar. The resize pointers are different depending on your operating system and theme.
Here are some examples of resize pointers:
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It is not possible to individually adjust the size of panel columns.

Fields

• Title: Shows the title for the highlighted (selected) lot in the Lots in This Account panel. When a new
lot is created by clicking the New Lot button, it has a default title of Lot n  where n is a number starting
at 0 (for each security account) and incrementing by 1. Deleting a lot does not reset the next number to
be used, but the title can be changed as required.

• Notes: Notes for the highlighted lot. Users are free to enter anything they wish and the notes can be
changed as required.

Panels

The order of the items in all the panels in this window can be adjusted by clicking on the column headings.

• Lots in This Account panel

This panel shows lots for this security account.

If Show only open lots is checked, only lots that have not been completely sold are shown.

Columns

• Type: Always blank for security lots. This window is also used for business lots (which link payments
to invoices) when coming from an Accounts Payable or Receivable account and in that case, Type
will be I for invoice. Credit Notes are also Type I.

• Opened: Open  if there are no splits in the lot, otherwise the date of the earliest split in this lot.

• Closed:  Open if the lot is not fully sold, otherwise the date of the last sell split.

• Title: Lot Title.

• Balance: Number of unsold securities in this lot.

• Gains: Calculated gains or losses for this lot.

• Splits free panel

This panel shows buy and sell splits for this security account which are not linked to a lot. Capital Gains
splits (Shares and Price are 0) are not shown.

Columns

• Date: Transaction Date Posted.

• Num: Transaction Num.

• Description: Transaction Description.

• Amount: Number of shares bought or sold from the transaction split. Positive for buys, negative for
sells. If the security transaction split has been split into multiple subsplits (because a split may only be
linked to 1 lot), this amount will not be the full transaction amount, but only the amount for this split.

• Value: Amount x split price.

• Gain/Loss: For sell splits, shows calculated gain or loss. This will be recalculated during scrubbing.
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• Balance: Cumulative number of unsold shares for free splits.

• Splits in Lot panel

This panel shows splits linked to the highlighted lot in the Lots in This Account panel. This panel will
be empty until a lot is highlighted in the Lots in This Account panel. Capital Gains splits (Shares and
Price are 0) are not shown.

Columns

• Date: Transaction Date Posted.

• Num: Transaction Num.

• Description: Transaction Description.

• Amount: Split number of shares bought or sold. Positive for buys, negative for sells. If the security
transaction split has been split into multiple subsplits (say by scrubbing because a split may only be
linked to 1 lot), this amount will not be the full transaction amount, but only the amount for this split.

• Value: Amount (No of Shares) x split price.

• Gain/Loss: For sell splits, shows calculated gain or loss. This will be recalculated during scrubbing.

• Balance: The number of unsold shares in this lot after this transaction.

Buttons

• >>: Links a free split (buy or sell) to a lot. This button is not enabled until both a lot and a free split are
highlighted. The split moves from the Splits free panel to the Splits in lot panel.

Multiple buy splits and multiple sell splits may be linked to the same lot. Refer to following section
about the Scrub Account button for details of the capital gains transactions created in these situations.

• <<: Unlinks a split from a lot. The split moves from the Splits in lot panel to the Splits free panel. This
button is not enabled until a split in the Splits in lot panel is highlighted. When the last split is unlinked
from a lot, the lot is automatically deleted if there is no capital gain/loss transaction.

• New Lot: Creates a new lot which shows in the Lots in This Account panel. The new lot is not linked
to any split.

• Scrub Account:

• Creates a lot for each buy transaction split that is not already linked to a lot.

A new lot is created for each unlinked buy transaction split because gains on investments, in some
jurisdictions, may be taxed at different rates depending on how long they were held before being sold.
As a separate capital gains transaction is created for each lot, this makes it easier to determine tax on
the capital gains based on the lot opened and closed dates.

If you know that the capital gains from a sale are all to be taxed at the same rate, you can manually
link multiple buys to a lot so scrubbing will only create 1 capital gains transaction.

It is also possible to manually link multiple sell transaction splits to a lot. In this case scrubbing
creates a capital gains transaction per sell transaction split based on the average cost of securities
held at the time of each sale, assuming acquisitions are allocated to sales using the security account
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costing method (currently only FIFO). As this makes it complicated to manually verify the costs are
correct, it may be wise to limit this to specific situations, say for example if there are multiple sales
on the same day.

• Links buy and sell transaction splits to lots using FIFO method.

• Calculates gain/loss and creates a separate capital gain/loss transaction for each lot that does not
already have one.

Note

If gain/loss splits have been manually entered as part of a sell transaction, scrubbing does not
recognize them, so if manually adding gain/loss, always separate the gain/loss splits from
the transaction that reduces the No of Shares, by putting them in a separate transaction.

• Scrub: Scrub only the highlighted lot. This button is only enabled if a lot is highlighted. If no buy splits
are linked to the highlighted lot, nothing is done. The Scrub button will link any free sell splits to the lot
as required until the sum of the sell split amounts equals the sum of the buy split amounts. If the sum
of the sell split amounts is greater than the sum of the buy split amounts, a sell split will itself be split
into 2 splits, with the remaining amount in an unlinked split.

Note

For both the Scrub Account and the Scrub buttons:

The Gain/Loss for each lot is recalculated and a capital gain transaction is created if needed.
The transaction has 1 split for the security account and the other with account Orphaned Gains-
CCC where CCC is the security currency. The Orphaned Gains-CCC  account is used because
GnuCash doesn't know which capital gain or loss account should be used, so the user must
change it to the required income (or expense) gain or loss account.

• Delete: Delete the highlighted lot. Any linked splits are automatically freed (unlinked). This button is
only enabled if a lot is highlighted.

• Close: Close the Lots in Account SSSS window.

For more details, see:

• Tutorial and Concepts Guide, Automatic Calculation of Capital Gain or Loss Using Lots [https://
www.gnucash.org/docs/vnone/C/gnucash-guide/invest-sell1.html#invest-sellLots].

• Investment Lots report.

Lots for Business Features

Introduction

For business features, lots are used to link payments or credit notes to the invoices to which they apply.
This is for both customer invoices and vendor bills.

There are 2 main uses for the Lots in Account window in relation to the business features:

1. To enquire about which payments or credit notes offset particular invoices. For each invoice and credit
note, GnuCash automatically creates 1 (and only 1) lot. By selecting the lot for the invoice or credit note
in the Lots in This Account panel, all the transaction splits for that lot show in the Splits in Lot panel.
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Tip

Alternatively, print the invoice and check the Payments option on the Display tab in the report
options. The Tax Invoice always shows payments so does not have the Payments option.

2. To correct mistakes that are hard to correct otherwise (either due to bugs in past versions of gnucash
or due to unintended use of said features). Some of these use cases are found on this wiki page [https://
wiki.gnucash.org/wiki/Business_Features_Issues]. In the context of the normal operation of business
features , the Lots in Account window is not used to create, delete, link or unlink lots. Lots are usually
generated and manipulated internally only by the business features programs.

To open the Lots in Account AAAA window, where AAAA is the Accounts Receivable (AR) or Accounts
Payable (AP) account, open the AR or AP account register, then select Actions → View Lots .

Figure 8.2. Lots in Account window for business features

An image of the Lots in Account window for an Accounts Receivable account.

Screen Elements

The screen elements of the Lots in Account window for an AR or AP account are the same as for a security
account, although the actions and data are different. As this window is only used for creating, deleting,
linking or unlinking lots in  exceptional circumstances, the differences are not described. See the section
called “Screen Elements” for a description of the screen elements and what the buttons do when used with
the lots of a security account.
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Chapter 9. Reports And Charts
Note

This section is a “work in process”. Some of the material has not been reviewed for V2.0. While
it may not be strictly accurate, it is at least a "guide".

Introduction
Reports and Charts give GnuCash the ability to present an overview of financial data in various ways.
This can range from a simple summary of account totals to an advanced portfolio view. This section will
present an explanation of the main GnuCash reports and how to adjust them.

To run a report or chart, click on the Reports menu, then either select a report (it will open with standard
options), or click on Saved Report Configuration to select a report you have previously configured and
saved.

Once the report has opened, click on the toolbar button Options to configure the report as needed, for
example to set the report date or select accounts.

Tip

If you intend to save a report configuration, you should choose a named report date option such
as Today rather than enter a specific date so it is not necessary to enter a specific date again in
future reports.

Tip

If you often run a report with a date as at the start or end of an accounting period, set the accounting
period start and end dates in Edit → Preferences → Accounting Period then select appropriate
report date options. See the section called “Accounting Period”.

Tip

If you cannot find a specific report to suit your requirements, you may be able to use the Find
Transaction assistant ( Edit → Find ) to select a set of transactions, and then report them using
Reports → Account Report . Further formatting or analysis may be done by copying and pasting
the report into a spreadsheet.

After you have configured a report, you can save the configuration for future use by clicking either the
Save Report Configuration or Save Report Configuration As... button.

Saving a Report Configuration
To save a report configuration for future use, while the required report tab is selected, go to the report
options, select the General tab and change the Report Name to a meaningful unique name. Do not confuse
this with the Report Title which prints at the top of a report.

Click the Save Report Configuration or Save Report Configuration As... button. This will
store your customized report options in a file below your home directory. The ex-
act location depends on your OS, its version and the GnuCash version. See wik-
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i:Configuration_Locations#GTK_CONFIG_HOME [https://wiki.gnucash.org/wiki/Configuration_Loca-
tions#GTK_CONFIG_HOME], GNC_DATA_HOME [https://wiki.gnucash.org/wiki/Configuration_Lo-
cations#GNC_DATA_HOME] and Files in GNC_DATA_HOME [https://wiki.gnucash.org/wiki/Config-
uration_Locations#In_GNC_DATA_HOME] Then it is GNC_DATA_HOME/saved-reports-ver-
sion.

The first time you save a report with a name that has not already been saved, you can use either the Save
Report Configuration or the Save Report Configuration As... button. You can modify the report name
before saving it.

After a report configuration for a specific name has been saved, the Save Report Configuration button will
immediately update the saved report configuration without giving the opportunity to save the configuration
with a new name. Use the Save Report Configuration As... button to save the current report configuration
with a new name.

After your customized report has been saved, it is available for use by the Reports → Saved Report Con-
figurations menu and it will also be listed when starting Reports → Sample & Custom → Custom Multi-
column Report .

Working with Saved Report Configurations
Selecting Reports → Saved Report Configurations will open a dialog window with the list of the Saved
Report Configurations you have previously created. In this context Saved Report Configurations means
the set of customized settings for standard reports.

The Saved Report Configurations window lists each of your previously saved report configurations, and
3 small buttons at the end of each. These buttons perform the following actions

• Load (and run) report configuration. Double clicking a report configuration also performs this action.

• Edit report configuration name. This enables a report configuration to be renamed.

• Delete report configuration.

Configuring Reports and Charts
GnuCash reports have many configuration options. First, run the original report itself. Then, access the
report options with the Options button on the toolbar.

Note

Check changed Graphic Engine Options

Report Options Buttons
After modifying report options, either

• Click the OK button to apply the changes, regenerate the report and close the options window.

or

• Click the Apply button to apply the changes, regenerate the report and leave the options window open
for possible further changes. In this case, both the Apply and OK buttons will be disabled, indicating
changes have been applied, until further changes are made.
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or

• Click the Cancel button to close the options window without applying any unapplied changes.

Common Report Options
Many reports share similar options. Some common ones include:

• Report Name: Set the title of the report. This is also used to print the report for later viewing.

• Date Options: Reports typically specify either a single date, or a date range, for the report. Dates can be
specified in two ways, either directly (using the date selector), or by selecting a relative date from the
menu. Relative dates allow you to specify dates like Beginning of this year or Today.

Tip

If you often run a report with a date as at the start or end of an accounting period, set the
accounting period start and end dates in Edit → Preferences → Accounting Period then select
appropriate report date options. See the section called “Accounting Period”.

• Step Size: This option is used on bar charts to determine the interval which each bar represents. Typical
values are daily, weekly, monthly, and yearly.

• Accounts: Select the appropriate accounts for the report. Note that in some reports only certain types of
accounts can be selected. For example, an expense piechart only allows expense accounts to be selected.

• Show Long Account Names: This option allows displaying either short account names (for example,
Power) or long account names (for example, Utilities:Power).

• Include Subaccounts?: Summary reports typically have an include all subaccounts option, which if se-
lected ensures that all subaccounts are included if the parent account is.

• Depth: This option allows the selection of how many levels the report displays subaccounts. If the
subaccounts go deeper than selected, an overall value for all the subaccounts is calculated and included
in a total. To make sure every account selected is individually displayed, select All.

• Style Sheet: Select a Style Sheet. Style sheets control how reports are displayed. At the moment, there
are four style sheets: Default, Easy, Footer and Technicolor. You can customize each of these from the
Edit → Style Sheets... menu item. This is described in the the section called “Changing Style Sheets”
section.

• Plot Dimensions: There are width and height options for most charts, which specify the displayed di-
mensions (in pixels).

• Report Currency: Select the report currency. Generally, values will be converted to this currency for
display.

The default Report Currency is defined in Edit → Preferences Reports tab. See the section called “Re-
ports”.

• Price Source: Select how stock and currency prices are calculated in this report. Choose between:

• Nearest in time (default for most reports): A price retrieved from the prices database on the date
nearest to the date of the report or of the datum for time-series reports.
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• Most recent: The latest price in the price database.

• Average Cost: The amount-weighted net average of all splits exchanging the commodity for another
regardless of account. Gain/loss splits are included in the calculation.

• Weighted Average: The gross amount-weighted average price of all splits exchanging the commodity
for another regardless of account. Gain/Loss splits are not in the calculation.

More information on Average Cost and Weighted Average may be found in the Investments chapter of
The Tutorial and Concepts Guide.

• Totals: Charts display totals in the chart legend if this option is selected.

• Maximum Slices: Controls the maximum number of slices displayed in a piechart - other accounts will
be placed in a slice marked Other.

• Maximum Bars: Controls the maximum number of bars displayed in a barchart.

• Display Columns: Choose columns to show from the register.

Reports Listed By Class
GnuCash has classified the main types of reports into major classes. These are all available under the
Reports menu.

General Reports

The General Reports include the Account Summary Report, the Future Scheduled Transactions Summary,
and the Transaction Report and also the reports in the Sample & Custom menu.

Account Summary

Future Scheduled Transactions Summary

Transaction Report

This report lists transactions in selected accounts during a specified financial period. Two fields may be
optionally used for sorting and totalling.
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Report Options

Figure 9.1. Transaction Report, Report Options

This is an image of the Transaction Report, Report Options, Display tab.

• Accounts tab

• Accounts: Select one or more accounts to be reported.

There are 4 buttons to aid account selection

Select All Select all accounts

Clear All Clear the selection and unselect all accounts

Select Children Select all descendants of selected account

Select Default Select the default account selection

• Show Hidden Accounts: Show accounts that have been marked hidden.

• Filter By: Optionally select accounts to be either included or excluded depending on Filter type

• Show Hidden Accounts: Show accounts that have been marked hidden in the Filter By list of accounts

• Filter Type: One of
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None Do not do any filtering

Include Transactions to/from Filter Accounts Include Transactions to/from Filter Accounts on-
ly

Exclude Transactions to/from Filter Accounts Exclude Transactions to/from all Filter Accounts

• Reset defaults button: Reset all values to their defaults

• Display tab

• Date refers to the 'posted date' i.e. effective date of a transaction.

• Reconciled Date refers to the 'date of reconciliation' of a transaction.

• Num is commonly used for check numbers.

• Description is a description of the transaction

• Memo is the memo field of a transaction. This can be used as a secondary description of a transaction.

• Notes: Display the notes if the memo is unavailable

• Account Name will print the account name containing the transaction.

• Use Full Account Name if the account name is enabled, this option will display the full account name
hierarchy.

• Account Code this refers to the 'account code' related to the account.

• Detail Level 1 : One of

Single Display 1 line per transaction,

Multi-Line Display a transaction header and 1 line per split.

If Detail Level is Multi-Line, check boxes Other Account Name and Use Full Other Account Name
are automatically deselected and disabled, and the Transfer column is not reported.

• Other Account Name: For multi-split transactions, this parameter should be unticked. See below for
more details.

• Use Full Other Account Name will enable display of full corresponding account name.

• Other Account Code will enable display of corresponding account code.

• Shares: Display number of shares

• Price: Display share prices

• Amount: One of

None Do not display Amount

Single Single column display

Double Two column display

1Before GnuCash 3.0 Detail Level was called Style on the General tab.
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• Subtotal Table will add a summary table for the various subtotals generated in the report. It lists the
same subtotals generated in tabular form.

• Running Balance refers to the running balance of the account holding the transaction.

• Totals will add a 'Grand Total' line adding all transactions in the report.

• Sign Reverses: One of

Global Preference Use reversing option specified in global prefer-
ence.

None Do not display signs reversed

Credit Accounts Reverse amount display for Liability, Payable,
Equity, Credit Card and Income accounts

Income and Expense Reverse amount display for Income and Expense
accounts

• Reset defaults button Reset all values to their defaults

• Filter tab

• Account Name Filter will include only selected accounts containing the substring. Alternatively, if
the next option is checked, the account name filter will be matched according to full POSIX regular
expressions.

• Use regular expressions for account name filter toggles regular expressions for account name filter.

• Transaction Filter will include only transactions which contain this substring in the description, notes,
or memo. Alternatively if the next option is checked, the filter will be matched using full POSIX
regular expressions.

• Use regular expressions for transaction filter toggles regular expressions for the transaction filter.

• Reconcile Status

All Show all transactions

Unreconciled Unreconciled only

Cleared Cleared only

Reconciled Reconciled only

• Void Transactions: One of

Non-void only Show only non-voided transactions

Void only Show only voided transactions

Both Show both and include voided transactions in to-
tals

• Closing transactions: One of

Excluding closing transactions Show only regular transactions

Show both closing and regular transactions Show both regular and closing transactions
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Show closing transactions only Show closing transactions only

• Reset defaults button: Reset all values to their defaults

• General tab

• Report name: Enter a descriptive name for this report

• Stylesheet: Select Default, Easy, Footer or Technicolor

• Start Date: Enter or select a specific Start Date

or select one of the following named start date options which will be used to determine the start date
each time the report is run

Today The current date

Start of this month First day of the current month

Start of previous month First day of the previous month

Start of current quarter First day of the current quarterly accounting pe-
riod

Start of previous quarter First day of the previous quarterly accounting pe-
riod

Start of this year First day of the current calendar year

Start of previous year First day of the previous calendar year

Start of accounting period First day of the accounting period as defined in
the global preferences

• End Date: Enter or select a specific End Date,

or select one of the following named end date options which will be used to determine the end date
each time the report is run

Today The current date

End of this month Last day of the current month

End of previous month Last day of the previous month

End of current quarter Last day of the current quarterly accounting peri-
od

End of previous quarter Last day of the previous quarterly accounting pe-
riod

End of this year Last day of the current calendar year

End of previous year Last day of the previous calendar year

End of accounting period Last day of the accounting period as defined in
the global preferences

• Detail Level1: One of

Single Display 1 line

Multi-Line Display N lines146
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• Common Currency: Convert all transactions into a common currency

• Report's currency: Select the currency to display values

• Show original currency amount Also show original currency amounts

• Table for Exporting: Formats the table for cut & paste exporting with extra cells

• Add options summary: Adds an informative text describing options that were changed by user. This
is mainly useful for troubleshooting reports.

• Reset defaults button: Reset all values to their defaults

• Sorting tab

• Primary Key: Primary Sort Key. One of

None Do not sort

Account Name Sort and subtotal by account name

Account Code Sort and subtotal by account code

Date Sort by date

Reconciled Date Sort by the reconciled date

Reconciled Status Sort by the reconciled status

Register Order Sort as within the register

Other Account Name Sort by account transferred from/to's name

Other Account Code Sort by account transferred from/to's code

Amount Sort by amount

Description Sort by description

Number Sort by check/transaction number

Memo Sort by memo

• Primary Subtotal: Subtotal according to the primary key

• Primary Subtotal for Date Key: Do a date subtotal. Only configurable if primary key is date or rec-
onciled date. One of None, weekly, monthly, quarterly or yearly

• Primary Sort Order: One of

Ascending Smallest to largest, earliest to latest

Descending Largest to smallest, latest to earliest

• Secondary Key: Secondary Sort Key. Same options as Primary Key

• Secondary Subtotal: Subtotal according to the secondary key

• Secondary Subtotal for Date Key: Do a date subtotal. Only configurable if primary key is date or
reconciled date. One of None, weekly, monthly, quarterly or yearly

• Secondary Sort Order: One of
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Ascending Smallest to largest, earliest to latest

Descending Largest to smallest, latest to earliest

• Show Full Account Name: Show the full account name for subtotals and subtitles

• Show Account Code: Show the account code for subtotals and subtitles

• Show Account Description: Show the account description for subtitles

• Show Informal Debit/Credit Headers: Show informal names for debit/credit in the subtitles. This
requires that subtotal is enabled, and the primary or sortkey is account or account code.

• Add indenting columns: Add columns to align transactions within the same grouping together, and
can be useful to highlight groups.

• Show subtotals only (hide transactional data): Will hide transactions. This may be useful for reports
whereby only subtotals are required.

• Reset defaults button: Reset all values to their defaults

Displaying Split Account Details

This is controled by the Detail Level1 option on the Display tab.

In Single line mode, there's only one line per transaction. So you can have the account name on one side
of the equation and

a. the other account name if there's only one other split in the transaction or
b. Split if there are multiple other splits in the transaction. You can't display multiple "other" account

names in one line. There's just no room for it.

In the case of Multi-Line mode, this report uses a completely different concept. For each transaction, every
split (both the split in this account and the split(s) in the other account(s) !) is printed on a separate line.
And every split really means every split: both the split which belongs in the account being reported and
the split(s) in the other account(s) that balance the transaction. So even the most basic transaction, with
only two splits (this account and other account) will print two lines in multiline mode.

For a simple transaction like this

Description Account Debit Credit

Cheques Received

Multiple Payers Income Account £30.00

Bank Account £30.00

then on a Transaction Report for the bank account the details appear pretty much as above.

For clarity of the accounts, you might enter transactions with multiple splits referring to the same account.
For example, the above transaction might well be entered like this

Description Account Debit Credit

Cheques Received
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First Payer Income Account £10.00

Second Payer Income Account £20.00

Bank Account £30.00

When this transaction is printed on the bank account's Transaction Report in Single line mode, then under
other account it simply prints the word split instead of the account name.

To display the additional split detail, you need to set Single/Multi-Line to Multi-Line and then tick Display
-> Account Name. Do not tick Display->Other Account Name.

You can choose whether or not to turn off the full account name using Display -> Use Full Account Name.

Use Full Other Account Name has no effect in Multi-Line mode.

Assets & Liabilities
The Assets & Liabilities reports includes the Balance Sheet report, Investment reports and the Net Worth
report.

• Advanced Portfolio:

Columns

• Account: Stock Account

• Symbol: Ticker Symbol/Abbreviation as defined in the Security Editor. A report option can suppress
this column.

• Listing: Type as defined in the Security Editor. A report option can suppress this column.

• Shares: Number of shares (quantity). A report option sets how many decimal places to show. A report
option can suppress this column.

• Price: Unit market price as at report date. A report option can suppress this column.

• Basis: Cost of all shares acquired by any means, including brokerage fees if the option to include
them is checked. Report option Basis calculation method can be set to Average, LIFO or FIFO.

• Value: Number of shares * Unit market price as at report date

• Money In: Sum of the cost of stock purchased, excluding stock acquired as part of a Dividend Rein-
vestment Plan. I.e. External money used to purchase shares.

• Money Out: Money from selling shares or a spin off transaction.

• Realized Gain: Money received for selling shares minus basis for shares sold, minus brokerage fees
for the sale if the option to include them in basis is checked.

• Unrealized Gain: Value less Basis for unsold shares

• Total Gain: Realized Gain + Unrealized Gain

• Rate of Gain: Total Gain / Money In * 100 (from GnuCash 2.6.1 onwards)

• Income: Total of all income transactions associated with a stock account.
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Note

To include income from dividends which are not reinvested (if there is no split to the stock
account in the income transaction, the report has no way of associating the income with a
particular stock) :

Ensure there is a dummy transaction split to the stock account with quantity 0, price 1 and
value 0 in the dividend transaction. Enter the dummy stock split with no values in the divi-
dend account and it will create the transaction with price 1 even though you cannot see the
Price column in that register.

In GnuCash 2.6.6, this report was modified to simplify the recording of dividend and interest
payments. With this change it may not be necessary to include the dummy stock split in
the transaction. The report will find income (and expense) transactions that are in the parent
account of the stock account being reported on. This is done by looking in the parent account
for transactions that have exactly two splits (not counting trading account splits) where the
other split is to an income or expense account with the same name as the stock's account.

For example given an account structure like

Assets (type ASSET)
  Broker (type ASSET)
    Widget Stock (type STOCK)
Income (type INCOME)
  Dividends (type INCOME)
    Widget Stock (type INCOME)

A transaction that debits the "Assets:Broker" account and credits the "Income:Dividend-
s:Widget Stock" account will count as income even though it doesn't have a split with ac-
count "Assets:Broker:Widget Stock".

This only works if the parent account ("Assets:Broker" in this case) is a Bank or Asset
account and the Income/Expense account has the same name as the stock account. It won't
double count transactions that have a dummy split since they won't have exactly two split
transactions.

It will not work if the income or expense account split is to a subaccount of the account with
the same name as the stock account i.e. "Income:Dividends:Widget Stock:Franked"

• Brokerage Fees: Brokerage Fees

• Total Return: Total Gain + Income

• Rate of Return: Total Return / Money In * 100

Common report options are described in the section called “Configuring Reports and Charts”

Report Specific Options

• Accounts Tab

• Include accounts with no shares: Unchecked (default) or checked.

• Display Tab
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• Show ticker symbols: Checked (default) or unchecked. If unchecked, Symbol column will be omit-
ted.

• Show listings: Checked (default) or unchecked. If unchecked, Listing column (source of shares
price quotes) will be omitted.

• Show number of shares: Checked (default) or unchecked. If unchecked, Shares column will be
omitted.

• Share decimal places: The number of decimal places to show in the number of shares. Default is 2.

• Show prices: Checked (default) or unchecked. If unchecked, Price column will be omitted.

• General Tab

• Price Source: Nearest in time (default) or Most Recent.

• Basis calculation method: Average (default), FIFO or LIFO.

• Set preference for price list data: Checked (default): Use price list data. If there is no relevant price
list data, transaction prices will be used and there will be a warning. Unchecked: Get prices from
stock transactions.

• How to report brokerage fees: Include in basis (default), Include in gain or Ignore.

• Asset Barchart:

The Asset Barchart report displays bars that present the value of all assets in a GnuCash file over time. By
default, the report shows all accounts in Accounts Receivable, Current Assets, Fixed Assets, Investments
and Special Accounts (if they exist) and it displays monthly bars for the current financial period. This
report provides a graphic view of the assets in the file over time.

Tip

Like all the generic reports, the user can assign a title and save the report with it's selected
options for re-use later.

The display is in the form of either a stacked barchart or simple barchart with an option to display a
table of the values.

This report calculates and displays a default of 8 bars or up to 24 separate asset accounts value at the end
of the day on several dates through a specified time period. The report automatically selects the most
significant accounts to display with all other selected accounts summed as Other.

The report exploits the outline structure of the chart of accounts to allow the user to select top level
accounts and sub-accounts down to a user-selectable depth. Selected sub-accounts below the selected
depth are automatically summed up into the next level when it is also selected. The default number of
sub-account levels is 2, giving a summary view. Increasing the number of sub-levels increases the detail
available to display. It is possible to un-select a higher level account and leave sub-accounts selected
to force greater detail to appear in the report.

By default the report includes all asset accounts and sub-accounts, as well as Imbalance and Orphan
Special accounts in whatever currencies or commodities may be present. The report's base currency is
the default currency of the GnuCash file but if the file has data for multiple currencies, then it can be
changed to another currency.
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Since each account may be individually selected, the report can be designed to focus on a small subset
of data such as current assets or investments.

The overall interval of the report defaults to start at the start of the current accounting period and to
end at the end of the current accounting period. Numerous other starting choices and ending choices
are available.

The first bar shows the selected values at the end of the day on the first date chosen. There are a number
of choices for step size from day to year with the default being month. Note that if any step date would
fall on the 29th, 30th or 31st in a month that does not have such a date the next interval will be 31 days
later. For that step only the date will slip up to 3 days into the following month. This is true for releases
at least through 2.4.13. Bug 639049 is open in Bugzilla to modify this behavior.

Currently, there is no option to start the report on the last day of any period. There is also no option to
show beginning balances or end of previous step balances. This makes it difficult to correlate this report
to business quarterly reports, for example.

The Net Worth linechart report, Liability barchart report and Net Worth barchart report are similar
except for the graphic type and default account groups selected.

Other features are customizable in a manner similar to other standard reports.

• Asset Piechart:

• Average Balance:

• Balance Sheet: This report summarizes assets, liabilities, and equity. When properly maintained, assets
should equal the sum of liabilities and equity. If that is not the case, there is some kind of internal
imbalance in the accounts.

• Balance Sheet using eguile-gnc:

• General Journal:

• Investment Lots:
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Figure 9.2. The Investment Lots Report
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The Investment Lots report shows details about lots in a selected set of accounts of type Stock or Mutual Fund. It
includes an optional capital gains summary chart and a table with columns for dates, purchases, sales, end balances,
capital gains (realized and unrealized, short term and long term), and return on investment (ROI). It also performs
optional lot validation checks.

For information about lots in GnuCash, see:

• the section called “Lots for Security Capital Gains”

Note

Lots can be used for both securities and invoices, but this report applies to securities.

• Tutorial and Concepts Guide

• Selling Shares with Automatic Calculation of Capital Gain or Loss Using Lots [https://www.gnu-
cash.org/docs/vnone/C/gnucash-guide/invest-sell1.html#invest-sellLots]

• Investment Lots [https://www.gnucash.org/docs/vnone/C/gnucash-guide/rpt_standardrpts.htm-
l#rpt_investlots] report

• Wiki: Concept of Lots [https://wiki.gnucash.org/wiki/Concept_of_Lots]

Account lots gains chart: Summarizes the lot gains and losses of each account.

Table Columns

Note

Most of the columns can be hidden in the report Column options.

Note

The Amount columns are denominated in each account's commodity. But the Value, Basis,
Price, and Gain columns are always denominated in the Report's currency, converted if nec-
essary.

• Lot Title

• GUID: The lot's internal, globally unique identifier. This column is hidden by default, as it is probably
not useful for most use cases. But it could come in handy for directly querying the GnuCash back
end data store.

• Date columns

• Opened: The date on which the lot was opened. In a well-formed lot, this is the transaction date
of the first (and ideally only) purchase split.

Warning

Placing more than one purchase split into a single lot can make ambiguous the holding
period, preventing gains from being accurately grouped by short term and long term.

• Closed: The date on which the lot was closed, which is the transaction date of the sale split that
reduces the lot balance to zero. If the lot is still open on the report end date, then Closed is blank.154
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• Bought columns

• Bought Amount: The total number of purchased shares.

• Bought Value (Basis): The total purchase value of the Bought Amount. This is the basis used for
computing gains.

• Bought Average Price: The average price of each purchased share.

• Sold columns

• Sold Splits: The total number of sold splits.

• Sold Amount: The total number of sold shares.

• Sold Basis: The total basis (purchase value) of the Sold Amount.

• Sold Value: The total value (sales proceeds) of the Sold Amount.

• Sold Average Price: The average sale price of each sold share.

Note

The Sold Amount, Sold Basis, and Sold Value columns can be optionally split into short-
term and long-term columns (e.g. ST Sold Amount and LT Sold Amount instead of Sold
Amount, etc.) via the Group gains by age (short term and long term) Columns option.

• End columns

• End Amount: The number of shares in the lot on the end date.

• End Basis: The basis (purchase value) of the End Amount.

• End Value: The value of the End Amount, using the share end price from the Price Source (e.g.
the latest price on the end date).

Note

The end price used to compute the End Value is displayed between the account name and
the lot rows.

• Realized gain columns

• Realized Gain: The capital gains (or losses) realized on sold shares. Sold Value minus Sold Basis.

• Realized ROI: The realized return on investment. Realized Gain divided by Sold Basis, as a per-
centage.

• Unrealized gain columns

• Unrealized Gain: The capital gains (or losses) that would be realized if the remaining shares were
sold on the end date. End Value minus End Basis.

• Unrealized ROI: The unrealized return on investment. Unrealized Gain divided by End Basis, as
a percentage.
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Note

The realized and unrealized gain columns can be optionally split into short-term and long-term
columns (e.g. ST Realized Gain and LT Realized Gain instead of Realized Gain, etc.) via the
Group gains by age (short term and long term) Columns option.

Report Options

• Accounts tab

These options control which accounts to include in the report, using a standard account selector.
Selected accounts that are not of type Stock or Mutual Fund are ignored.

Tip

Select only taxable accounts to scope the report to taxable capital gains.

Additional options:

• Include accounts with no shares: When disabled, accounts with an empty balance on the report's
end date are ignored. This can be useful when wanting to see only unrealized gains.

• Include accounts with no lots: If some commodity accounts intentionally do not use lots, then
disabling this option is a convenient way to prevent such accounts from cluttering the report.

• Chart tab

These options control the Account Lot Gains chart.

• Show Chart: The other chart options are ignored when this option is disabled.

• Chart type

Option

Stacked Bar Chart (default)

Bar Chart

The following chart examples each show the same four accounts that contain a mix of realized and
unrealized gains and losses, both short-term and long-term:
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Figure 9.3. The Investment Lots Report, Stacked Bar Chart
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Figure 9.4. The Investment Lots Report, Bar Chart
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• Chart location

Option Description

Top (default) Display the chart at the top of the report, above
the table

Bottom Display the chart at the bottom of the report, be-
low the table

• Plot width and Plot height: Controls the chart's dimensions.

Note

The chart gain categories are controlled by the Columns tab's Gains options.

• Columns tab

These options control which table columns are visible.

• Show lot guid column: Disabled by default.

• Show date columns

• Show bought columns

• Show sold columns

• Show end columns

• Gains options

Note

These options impact both the table columns and the chart.

• Show realized gain columns

• Show unrealized gain columns

• Group gains by age (short term and long term): Different governments can have different rules
regarding how long shares must be held to qualify for different tax treatment.

Option Description

No Do not group gains by age

Gains Only (default) Group gains by age

Gains and Sales Also group the Sold columns by age

• Long term gains age (years): Shares held longer than this many years count as long term. This
option is ignored when the Group gains by age (short term and long term) option is disabled.
Default: 1 year.

• Display tab
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• Show long account names: Controls which name to use for all accounts in the report: long (ful-
ly-qualified) or short.

• Show mnemonic in amounts: Controls whether the currency mnemonic will be use when reporting
amounts. I.e. "123 RIO" versus just "123". This setting only impacts amounts not values, which
are always displayed in the Report's currency, with its mnemonic.

• Include closed lots: Allows closed lots to be filtered out. This can be useful when wanting to see
only unrealized gains.

• Show blanks instead of zeros in table cells: This can make the report table look less cluttered. Does
not apply to Account Lots Total and Grand Total rows.

• Show lot split rows: When enabled, rows for each of the bought and sold splits pertaining to the lot
(within the report's date window) will be displayed nested under each lot row. Disabled by default.

• General tab

See the section called “Common Report Options”.

Note

The Start date and End date options define the lot's date window. Splits outside of this win-
dow are not included in the report. Except that splits from before the Start date are counted
only insofar as needed to calculate the Sold Basis, End Basis, and End Amount columns.
But these splits are not included in the report's other Bought columns and Sold columns, nor
are they shown when the Show lot split rows option is enabled.

• Validation tab

These options control how lots and accounts are validated. The report shows optional validation
warnings that help identify potential lot problems.

• Include only accounts with warnings: Enable this option to see only accounts that have one of
more of the enabled warnings. This can be useful for quickly validating that lots are well-formed,
especially in combination with selecting all accounts and all dates. Disabled by default.

• Warn if a lot has more than one bought split: The Scrub operation only adds one purchase per
lot, but GnuCash does not stop a user from manually adding multiple purchase splits to the same
lot--even though this is arguably bad practice. Having multiple purchase dates makes the holding
period ambiguous. But if this is desired, consider disabling both this warning and the Columns
tab's Group gains by age (short term and long term)  option. If the column option is left enabled,
then the report will use the date of the last purchase split for determining the holding period, but
continue to use the first purchase date for the lot Opened column.

Note

The last purchase date is used to calculate the holding period because long term gains
often receive favorable tax treatment, so it is probably worse to misidentify a gain as long-
term rather than as short-term. But better still is to not have more than one purchase per
lot, so the holding periods are unambiguous.

Example:
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Warning: Above lot has 2 bought splits. Consider separating them
into their own lots.

• Warn if a lot's balance drops below zero: The Scrub operation will not create negative lot balances.
But GnuCash does not prevent users from manually creating them. When this option is enabled,
the report shows a warning if a lot's balance becomes negative during the report date window.

Example:

Warning: Above lot's balance is negative on 10/29/2022. Consider
removing the responsible sale split from the lot and then scrubbing.

• Warn if a lot has a blank title: Disabled by default. Lot titles are optional. Enabling this warning
will flag lots with blank (empty or whitespace) titles.

Example:

Warning: Above lot's title is blank.

• Warn if the "Realized Gain/Loss" split(s) sum does not match the computed gains: The report
recomputes the gain/loss values from each sale, compares them with the sum of the lot's generated
“Realized Gain/Loss” splits and warns if they do not match.

Example:

Warning: Above lot's computed gain $(1,518.79) is not equal to the
"Realized Gain/Loss" split(s) sum $(1,518.80). Difference: $0.01

Note

If a “Realized Gain/Loss” split is incorrect, it can often be repaired thus:

1. Remove the sale split from the lot,

2. Delete the bad “Realized Gain/Loss” split,

3. Add the sale split back to the lot, to recreate the “Realized Gain/Loss” split, and

4. Reload this report and verify that the warning is gone.

• Warn if a split is not assigned to a lot: Realized and unrealized gains cannot be computed for splits
that are not in a lot. This warning flags accounts containing unassigned splits.

Option Description

No Warning disabled

Count (default) Warning message identifies the number of unas-
signed splits

List Unassigned splits are listed after the warning
message

Example:

Warning: 2 split(s) are not assigned to a lot. Do lots need to
be scrubbed? 161
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• Warn if the account balance does not match the computed lots' end balance: This is often another
indication that the account has splits that are not included in a lot.

Example:

Warning: End amount 236.5 RIO is not equal to actual account balance
234 RIO. Difference: 2.5 RIO. Do lots need to be scrubbed?

• General Ledger:

• Investment Portfolio: This report summarizes the value of the stocks in the current portfolio.

• Liability Barchart:

• Liability Piechart:

• Net Worth Barchart: Net worth is the difference between the value of assets or liabilities.

• Net Worth Linechart: Net worth plotted over time. Net worth is the difference between the value of
assets or liabilities.

• Price Scatterplot:

Business Reports

The Business Reports includes Customer and Vendor Reports and Printable Invoices as well as Aging
reports.

Customer Report

Customer Summary

Easy Invoice

Employee Report

Fancy Invoice

Job Report

Payable Aging

This report provides a listing of vendors and their aged outstanding balances. Vendors may be included if
they have posted business transactions (e.g. invoices) for the selected accounts payable account. It shows
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their current balance, and how much they have due from invoices over time periods 0-30 days, 31-60 days,
61-90 days, and over 90 days. The report also contains links to each vendor and to their current vendor
report.

Optionally, vendor address details may be also shown.

Tip

To export vendor address details, say in order to do a mail merge, select the optional vendor
address details in the report options display tab, apply the options to regenerate the report, then
copy and paste the report into a spreadsheet. Alternatively, the report can be exported to a .html
file, then read into a spreadsheet.

Report Options

Note

See the section called “Common Report Options” in the Configuring Reports and Charts section
of this help manual for more details of the common options.

• General tab

• Report name: Enter a descriptive name for this report - see the section called “Common Report Op-
tions”.

• Stylesheet: Select a style sheet for this report - see the section called “Common Report Options”.

• To: Select a date to report on or a named date. Transactions up to and including the selected date will
be used to calculate the outstanding aged balances. See the section called “Common Report Options”.

• Report's currency: Select the currency to display the values in - see the section called “Common
Report Options”

• Price Source: Select the source of price information used for currency conversion if needed. One of

Average Cost The volume-weighted net average price of all ex-
changes.

Weighted Average (default) The volume-weighted gross average price of all
exchanges up to the date of the report

Most recent The most recent recorded price

Nearest in time The price recorded nearest in time to the report
date

• Show Multi-currency Totals: If not selected, all totals are shown in the report currency.

• Sort By: Sort companies by one of

Name (default) Company name

Total Owed Total amount owed to company

Bracket Total Owed Amount owed in oldest bracket. If same, use next
oldest

• Sort Order: One of
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Ascending (default) 0 … 999,999.99, A … Z

Descending 999,999.99 … 0, Z … A

• Show zero balance items: Show companies even if they have a zero outstanding balance.

• Due or Post Date: Leading date. Which date to use to determine aging. One of

Due Date (default)

Post Date

• Payable Account: The accounts payable account used to select vendors to be reported. Vendors are
included if they have a posted business transaction (usually an invoice) on or before the report date
and also meet the Show zero balance items criteria.

• Display tab

• Address Name: Display vendor address name. This, and other fields, may be useful if copying this
report to a spreadsheet for use in a mail merge.

• Address 1: Display address line 1.

• Address 2: Display address line 2.

• Address 3: Display address line 3.

• Address 4: Display address line 4.

• Phone: Display address phone number.

• Fax: Display address fax number.

• Email: Display email address.

• Active: Display vendor active status.

Printable Invoice

Receivable Aging

This report provides a listing of customers and their aged outstanding balances. Customers may be included
if they have posted business transactions (e.g. invoices) for the selected accounts receivable account. It
shows their current balance, and how much they have outstanding from invoices over time periods 0-30
days, 31-60 days, 61-90 days, and over 90 days. The report also contains links to each customer and to
their current customer report.

Optionally, customer address details may be also shown.

Tip

To export customer address details, say in order to do a mail merge, select the optional customer
address details in the report options display tab, apply the options to regenerate the report, then
copy and paste the report into a spreadsheet. Alternatively, the report can be exported to a .html
file, then read into a spreadsheet.
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Report Options

Note

See the section called “Common Report Options” in the Configuring Reports and Charts section
of this help manual for more details of the common options.

• General tab

• Report name: Enter a descriptive name for this report - see the section called “Common Report Op-
tions”.

• Stylesheet: Select a style sheet for this report - see the section called “Common Report Options”.

• To: Select a date to report on or a named date. Transactions up to and including the selected date will
be used to calculate the outstanding aged balances. See the section called “Common Report Options”.

• Report's currency: Select the currency to display the values in - see the section called “Common
Report Options”.

• Price Source: Select the source of price information used for commodity conversion if needed. One of

Average Cost The volume-weighted net average price of all ex-
changes

Weighted Average (default) The volume-weighted gross average price of all
exchanges

Most recent The most recent recorded price

Nearest in time The price recorded nearest in time to the report
date

• Show Multi-currency Totals: If not selected, all totals are shown in the report currency.

• Sort By: Sort companies by one of

Name (default) Company name

Total Owed Total amount owed by company

Bracket Total Owed Amount owed in oldest bracket. If same, use next
oldest

• Sort Order: One of

Ascending (default) 0 … 999,999.99, A … Z

Descending 999,999.99 … 0, Z … A

• Show zero balance items: Show companies even if they have a zero outstanding balance.

• Due or Post Date: Leading date. Which date to use to determine aging. One of

Due Date (default)

Post Date 165
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• Receivables Account: The accounts receivable account used to select customers to be reported. Cus-
tomers are included if they have a posted business transaction (usually an invoice) on or before the
report date and also meet the Show zero balance items criteria.

• Display tab

• Address Source: Which customer address fields to display. One of

Billing (default) Address fields from billing address.

Shipping Address fields from shipping address.

• Address Name: Display customer address name. This, and other fields, may be useful if copying this
report to a spreadsheet for use in a mail merge.

• Address 1: Display address line 1.

• Address 2: Display address line 2.

• Address 3: Display address line 3.

• Address 4: Display address line 4.

• Phone: Display address phone number.

• Fax: Display address fax number.

• Email: Display email address.

• Active: Display vendor active status.

Tax Invoice

Vendor Report

Income & Expense
The Income & Expense reports includes the Cash Flow and Income Statement reports.

• Cash Flow:

• Equity Statement:

• Expense Barchart:

• Expense Piechart:

• Expense vs Day of Week:

• Income & Expense Chart:

• Income Barchart:

• Income Piechart:
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• Income Statement: This report summarizes sources of income and expenditure. (This report was called
Profit & Loss in gnucash-1.8.)

• Income vs Day of Week:

• Profit & Loss: This is the same report as the Income Statement but with a different title.

• Trial Balance: This report summarizes sources of income and expenditure.

Sample & Custom

Sample Report

Report illustrating basic techniques used to create GnuCash reports.

Sample Graphs

Sample Pie chart and Bar chart.

Average Balance

Bar chart with balance per month.

Expenses vs. Day of Week

Pie chart.

Income vs. Day of Week

Pie chart.

Budget

Budget Balance Sheet

Budget Barchart

Budget Flow

Budget Income Statement

Budget Profit & Loss

Budget Report

This report is used to compare budgeted and real amounts for selected accounts. It allows you to review
how well you follow the budget.

The report is generated as a table in which each row represents an account and each set of columns shows
the budgeted amount, the real amount, and the difference between them for each report period.
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Each entry in the real amount column is the sum of all the splits in the row's account over the column's
period. For example, if the report is set up for monthly periods, the column is for May, and the row is for
Expenses:Groceries, then the value will be the sum of all Expenses:Groceries splits for that May.

The report supports selecting a range of periods instead all of them. Periods that are out of range can be
included in the report as the consolidated columns around the selected range. This allows you to focus on
particular periods, for example the current one, and is especially useful for budgets with many periods.
For example, if you have a 12 period budget you can make a 3 column report with the format "(all periods
before columns set) (current period columns set) (all periods after columns set)" that is easily fits on the
screen and allows you to match values with account names.

Budget report options

Note

Here we describe only options that are specific for the Budget Report. You can find information
about standard parameters in the section called “Configuring Reports and Charts”.

• Show budget - include the budgeted values for the period

• Show actual - include the real values for the period

• Show difference - include the difference between budgeted and real values for the period. Enabling this
option does not force including budgeted and actual values in the report

• Show Column with totals - Adds a final column set containing budgeted, real value, and difference
columns summing those values across all periods of the report.

• Rollup budget amounts to parent - not used in the report, can be deleted or should be fixed

• Include accounts with zero total balances and budget values - enables display of accounts with no
budget or splits in any period.

• Budget - Select the budget to use for report generation

• Report for range of budget periods - Enables reporting on a subset of the budget by selecting a beginning
and an ending period.

• Range start - a combobox with a list of options to select the start period:

1. First - select first budget period

2. Previous - select previous period.

3. Current - select current period.

4. Next - select next period.

5. Last - select last budget period

6. Manual - enables spinbox where you can select exact period

Note

The current, previous, and next options select the period based on the date on which the report
is run, with current being the period in which the date falls, previous being the one before that,
and next the period after. If the current date falls outside the date range covered by the budget,
the first or last period will be used as appropriate.
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• Exact start period - options for select exact start period, enabled only if the range start option is set
to Manual

• Range end - a combobox with a list of options to select the end period. Values are the same as in Range
start options

• Exact end period - the same as Exact start period but for the end of range

• Include collapsed periods before selected - if on, then includes in the report all budget periods, that are
before selected period range, as a single consolidated column set

• Include collapsed periods after selected - if on, then includes in the report all budget periods, that are
after selected period range, as a single consolidated column set.

Country Specific Reports
Some report are only useful in specific regions. Each tax authority has other requirements. The availability
of this reports depend on your Locale Settings [https://wiki.gnucash.org/wiki/Locale_Settings]. As there
is currently not more than one report per country they are merged into the the section called “General
Reports”.

Important

To get useful data, the user has to segregate taxable and non taxable income into different ac-
counts, as well as deductible and non deductible expenses. The user must also set the TXF cate-
gory of each tax related account. This can be done by the Income Tax Information dialog, reach-
able by Edit → Tax Report Options . Its usage is explained in the section called “Setting Tax
Report Options”.

US: Tax Schedule Report and TXF Export

Note

This report is also visible, if no tax report for your region is available in GnuCash.

The tax schedule report lists all taxable income and deductible expense amounts used in the preparation of
US Income Tax returns. The purpose of the report is to provide a complete audit trail for these amounts. The
report is intended to be used by a tax payer to manually prepare his or her own tax return, or alternatively,
to be provided to a tax preparer for that purpose. The report can also be used to generate an export of all tax
related income and expenses to a TXF (Tax eXchange Format) file (this is in addition to exporting to the
HTML format that all reports allow). The TXF file can be imported into tax filing programs such as TaxCut
or TurboTax. The report should be run, inspected carefully for errors or omissions, and then corrections
made to transactions, report settings, currency conversion rates or the account structure as needed. This
process should be repeated as often as needed until all the amounts on the report are correct before a final
version is used and saved along with the tax returns.

For accounts specified in the report options (none = all) that are also flagged as Tax-related, all transac-
tions for the time period selected (also in the report options) are included. The report sorts transactions by
date within account providing subtotals by account within tax code within Form or Schedule line number.
Support is also provided for multiple copies of and for sub-line items for selected Forms/Schedules. Op-
tionally uses special date processing to include federal estimated tax payments after year end.

All totals are in USD since this is the currency required for filing US Income Tax returns. Non-USD
transaction amounts are converted to USD using the transaction conversion rate to USD, if available. If
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not, a conversion rate from the price database is used (either the date nearest the transaction date or nearest
the report date as specified in the report options; if none is available, transaction amounts are converted to
zero and the report provides a comment accordingly). A complete audit trail of conversions is provided.

DE: Steuer-Bericht und ElStEr Export

Note

This report is only visible, if the language is set to de | deutsch.

Printing or Exporting Reports and Charts
Note

Verify !!! How customize printing with Gnome?

GnuCash is able to print reports and to export the reports to HTML (web) pages. The Print GnuCash
Document dialog is accessed from the Print button on the toolbar or go to File → Print in the menu. To
Export a report to a web page (HTML) select the Export button on the Toolbar and type in a file name.

Most reports, being presented in HTML, can also be copied and pasted into a spreadsheet.

The Print GnuCash Document dialog is used to select which Printer to send the print job to or to print to
a File. It also contains a Preview button to view the document before printing. Press Print to send the job
to the selected printer or Cancel to dismiss the Print dialog.

Printing from an open register prints the Account Report, which is also called the Register Report. This
lists transactions in the account with a total. Other reports print as viewed in the Report screen.

Creating or Modifying Reports and Charts
It is possible to modify existing or write own reports, if the available ones are not suitable. To do this you
will need to know Guile, GNOME's implementation of Scheme, which again is a LISP-like programming
language, and it is an excellent idea to have a copy of the GnuCash source code available.

Introductory files in the source code

• gnucash/report/doc/report-html.txt [https://github.com/Gnucash/gnucash/tree/stable/gnucash/re-
port/doc/report-html.txt] documents the reporting interface.

• gnucash/report/reports/example/sample-report.scm [https://github.com/Gnucash/gnucash/tree/sta-
ble/gnucash/report/reports/example/sample-report.scm] is an example demonstrating different types of
options.

Accessing the GnuCash Application Programming Inter-
face (API)

To get informations from your GnuCash book for your report it is also necessary to access data from the
GnuCash engine. This binding is generated by Swig and based on a set of Scheme wrapper functions in
bindings/guile [https://github.com/Gnucash/gnucash/tree/stable/bindings/guile]. 2

2Up to version 2.0.5 G-Wrap was used and the file was src/g-wrap/gnc.html.
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Tip

Examine some of the other reports in gnucash/report/ [https://github.com/Gnucash/gnu-
cash/tree/stable/gnucash/report/] for an indication of how they are used.

Some users started a table in https://wiki.gnucash.org/wiki/Custom_Reports#The_Gnu-
Cash_API.

Because the above file only contains the syntax of the function you can use the nightly Doxygen generated
API documentation online for the stable branch [https://code.gnucash.org/docs/STABLE/] 3 to get more
information about the functions.

After setting up a build environment [https://wiki.gnucash.org/wiki/Building] you can also generate it
locally by running

# make users:
make doc
# ninja users:
ninja doc

in your build directory and then open BUILDDIR/libgnucash/doc/html/index.html with your
preferred browser.

Report Rendering
At present, reports are produced by calling a HTML-generation API, which outputs a dialect of HTML
and rendering this with a HTML widget. This has limitations, particularly when trying to align objects
precisely, as might be necessary for printing onto pre-printed invoices for example.

See also the section called “Printing or Exporting Reports and Charts”.

3After the first feature of the next major release got implemented a future branch [https://code.gnucash.org/docs/FUTURE/] will also appear.
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Chapter 10. Customizing GnuCash

Account Display Options
The View → Filter By ... is used to set or modify the view of the account tree window. The Accounts tab
of this form allows the selection of the types of accounts to display. These selections effect the view on
each specific open window of the account tree.

The Other tab allows enabling/disabling of the options; Show Hidden accounts, Show zero total accounts.

The account tree window, by default, only shows the quantity of each commodity that you own, under the
column heading Total. Often, however, you may want to display other values. This is easily accomplished
by clicking on the Options button (the small down pointing arrow on the right side of the main account
window Titlebar), and selecting the option(s) to display. These selections set the view on all open windows
of the account tree.

Setting Preferences
The GnuCash Preferences window allows you to customize your GnuCash session by setting several op-
tions. From the GnuCash menu select Edit → Preferences ( GnuCash → Preferences on macOS). The Gnu-
Cash Preferences window will open. Using the tabs on the left make your desired changes. The settings
in this dialog are set per user and not stored with the file. This is in contrast to the settings described in
the section called “Book Options”, which are kept with, and are part of, the file (or Book), and as such are
common to all users. So GnuCash Preferences settings are individual to each user who uses a given file
and any changes made by one user will not affect other users of that file. Also, a given user's preferences
will be common to all files that that user opens with GnuCash.

Tip

Pausing the cursor for a couple of seconds over options in these windows will display a tooltip
with in-depth information on the choice.

Note

The changes you make will be applied at once.

To close the GnuCash Preferences window press the Close button.

Each tab in the GnuCash Preferences window is discussed in its own section below. For a listing of the
tabs, see Chapter 10, Customizing GnuCash.

Note

The presentation of the sections that follows matches the order of the tabs, which are sorted
alphabetically by name, in English. The order of the tabs may be different in other languages.
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Accounting Period

Figure 10.1. The Preferences window, Accounting Period tab

• Start Date: This item sets the accounting period’s start date.

• Relative: Use the specified relative starting date for profit/loss calculations. Also use this date for net
assets calculations. Relative defines start by today or start of current/previous year, quarter, month.

• Absolute: Use the specified absolute starting date for profit/loss calculations. Also use this date for
net assets calculations.

• End Date: This item sets the accounting period’s end date.

• Relative: Use the specified relative ending date for profit/loss calculations. Also use this date for net
assets calculations.

• Absolute: Use the specified absolute ending date for profit/loss calculations. Also use this date for
net assets calculations.

• Summarybar content

• Include grand total: If checked, show in the Summarybar a grand total of all accounts converted to
the default currency.
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• Include non-currency totals: if this option is selected, GnuCash will include in the Summarybar a
total for non-currency items (for instance number of shares).

Accounts

Figure 10.2. The Preferences window, Accounts tab

• Separator Character: The account separator is the character that separates a parent account from its sub-
account, for example Utilities:Electric. The default is a : (Colon), but you can also select / (Slash), \
(Backslash), - (Dash) or . (Period), or any Unicode character that isn’t a letter or a number.

• Reverse Balanced accounts: This option lets you determine whether account balances will display as
positive or negative numbers:

• Income & Expense assigns a positive credit balance to income account balances and a negative debit
balance to expense account balances. See the section called “Types of GnuCash Accounts” for more
information on these account types.

• Credit accounts (default) displays a positive balance for account types that would normally carry a
credit balance (income, credit, liability, equity). See the section called “Types of GnuCash Accounts”
for more information on these account types.

• None shows all credit balances as negative and all debit balances as positive.
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• Labels: Select this option if you want column headings in the register to refer to debits and credits instead
of the default informal headings such as withdrawal and deposit.

• Default Currency: This item determines which currency will be selected by default when creating new
accounts.

• Locale: Use the system locale currency for all newly created accounts.

• Choose: specify the currency to use, independent of your system settings.

• Account Color: This option lets you manage the display of the account color set in the Edit Account
window:

• Show the Account Colors as background: show the accounts color as account name background in
the Accounts Page.

• Show the Account Colors on tabs: show the accounts color as background in the account register tabs.

Business

Figure 10.3. The Preferences window, Business tab

• General

• Enable extra buttons: If checked, extra toolbar buttons for common business functions are shown.
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• Open in new window: If checked, each invoice will be opened in its own top level window. If clear,
the invoice will be opened in the current window.

• Accumulate splits on post: Whether multiple entries in an invoice which transfer to the same account
should be accumulated into a single split by default.

• Invoices

• Report for printing: Allows to select the invoice report to be used for printing.

• Tax Included: Whether tax is included by default in entries on invoices. This setting is inherited by
new customers and vendors.

• Auto pay on posting: If enabled, at post time automatically attempt to pay customer documents with
outstanding pre-payments and counter documents.

Note

Counter documents are documents with opposite sign. For example for an invoice, customer
credit notes and negative invoices are considered counter documents.

The pre-payments and documents obviously have to be against the same customer.

• Bills

• Notify when due: Lets you set whether you want to be notified at GnuCash startup of when a bill
is soon to be due.

• Days in advance: How many days before the due date to warn about bills coming due.

• Tax Included: Whether tax is included by default in entries on bills. This setting is inherited by new
customers and vendors.

• Process payments on posting: If enabled, at post time automatically attempt to pay vendor documents
with outstanding pre-payments and counter documents.

Note

Counter documents are documents with opposite sign. For example for a bill, vendor credit
notes and negative bills are considered counter documents.

The pre-payments and documents obviously have to be against the same vendor.
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General

Figure 10.4. The Preferences window, General tab

• General

• Display "Tip of the Day" dialog: This option displays or hides the section called “The “Tip of The
Day” Screen” when GnuCash is started.

• Show splash screen: With this option you can enable or disable the visualization of the startup screen
while GnuCash is starting up.

• Perform account list setup on new file: This option turns off the display of the New Account Hierarchy
Setup assistant when the entry File → New File is selected from the GnuCash menu.

• Set book option on new files to use split "action" field for "Num" field on registers/reports: If selected,
the displayed setting on the New Book Options dialog for the Use Split Action Field for Number
setting will be selected and, if saved, the book option for the new file will be set so that the "Num" field
on registers shows/updates the split-action field and the transaction-num field is shown on the second
line in double line mode (and is not visible in single line mode). Otherwise, the displayed setting on
the dialog will not be selected and, if saved, the book option for the new file will be set so that the
"Num" field on registers shows/updates the transaction-num field. See the discussion in the section
called “Book Options” about how to set book options including the option for the section called “Use
Split Action Field for Number”. Regardless of the setting of this preference, the user can modify the
initially displayed setting for this option on the New Book Options dialog before saving the options.
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Note

If the New Book Options dialog appears in situations where a new book is being set up, the
settings from this preference will determine the default setting for the corresponding check box
on the dialog. However, the OK button on the New Book Options dialog must be pressed for
the setting to be made for the new book; otherwise it will default to not selected.

• Files

Note

The following options are only relevant for files saved in XML format.

• Compress files: This option determines whether the GnuCash data file will be compressed or not.

• Show auto-save confirmation question: If this option is enabled, GnuCash will show you a confirma-
tion screen each time the auto-save process is started.

• Auto-save time interval: This field sets the number of minutes between each automatic saving of the
file. Set to 0 to disable the auto-save feature.

• Enable timout on "Save changes on closing" question: If enabled, the Save changes on closing ques-
tion will only wait a limited number of seconds for an answer. If the user didn’t answer within that
time, the changes will be saved automatically and the question window closed. You can set the num-
ber of seconds in the Time to wait for answer field.

• Retain log files: In this section you can set your preferences about the log files using the provided
radio buttons.

• Never: Disable the creation of log files.

• For: Enter a specific number of days for which keep the files.

• Forever: Disable the auto deletion of log files; retains the log files forever.

• Search Dialog

• New search limit: Defaults to "new search" if fewer than this number of items is returned.
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Import

Figure 10.5. The Preferences window, Import tab

• General

• Enable skip transaction action: Enable the SKIP action in the transaction matcher. If enabled, a trans-
action whose best match’s score is in the yellow zone (above the Auto-ADD threshold but below the
Auto-CLEAR threshold) will be skipped by default.

• Enable update match action: Enable the UPDATE AND RECONCILE action in the transaction
matcher. If enabled, a transaction whose best match’s score is above the Auto-CLEAR threshold and
has a different date or amount than the matching existing transaction will cause the existing transac-
tion to be updated and cleared by default.

• Use Bayesian matching: Use Bayesian algorithms to match new transactions with existing accounts.

• Match display threshold: The minimal score a potential match must have to be displayed in the match
list.

• Auto-add threshold: A transaction whose best match’s score is in the red zone (above display thresh-
old, but below or equal to Auto-add threshold) will be added by default.

• Auto-clear threshold: A transaction whose best match’s score is in the green zone (above or equal to
Auto-clear threshold) will be cleared by default.
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• Likely match day threshold: A transaction whose date is within the threshold is likely to be a match.
Default is 4 days.

• Unlikely match day threshold: A transaction whose date is outside the threshold is unlikely to be a
match. Default is 14 days.

• Commercial ATM fees threshold: In some places commercial ATMs (not belonging to a financial
institution) are installed in places like convenience stores. These ATMs add their fee directly to the
amount instead of showing up as a separate transaction or in your monthly banking fees. For example,
you withdraw $100, and you are charged $101.50 plus Interac fees. If you manually entered that $100,
the amounts won’t match. You should set this to whatever is the maximum such fee in your area (in
units of your local currency), so the transaction will be recognized as a match by GnuCash.

• Automatically create new commodities: Enables the automatic creation of new commodities if any
unknown commodity is encountered during import. If not enabled, the user will be asked what to do
with each unknown commodity.

• QIF Import

• Show documentation: The first time you use the QIF importer you may notice that the importer has
detailed instructions on how to import a file. Once you have become familiar with using the importer,
you might want to turn off this option. Turning off the option gives you less detail in the importer
screens.

• Default transaction status (overridden by the status given by the QIF file): In this section you can set
the default status for imported transactions using the provided self-explainingradio buttons:

• Not cleared (Default)

• Cleared

• Reconciled
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Numbers, Date, Time

Figure 10.6. The Preferences window, Numbers, Date, Time tab

• Numbers

• Force Prices to display as decimals: Prices will round as necessary to display them as decimals instead
of displaying the exact fraction if the fractional part cannot be exactly represented as a decimal.

• Display negative amounts in red: If you turn off this option, GnuCash will display negative numbers
in black.

• Automatic Decimal Point: This option will automatically insert a decimal point into numbers you
type in.

Note

When a calculation is entered in the Amount field, the decimal sign is inserted into every
operand that omits a decimal separator.

• Decimal Places: This field allows you to set the number of decimal places to be used.

• Date Format: This option controls the appearance of the date (you can see a preview of the date beside
each of the choices). The available choices are:

• US: Use the date format common in the United States.
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• UK: Use the date format common in the United Kingdom.

• Europe: Use the date format common in continental Europe.

• ISO: Use the date format specified by the ISO-8601 standard.

• Locale: Use the date format specified by the system locale.

• Date completion: This option lets you manage the case when a date is entered without a year:

• In the current calendar year: Dates will be completed so that they are within the current calendar year.

• In a sliding 12-month window starting a configurable number of months before the current month:
(Default) Dates will be completed so that they are close to the current date. You can enter the max-
imum number of months to go backwards in time when completing dates in a range of 0…11 with
6 as default.

• Time Format

• Use 24-hour clock: Lets you specify if you want to use 24 or 12 hours time format. That is if 11
o’clock at night should be represented as 11PM or 23:00.

Online Banking

Figure 10.7. The Preferences window, Online Banking tab
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• Online Banking

Note

This section is shown only if GnuCash is compiled with Aqbanking and HBCI support.

• Close log window when finished: Close the log window when the operation is completed.

• Remember PIN: Enable this option if you want GnuCash to remember the PIN you enter for online
banking authentication.

• Verbose debug messages: Enable this option if you want GnuCash to show more information about
the online banking operations.

Online Quotes

Figure 10.8. The Preferences window, Online Quotes tab

The Online Quotes tab allows you to set options that affect the fetching of online quotes with the perl
module Finance::Quote.

• Alpha Vantage API key: To retrieve online quotes from Alphavantage, this key needs to be set. A key
can be retrieved from the Alpha Vantage website [https://www.alphavantage.co/].
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See also:

• the section called “Finance::Quote Sources”,

• “Automatic Updating Exchange Rates” in the guide.

Printing

Figure 10.9. The Preferences window, Printing tab

The Printing tab allows you to set some options that affect the printing of checks on paper.

• Print date format: Enable this option if you want to print on the check, below the actual date, its format
in 8 point type.

• Print blocking chars: Enable this option to print a series of three asterisks before and after each text
field in the check.

• Default font: Click the button on the left to open a Pick a Font screen in which you can customize the
font that will be used to print checks.
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Register

Figure 10.10. The Preferences window, Register tab

• Actions

• 'Enter' moves to blank transaction: If selected, move the cursor to the blank transaction at the end of
the register after the user presses the Enter key. Otherwise the cursor will be moved down one row.

• Auto-raise lists: If selected, all lists will automatically be expanded when input focus is in the list field.

• Tab order includes Transfer on Memorized Transaction: If selected, when the transaction is auto
filled, pressing the Tab key in the register the cursor’s jump will include the Transfer field.

• Reconciling

• Check cleared transactions: If selected, automatically check off cleared transactions when reconciling.

• Automatic credit card payment: If selected, after reconciling a credit card statement, prompt the user
to enter a credit card payment.

• Always reconcile to today: If selected, always open the reconcile screen with today’s date for state-
ment date, regardless of previous reconciliation.

• Graphics
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• Use GnuCash built-in color theme: If selected, the original GnuCash register color theme will be
used. Otherwise the system color theme will be applied to register windows.

• Double mode colors alternate with transactions: If selected, configures the register window to alter-
nate between the primary and secondary colors with each transaction, instead of each row.

• Draw horizontal lines between rows: If selected, GnuCash will draw a horizontal line between each
row.

• Draw vertical lines between columns: If selected, GnuCash will draw a vertical line between the cells
in each row.

Register Defaults

Figure 10.11. The Preferences window, Register Defaults tab

The Register Defaults tab preferences affect the behavior of the transaction register windows.

• Default Style

Here you can choose from 3 different styles for register windows:

• Basic ledger: Show all transactions on one line. (Two in double line mode.)

• Auto-split ledger: Automatically expand the current transaction to show all splits. All other transac-
tions are shown on one line. (Two in double line mode.)
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• Transaction journal: All transactions are expanded to show all splits.

• Other Defaults

• Register opens in a new window: If selected, register will be in a separate window instead of in a tab.

• Double line mode: If selected, show two lines of information for each transaction instead of one.

• Only display leaf account names: If selected, only the name of the leaf accounts will be displayed
in the Account selection popup. The default behavior is to display the full account name including
the path in the account tree.

Warning

Enabling this option implies that you use unique leaf account names.

• Number of transactions: How many transactions to show in a register. Set to 0 to show all transactions.

Reports

Figure 10.12. The Preferences window, Reports tab

The Reports tab preferences affect the behavior of GnuCash reports.

• Default Report Currency: This item determines which currency will be used by default when creating
reports. You can choose:
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• Locale: Use the system locale currency for all newly created reports.

• Choose: Use the specified currency for all newly created reports.

• Location

• Report opens in a new window: if you select this option, the reports will open up in a new window,
instead of in a tab.

Scheduled Transactions

Figure 10.13. The Preferences window, Scheduled Transactions tab

The Scheduled Transactions tab preferences affect the behavior of GnuCash for scheduling transactions.
More information about scheduled transactions can be found in the section called “Scheduling Transac-
tions”.

• Since Last Run Dialog

• Run when data file opened: If selected, the Since Last Run screen will appear when GnuCash opens
the file.

• Show notification window: If selected, a list of scheduled and created transactions will appear when
GnuCash opens the file.
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• Review created transactions: If selected, set Review created transactions as the default for the Since
Last Run dialog.

• Transaction Editor Defaults

• Auto-Create new transactions: If selected, new scheduled transactions will automatically be entered
into the register. If the auto-create option is enabled, you can also check Notify before transactions
are created so that you will be able to confirm creating the transactions.

• Create in advance: The default number of days in advance to create the registered scheduled trans-
actions.

• Remind in advance: The default number of days in advance to remind about new scheduled transac-
tions.

Windows

Figure 10.14. The Preferences window, Windows tab

• Window Geometry

• Save window size and position: If selected, next time GnuCash starts it will re-use the window size
and position configured in the last run.

• Tabs
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• Show close button on notebook tabs: Adds a small close icon on each tab, to make it easier to close
the various tabs.

• Bring the most recent tab to the front: If selected, the newly created tab will be shown over the other
tabs.

• Open new tabs adjacent to current tab: If selected, open new tabs adjacent to the current tab instead
of at the end.

• Width: The width of tab label expressed in characters.

Note

If the text in the tab is longer than this value (the test is approximate) then the tab label will
have the middle cut and replaced with an ellipsis.

• Tab Position

Position the tabs at the Top (default), Bottom, Left or Right.

• Summary Bar Position

Position the Summary Bar at the Top or at the Bottom (default) of the GnuCash main window.

Book Options
The File → Properties menu item is used to set or modify choices that affect how a specific GnuCash file
(also referred to as a Book) operates. Selecting this menu item brings up the Book Optionsdialog. This
dialog also appears in situations where you are importing transactions into a new book, with the title New
Book Options. It is automatically raised in these 'new book' situations because these settings can affect
how imported data are converted to GnuCash transactions and so should be considered and set before your
first import (specifically, the the section called “Use Split Action Field for Number” setting).

The settings in this dialog are kept with, and are part of, the file (or Book). This is in contrast to the settings
described in the section called “Setting Preferences”, which are set per user and not stored with the file.
So Book Options settings are shared by all users who use a given file and any changes made by one user
will affect all users of that file.

Tip

Pausing the cursor for a couple of seconds over options in these tabs will display a tooltip with
a more detailed description of the choice.

The Book Options dialog has five buttons that are common to all tabs. The Reset defaults button takes all
items on the visible tab and sets their value to the default setting; it only affects the visible tab. The Help
button opens up a help window to this section. The Cancel button closes the dialog, making no changes to
the saved settings for Book Options. The Apply button is initially insensitive but becomes sensitive when
any setting is set or changed. Selecting it saves the setting(s) for the book but keeps the Book Options dialog
open. Typically, the changes are reflected in the affected areas of GnuCash as soon as the button is pressed,
so it can be used to 'see' the effect of a given option without having to re-open the dialog. The Apply button
is not sensitive on the dialog if it appears during transaction import (that is, 'new book') situations. The
OK button behaves like the Apply button except that it immediately closes the dialog, as well.
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Accounts Book Options Tab

Figure 10.15. The Book Options window, Accounts tab

The Accounts tab of this dialog allows the selection of options that affect how accounting registers func-
tion.

Use Trading Accounts

Check the Use Trading Accounts checkbox to have trading accounts used for transactions involving more
than one currency or commodity.

Tip

To avoid several problems on multiple currency accounting read Peter Selinger's Tutorial on
multiple currency accounting [https://www.mathstat.dal.ca/~selinger/accounting/tutorial].

Day Threshold for Read-Only Transactions

Use the Day Threshold for Read-Only Transactions spin-box to choose the number of days before today,
prior to which, transactions will be read-only and cannot be edited anymore in the registers. This thresh-
old is marked by a red line in the account register windows. If zero, all transactions can be edited and
none are read-only. This feature is intended to be used to guard against accidental changes to non-current
transactions.

Use Split Action Field for Number

Note

This option is only available in GnuCash version 2.6 or later.

Check the Use Split Action Field for Number checkbox to have the split action field of the anchor split
used for the 'Num' column in registers, reports and import/export functions, where applicable, in place of
the transaction number; the transaction number is then shown as 'T-Num' on reports and on the second line
of registers. This choice has a corresponding effect on business features.

The difference between the two is that with the checkbox not selected, the same 'Num' is displayed for
a given transaction regardless of what register it is viewed in and with the checkbox selected, a different
'Num' can be entered/displayed for a given transaction in each register it is viewed in. In both cases, the
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'next number logic' of the 'Num' cell is based on the account of the register the transaction is entered to
or viewed from but in one case it fills the transaction number, in the other, it fills the split action field
of the anchor split. In both cases, both fields are visible and can be viewed and used as free-form text in
double-line mode for any value the user wants.

Warning

Initial setup of GnuCash: It is expected that, after careful consideration of the consequences,
this option will be set when a new GnuCash file is created and not changed thereafter (see next
warning). For this reason, a preference is provided (see Setting Preferences - General ) that can
establish an initial default setting for new files, so that if you will have more than one file, it is
easier to set them all up consistently. You may wish to set up a test file and experiment with the
two settings to understand the differences before establishing your first real GnuCash file.

Tip

Moving from Quicken: For users that are switching from other personal accounting applications,
such as Quicken, selecting this option may be more consistent with the numbering approach used
there and can preserve the numbering of historical data brought over; this option should be set
before performing the initial import.

Warning

Changing this option for an existing GnuCash file: If you change this option for an existing file,
historical data will not be changed. This means that if you set the option one way, enter (or
import) transactions, then change the option and enter (or import) additional transactions and
switch back-and-forth, you will end up with a file that will appear to have inconsistent treatment
of numbers in registers, reports and exports. This is because the setting of this option at the time
of data entry/import determines where the number data is stored and the setting at the time of data
display/reporting/exporting determines which field is displayed as number.

There is no reason to avoid changing this option for an existing GnuCash file if you understand
the implications. If you elect to make this change, it should probably be done between accounting
periods with the understanding that number data prior to the date the option is changed will be
displayed/reported/exported differently from that after the date.

Warning

If you change this option, and press Apply or OK, open registers and labels on query and sorting
dialogs will be refreshed to reflect the new option immediately. But open reports need to be
individually reloaded by the user to have the change reflected on the report.

Warning

This option is only available in GnuCash version 2.6 or later. If a GnuCash file from an earlier
version is opened in version 2.6 or later, and this feature is not used, this feature will not prevent
the file from being opened in the earlier version of GnuCash. However, if the option is set, the
file will not be able to be opened by the earlier version, even if the option is set back to its original
setting. A warning dialog will be displayed from the earlier version. Do not set this option if you
want to open the file with an earlier version.
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Budgeting Book Options Tab

Figure 10.16. The Book Options window, Budgeting tab

The Budgeting tab allows you to specify the budget to be used for reports when none has otherwise been
specified.

Business Book Options Tab

Figure 10.17. The Book Options window, Business tab
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The Business tab allows you to enter values that are in turn used by the business features of GnuCash:

Company Name

The name of the company is used in many reports.

Company Contact Person

The name of the contact person to print on invoices.

Company Phone, Fax, Email Address

The references of your business.

Company Website URL

The internet address of the company’s website.

Company ID

The tax ID of your company.

Default Customer TaxTable

The default taxtable applicable to your most common customers.

Default Vendor TaxTable

The default taxtable applicable to your most common vendors.

Fancy Date Format

The default date format used for fancy printed dates (e.g. on invoices).

Reset Defaults

Press the button to reset all values to their defaults.

Note

None of the above values is required to use GnuCash but, if given, will be used throughout the
program. (f.e. in reports, invoices etc...)
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Counters Book Options Tab

Figure 10.18. The Book Options window, Counters tab

The Counters tab allows you to set the 'previous' value for each number indicated: Bill, Customer, Em-
ployee, etc. These counters are used by the Chapter 7, Business Features of GnuCash.

The number entered here will be incremented when the various business features calculate a value for
a corresponding field on a dialog. For example, if you leave the Customer Number field blank on the
New Customer dialog, the customer will be assigned the number in the counter field plus 1. The numbers
displayed in the tab are incremented as these business features are used. (But note that if you have the
Book Options dialog open, you need to close it and re-open it to see the changes; the displayed field values
are not automatically refreshed.)

The corresponding format fields are used to specify printf-style format strings that are used to format the
printing of the number. For example, to put the literal "C - " in front of the customer number, you would
put "C - %li" (without the quotes) in the customer format string field. If the value in the customer number
field was 5, the next customer added would be assigned the number "C - 6". As another example, if you
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wanted the number to be printed with leading zeros and 5 characters wide, you would enter "C - %05li"
and the next customer number would be assigned the number "C - 00006".

Note

For historical reasons GnuCash accepts multiple format specifiers although they all yield the same
end result. You can choose "li", "lli" or I64i".

Changing Style Sheets
GnuCash has four default style sheets for web-page reports. These style sheets can be altered by using the
HTML Style Sheets editor. To access the editor go to Edit → Style Sheets...

Using the Style Sheet Editor you may display/modify the setting of a Style Sheet.

Note

Changing the Style Sheet will change the appearance of all reports that have selected that Style
Sheet. A Reload is required to view the changes, if the report(s) are currently displayed.

To add a new Style Sheet click the New... button in the Style Sheet pane. The New Style Sheet dialog will
appear. Fill in the name field with the name of the new Style Sheet and choose a template. To remove a
Style Sheet select the Style Sheet from the list and click Delete.

Default Style Sheet
The Default Style Sheet has four tabs to alter the appearance of reports utilizing it, Colors, Fonts, General
and Tables.

Colors Tab

• Alternate Table Cell Color: Opens the color picker to choose a color that will be applied to alternate
table rows.

Fonts Tab

• Title: Select the font and size for Titles.

• Account Link: Select the font and size for Account Links.

• Number Cell: Select the font and size for Number Cells.

• Negative Values in Red: Select to have negative values displayed in red.

• Text Cell: Select the font and size for Text Cells.

• Total Number Cell: Select the font and size for Total Number Cells.

• Total Label Cell: Select the font and size for Total Label Cells.

• Centered Label Cell: Select the font and size for Centered Label Cells.

General Tab

• Background Color: Opens the color picker to choose a new background color.

• Background Pixmap: Use the Browse button to select a picture to use as the background in reports.
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• Enable Links: Select this to enable blue hyperlinks in reports.

Tables Tab

• Table cell spacing: Sets the space between table cells

• Table cell padding: Sets the space between table cell edges and contents

• Table border width: Sets the width of the borders on tables.

Easy Style Sheet
The Easy Style Sheet has five tabs to alter the appearance of reports: Colors, Fonts, General, Images and
Tables.

Colors

• Background Color: Opens the color picker to choose a new background color.

• Text Color: Opens the color picker to choose a new text color.

• Text Cell Color: Opens the color picker to choose a new text cell color.

• Link Color: Opens the color picker to choose a new link color.

• Alternate Table Cell Color: Opens the color picker to choose a new color for alternate table rows.

• Subheading/Subtotal Cell Color: Opens the color picker to choose a new color for subheading/subtotal
table rows.

• Sub-subheading/total Cell Color: Opens the color picker to choose a new color for sub-subheading/total
table rows.

• Grand Total Cell Color: Opens the color picker to choose a new color for grand total rows.

Fonts

• Title: Select the font and size for Titles.

• Account Link: Select the font and size for Account Links.

• Number Cell: Select the font and size for Number Cells.

• Negative Values in Red: Select to have negative values displayed in red.

• Number Header: Select the font and size for Number Header table rows.

• Text Cell: Select the font and size for Text Cells.

• Total Number Cell: Select the font and size for Total Number Cells.

• Total Label Cell: Select the font and size for Total Label Cells.

• Centered Label Cell: Select the font and size for Centered Label Cells.

General

• Preparer: Name of the person preparing the report.
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• Prepared for: Name of Organization or Company the report is prepared for.

• Show preparer info: Show the Preparer information in the report.

• Enable Links: Select this to enable blue hyperlinks in reports.

Images

• Background Tile: Use the Browse button to select a picture to use as the background in reports. The
Clear button will clear the selection.

• Heading Banner: Use the Browse button to select a picture to use as the heading in reports. The Clear
button will clear the selection.

• Heading Alignment: Select from pull-down list; Left, Right, Center, to specify the alignment of the
banner at the top of report(s).

• Logo: Use the Browse button to select a picture to use as the logo in reports. The Clear button will
clear the selection.

Tables

• Table cell spacing: Sets the space between table cells

• Table cell padding: Sets the space between table cell edges and contents

• Table border width: Sets the width of the borders on tables.

Footer Style Sheet
The Footer Style Sheet has the same five tabs to alter the appearance of reports as the Easy Style Sheets:
Colors, Fonts, General, Images and Tables.

Colors

• Background Color: Opens the color picker to choose a new background color.

• Text Color: Opens the color picker to choose a new text color.

• Text Cell Color: Opens the color picker to choose a new text cell color.

• Link Color: Opens the color picker to choose a new link color.

• Alternate Table Cell Color: Opens the color picker to choose a new color for alternate table rows.

• Subheading/Subtotal Cell Color: Opens the color picker to choose a new color for subheading/subtotal
table rows.

• Sub-subheading/total Cell Color: Opens the color picker to choose a new color for sub-subheading/total
table rows.

• Grand Total Cell Color: Opens the color picker to choose a new color for grand total rows.

Fonts

• Title: Select the font and size for Titles.
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• Account Link: Select the font and size for Account Links.

• Number Cell: Select the font and size for Number Cells.

• Negative Values in Red: Select to have negative values displayed in red.

• Number Header: Select the font and size for Number Header table rows.

• Text Cell: Select the font and size for Text Cells.

• Total Number Cell: Select the font and size for Total Number Cells.

• Total Label Cell: Select the font and size for Total Label Cells.

• Centered Label Cell: Select the font and size for Centered Label Cells.

General

• Preparer: Name of the person preparing the report.

• Prepared for: Name of Organization or Company the report is prepared for.

• Show preparer info: Show the Preparer information in the report.

• Enable Links: Select this to enable blue hyperlinks in reports.

• Footer: Text to be included in report footer.

Images

• Background Tile: Use the Browse button to select a picture to use as the background in reports. The
Clear button will clear the selection.

• Heading Banner: Use the Browse button to select a picture to use as the heading in reports. The Clear
button will clear the selection.

• Heading Alignment: Select from pull-down list; Left, Right, Center, to specify the alignment of the
banner at the top of report(s).

• Logo: Use the Browse button to select a picture to use as the logo in reports. The Clear button will
clear the selection.

Tables

• Table cell spacing: Sets the space between table cells

• Table cell padding: Sets the space between table cell edges and contents

• Table border width: Sets the width of the borders on tables.

Technicolor Style Sheet
The Technicolor Style Sheet has has five tabs to alter the appearance of reports: Colors, Fonts, General,
Images and Tables.

Colors

• Background Color: Opens the color picker to choose a new background color.
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• Text Color: Opens the color picker to choose a new text color.

• Text Cell Color: Opens the color picker to choose a new text cell color.

• Link Color: Opens the color picker to choose a new link color.

• Alternate Table Cell Color: Opens the color picker to choose a new color for alternate table rows.

• Subheading/Subtotal Cell Color: Opens the color picker to choose a new color for subheading/subtotal
table rows.

• Sub-subheading/total Cell Color: Opens the color picker to choose a new color for sub-subheading/total
table rows.

• Grand Total Cell Color: Opens the color picker to choose a new color for grand total rows.

Fonts

• Title: Select the font and size for Titles.

• Account Link: Select the font and size for Account Links.

• Number Cell: Select the font and size for Number Cells.

• Negative Values in Red: Select to have negative values displayed in red.

• Number Header: Select the font and size for Number Header table rows.

• Text Cell: Select the font and size for Text Cells.

• Total Number Cell: Select the font and size for Total Number Cells.

• Total Label Cell: Select the font and size for Total Label Cells.

• Centered Label Cell: Select the font and size for Centered Label Cells.

General

• Preparer: Name of the person preparing the report.

• Prepared for: Name of Organization or Company the report is prepared for.

• Show preparer info: Show the Preparer information in the report.

• Enable Links: Select this to enable blue hyperlinks in reports.

Images

• Background Tile: Use the Browse button to select a picture to use as the background in reports. The
Clear button will clear the selection.

• Heading Banner: Use the Browse button to select a picture to use as the heading in reports. The Clear
button will clear the selection.

• Heading Alignment: Select from pull-down list; Left, Right, Center, to specify the alignment of the
banner at the top of report(s).

• Logo: Use the Browse button to select a picture to use as the logo in reports. The Clear button will
clear the selection.
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Tables

• Table cell spacing: Sets the space between table cells

• Table cell padding: Sets the space between table cell edges and cell contents

• Table border width: Sets the width of the borders on tables.

Setting Tax Report Options
The tax report can be used to prepare online tax reports for specific countries, see the section called “Country Specific
Reports”. Currently US and partial DE are supported.

Localization

Before it can be used in other regions, one needs to provide a localized taxtable. See the in-
structions in the wiki [https://wiki.gnucash.org/wiki/Translation#How_to_create_localized_In-
come_Tax_Tables].

The Income Tax Information dialog is used to set Tax Report Options. The settings on accounts in this
dialog are used by the TXF Export function in reports to select the accounts for export. To access this
dialog go to Edit → Tax Report Options .

Tip

If the Income Tax features are used, it is strongly recommended that the Tax Info column be made
visible on the accounts tab (click large downward-pointing arrow and select Tax Info check box).
The Tax Info column will display the Form/Schedule and tax category (e.g., Schedule D Dividend,
cap gain distrib.) assigned to an account, if any. Alternatively, it will display the following error
messages which can be corrected through Edit → Tax Report Options :

• Tax-related but has no tax code
• Tax entity type not specified
• Tax type "tax_type": invalid code "code" for account type"
• Not tax-related; tax type "tax_type": invalid code "code" for account type
• Invalid code "code" for tax type "tax_type"
• Not tax-related; invalid code "code" for tax type "tax_type"
• No form: code "code", tax type "tax_type"
• Not tax-related; no form: code "code", tax type "tax_type"
• No description: form "form", code "code", tax type "tax_type"
• Not tax-related; no description: form "form", code "code", tax type "tax_type"
• Not tax-related; "form"("copy") "desc" (code "code", tax type "tax_type")

The Income Tax Identity must be set in order to assign codes to individual accounts. Click Edit to set the
identity. The Tax Name is optional. If entered, it will be printed at the top of the report. A Type must be
selected in order to activate the tax category selections. The choices are:

• Individual, Joint, etc. - Files US Form 1040 Tax Return
• Partnership - Files US Form 1065 Tax Return
• Corporation - Files US Form 1120 Tax Return
• S Corporation - Files US Form 1120S Tax Return
• None - No Income Tax Options Provided

While the Income Tax Entity Type can be changed after tax categories have been assigned to accounts,
you should be cautioned that you will need to manually change each one if you do so, which could be quite
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tedious. The tax categories are unique for each Income Tax Entity Type, so changing the type will make
all previously assigned categories invalid. It is assumed (and highly recommended) that each GnuCash
file is for only one tax entity and this is where you specify its type of tax entity. You should not keep,
for example, personal and partnership accounts mixed in one GnuCash file if you plan to use the Income
Tax Reporting features.

A given TXF code can be assigned to multiple accounts. The Tax Schedule Report will combine accounts
by code and generate a detailed TXF record for each account and a summary TXF record for the total as
calculated by the report.

For codes for which the "Payer Name Source" is not grayed, the payer on the TXF record will be based on
what is specified here, either the account name of the account or the account name of the account’s parent
account. This feature is typically used for interest accounts or stocks or mutual funds that pay dividends
where the individual payees are shown on the tax schedule. For example, if the parent account’s name is
the name of your broker and the sub-account’s names are the names of individual stocks that pay dividends
and the name on the 1099-DIV received is that of the broker, in order to match that name, you would
select ’Parent Account’; the total dividends from the broker would be exported and, if you had several
brokers, there would be an amount exported and a subtotal for each broker, along with each brokers name.
Alternatively, if you had a parent account named Directly Held, for example, and below it sub-accounts
for one or more stocks, you would receive a 1099-DIV from the issuer of each stock separately and, in
order to match that name, you would select Current Account; the total dividends from each stock would
be exported and, if you had several stocks, there would be an amount exported and a subtotal for each
stock, along with each stock’s name as the payer.

Some tax Forms/Schedules need to have multiple copies filed under some circumstances (for example,
Schedule C if a taxpayer and spouse have separate businesses). For tax categories on these Forms/Sched-
ules, the Copy Number is not grayed out and can be used to segregate accounts by copy number.

• Accounts: This pane contains the list of accounts. Select an account to set a TXF category. If no account
is selected nothing is changed. If multiple accounts are selected, all of the accounts will be set to the
selected item.

• Tax Related: Select this check-box to add tax information to an account then select the TXF Category
below. This setting is displayed on the account edit dialogue but cannot be changed from there.

• TXF Categories: Select the desired one. A detailed description appears just below (if available, otherwise
it says No help available), along with the TXF code for the category and information about what line
number on the form or schedule the amounts are included in by tax year (used for detailed sort on report).

• Payer Name Source: Select an option to determine where the text description that is exported along with
the value of the account is derived from, as described above. This is usually the name of a bank, stock,
or mutual fund that pays dividends or interest. Occasionally, it is a description of a deduction.

• Copy Number: A copy number that is exported along with the value of the account. This is used to
segregate amounts between different copies of the same Form/Schedule that may need to be filed (e.g.,
Schedule C(1), Schedule C(2), etc.). This is also used to sort the report.

TXF Export - Known Anomalies and Limitations
TaxCut 1999

• Code: N488 "^ Sched B \ Div. income, cap gain distrib."

• Code: N286 "^ Sched B \ Dividend income"

These two codes, from the same payer, are not correlated. The user will have to adjust for this after import.
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TaxCut 1999, 2000

• Code: N521 " F1040 \ Federal estimated tax, quarterly"

Does not accept the date field and does not import the individual payment amounts, only the total. The
date and individual payment amounts, only matter if you have to compute the penalty. (this may be a
TurboTax enhancement)

• Code: N460 " W-2 \ Salary or wages, self"

• Code: N506 " W-2 \ Salary or wages, spouse"

• and other related codes.

Use Copy Number to separate information from more than one job.

TurboTax 1999, 2000

• Code: N521 " F1040 \ Federal estimated tax, quarterly"

Does not accept the dates outside of the tax year. This is a problem for the last payment that is due Jan 15.
GnuCash changes the the date of the last payment to Dec 31 for the export unless the "Do not use special
date processing" option is selected in the report options display tab. The user will have to adjust for this
after import. The date only matters if you have to compute the penalty.

TXF Tax eXport Format

• Duplicate Codes

Codes can be assigned to multiple accounts and the amounts will be summed for all the accounts generating
one detail TXF record per account and one summary TXF record for the sum. Codes that let you select
"Payer Name Source" will generate a separate summary TXF account with each change in payer. Selecting
the "Print TXF export parameters" option will cause the report to show to which codes this applies (Payer
Name Source option Y) and, for the accounts assigned to those codes, the Name Source each account is set
to and the TXF item number that will be assigned to each. A summary TXF record will be generated for
each change in assigned item line number. These may not be handled the same by TaxCut and TurboTax.

• Code: N673 "Short/Long gain or loss"

Short term or long term gain or loss from the sale of a security; generates TXF output for only the date
sold and sales amount, with the date acquired and cost basis information left blank (to be separately added
in the tax software). The code can be assigned to either a short-, long-, or mixed-term gain/loss income
account and the security sales transaction should be entered as illustrated in Section 8.7, Selling Shares, of
the GnuCash Tutorial and Concepts Guide. The report uses the transaction split of the gain/loss account to
find one or more other splits in the same transaction with negative share quantities. For each of these found,
it generates a detailed TXF output record with the quantity sold, the name of the security, the date sold,
and the sales amount. Note that if, for a given transaction, more than one transaction split is to a gain/loss
income account assigned to code 673, TXF output data will be erroneously repeated. That is because the
report will fetch the same data, and re-output it, for each transaction split set to a gain/loss income account
within the same transaction. For this reason, there should be no more than one gain/loss account entered
per transaction to use this tax reporting code properly. (Note that no amounts are used from GnuCash’s
lot-tracking; a future enhancement is expected to use this data to provide capital gain reporting).

Detailed TXF Category Descriptions
Table 32. Detailed TXF Category Descriptions
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Table 10.1. Detailed TXF Category Descriptions

Tax Form \ TXF Code

Description

Extended TXF Help messages

< help \ H001

Name of Current account is exported.

Categories marked with a “<” or a “^”, require a
Payer identification to be exported. “<” indicates
that the name of this account is exported as this Pay-
er ID. Typically, this is a bank, stock, or mutual fund
name.

^ help \ H002

Name of Parent account is exported.

Categories marked with a “<” or a “^”, require a
Payer identification to be exported. “^” indicates
that the name of the PARENT of this account is ex-
ported as this Payer ID. Typically, this is a bank,
stock, or mutual fund name.

# help \ H003

Not implemented yet, Do NOT Use!

Categories marked with a “#” not fully implemented
yet! Do not use these codes!

none \ N000

Tax Report Only - No TXF Export

This is a dummy category and only shows up on the
tax report, but is not exported.

Help F1040 \ H256

Form 1040 - the main tax form

Form 1040 is the main form of your tax return.

F1040 \ N261

Alimony received

Amounts received as alimony or separate mainte-
nance. Note: child support is not considered alimo-
ny.

F1040 \ N257

Other income, misc.

Miscellaneous income such as: a hobby or a farm
you operate mostly for recreation and pleasure, jury
duty pay. Exclude self employment income, gam-
bling winnings, prizes and awards.

F1040 \ N258

Sick pay or disability pay

Amounts you receive from your employer while you
are sick or injured are part of your salary or wages.
Exclude workers’ compensation, accident or health
insurance policy benefits, if you paid the premiums.

F1040 \ N260

State and local tax refunds

Refund of state or local income tax refund (or credit
or offset) which you deducted or took a credit for
in an earlier year. You should receive a statement,
Form 1099-G. Not reportable if you didn’t itemize
last year.

F1040 \ N262

IRA contribution, self

Contribution to a qualified IRA. If you or your
spouse are covered by a company retirement plan,
this amount could be limited or eliminated.

F1040 \ N263

Keogh deduction, self

Contributions to a Keogh or HR 10 plan of a sole
proprietor or a partnership.

F1040 \ N264

Alimony paid

Amounts payed as alimony or separate mainte-
nance. Note: child support is not considered alimo-
ny.
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Tax Form \ TXF Code

Description

Extended TXF Help messages

< F1040 \ N265

Early withdrawal penalty

Penalty on Early Withdrawal of Savings from CD’s
or similar instruments. This is reported on Form
1099-INT or Form 1099-OID.

F1040 \ N266

Social Security income, self

The part of any monthly benefit under title II of the
Social Security Act. These will be reported on Form
SSA-1099.

F1040 \ N269

Taxable fringe benefits

Fringe benefits you receive in connection with the
performance of your services are included in your
gross income as compensation. Examples: Acci-
dent or Health Plan, Educational Assistance, Group-
Term Life Insurance, Transportation (company car).

F1040 \ N481

IRA contribution, spouse

Contribution of a working spouse to a qualified IRA.
If you or your spouse are covered by a company re-
tirement plan, the deductible contribution could be
limited or eliminated.

F1040 \ N482

IRA contrib., non-work spouse

IRA contribution for a non-working spouse.

F1040 \ N483

Social Security inc., spouse

Spouse’s part of any monthly benefit under title II
of the Social Security Act. These will be reported on
Form SSA-1099.

F1040 \ N516

Keogh deduction, spouse

Spouse Contributions to a Keogh or HR 10 plan of
a sole proprietor or a partnership.

F1040 \ N517

SEP-IRA deduction, self

Contributions made to a simplified employee pen-
sion plan (SEP-IRA).

F1040 \ N518

SEP-IRA deduction, spouse

Spouse contributions made to a simplified employee
pension plan (SEP-IRA).

F1040 \ N519

RR retirement income, self

The part of tier I railroad retirement benefits, which
are treated as a social security benefits. These will
be reported on Form RRB-1099.

F1040 \ N520

RR retirement inc., spouse

Spouse’s part of tier I railroad retirement benefits,
which are treated as a social security benefits. These
will be reported on Form RRB-1099.

F1040 \ N521

Federal estimated tax, quarterly

The quarterly payments you made on your estimat-
ed Federal income tax (Form 1040-ES). Include any
overpay from your previous year return that you ap-
plied to your estimated tax. NOTE: If a full year (Jan
1, YEAR to Dec 31, YEAR) is specified, GnuCash
adjusts the date to Mar 1, YEAR to Feb 28, YEAR
+1. Thus, the payment due Jan 15 is exported for the
correct year.

F1040 \ N607 Contributions made to your medical savings ac-
count that were not reported on your Form W-2.
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Tax Form \ TXF Code

Description

Extended TXF Help messages

Medical savings contribution, self

F1040 \ N608

Medical savings contribution, spouse

Contributions made to your spouse’s medical sav-
ings account that were not reported on their Form
W-2.

F1040 \ N609

SIMPLE contribution, self

Contributions made to your SIMPLE retirement
plan that were not reported on your Form W-2.

F1040 \ N610

SIMPLE contribution, spouse

Contributions made to your spouse’s SIMPLE re-
tirement plan that were not reported on your
spouse’s Form W-2.

F1040 \ N611

Fed tax withheld, Social Security, self

The amount of federal income taxes withheld from
your part of any monthly benefit under title II of the
Social Security Act.

F1040 \ N612

Fed tax withheld, Social Security, spouse

The amount of federal income taxes withheld from
your spouse’s part of any monthly benefit under title
II of the Social Security Act.

F1040 \ N613

Fed tax withheld, RR retire, self

The amount of federal income taxes withheld from
your part of tier I railroad retirement benefits, which
are treated as a social security benefits.

F1040 \ N614

Fed tax withheld, RR retire, spouse

The amount of federal income taxes withheld from
your spouse’s part of tier I railroad retirement ben-
efits, which are treated as a social security benefits.

F1040 \ N636

Student loan interest

The amount of interest you paid this year on quali-
fied student loans.

Help F1099-G \ H634

Form 1099-G - certain Government payments

Form 1099-G is used to report certain government
payments from federal, state, or local governments.

F1099-G \ N260

State and local tax refunds

Refund of state or local income tax refund (or credit
or offset) which you deducted or took a credit for
in an earlier year. You should receive a statement,
Form 1099-G. Not reportable if you didn’t itemize
last year.

F1099-G \ N479

Unemployment compensation

Total unemployment compensation paid to you this
year. Reported on Form 1099-G.

F1099-G \ N605

Unemployment comp repaid

If you received an overpayment of unemployment
compensation this year or last and you repaid any of
it this year, subtract the amount you repaid from the
total amount you received.

F1099-G \ N606

Fed tax withheld, unemployment comp

The amount of federal income taxes withheld from
your unemployment compensation.

F1099-G \ N672

Qualified state tuition earnings

Qualified state tuition program earnings you re-
ceived this year.
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Tax Form \ TXF Code

Description

Extended TXF Help messages

Help F1099-MISC \ H553

Form 1099-MISC - MISCellaneous income

Form 1099-MISC is used to report miscellaneous
income received and direct sales of consumer goods
for resale.

^ F1099-MISC \ N259

Prizes and awards

The amount of prizes and awards that are not for
services performed. Included is the fair market value
of merchandise won on game shows.

^ F1099-MISC \ N557

Other income

The amount of prizes and awards that are not for
services performed. Included is the fair market val-
ue of merchandise won on game shows. Included is
all punitive damages, any damages for nonphysical
injuries or sickness, and any other taxable damages,
Deceased employee’s wages paid to estate or bene-
ficiary.

^ F1099-MISC \ N555

Rents

Amounts received for all types of rents, such as real
estate rentals for office space, machine rentals, and
pasture rentals.

^ F1099-MISC \ N556

Royalties

The gross royalty payments received from a pub-
lisher or literary agent.

^ F1099-MISC \ N558

Federal tax withheld

The amount of federal income tax withheld (backup
withholding) from 1099-MISC income.

^ F1099-MISC \ N559

Fishing boat proceeds

Your share of all proceeds from the sale of a catch
or the fair market value of a distribution in kind that
you received as a crew member of a fishing boat.

^ F1099-MISC \ N560

Medical/health payments

The amount of payments received as a physician or
other supplier or provider of medical or health care
services. This includes payments made by medical
and health care insurers under health, accident, and
sickness insurance programs.

^ F1099-MISC \ N561

Non employee compensation

The amount of non-employee compensation re-
ceived. This includes fees, commissions, prizes and
awards for services performed, other forms of com-
pensation for services you performed for a trade or
business by which you are not employed. Also in-
clude oil and gas payments for a working interest.

^ F1099-MISC \ N562

Crop insurance proceeds

The amount of crop insurance proceeds as the result
of crop damage.

^ F1099-MISC \ N563

State tax withheld

The amount of state income tax withheld (state
backup withholding) from 1099-MISC income.

Help F1099=MSA \ H629

Form 1099-MSA Medical Savings Account

Form 1099-MSA is used to report medical savings
account distributions.
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Tax Form \ TXF Code

Description

Extended TXF Help messages

F1099-MSA \ N631

MSA gross distribution

The amount you received this year from a Medical
Savings Account. The amount may have been a di-
rect payment to the medical service provider or dis-
tributed to you.

F1099-MSA \ N632

MSA earnings on excess contrib

The earnings on any excess contributions you with-
drew from an MSA by the due date of your income
tax return. If you withdrew the excess, plus any
earnings, by the due date of your income tax return,
you must include the earnings in your income in the
year you received the distribution even if you used
it to pay qualified medical expenses.

Help F1099-R \ H473

Form 1099-R - Retirement distributions

Form 1099-R is used to report taxable and non-tax-
able retirement distributions from retirement, pen-
sion, profit-sharing, or annuity plans. Use a separate
Form 1099-R for each payer.

^ F1099-R \ N475

Total pension gross distribution

The gross amount of a distribution from a qualified
pension or annuity plan. Note: IRA distributions are
not included here.

^ F1099-R \ N476

Total pension taxable distribution

The taxable amount of a distribution from a qual-
ified pension or annuity plan. Note: IRA distribu-
tions are not included here.

^ F1099-R \ N477

Total IRA gross distribution

The gross amount of a distribution from a qualified
Individual Retirement Arrangement (IRA) plan.

^ F1099-R \ N478

Total IRA taxable distribution

The taxable amount of a distribution from a qual-
ified Individual Retirement Arrangement (IRA)
plan.

^ F1099-R \ N529

Pension federal tax withheld

The amount of federal income taxes withheld from
your pension distribution.

^ F1099-R \ N530

Pension state tax withheld

The amount of state income taxes withheld from
your pension distribution.

^ F1099-R \ N531

Pension local tax withheld

The amount of local income taxes withheld from
your pension distribution.

^ F1099-R \ N532

IRA federal tax withheld

The amount of federal income taxes withheld from
your IRA distribution.

^ F1099-R \ N533

IRA state tax withheld

The amount of state income taxes withheld from
your IRA distribution.

^ F1099-R \ N534

IRA local tax withheld

The amount of local income taxes withheld from
your IRA distribution.
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Tax Form \ TXF Code

Description

Extended TXF Help messages

^ F1099-R \ N623

SIMPLE total gross distribution

The gross amount of a distribution received from a
qualified SIMPLE pension plan.

^ F1099-R \ N624

SIMPLE total taxable distribution

The taxable amount of a distribution received from a
qualified SIMPLE plan. This amount may be subject
to a federal penalty of up to 25%.

^ F1099-R \ N625

SIMPLE federal tax withheld

The amount of federal income taxes withheld from
a SIMPLE distribution received.

^ F1099-R \ N626

SIMPLE state tax withheld

The amount of state income taxes withheld from a
SIMPLE distribution received.

^ F1099-R \ N627

SIMPLE local tax withheld

The amount of local income taxes withheld from a
SIMPLE distribution received.

Help F2106 \ H380

employee business expenses

Form 2106 is used to deduct employee business ex-
penses. You must file this form if you were reim-
bursed by your employer or claim job-related trav-
el, transportation, meal, or entertainment expenses.
Use a separate Form 2106 for your spouse’s expens-
es.

F2106 \ N381

Education expenses

Cost of tuition, books, supplies, laboratory fees, and
similar items, and certain transportation costs if the
education maintains or improves skills required in
your present work or is required by your employer
or the law to keep your salary, status, or job, and the
requirement serves a business purpose of your em-
ployer. Expenses are not deductible if they are need-
ed to meet the minimum educational requirements
to qualify you in your work or business or will lead
to qualifying you in a new trade or business.

F2106 \ N382

Automobile expenses

Total annual expenses for gasoline, oil, repairs, in-
surance, tires, license plates, or similar items.

F2106 \ N384

Local transportation expenses

Local transportation expenses are the expenses of
getting from one workplace to another when you are
not traveling away from home. They include the cost
of transportation by air, rail, bus, taxi, and the cost
of using your car. Generally, the cost of commuting
to and from your regular place of work is not de-
ductible.

F2106 \ N385

Other business expenses

Other job-related expenses, including expenses for
business gifts, trade publications, etc.

F2106 \ N386

Meal/entertainment expenses

Allowable meals and entertainment expense, in-
cluding meals while away from your tax home
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Tax Form \ TXF Code

Description

Extended TXF Help messages

overnight and other business meals and entertain-
ment.

F2106 \ N387

Reimb. business expenses (non-meal/ent.)

Reimbursement for business expenses from your
employer that is NOT included on your Form W-2.
Note: meals and entertainment are NOT included
here.

F2106 \ N388

Reimb. meal/entertainment expenses

Reimbursement for meal and entertainment expens-
es from your employer that is NOT included on your
Form W-2.

F2106 \ N389

Job seeking expenses

Fees to employment agencies and other costs to look
for a new job in your present occupation, even if you
do not get a new job.

F2106 \ N390

Special clothing expenses

cost and upkeep of work clothes, if you must wear
them as a condition of your employment, and the
clothes are not suitable for everyday wear. Include
the cost of protective clothing required in your work,
such as safety shoes or boots, safety glasses, hard
hats, and work gloves.

F2106 \ N391

Employee home office expenses

Your use of the business part of your home must be:
exclusive, regular, for your trade or business, AND
The business part of your home must be one of the
following: your principal place of business, a place
where you meet or deal with patients, clients, or cus-
tomers in the normal course of your trade or busi-
ness, or a separate structure (not attached to your
home) you use in connection with your trade or busi-
ness. Additionally, Your business use must be for
the convenience of your employer, and You do not
rent all or part of your home to your employer and
use the rented portion to perform services as an em-
ployee. See IRS Pub 587.

F2106 \ N383

Travel (away from home)

Travel expenses are those incurred while traveling
away from home for your employer. The cost of
getting to and from your business destination (air,
rail, bus, car, etc.), taxi fares, baggage charges, and
cleaning and laundry expenses. Note: meal and en-
tertainment expenses are not included here.

Help F4137 \ H503

Form 4137 - tips not reported

Form 4137 is used to compute social security and
Medicare tax owed on tips you did not report to your
employer.

F4137 \ N505

Total cash/tips not reported to employer

The amount of tips you did not report to your em-
ployer.

Help F2441 \ H400

Form 2441 - child and dependent credit

Form 2441 is used to claim a credit for child and
dependent care expenses.
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Tax Form \ TXF Code

Description

Extended TXF Help messages

< F2441 \ N401

Qualifying child/dependent care expenses

The total amount you actually paid to the care
provider. Also, include amounts your employer paid
to a third party on your behalf.

< F2441 \ N402

Qualifying household expenses

The cost of services needed to care for the qualify-
ing person as well as to run the home. They include
the services of a babysitter, cleaning person, cook,
maid, or housekeeper if the services were partly for
the care of the qualifying person.

Help F3903 \ H403

Form 3903 - moving expenses

Form 3903 is used to claim moving expenses.

F3903 \ N406

Transport/storage of goods

The amount you paid to pack, crate and move your
household goods and personal effects. You may in-
clude the cost to store and insure household goods
and personal effects within any period of 30 days
in a row after the items were moved from your old
home.

F3903 \ N407

Travel/lodging, except meals

The amount you paid to travel from your old home
to your new home. This includes transportation and
lodging on the way. Although not all members of
your household must travel together, you may only
include expenses for one trip per person. Do not in-
clude meals.

Help F4684 \ H412

Form 4684 - casualties and thefts

Form 4684 is used to report gains and losses from
casualties and thefts.

F4684 \ N416

FMV after casualty

The fair market value (FMV) is the price at which
the property would change hands between a willing
buyer and seller, each having knowledge of the rele-
vant facts. The FMV after a theft is zero if the prop-
erty is not recovered. The FMV is generally deter-
mined by competent appraisal.

F4684 \ N413

Basis of casualty property

Cost or other basis usually means original cost plus
improvements. Subtract any postponed gain from
the sale of a previous main home. Special rules ap-
ply to property received as a gift or inheritance. See
Pub 551, Basis of Assets, for details.

F4684 \ N414

Insurance/reimbursement

The amount of insurance or other reimbursement
you received expect to receive.

F4684 \ N415

FMV before casualty

The fair market value (FMV) is the price at which
the property would change hands between a willing
buyer and seller, each having knowledge of the rel-
evant facts. FMV is generally determined by com-
petent appraisal.

Help F4835 \ H569 Form 4835 is used to report farm rental income re-
ceived as a share of crops or livestock produced by
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Tax Form \ TXF Code

Description

Extended TXF Help messages

Form 4835 - farm rental income your tenant if you did not materially participate in
the operation or management of the farm. Use a dif-
ferent copy of Form 4835 for each farm rented.

F4835 \ N572

Total cooperative distributions

Distributions received from a cooperative. This in-
cludes patronage dividends, non patronage distribu-
tions, per-unit retain allocations, and redemption of
non qualified notices and per unit retain allocations.
Reported on Form 1099-PATR.

F4835 \ N571

Sale of livestock/produce

Income you received from livestock, produce,
grains, and other crops based on production. Under
both the cash and the accrual methods of reporting,
you must report livestock or crop share rentals re-
ceived in the year you convert them into money or
its equivalent.

F4835 \ N573

Agricultural program payments

Government payments received for: price support
payments, market gain from the repayment of a se-
cured Commodity Credit Corporation (CCC) loan
for less than the original loan amount, diversion pay-
ments, cost-share payments (sight drafts), payments
in the form of materials (such as fertilizer or lime)
or services (such as grading or building dams). Re-
ported on Form 1099-G.

F4835 \ N574

CCC loans reported/election

Generally, you do not report CCC loan proceeds as
income. However, if you pledge part or all of your
production to secure a CCC loan, you may elect to
report the loan proceeds as income in the year you
receive them, instead of the year you sell the crop.

F4835 \ N575

CCC loans forfeited/repaid

The full amount forfeited or repaid with certificates,
even if you reported the loan proceeds as income.
See IRS Pub 225.

F4835 \ N576

Crop insurance proceeds received

You generally include crop insurance proceeds in
the year you receive them. Treat as crop insurance
proceeds the crop disaster payments you receive
from the federal government.

F4835 \ N577

Crop insurance proceeds deferred

If you use the cash method of accounting and re-
ceive crop insurance proceeds in the same tax year
in which the crops are damaged, you can choose
to postpone reporting the proceeds as income until
the following tax year. A statement must also be at-
tached to your return. See IRS Pub 225.

F4835 \ N578

Other income

Illegal Federal irrigation subsidies, bartering in-
come, income from discharge of indebtedness, state
gasoline or fuel tax refund, the gain or loss on the
sale of commodity futures contracts, etc.

F4835 \ N579

Car and truck expenses

The business portion of car or truck expenses, such
as, for gasoline, oil, repairs, insurance, tires, license
plates, etc.
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F4835 \ N580

Chemicals

Chemicals used in operating your farm, such as in-
sect sprays and dusts.

F4835 \ N581

Conservation expenses

Your expenses for soil or water conservation or for
the prevention of erosion of land used in farming. To
take this deduction, your expenses must be consis-
tent with a plan approved by the Natural Resources
Conservation Service (NRCS) of the Department of
Agriculture.

F4835 \ N582

Custom hire expenses

Amounts you paid for custom hire (machine work)
(the machine operator furnished the equipment). Do
not include amounts paid for rental or lease of equip-
ment you operated yourself.

F4835 \ N583

Employee benefit programs

Contributions to employee benefit programs, such
as accident and health plans, group-term life insur-
ance, and dependent care assistance programs. Do
not include contributions that are a incidental part of
a pension or profit-sharing plan.

F4835 \ N584

Feed purchased

The cost of feed for your livestock. Generally, you
cannot currently deduct expenses for feed to be con-
sumed by your livestock in a later tax year. See in-
structions for Schedule F.

F4835 \ N585

Fertilizers and lime

The cost of fertilizer, lime, and other materials ap-
plied to farm land to enrich, neutralize, or condition
it. You can also deduct the cost of applying these
materials. However, see Prepaid Farm Supplies, in
Pub 225, for a rule that may limit your deduction for
these materials.

F4835 \ N586

Freight and trucking

The costs of freight or trucking of produce or live-
stock.

F4835 \ N587

Gasoline, fuel, and oil

The costs of gas, fuel, oil, etc. for farm equipment.

F4835 \ N588

Insurance (other than health)

Premiums paid for farm business insurance, such
as: fire, storm, crop, theft and liability protection of
farm assets. Do not include premiums for employee
accident and health insurance.

F4835 \ N589

Interest expense, mortgage

The interest you paid to banks or other financial in-
stitutions for which you received a Form 1098, for
a mortgage on real property used in your farming
business (other than your main home). If you paid
interest on a debt secured by your main home, and
any proceeds from that debt were used in your farm-
ing operation, refer to IRS Pub 225.

F4835 \ N590 The interest you paid for which you did not receive
a Form 1098 (perhaps someone else did, and you are
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Interest expense, other liable too), for a mortgage or other loans for your
farm business.

F4835 \ N591

Labor hired

The amounts you paid for farm labor. Do not in-
clude amounts paid to yourself. Count the cost of
boarding farm labor but not the value of any prod-
ucts they used from the farm. Count only what you
paid house-hold help to care for farm laborers.

F4835 \ N592

Pension/profit-sharing plans

Enter your deduction for contributions to employee
pension, profit-sharing, or annuity plans. If the plan
included you as a self-employed person, see the in-
structions for Schedule C (Form 1040).

F4835 \ N593

Rent/lease vehicles, equip.

The business portion of your rental cost, for rented
or leased vehicles, machinery, or equipment. But if
you leased a vehicle for a term of 30 days or more,
you may have to reduce your deduction by an in-
clusion amount. For details, see the instructions for
Schedule C (Form 1040).

F4835 \ N594

Rent/lease land, animals

Amounts paid to rent or lease property such as pas-
ture or farm land.

F4835 \ N595

Repairs and maintenance

Amounts you paid for repairs and maintenance of
farm buildings, machinery, and equipment. You can
also include what you paid for tools of short life or
minimal cost, such as shovels and rakes.

F4835 \ N596

Seeds and plants purchased

The amounts paid for seeds and plants purchased for
farming.

F4835 \ N597

Storage and warehousing

Amounts paid for storage and warehousing of crops,
grains, etc.

F4835 \ N598

Supplies purchased

Livestock supplies and other supplies, including
bedding, office supplies, etc.

F4835 \ N599

Taxes

Real estate and personal property taxes on farm
business assets; Social security and Medicare taxes
you paid to match what you are required to withhold
from farm employees’ wages and any Federal un-
employment tax paid; Federal highway use tax.

F4835 \ N600

Utilities

Amounts you paid for gas, electricity, water, etc., for
business use on the farm. Do not include personal
utilities. You cannot deduct the base rate (including
taxes) of the first telephone line into your residence,
even if you use it for business.

F4835 \ N601

Vet, breeding, medicine

The costs of veterinary services, medicine and
breeding fees.
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F4835 \ N602

Other farm expenses

Include all ordinary and necessary farm rental ex-
penses not deducted elsewhere on Form 4835, such
as advertising, office supplies, etc. Do not include
fines or penalties paid to a government for violating
any law.

Help F4952 \ H425

Form 4952 - investment interest

Form 4952 is used to compute the amount of invest-
ment interest expense deductible for the current year
and the amount, if any, to carry forward to future
years.

F4952 \ N426

Investment interest expense

The investment interest paid or accrued during the
tax year, regardless of when you incurred the in-
debtedness. Investment interest is interest paid or
accrued on a loan (or part of a loan) that is allocable
to property held for investment.

Help F6252 \ H427

Form 6252 - income from casual sales

Form 6252 is used to report income from casual
sales of real or personal property when you will re-
ceive any payments in a tax year after the year of
sale (i.e., installment sale).

F6252 \ N428

Selling price

Enter the total of any money, face amount of the in-
stallment obligation, and the FMV of other property
that you received or will receive in exchange for the
property sold.

F6252 \ N429

Debt assumed by buyer

Enter only mortgages or other debts the buyer as-
sumed from the seller or took the property subject to.
Do not include new mortgages the buyer gets from
a bank, the seller, or other sources.

F6252 \ N431

Depreciation allowed

Enter all depreciation or amortization you deduct-
ed or should have deducted from the date of pur-
chase until the date of sale. Add any section 179 ex-
pense deduction. Several other adjustments are al-
lowed, See Form 6252 instructions.

F6252 \ N432

Expenses of sale

Enter sales commissions, advertising expenses, at-
torney and legal fees, etc., in selling the property.

F6252 \ N434

Payments received this year

Enter all money and the fair market value (FMV) of
any property you received in this tax year. Include
as payments any amount withheld to pay off a mort-
gage or other debt, such as broker and legal fees. Do
not include interest whether stated or unstated.

F6252 \ N435

Payments received prior years

Enter all money and the fair market value (FMV)
of property you received before this tax year from
the sale. Include allocable installment income and
any other deemed payments from prior years. Do not
include interest whether stated or unstated.

Help F8815 \ H441 Form 8815 is used to compute the amount of inter-
est you may exclude if you cashed series EE U.S.
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Form 8815 - EE U.S. savings bonds sold for educa-
tion

savings bonds this year that were issued after 1989
to pay for qualified higher education costs.

F8815 \ N442

Qualified higher education expenses

Qualified higher education expenses include tuition
and fees required for the enrollment or attendance of
the person(s). Do not include expenses for room and
board, or courses involving sports, games, or hob-
bies that are not part of a degree or certificate grant-
ing program.

F8815 \ N443

Nontaxable education benefits

Nontaxable educational benefits. These benefits in-
clude: Scholarship or fellowship grants excludable
from income under section 117; Veterans’ educa-
tional assistance benefits; Employer-provided edu-
cational assistance benefits that are not included in
box 1 of your W-2 form(s); Any other payments
(but not gifts, bequests, or inheritances) for educa-
tional expenses that are exempt from income tax by
any U.S. law. Do not include nontaxable education-
al benefits paid directly to, or by, the educational in-
stitution.

F8815 \ N444

EE US savings bonds proceeds

Enter the total proceeds (principal and interest) from
all series EE and I U.S. savings bonds issued after
1989 that you cashed during this tax year.

F8815 \ N445

Post-89 EE bond face value

The face value of all post-1989 series EE bonds
cashed this tax year.

Help F8863 \ H639

Form 8863 - Hope and Lifetime Learning education
credits

Form 8863 is used to compute the Hope and Life-
time Learning education credits. IRS rules are strin-
gent for these credits. Refer to IRS Publication 970
for more information.

F8863 \ N637

Hope credit

Expenses qualified for the Hope credit are amounts
paid this tax year for tuition and fees required for
the student’s enrollment or attendance at an eligible
educational institution.

F8863 \ N638

Lifetime learning credit

Expenses qualified for the Lifetime Learning credit
are amounts paid this tax year for tuition and fees
required for the student’s enrollment or attendance
at an eligible educational institution.

Help F8829 \ H536

Form 8829 - business use of your home

Form 8829 is used only if you file a Schedule C,
Profit or Loss from Business, and you meet specif-
ic requirements to deduct expenses for the business
use of your home. IRS rules are stringent for this
deduction. Refer to IRS Publication 587.

F8829 \ N537

Deductible mortgage interest

The total amount of mortgage interest that would be
deductible whether or not you used your home for
business (i.e., amounts allowable as itemized deduc-
tions on Schedule A, Form 1040). Form 8829 com-
putes the deductible business portion.
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F8829 \ N538

Real estate taxes

The total amount of real estate taxes that would be
deductible whether or not you used your home for
business (i.e., amounts allowable as itemized deduc-
tions on Schedule A, Form 1040). Form 8829 com-
putes the deductible business portion.

F8829 \ N539

Insurance

The total amount of insurance paid for your home,
in which an area or room is used regularly and ex-
clusively for business. Form 8829 computes the de-
ductible business portion.

F8829 \ N540

Repairs and maintenance

The total amount of repairs and maintenance paid
for your home, in which an area or room is used reg-
ularly and exclusively for business. Form 8829 com-
putes the deductible business portion.

F8829 \ N541

Utilities

The total amount of utilities paid for your home,
in which an area or room is used regularly and ex-
clusively for business. Form 8829 computes the de-
ductible business portion.

F8829 \ N542

Other expenses

If you rent rather than own your home, include rent
paid for your home, in which an area or room is used
regularly and exclusively for business. Form 8829
computes the deductible business portion.

Help F8839 \ H617

Form 8839 - adoption expenses

Form 8839 is used to report qualified adoption ex-
penses.

F8839 \ N618

Adoption fees

Adoption fees that are reasonable and necessary, di-
rectly related to, and for the principal purpose of, the
legal adoption of an eligible child.

F8839 \ N619

Court costs

Court costs that are reasonable and necessary, di-
rectly related to, and for the principal purpose of, the
legal adoption of an eligible child.

F8839 \ N620

Attorney fees

Attorney fees that are reasonable and necessary, di-
rectly related to, and for the principal purpose of, the
legal adoption of an eligible child.

F8839 \ N621

Traveling expenses

Traveling expenses (including meals and lodging)
while away from home, directly related to, and for
the principal purpose of, the legal adoption of an el-
igible child.

F8839 \ N622

Other expenses

Other expenses that are reasonable and necessary,
directly related to, and for the principal purpose of,
the legal adoption of an eligible child.

Home Sale \ N392

Home Sale worksheets (was F2119)

Home Sale worksheets (replaces Form 2119) are
used to report the sale of your personal residence.
See IRS Pub 523.

Home Sale \ N393

Selling price of old home

The selling price is the total amount you receive for
your home. It includes money, all notes, mortgages,
or other debts assumed by the buyer as part of the
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sale, and the fair market value of any other proper-
ty or any services you receive. Reported on Form
1099-S.

Home Sale \ N394

Expense of sale

Selling expenses include commissions, advertising
fees, legal fees, title insurance, and loan charges
paid by the seller, such as loan placement fees or
"points."

Home Sale \ N396

Fixing-up expenses

Fixing-up expenses are decorating and repair costs
that you paid to sell your old home. For example,
the costs of painting the home, planting flowers, and
replacing broken windows are fixing-up expenses.
Fixing-up expenses must meet all the following con-
ditions. The expenses: Must be for work done dur-
ing the 90-day period ending on the day you sign
the contract of sale with the buyer; Must be paid
no later than 30 days after the date of sale; Cannot
be deductible in arriving at your taxable in-come;
Must not be used in figuring the amount realized;
and Must not be capital expenditures or improve-
ments.

Home Sale \ N397

Cost of new home

The cost of your new home includes costs incurred
within the replacement period (beginning 2 years
before and ending 2 years after the date of sale) for
the following items: Buying or building the home;
Rebuilding the home; and Capital improvements or
additions.

Help Sched A \ H270

Schedule A - itemized deductions

Schedule A is used to report your itemized deduc-
tions.

Sched A \ N271

Subscriptions

Amounts paid for subscriptions to magazines or ser-
vices that are directly related to the production or
collection of taxable income. (example: subscrip-
tions to investment publications, stock newsletters,
etc.).

Sched A \ N272

Gambling losses

Gambling losses, but only to the extent of gambling
winnings reported on Form 1040. Note: not subject
to the 2% AGI of limitation.

Sched A \ N273

Medicine and drugs

Prescription medicines, eyeglasses, contact lenses,
hearing aids. Over-the-counter medicines are not
deductible.

Sched A \ N274

Medical travel and lodging

Lodging expenses while away from home to receive
medical care in a hospital or a medical care facility
related to a hospital. Do not include more than $50
a night for each eligible person. Ambulance service
and other travel costs to get medical care.
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Sched A \ N275

State income taxes

State income taxes paid this year for a prior year.
Include any part of a prior year refund that you chose
to have credited to this years state income taxes.

Sched A \ N276

Real estate taxes

Include taxes (state, local, or foreign) you paid on
real estate you own that was not used for business,
but only if the taxes are based on the assessed val-
ue of the property. Do not include taxes charged for
improvements that tend to increase the value of your
property (for example, an assessment to build a new
sidewalk).

Sched A \ N277

Other taxes

Other taxes paid not included under state and local
income taxes, real estate taxes, or personal property
taxes. You may want to take a credit for the foreign
tax instead of a deduction.

Sched A \ N280

Cash charity contributions

Contributions or gifts by cash or check you gave to
organizations that are religious, charitable, educa-
tional, scientific, or literary in purpose. You may al-
so deduct what you gave to organizations that work
to prevent cruelty to children or animals. For do-
nations of $250 or more, you must have a state-
ment from the charitable organization showing the
amount donated and the value of goods or services
you received.

Sched A \ N281

Tax preparation fees

Fees you paid for preparation of your tax return, in-
cluding fees paid for filing your return electronical-
ly.

Sched A \ N282

Investment management fees

Investment interest is interest paid on money you
borrowed that is allocable to property held for in-
vestment. It does not include any interest allocable
to passive activities or to securities that generate tax-
exempt income.

Sched A \ N283

Home mortgage interest (1098)

Home mortgage interest and points reported to you
on Form 1098. The interest could be on a first or
second mortgage, home equity loan, or refinanced
mortgage.

Sched A \ N284

Points paid (no 1098)

Generally, you must deduct points you paid to refi-
nance a mortgage over the life of the loan. If you
used part of the proceeds to improve your main
home, you may be able to deduct the part of the
points related to the improvement in the year paid.
See Pub. 936 Use this line for points not reported on
Form 1098.

Sched A \ N484

Doctors, dentists, hospitals

Insurance premiums for medical and dental care,
medical doctors, dentists, eye doctors, surgeons, X-
ray, laboratory services, hospital care, etc. See IRS
Pub 502.
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Sched A \ N486

Misc., subject to 2% AGI limit

Safety equipment, small tools, and supplies you
needed for your job; Uniforms required by your em-
ployer and which you may not usually wear away
from work; subscriptions to professional journals;
job search expenses; certain educational expenses.
You may need to file Form 2106.

Sched A \ N485

Non-cash charity contributions

The fair market value of donated property, such as
used clothing or furniture.

Sched A \ N522

State estimated tax, quarterly

State estimated tax payments made this year.

Sched A \ N523

Misc., no 2% AGI limit

Other miscellaneous itemized deductions that are
not reduced by 2% of adjusted gross income, such
as casualty and theft losses from income-producing,
amortizable bond premium on bonds acquired be-
fore October 23, 1986, federal estate tax on income
in respect to a decedent, certain unrecovered invest-
ment in a pension, impairment-related work expens-
es of a disabled person.

Sched A \ N535

Personal property taxes

Enter personal property tax you paid, but only if it
is based on value alone. Example: You paid a fee
for the registration of your car. Part of the fee was
based on the car s value and part was based on its
weight. You may deduct only the part of the fee that
is based on the car s value.

Sched A \ N544

Local income taxes

Local income taxes that were not withheld from
your salary, such as local income taxes you paid this
year for a prior year.

Sched A \ N545

Home mortgage interest (no 1098)

Home mortgage interest paid, for which you did not
receive a Form 1098 from the recipient. The interest
could be on a first or second mortgage, home equity
loan, or refinanced mortgage.

Help Sched B \ H285

Schedule B - interest and dividend income

Schedule B is used to report your interest and divi-
dend income.

^ Sched B \ N286

Dividend income, Ordinary

Ordinary dividends from mutual funds, stocks, etc.,
are reported to you on a 1099-DIV. Note: these are
sometimes called short term capital gain distribu-
tions. Do not include (long term) capital gain distri-
butions or non-taxable dividends here, these go on
Sched D

< Sched B \ N287

Interest income

Taxable interest includes interest you receive from
bank accounts, credit unions, loans you made to oth-
ers. There are several categories of interest, be sure
you select the correct one!
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< Sched B \ N288

Interest income, US government

Interest on U.S. obligations, such as U.S. Treasury
bills, notes, and bonds issued by any agency of the
United States. This income is exempt from all state
and local income taxes. There are several categories
of interest, be sure you select the correct one!

< Sched B \ N289

Interest income, State and municipal bond

Interest on bonds or notes of states, counties, cities,
the District of Columbia, or possessions of the Unit-
ed States is generally free of federal income tax (but
you may pay state income tax). There are several
categories of interest, be sure you select the correct
one!

< Sched B \ N290

Interest income, tax-exempt private activity bond

Interest income from a qualified tax-exempt private
activity bond is not taxable if it meets all require-
ments. This income is included on your Schedule
B as non-taxable interest income. There are several
categories of interest, be sure you select the correct
one!

< Sched B \ N487

Dividend income, non-taxable

Some mutual funds pay shareholders non-taxable
dividends. The amount of non-taxable dividends
are indicated on your monthly statements or Form
1099-DIV.

< Sched B \ N489

Interest income, non-taxable

Non-taxable interest income other than from bonds
or notes of states, counties, cities, the District of Co-
lumbia, or a possession of the United States, or from
a qualified private activity bond. There are several
categories of interest, be sure you select the correct
one!

< Sched B \ N490

Interest income, taxed only by fed

Interest income that is taxed on your federal return,
but not on your state income tax return - other than
interest paid on U.S. obligations. There are several
categories of interest, be sure you select the correct
one!

< Sched B \ N491

Interest income, taxed only by state

Interest income that is not taxed on your federal re-
turn, but is taxed on your state income tax return -
other than interest income from state bonds or notes,
the District of Columbia, or a possession of the Unit-
ed States. There are several categories of interest, be
sure you select the correct one!

< Sched B \ N492

Interest income, OID bonds

Interest income from Original Issue Discount (OID)
bonds will be reported to you on Form 1099-OID.
There are several categories of interest, be sure you
select the correct one!

< Sched B \ N524

Interest income, Seller-financed mortgage

Interest the buyer paid you on a mortgage or oth-
er form of seller financing, for your home or other
property and the buyer used the property as a per-
sonal residence. There are several categories of in-
terest, be sure you select the correct one!
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< Sched B \ N615

Fed tax withheld, dividend income

The amount of federal income taxes withheld from
dividend income. This is usually reported on Form
1099-DIV.

< Sched B \ N616

Fed tax withheld, interest income

The amount of federal income taxes withheld from
interest income. This is usually reported on Form
1099-INT.

Help Sched C \ H291

Schedule C - self-employment income

Schedule C is used to report income from self-em-
ployment. Use a separate Schedule C to report in-
come and expenses from different businesses.

Sched C \ N293

Gross receipts or sales

The amount of gross receipts from your trade or
business. Include amounts you received in your
trade or business that were properly shown on
Forms 1099-MISC.

Sched C \ N294

Meals and entertainment

Total business meal and entertainment expenses.
Business meal expenses are deductible only if they
are (a) directly related to or associated with the ac-
tive conduct of your trade or business, (b) not lavish
or extravagant, and (c) incurred while you or your
employee is present at the meal.

Sched C \ N296

Returns and allowances

Credits you allow customers for returned merchan-
dise and any other allowances you make on sales.

Sched C \ N297

Wages paid

The total amount of salaries and wages for the tax
year. Do not include amounts paid to yourself.

Sched C \ N298

Legal and professional fees

Accountant’s or legal fees for tax advice related to
your business and for preparation of the tax forms
related to your business.

Sched C \ N299

Rent/lease vehicles, equip.

The amount paid to rent or lease vehicles, machin-
ery, or equipment, for your business. If you leased
a vehicle for a term of 30 days or more, you may
have to reduce your deduction by an amount called
the inclusion amount. See Pub. 463.

Sched C \ N300

Rent/lease other business property

The amounts paid to rent or lease real estate or prop-
erty, such as office space in a building.

Sched C \ N301

Supplies (not from Cost of Goods Sold)

The cost of supplies not reported under Cost Of
Goods Sold.

Sched C \ N302

Other business expenses

Other costs not specified on other lines of Sched-
ule C, such as: Clean-fuel vehicles and refueling
property; Donations to business organizations; Ed-
ucational expenses; Environmental cleanup costs;
Impairment-related expenses; Interview expense al-
lowances; Licenses and regulatory fees; Moving
machinery; Outplacement services; Penalties and
fines you pay for late performance or nonperfor-
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mance of a contract; Subscriptions to trade or pro-
fessional publications.

Sched C \ N303

Other business income

The amounts from finance reserve income, scrap
sales, bad debts you recovered, interest (such as on
notes and accounts receivable), state gasoline or fu-
el tax refunds you got this year, prizes and awards
related to your trade or business, and other kinds of
miscellaneous business income.

Sched C \ N304

Advertising

The amounts paid for advertising your trade or busi-
ness in newspapers, publications, radio or televi-
sion. Also include the cost of brochures, business
cards, or other promotional material.

Sched C \ N305

Bad debts from sales/services

Include debts and partial debts from sales or ser-
vices that were included in income and are definite-
ly known to be worthless.

Sched C \ N306

Car and truck expenses

You can deduct the actual expenses of running your
car or truck, or take the standard mileage rate.

Sched C \ N307

Commissions and fees

The amounts of commissions or fees paid to inde-
pendent contractors (non employees) for their ser-
vices.

Sched C \ N308

Employee benefit programs

Contributions to employee benefit programs that are
not an incidental part of a pension or profit-shar-
ing plan. Examples are accident and health plans,
group-term life insurance, and dependent care assis-
tance programs.

Sched C \ N309

Depletion

The amounts for depletion. If you have timber de-
pletion, attach Form T. See Pub. 535.

Sched C \ N310

Insurance, other than health

Premiums paid for business insurance. Do not in-
clude amounts paid for employee accident and
health insurance. nor amounts credited to a reserve
for self-insurance or premiums paid for a policy that
pays for your lost earnings due to sickness or dis-
ability. See Pub. 535.

Sched C \ N311

Interest expense, mortgage

The interest you paid to banks or other financial in-
stitutions for which you received a Form 1098, for
a mortgage on real property used in your business
(other than your main home).

Sched C \ N312

Interest expense, other

The interest you paid for which you did not receive
a Form 1098 (perhaps someone else did, and you are
liable too), for a mortgage or other loans for your
business.

Sched C \ N313

Office expenses

The cost of consumable office supplies such as
business cards, computer supplies, pencils, pens,
postage stamps, rental of postal box or postage
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machines, stationery, Federal Express and UPS
charges, etc.

Sched C \ N314

Pension/profit sharing plans

You can set up and maintain the following small
business retirement plans for yourself and your em-
ployees, such as: SEP (Simplified Employee Pen-
sion) plans; SIMPLE (Savings Incentive Match Plan
for Employees) plans; Qualified plans (including
Keogh or H.R. 10 plans). You deduct contributions
you make to the plan for yourself on Form 1040.

Sched C \ N315

Repairs and maintenance

The cost of repairs and maintenance. Include labor,
supplies, and other items that do not add to the value
or increase the life of the property. Do not include
the value of your own labor. Do not include amounts
spent to restore or replace property; they must be
capitalized.

Sched C \ N316

Taxes and licenses

Include the following taxes: State and local sales
taxes imposed on you as the seller of goods or ser-
vices; Real estate and personal property taxes on
business assets; Social security and Medicare taxes
paid to match required withholding from your em-
ployees’ wages; Also, Federal unemployment tax
paid; Federal highway use tax.

Sched C \ N317

Travel

Expenses for lodging and transportation connected
with overnight travel for business while away from
your tax home.

Sched C \ N318

Utilities

The costs of electricity, gas, telephone, etc. for your
business property.

Sched C \ N493

Cost of Goods Sold - Purchases

If you are a merchant, use the cost of all merchandise
you bought for sale. If you are a manufacturer or
producer, this includes the cost of all raw materials
or parts purchased for manufacture into a finished
product. You must exclude the cost of merchandise
you withdraw for your personal or family use.

Sched C \ N494

Cost of Goods Sold - Labor

Labor costs are usually an element of cost of goods
sold only in a manufacturing or mining business. In
a manufacturing business, labor costs that are prop-
erly allocable to the cost of goods sold include both
the direct and indirect labor used in fabricating the
raw material into a finished, salable product.

Sched C \ N495

Cost of Goods Sold - Materials/supplies

Materials and supplies, such as hardware and chem-
icals, used in manufacturing goods are charged to
cost of goods sold. Those that are not used in
the manufacturing process are treated as deferred
charges. You deduct them as a business expense
when you use them.
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Sched C \ N496

Cost of Goods Sold - Other costs

Other costs incurred in a manufacturing or mining
process that you charge to your cost of goods sold
are containers, freight-in, overhead expenses.

Help Sched D \ H320

Schedule D - capital gains and losses

Schedule D is used to report gains and losses from
the sale of capital assets.

# Sched D \ N321

Short Term gain/loss - security

Short term gain or loss from the sale of a security.
Not yet implemented in GnuCash.

# Sched D \ N323

Long Term gain/loss - security

Long term gain or loss from the sale of a security.
Not yet implemented in GnuCash.

^ Sched D \ N488

Dividend income, capital gain distributions

Sometimes called long term capital gain distribu-
tions. These are from mutual funds, other regulat-
ed investment companies, or real estate investment
trusts. These are reported on your monthly state-
ments or Form 1099-DIV. Note: short term capital
gain distributions are reported on Sched B as ordi-
nary dividends

# Sched D \ N673

Short/Long Term gain or loss

Short term or long term gain or loss from the sale
of a security; for use when only the date sold and
net sales amount are available and the date acquired
and cost basis information is not available and will
be separately added in the tax software.

Help Sched E \ H325

Schedule E - rental and royalty income

Schedule E is used to report income or loss from
rental real estate, royalties, and residual interest in
REMIC’s. Use a different copy for each rental or
royalty. Use the Schedule K-1 categories for part-
nership rental income and loss amounts.

Sched E \ N326

Rents received

The amounts received as rental income from real es-
tate (including personal property leased with real es-
tate) but you were not in the real estate business. (If
you are in the business of renting personal property,
use Schedule C.)

Sched E \ N327

Royalties received

Royalties received from oil, gas, or mineral proper-
ties (not including operating interests); copyrights;
and patents.

Sched E \ N328

Advertising

Amounts paid to advertise rental unit(s) in newspa-
pers or other media or paid to realtor’s to obtain ten-
ants.

Sched E \ N329

Auto and travel

The ordinary and necessary amounts of auto and
travel expenses related to your rental activities, in-
cluding 50% of meal expenses incurred while trav-
eling away from home.

Sched E \ N330

Cleaning and maintenance

The amounts paid for cleaning services (carpet,
drapes), cleaning supplies, locks and keys, pest con-
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trol, pool service, and general cost of upkeep of the
rental property.

Sched E \ N331

Commissions

The amounts paid as Commissions to realtor’s or
management companies to collect rent.

Sched E \ N332

Insurance

Insurance premiums paid for fire, theft, liability.

Sched E \ N333

Legal and professional fees

The amounts of fees for tax advice and the prepara-
tion of tax forms related to your rental real estate or
royalty properties.

Sched E \ N334

Mortgage interest expense

Interest paid to banks or other financial institutions
for a mortgage on your rental property, and you re-
ceived a Form 1098.

Sched E \ N335

Other interest expense

Interest paid for a mortgage on your rental property,
not paid to banks or other financial institutions or
you did not receive a Form 1098.

Sched E \ N336

Repairs

You may deduct the cost of repairs made to keep
your property in good working condition. Repairs
generally do not add significant value to the proper-
ty or extend its life.

Sched E \ N337

Supplies

Miscellaneous items needed to maintain the proper-
ty, such as: brooms, cleaning supplies, nails, paint
brushes, etc.

Sched E \ N338

Taxes

The amounts paid for real estate and personal prop-
erty taxes. Also include the portion of any payroll
taxes you paid for your employees.

Sched E \ N339

Utilities

The costs of electricity, gas, telephone, etc. for your
rental property.

Sched E \ N341

Other expenses

Other expenses that are not listed on other tax lines
of Schedule E. These might include the cost of gar-
dening and/or snow removal services, association
dues, bank charges, etc.

Sched E \ N502

Management fees

The amount of fees to a manager or property man-
agement company to oversee your rental or royalty
property.

Help Sched F \ H343

Schedule F - Farm income and expense

Schedule F is used to report farm income and ex-
pense. Use a different copy of Schedule F for each
farm you own.

Sched F \ N344

Labor hired

The amounts you paid for farm labor. Do not in-
clude amounts paid to yourself. Count the cost of
boarding farm labor but not the value of any prod-
ucts they used from the farm. Count only what you
paid house-hold help to care for farm laborers.
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Sched F \ N345

Repairs and maintenance

Amounts you paid for repairs and maintenance of
farm buildings, machinery, and equipment. You can
also include what you paid for tools of short life or
minimal cost, such as shovels and rakes.

Sched F \ N346

Interest expense, mortgage

The interest you paid to banks or other financial in-
stitutions for which you received a Form 1098, for
a mortgage on real property used in your farming
business (other than your main home). If you paid
interest on a debt secured by your main home, and
any proceeds from that debt were used in your farm-
ing operation, refer to IRS Pub 225.

Sched F \ N347

Interest expense, other

The interest you paid for which you did not receive
a Form 1098 (perhaps someone else did, and you are
liable too), for a mortgage or other loans for your
farm business.

Sched F \ N348

Rent/lease land, animals

Amounts paid to rent or lease property such as pas-
ture or farm land.

Sched F \ N349

Rent/lease vehicles, equip.

The business portion of your rental cost, for rented
or leased vehicles, machinery, or equipment. But if
you leased a vehicle for a term of 30 days or more,
you may have to reduce your deduction by an in-
clusion amount. For details, see the instructions for
Schedule C (Form 1040).

Sched F \ N350

Feed purchased

The cost of feed for your livestock. Generally, you
cannot currently deduct expenses for feed to be con-
sumed by your livestock in a later tax year. See in-
structions for Schedule F.

Sched F \ N351

Seeds and plants purchased

The amounts paid for seeds and plants purchased for
farming.

Sched F \ N352

Fertilizers and lime

The cost of fertilizer, lime, and other materials ap-
plied to farm land to enrich, neutralize, or condition
it. You can also deduct the cost of applying these
materials. However, see Prepaid Farm Supplies, in
Pub 225, for a rule that may limit your deduction for
these materials.

Sched F \ N353

Supplies purchased

Livestock supplies and other supplies, including
bedding, office supplies, etc.

Sched F \ N355

Vet, breeding, and medicine

The costs of veterinary services, medicine and
breeding fees.

Sched F \ N356

Gasoline, fuel, and oil

The costs of gas, fuel, oil, etc. for farm equipment.
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Sched F \ N357

Storage and warehousing

Amounts paid for storage and warehousing of crops,
grains, etc.

Sched F \ N358

Taxes

Real estate and personal property taxes on farm
business assets; Social security and Medicare taxes
you paid to match what you are required to withhold
from farm employees’ wages and any Federal un-
employment tax paid; Federal highway use tax.

Sched F \ N359

Insurance, other than health

Premiums paid for farm business insurance, such
as: fire, storm, crop, theft and liability protection of
farm assets. Do not include premiums for employee
accident and health insurance.

Sched F \ N360

Utilities

Amounts you paid for gas, electricity, water, etc., for
business use on the farm. Do not include personal
utilities. You cannot deduct the base rate (including
taxes) of the first telephone line into your residence,
even if you use it for business.

Sched F \ N361

Freight and trucking

The costs of freight or trucking of produce or live-
stock.

Sched F \ N362

Conservation expenses

Your expenses for soil or water conservation or for
the prevention of erosion of land used in farming. To
take this deduction, your expenses must be consis-
tent with a plan approved by the Natural Resources
Conservation Service (NRCS) of the Department of
Agriculture.

Sched F \ N363

Pension/profit sharing plans

Enter your deduction for contributions to employee
pension, profit-sharing, or annuity plans. If the plan
included you as a self-employed person, see the in-
structions for Schedule C (Form 1040).

Sched F \ N364

Employee benefit programs

Contributions to employee benefit programs, such
as accident and health plans, group-term life insur-
ance, and dependent care assistance programs. Do
not include contributions that are a incidental part of
a pension or profit-sharing plan.

Sched F \ N365

Other farm expenses

Include all ordinary and necessary farm expenses
not deducted elsewhere on Schedule F, such as ad-
vertising, office supplies, etc. Do not include fines
or penalties paid to a government for violating any
law.

Sched F \ N366

Chemicals

Chemicals used in operating your farm, such as in-
sect sprays and dusts.

Sched F \ N367

Custom hire expenses

Amounts you paid for custom hire (machine work)
(the machine operator furnished the equipment). Do
not include amounts paid for rental or lease of equip-
ment you operated yourself.
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Sched F \ N372

Agricultural program payments

Government payments received for: price support
payments, market gain from the repayment of a se-
cured Commodity Credit Corporation (CCC) loan
for less than the original loan amount, diversion pay-
ments, cost-share payments (sight drafts), payments
in the form of materials (such as fertilizer or lime)
or services (such as grading or building dams). Re-
ported on Form 1099-G.

Sched F \ N373

CCC loans reported/election

Generally, you do not report CCC loan proceeds as
income. However, if you pledge part or all of your
production to secure a CCC loan, you may elect to
report the loan proceeds as income in the year you
receive them, instead of the year you sell the crop.

Sched F \ N374

CCC loans forfeited or repaid

The amount forfeited or repaid with certificates,
even if you reported the loan proceeds as income.
See IRS Pub 225.

Sched F \ N375

Crop insurance proceeds received

You generally include crop insurance proceeds in
the year you receive them. Treat as crop insurance
proceeds the crop disaster payments you receive
from the federal government.

Sched F \ N376

Crop insurance proceeds deferred

If you use the cash method of accounting and re-
ceive crop insurance proceeds in the same tax year
in which the crops are damaged, you can choose
to postpone reporting the proceeds as income until
the following tax year. A statement must also be at-
tached to your return. See IRS Pub 225.

Sched F \ N377

Other farm income

Illegal Federal irrigation subsidies, bartering in-
come, income from discharge of indebtedness, state
gasoline or fuel tax refund, the gain or loss on the
sale of commodity futures contracts, etc.

Sched F \ N368

Sales livestock/product raised

Amounts you received from the sale of livestock,
produce, grains, and other products you raised.

Sched F \ N369

Resales of livestock/items

Amounts you received from the sales of livestock
and other items you bought specifically for resale.
Do not include sales of livestock held for breeding,
dairy purposes, draft, or sport. These are reported on
Form 4797, Sales of Business Property.

Sched F \ N370

Custom hire income

The income you received for custom hire (machine
work).

Sched F \ N371

Total cooperative distributions

Distributions received from a cooperative. This in-
cludes patronage dividends, non patronage distribu-
tions, per-unit retain allocations, and redemption of
non qualified notices and per unit retain allocations.
Reported on Form 1099-PATR.
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Sched F \ N378

Cost of resale livestock/items

The cost or other basis of the livestock and other
items you actually sold.

Sched F \ N543

Car and truck expenses

The business portion of car or truck expenses, such
as, for gasoline, oil, repairs, insurance, tires, license
plates, etc.

Help Sched H \ H565

Schedule H - Household employees

Schedule H is used to report Federal employment
taxes on cash wages paid this year to household em-
ployees. Federal employment taxes include social
security, Medicare, withheld Federal income, and
Federal unemployment (FUTA) taxes.

^ Sched H \ N567

Cash wages paid

For household employees to whom you paid $1,100
(as of 1999) or more each of cash wages that are sub-
ject to social security and Medicare taxes. To find
out if the wages are subject to these taxes, see the
instructions for Schedule H.

^ Sched H \ N568

Federal tax withheld

Federal income tax withheld from total cash wages
paid to household employees during the year.

Help Sched K-1 \ H446

Schedule K-1 - partnership income, credits, deduc-
tions

Schedule K-1 is used to report your share of a part-
nership’s income, credits, deductions, etc. Use a
separate copy of Schedule K-1 for each partnership.

# Sched K-1 \ N448

Ordinary income or loss

Your share of the ordinary income (loss) from the
trade or business activities of the partnership. This is
reported to you on Schedule K-1. (You usually re-
port this on Schedule E, See instructions for Sched-
ule K-1)

# Sched K-1 \ N449

Rental real estate income or loss

The income or (loss) from rental real estate activities
engaged in by the partnership. This is reported to
you on Schedule K-1. (You usually report this on
Schedule E, See instructions for Schedule K-1)

# Sched K-1 \ N450

Other rental income or loss

The income or (loss) from rental activities, other
than the rental of real estate. This is reported to you
on Schedule K-1. (You usually report this on Sched-
ule E, See instructions for Schedule K-1)

Sched K-1 \ N451

Interest income

The amount of interest income the partnership re-
ported to you on Schedule K-1. (You report this on
Schedule B)

Sched K-1 \ N452

Dividends, ordinary

The amount of dividend income the partnership re-
ported to you on Schedule K-1. (You report this on
Schedule B)

# Sched K-1 \ N453

Net ST capital gain or loss

The short-term gain or (loss) from sale of assets the
partnership reported to you on K-1. (You report this
on Schedule D)
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# Sched K-1 \ N454

Net LT capital gain or loss

The long-term gain or (loss) from the sale of assets
the partnership reported to you on Schedule K-1.
(You report this on Schedule D)

Sched K-1 \ N455

Guaranteed partner payments

A guaranteed payments the partnership reported to
you on Schedule K-1. (You report this on Schedule
E)

# Sched K-1 \ N456

Net Section 1231 gain or loss

The gain or (loss) from sale of Section 1231 assets
the partnership reported to you on Schedule K-1.
(You report this on Form 4797)

Sched K-1 \ N527

Royalties

The amount of the royalty income the partnership
reported to you on Schedule K-1. (You report this
on Schedule E)

Sched K-1 \ N528

Tax-exempt interest income

The amount of tax-exempt interest income the part-
nership reported to you on Schedule K-1. (You re-
port this on Form 1040)

Help W-2 \ H458

Form W-2 - Wages earned and taxes withheld

Form W-2 is used by your employer to report
the amount of wages and other compensation you
earned as an employee, and the amount of feder-
al and state taxes withheld and fringe benefits re-
ceived. Use a separate copy of Form W-2 for each
employer.

^ W-2 \ N267

Reimbursed moving expenses, self

Qualified moving expense reimbursements paid di-
rectly to you by an employer.

^ W-2 \ N460

Salary or wages, self

The total wages, tips, and other compensation, be-
fore any payroll deductions, you receive from your
employer.

^ W-2 \ N461

Federal tax withheld, self

The amount of Federal income tax withheld from
your wages for the year.

^ W-2 \ N462

Social Security tax withheld, self

The amount of social security taxes withheld from
your wages.

^ W-2 \ N463

Local tax withheld, self

The amount of local taxes withheld from your
wages.

^ W-2 \ N464

State tax withheld, self

The amount of state taxes withheld from your
wages.

^ W-2 \ N465

Dependent care benefits, self

The amount dependent care benefits, including the
fair market value of employer-provided or employ-
er-sponsored day-care facilities you received.

^ W-2 \ N480

Medicare tax withheld, self

The amount of Medicare taxes withheld from your
wages.
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^ W-2 \ N506

Salary or wages, spouse

The total wages, tips, and other compensation, be-
fore any payroll deductions, your spouse receives
from your spouse’s employer.

^ W-2 \ N507

Federal tax withheld, spouse

The amount of Federal income tax withheld from
your spouse’s wages for the year.

^ W-2 \ N508

Social Security tax withheld, spouse

The amount of social security taxes withheld from
your spouse’s wages.

^ W-2 \ N509

Local tax withheld, spouse

The amount of local taxes withheld from your
spouse’s wages.

^ W-2 \ N510

Medicare tax withheld, spouse

The amount of Medicare taxes withheld from your
spouse’s wages.

^ W-2 \ N511

State tax withheld, spouse

The amount of state taxes withheld from your
spouse’s wages.

^ W-2 \ N512

Dependent care benefits, spouse

The amount dependent care benefits, including the
fair market value of employer-provided or em-
ployer-sponsored day-care facilities your spouse re-
ceived.

^ W-2 \ N546

Reimbursed moving expenses, spouse

Qualified moving expense reimbursements paid di-
rectly to your spouse by your spouse’s employer.

Help W-2G \ H547

Form W-2G - gambling winnings

Form W-2G is used to report certain gambling win-
nings.

^ W-2G \ N549

Gross winnings

The amount of gross winnings from gambling. This
may include winnings from horse racing, dog rac-
ing, jai alai, lotteries, keno, bingo, slot machines,
sweepstakes, and wagering pools. If the amount is
large enough, it will be reported on Form W-2G.

^ W-2G \ N550

Federal tax withheld

The amount of federal income taxes withheld from
gross gambling winnings.

^ W-2G \ N551

State tax withheld

The amount of state income taxes withheld from
gross gambling winnings.

Source: https://github.com/Gnucash/gnucash/tree/stable/libgnucash/tax/us/txf-help.scm

Reset Warnings...
GnuCash gives warnings when certain operations are attempted, such as removing a transaction or remov-
ing the splits of a transaction. The warning message gives you the option to not give you these warnings
when attempting the operation. Check-boxes labeled Remember and don’t ask me again and Remember
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and don’t ask me again this session allow disabling the warnings. This option permits reseting the warnings
to the default, IE make the warning happen. Warnings may be selectivly enabled.

Changing the Language or Region
The language of the GnuCash user interface is not modifiable directly from the program’s preferences.

The way you can change the language depends on the operating system you are running GnuCash on.

Linux

In general you should set the LANGUAGE and LANG environment variables before starting GnuCash.
To do this you need to open a terminal and run the following command:

LANGUAGE=ll_LL LANG=ll_LL gnucash

ll_LL is the locale you want to run GnuCash with (de_DE for Deutsch, it_IT for Italian etc.)

Note

On some systems (e.g. Ubuntu) the encoding could be part of the locales name, like ll_L-
L.UTF-8. You can use these names as well.

macOS

If you want to use a different translation from the one that is automatically selected, you can run the
following in Terminal.app:

defaults write $(mdls -name kMDItemCFBundleIdentifier -raw /Applications/GnuCash.app)
AppleLanguages "(de, en)"

Use whatever language codes you want, replacing Deutsch and English. It won’t work if there isn’t
a translation file for the language you want.

If you want to unset it (that is, return to using the system settings), run this:

defaults delete $(mdls -name kMDItemCFBundleIdentifier -raw /Applications/GnuCash.app)

Windows™

If you are running GnuCash 2.4.0 (or newer) on Windows, you can set the interface language by
editing the file environment with a text editor (e.g. Notepad). By default this file is installed in c:
\Program Files\gnucash\etc\gnucash. Change this file such that the last few lines are:

# If you wish GnuCash to use a different language, uncomment the two parameters
# below and set LANG to your preferred locale
LANG=ll_LL
LANGUAGE={LANG}

ll_LL is the locale you want to run GnuCash with (de_DE for Deutsch, it_IT for Italian etc.)

Tip

More and updated information about this topic can be found on the Locale Settings page [https://
wiki.gnucash.org/wiki/Locale_Settings] of the GnuCash wiki.
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Chapter 11. Setting Up the Quote
Retrieval
If you have more than a couple of commodities, you will tire of having to update their quotes constantly. GnuCash
has the ability to automatically download the most recent quote for your commodities using the Internet. This is
accomplished through the Perl module Finance::Quote, which must be installed in order to activate this feature.

Prerequisites for an Online Quote update with Finance::Quote are

• the Perl language interpreter and

• the Perl-module Finance::Quote with any dependencies

• the Perl-module JSON::Parse to manage the output of Finance::Quote.

Note

If you get stuck while performing the steps described here, you can reach many helpful users on
the channels mentioned under the section called “GnuCash On-line Assistance”.

You can also leave out this step and manually update your stock quotes.

Installing Perl
The installation of Perl is essentially dependent on the operating system used. The effort for installation is low and
is described in this section.

To check if Perl is already installed on your system, call the command perl -v in the terminal.

$ perl -v
This is perl 5, version 30, subversion 0 (v5.30.0) built for x86_64-linux-gnu-thread-multi

If you are shown the version number of the Perl interpreter, skip the next details and continue instead with
the section called “Installing Finance::Quote”.

Procedure 11.1. On Linux

1. On most systems Perl is probably already installed. If with the previous command does not show a
version, then the easiest way is to use your system’s package manager for installation.

2. When using the GnuCash FlatPak package, Perl and Finance::Quote are already functionally installed.

Procedure 11.2. On macOS

• Perl is normally already set up under macOS.

Procedure 11.3. On Windows

1. Under Windows run the program Install Online Price Retrieval for GnuCash to run. This will install
Strawberry Perl [https://en.wikipedia.org/wiki/Strawberry_Perl].

2. For execution you need Administrator privilegies, which are requested in the dialog. The installation
can take more then 15 minutes.

234

https://en.wikipedia.org/wiki/Strawberry_Perl
https://en.wikipedia.org/wiki/Strawberry_Perl


Setting Up the Quote Retrieval

3. If during the installation the error message No such file or directory  or permission
denied are displayed, then it may help to disable the antivirus software temporarily.

Tip

Afterwards it’s a good idea to include the folder where GnuCash is installed, under Windows
e.g. C:\Program Files (x86)\gnucash\bin, to your PATH environment variable.
This way it’s easier for you to use some the section called “Using gnucash-cli for Testing and
Automation.” when needed. Please refer to the documentation for your operating system for more
information.

Installing Finance::Quote
To determine if the Perl module Finance::Quote is already installed on your system, type perldoc Fi-
nance::Quote in a terminal window and check to see if there is any documentation available.

$ perldoc Finance::Quote
NAME
    Finance::Quote - Get stock and mutual fund quotes from various exchanges

SYNOPSIS
    [...]

If you are now shown documentation, then Finance::Quote is already installed and you can configure peri-
odical quotes update as described in the section called “Updating Quotes Automatically with gnucash-cli”.
If no documentation is displayed, you will have to continue with this chapter.

The process of installing Finance::Quote depends on the system. For the different supported systems, you
can follow the instructions below:

Procedure 11.4. On Linux

1. Close GnuCash.

2. Next, update Finance::Quote with sudo gnc-fq-update.

3. Run the gnucash-cli --quotes info command to verify that the program is already in a
directory that is entered in the PATH environment variable. 1

4. If Finance::Quote works properly, the command returns the version number of Finance::Quote mod-
ule currently installed as well as a list of sources available via the Finance::Quote module. It will also
inform you if there is a problem with your installation or if it is missing, and may suggest a fix.

Procedure 11.5. On macOS

Note

You must be logged in with a user id that can administer the mac to use this procedure.

1. Close GnuCash.

1If you’ve installed GnuCash packages provided by your distribution, gnucash-cli will be on your PATH. The Finance::Quote version provided
by your package manager can be checked at  Finance::Quote-versions [https://repology.org/project/perl:finance-quote/versions] or by using your
package manager's info command.
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2. Install Xcode 2 if it is not installed. It contains devel tools, which are required by CPAN to build and
test the needed Finance::Quote modules.

3. Open a Finder window, select Applications from the sidebar, double-click Utilities in the file area,
then double-click on Terminal to open Terminal.

4. In the Terminal window enter sudo /Applications/Gnucash.app/Contents/Re-
sources/bin/gnc-fq-update. That script asks lots of questions. Accept the default for each.

5. Type exit or Ctrl+D to terminate the shell followed by Command+Q to quit Terminal.

Procedure 11.6. On Windows

1. Close GnuCash.

2. Run Install Online Price Retrieval for GnuCash. This is a small utility that installs Finance::Quote
for you.

Using gnucash-cli for Testing and Automation.
GnuCash provides a commandline facility gnucash-cli that one can use with the --quotes option in a terminal session
to check the version and supported source modules, to display the quotes or exchange rates for selected securities or
currencies, or to update all of the prices in a book without launching the GUI.

Note

In GnuCash version 4.x and earlier one used separate perl programs gnc-fq-check instead of
gnucash-cli --quote info and gnc-fq-dump instead of gnucash-cli --quote
dump.

Displaying the Finance::Quote Version and Supported
Sources
The --quotes info option returns the version number of the currently installed Finance::Quote module and a list
of available sources. It informs you also if there is a problem with your installation and gives the reasons.

The latest Finance::Quote version is 1.58. The list of sources that follows depends on the Finance::Quote
version.

The input of

gnucash-cli { -Q | --quotes } info
in the terminal produces the following output:

$ gnucash-cli --quotes info
Found Finance::Quote version 1.57.
Finance::Quote sources:
aex          alphavantage              amfiindia    asegr        asx
aufunds      australia    bamosz       bet          bloomberg    bourso

2You can install Xcode from the App Store or install the much smaller Xcode command line tools by running  sudo xcode-select --
install from a Terminal.app prompt.
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bse          bseindia     bvb          canada       canadamutual
comdirect    cse          deka         dutch        dwsfunds     europe
fetch_live_currencies     fidelity     fidelity_direct
finanzpartner             fondsweb     fool         france       ftfunds
fundata      fundlibrary  goldmoney    googleweb    greece       hu
hufund       hungary      hustock      iexcloud     india        indiamutual
known_currencies          marketwatch  morningstarau
morningstarch             morningstarjp             morningstaruk
mstaruk      nasdaq       nseindia     nyse         nzx          onvista
oslobors     romania      seb_funds    sinvestor    six
tesouro_direto            tiaacref     tmx          tradegate    tradeville
treasurydirect            troweprice   troweprice_direct         tsp
tsx          twelvedata   ukfunds      unionfunds   usa          xetra
yahoo_json   yahooweb     za

If there's a problem with your installation it will tell you about it. For example in this case we're missing
the Perl modules Finance::Quote and JSON::Parse:

$ gnucash-cli --quotes info
Failed to initialize Finance::Quote: missing_modules Finance::Quote JSON::Parse

In this case, Finance::Quote is not installed correctly and therefore cannot be used for quote retrieval
with GnuCash. Please install Finance::Quote according to the instructions at the section called “Installing
Finance::Quote”.

Displaying Quotes in a Terminal Window
The --quotes dump option provides quotes for a source and a list of of symbols in a format that is easy for humans
to read. This is useful to verify that a particular online quote source is accessible and provides data.

You can also check to see if the symbol you want to use for your online price retrieval is available at the desired
quote source.

Tip

You may use gnucash-cli --quotes dump to test quote sources and symbols individually
should GnuCash report an error during quote retrieval. The command will show the fields required
by GnuCash; use gnucash-cli --verbose --quotes dump to see all of the information
returned by Finance::Quote.

To display a quote for one or more stocks or the exchange rate for one or more currencies you can use
gnucash-cli --quotes dump as follows:

gnucash-cli { -Q | --quotes } dump [ -V | --verbose ] Source Symbol...

It offers two output forms for non-currency securities and one for currency exchange rates.

Currencies

Currencies use the source currency and require at least two ISO 4217 [https://en.wikipedia.org/wi-
ki/ISO_4217] currency codes; the exchange rates are denominated in the first code. 3 For example:

3Since Finance::Quote 1.41 the default source for currencies is “Alpha Vantage”. See also the notes on Table A.1, “Currency source for Fi-
nance::Quote”.
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$ gnucash-cli --quotes dump currency USD GBP EUR
1 GBP = 1.2796 USD

1 EUR = 1.09837 USD

Stocks

To retrieve quotes of your securities, please enter the quote source and the desired symbol.

• A short form displaying only the fields that GnuCash uses along with comments indicating whether
the fields are optional or required; you can use this to determine if GnuCash will be able to use the
quote to update your book's price database.

$ gnucash-cli --quotes dump yahooweb AAPL
Finance::Quote fields GnuCash uses:
    symbol: AAPL            <=== required
      date: 07/28/2023      <=== recommended
  currency: USD             <=== required
      last: 193.22          <=\ 
       nav:                 <=== one of these
     price:                 <=/ 

• With the --verbose option a possibly longer output showing all of the fields Finance::Quote
returned. This can be useful to troubleshoot problems with a Finance::Quote source module.

$ ALPHAVANTAGE_API_KEY=123456789 gnucash-cli --verbose --quotes dump alphavantage INTC
INTC:
        open => 34.8200
     isodate => 2023-07-27
       close => 34.3600
        date => 07/27/2023
      symbol => INTC
    currency => USD
currency_set_by_fq => 1
         low => 34.1100
      volume => 58890821
     success => 1
        high => 35.0300
         net => 0.1900
        last => 34.5500
    p_change => 0.5530
      method => alphavantage

Note

Notice that in this case we used alphavantage and provided the ALPHAVAN-
TAGE_API_KEY on the command line. That's not necessary if the key is already stored
in Edit → Preferences the section called “Online Quotes”.

To test if Finance::Quote works for currencies inside GnuCash, do the following:

1. create a transaction with the desired commodity in the book currency,
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2. make a right click on it,

3. select Edit Exchange Rate in the context menu.

4. In the the section called “Transfer Funds Dialog Box” window click the Get exchange rate button.

If the exchange rate source and the symbol are set, the current rate will be entered in the exchange rate field.

Updating Quotes Automatically with gnucash-cli
With the command gnucash-cli --quotes get ${HOME}/gnucash-filename 4 you can receive the
current prices of your foreign exchange and securities and write them directly into your GnuCash-file
without starting the user interface. This enables an automatic, regular updating of the prices.

Note

The command fails if exclusive access to the data file is not possible, for example, the data file
is opened in another GnuCash instance, or the last session for the file crashed.

The specified file ${HOME}/gnucash-filename depends on the name and location of your data file.
This can be determined from the name displayed in the top frame of the GnuCash window before the “-”.

Tip

The file name can also be found in the list of recently opened files in the File menu. If you hover
the mouse pointer on the menu item numbered 1 in the list of recently opened files, the full file
name is displayed in the statusbar.

You have to register the gnucash-cli with a scheduler in order to get Online Quotes automatically and
periodically. The method depends on your OS.

Example 11.1. Automated quote retrieval every Friday at 4:00 p.m.

Procedure 11.7. On Linux and macOS

Register gnucash-cli with cron.

1. Run crontab -e.

2. Add the following line to your crontab:

0 16 * * 5 gnucash-cli --quotes get ${HOME}/gnucash-filename > /dev/null 2>&1

Important

On Linux if there is no graphic session that has already started the dbus, running on your
computer at the time of the quote request, you must do the entry as follows instead:

0 16 * * 5 env `dbus-launch` sh -c 'trap "kill $DBUS_SESSION_BUS_PID" EXIT;
gnucash-cli --quotes get ${HOME}/gnucash-filename > /dev/null 2>&1

4This replaces the command GnuCash --add-price-quotes ${HOME}/gnucash-filename in GnuCash version 4.x and earlier.
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(Do not copy the line breaks into the crontab, they were inserted here only for the purpose
of readability).

Procedure 11.8. On Windows

Register gnucash-cli with Task Scheduler.

1. Select Start → System → Task Scheduler

2. Select Create Task….

3. Enter the appropirate items on Create Task Window.

Adjust the time to the close of the stock exchange and consider fund quotes, that the net asset value (NAV)
is determined well after the markets closed. The types have their description in the section called “Price
Editor”.

Some users have made additions to the wiki and shared their experiences on the Online Quotes Page
on GnuCash Wiki [https://wiki.gnucash.org/wiki/Online_Quotes#Updating_enabled_Quotes_from_out-
side_GnuCash].
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Appendix A. GnuCash Tips and tidbits
GnuCash Version 2.6.20 + Finance::Quote Version 1.47, March 2018

This chapter gives you some background information about Finance::Quote.

Finance::Quote Sources
There are 3 types of sources of which the first - currency - is hardcoded and responsible to fetch ISO
currencies. The other two can be selected in the security editor.

Finance::Quote Sources - Currency source

Table A.1. Currency source for Finance::Quote

GnuCash Name Finance::Quote Name Notes

Currency currency

End of 2017 the provider changed.
Make sure, you updated F::Q to at
least version 1.47 and follow the
instructions at Alphavantage be-
low.

Quote Sources - Individual sources

Table A.2. Individual sources for quotes

GnuCash Name Finance::Quote Name URL, Notes

Alphavantage, US alphavantage

You need to

1. register at https://www.alpha-
vantage.co/ and

Important

Watch the restrictions
of the Free API Key in
their FAQ!

2. store the key which you got
there in Edit → Preferences
the section called “Online
Quotes”.

Amsterdam Euronext eXchange,
NL

aex

https://www.aex.nl

includes former sources
AEX-“Futures” and -“Options”

American International Assur-
ance, HK

aiahk https://www.aia.com.hk

Association of Mutual Funds In
India, IN

amfiindia https://www.amfiindia.com

Athens Stock Exchange, GR asegr https://www.ase.gr
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GnuCash Name Finance::Quote Name URL, Notes

Australian Stock Exchange, AU asx

https://www.asx.com.au

Requires at least F::Q 1.41 to get
quotes for stocks starting with 'X',
like “XRO”, which are not in-
dices.

BAMOSZ funds, HU bamosz https://www.bamosz.hu

BMO NesbittBurns, CA bmonesbittburns https://bmonesbittburns.com

Bucharest Stock Exchange (Bursa
de Valori Bucuresti), RO

bsero https://www.bvb.ro

Budapest Stock Exchange (BET),
ex-BUX, HU

bse or bet https://www.bet.hu

Citywire Funds, GB citywire https://citywire.co.uk

Colombo Stock Exchange, LK cse https://www.cse.lk

Cominvest Asset Management,
ex-Adig, DE

cominvest

https://www.cominvest-am.de

Obsolete, update: https://eg-
gert.org/software/Comdirect.pm

Deka Investments, DE deka https://www.deka.de

DWS, DE dwsfunds https://www.dws.de

Equinox Unit Trusts, ZA za_unittrusts https://www.equinox.co.za

Fidelity Investments, US fidelity_direct https://www.fidelity.com

Fidelity Fixed, US fidelityfixed
https://www.fidelity.com/fixed-
income-bonds/overview

Finance Canada financecanada https://finance.canada.com

Financial Times Funds service,
GB

ftfunds https://funds.ft.com

Finanzpartner, DE finanzpartner https://www.finanzpartner.de

First Trust Portfolios, US ftportfolios_direct https://www.ftportfolios.com

Fund Library, CA fundlibrary

https://www.fundlibrary.com

This module uses an id that rep-
resents the mutual fund on https://
www.fundlibrary.com. There is
no easy way of fetching the id ex-
cept to jump onto the fundlibrary
website, look up the fund and view
the url for clues to its id number.

GoldMoney spot rates, JE goldmoney https://www.goldmoney.com

HElsinki stock eXchange, FI hex https://www.hex.com

Man Investments, AU maninv
https://
www.maninvestments.com.au

Morningstar, GB mstaruk https://morningstar.co.uk

Morningstar, JP morningstarjp https://www.morningstar.co.jp
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GnuCash Name Finance::Quote Name URL, Notes

Morningstar, SE morningstar https://www.morningstar.se

Motley Fool, US fool https://www.fool.com

New Zealand stock eXchange, NZ nzx https://www.nzx.com

Paris Stock Exchange/Boursora-
ma, FR

bourso https://www.boursorama.com

Paris Stock Exchange/LeRevenu,
FR

lerevenu https://bourse.lerevenu.com

Platinum Asset Management, AU platinum https://www.platinum.com.au

SIX Swiss Exchange Funds, CH sixfunds
https://www.six-swiss-
exchange.com

SIX Swiss Exchange Shares, CH sixshares
https://www.six-swiss-
exchange.com

Skandinaviska Enskilda Banken
funds, SE

seb_funds

https://www.seb.se

Consult https://taz.vv.se-
bank.se/cgi-bin/pts3/pow/Fonder/
kurser/kurslista_body.asp for all
available funds.

Sharenet, ZA za https://www.sharenet.co.za

StockHouse Canada, CA stockhousecanada_fund https://www.stockhouse.ca

TD Waterhouse Funds, CA tdwaterhouse
https://
www.tdassetmanagement.com

TD Efunds, CA tdefunds https://www.tdwaterhouse.ca

TIAA-CREF, US tiaacref https://www.tiaa-cref.org

Toronto Stock eXchange, CA tsx https://www.TMXmoney.com

T. Rowe Price, US troweprice_direct https://www.troweprice.com

Trustnet via tnetuk.pm, GB tnetuk https://www.trustnet.com

Trustnet via trustnet.pm, GB trustnet https://www.trustnet.com

Union Investment, DE unionfunds https://www.union-invest.de

US Treasury Bonds, US usfedbonds https://www.publicdebt.treas.gov

US Govt. Thrift Savings Plan, US tsp https://www.tsp.gov

Vanguard, US vanguard part of AlphaVantage

VWD, DE (unmaintained) vwd

See https://lists.gnu-
cash.org/pipermail/gnu-
cash-user/2008-
February/023686.html

Yahoo USA

Yahoo Asia

Yahoo Australia

Yahoo Brasil

yahoo

yahoo_asia

yahoo_australia

yahoo_brasil

CSV interface since 2017-11-01
shut off
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GnuCash Name Finance::Quote Name URL, Notes

Yahoo Europe

Yahoo New Zealand

yahoo_europe

yahoo_nz

Yahoo as JSON, US yahoo_json
https://finance.yahoo.com/
through "JavaScript Object Nota-
tion"

Yahoo as YQL, US yahoo_yql
https://finance.yahoo.com/
through "Yahoo Query Language"

Zuerich Investments (replaced) zifunds
Zürich Invest has been purchased
by Deutsche Bank and integrated
into DWS.

Finance::Quote Sources - Multiple sources
Here the first successful result of a list of sources gets returned.

Table A.3. Multiple sources for quotes

Name

Asia disappeared with Yahoo

Australia (ASX, ...)

Brasil disappeared with Yahoo

Canada (Alphavantage, TSX, ...)

Canada Mutual (Fund Library, StockHouse, ...)

Dutch (AEX, ...)

Europe (asegr, bsero, hex ...)

Greece (ASE, ...)

Hungary (Bamosz, BET, ...)

India Mutual (AMFI, ...)

Fidelity (Fidelity, ...)

Finland (HEX, ...)

First Trust (First Trust, ...)

France (Boursorama, LeRevenu, ...)

Nasdaq (Alphavantage, Fool, ...)

New Zealand (NZX, ...)

NYSE (Alphavantage, Fool, ...)

South Africa (Sharenet, ...)

Romania (bsero, ...)

T. Rowe Price

U.K. Funds (citywire, FTfunds, MStar, tnetuk, ...)

U.K. Unit Trusts (trustnet, ...)

USA (Alphavantage, Fool ...)
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Sources: src/engine/gnc-commodity.c:gnc_quote_source (commit c0fd3b3, which was adjusted for
Finance::Quote 1.47), GnuCash-Wiki [https://wiki.gnucash.org/wiki/], bugzilla [https://bugs.gnu-
cash.org/page.cgi?id=browse.html&product=GnuCash], mailing list archive [https://wiki.gnucash.org/wi-
ki/Mailing_Lists#Mailing_List_Archives].

Yahoo Specifics
Yahoo has offered quotes from many exchanges and markets. Alphavatage will behave similar but without delay. If
you are not asking for US markets, you have to specify where to look. A typical Yahoo symbol has the form {<ISIN>|
<ticker>}<market suffix>.

Dots in Ticker Symbols

Because Yahoo uses the dot . as separator for the market, dots in symbols like in “BT.A” at the
London Stock Exchange [https://www.londonstockexchange.com] are replaced by dash - result-
ing in “BT-A.L”.

Table A.4. Yahoo Codes for Exchanges and Markets

Country Market or Index Suffix Delay

Argentina Buenos Aires Stock Ex-
change (BYMA)

.BA 30 min

Australia Australian Stock Ex-
change

.AX 20 min

Austria Vienna Stock Exchange .VI 15 min

Belgium Euronext Brussels .BR 15 min

Brazil Sao Paolo Stock Ex-
change (BOVESPA)

.SA 15 min

Canada Canadian Securities Ex-
changeToronto Stock
Exchange

.CN 15 min

Canada NEO Exchange .NE Real-time

Canada Toronto Stock Exchange .TO 15 min

Canada TSX Venture Exchange
(TSXV)

.V 15 min

Chile Santiago Stock Ex-
change

.SN 15 min

China Shanghai Stock Ex-
change

.SS 30 min

China Shenzhen Stock Ex-
change

.SZ 30 min

Czech Republic Prague Stock Exchange
Index

.PR 20 min

Denmark Nasdaq OMX Copen-
hagen

.CO Real-time

Egypt Egyptian Exchange In-
dex (EGID)

.CA 20 min

Estonia Nasdaq OMX Tallinn .TL Real-time
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Country Market or Index Suffix Delay

Finland Nasdaq OMX Helsinki .HE Real-time

France Euronext .NX 15 min

France Euronext Paris .PA 15 min

Germany Berlin Stock Exchange .BE 15 min

Germany Bremen Stock Exchange .BM 15 min

Germany Dusseldorf Stock Ex-
change

.DU 15 min

Germany Frankfurt Stock Ex-
change

.F 15 min

Germany Hamburg Stock Ex-
change

.HM 15 min

Germany Hanover Stock Exchange .HA 15 min

Germany Munich Stock Exchange .MU 15 min

Germany Stuttgart Stock Exchange .SG 15 min

Germany Deutsche Boerse XE-
TRA

.DE 15 min

Global Currency Rates =X Real-time

Greece Athens Stock Exchange
(ATHEX)

.AT 15 min

Hong Kong Hong Kong Stock Ex-
change (HKEX)

.HK 15 min (Real-time in HK)

Hungary Budapest Stock Ex-
change

.BD 15 min

Iceland Nasdaq OMX Iceland .IC Real-time

India Bombay Stock Exchange .BO Real-time

India National Stock Exchange
of India

.NS Real-time**

Indonesia Indonesia Stock Ex-
change (IDX)

.JK 10 min

Ireland Euronext Dublin .IR 15 min

Israel Tel Aviv Stock Ex-
change

.TA 20 min

Italy EuroTLX .TI 20 min

Italy Italian Stock Exchange,
former Milano

.MI 20 min

Japan Nikkei Indices N/A 30 min

Japan Tokyo Stock Exchange .T 20 min

Latvia Nasdaq OMX Riga .RG Real-time

Lithuania Nasdaq OMX Vilnius .VS Real-time

Malaysia Malaysian Stock Ex-
change

.KL 15 min
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Country Market or Index Suffix Delay

Mexico Mexico Stock Exchange
(BMV)

.MX 20 min

Netherlands Euronext Amsterdam .AS 15 min

New Zealand New Zealand Stock Ex-
change (NZX)

.NZ 20 min

Norway Oslo Stock Exchange .OL 15 min

Portugal Euronext Lisbon .LS 15 min

Qatar Qatar Stock Exchange .QA 15 min

Russia Moscow Exchange
(MOEX)

.ME Real-time

Singapore Singapore Stock Ex-
change

.SI 20 min

South Africa Johannesburg Stock Ex-
change

.Jo 15 min

South Korea Korea Stock Exchange .KS 20 min

South Korea KOSDAQ .KQ 20 min

Spain Madrid SE C.A.T.S. .MC 15 min

Saudi Arabia Saudi Stock Exchange
(Tadawul)

.SAU 15 min

Sweden Nasdaq OMX Stockholm .ST Real-time

Switzerland Swiss Exchange (SIX) .SW 30 min

Taiwan Taiwan OTC Exchange .TWO 20 min

Taiwan Taiwan Stock Exchange
(TWSE)

.TW 20 min

Thailand Stock Exchange of Thai-
land (SET)

.BK 15 min

Turkey Borsa #stanbul .IS 15 min

United Kingdom FTSE Indices N/A 15 min

United Kingdom London Stock Exchange .L 20 min

United Kingdom London Stock Exchange .IL 20 min

United States of America Chicago Board of Trade
(CBOT)

.CBT 10 min

United States of America Chicago Mercantile Ex-
change (CME)

.CME 10 min

United States of America Dow Jones Indexes N/A Real-time

United States of America NASDAQ Stock Ex-
change

N/A Real-time*

United States of America ICE Futures US, for-
mer New York Board of
Trade

.NYB 30 min

United States of America New York Commodities
Exchange (COMEX)

.CMX 30 min
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Country Market or Index Suffix Delay

United States of America New York Mercantile
Exchange (NYMEX)

.NYM 30 min

United States of America Options Price Reporting
Authority (OPRA)

N/A 15 min

United States of America OTC Bulletin Board
Market

N/A Real-time

United States of America OTC Markets Group N/A 15 min

United States of America S & P Indices N/A Real-time

Venezuela Caracas Stock Exchange .CR 15 min

Source: https://help.yahoo.com/kb/SLN2310.html?redirect=true queried at 2020-04-14.

TIAA-CREF Specifics
TIAA-CREF Annuities are not listed on any exchange, unlike their mutual funds TIAA-CREF provides unit values
via a cgi on their website. The cgi returns a csv file in the format

bogus_symbol1,price1,date1
bogus_symbol2,price2,date2
…

where bogus_symbol takes on the following values for the various annuities:

Note

The symbols are case-sensitive and changed their capitalization in the last time.

Table A.5. Pseudo-symbols that can be used for TIAA-CREF quotes

Name Symbol bogus

CREF Bond Market Account CREFbond 41081991

CREF Equity Index Account CREFequi 41082540

CREF Global Equities Account CREFglob 41081992

CREF Growth Account CREFgrow 41082544

CREF Inflation-Linked Bond Ac-
count

CREFinfb 41088773

CREF Money Market Account CREFmony 41081993

CREF Social Choice Account CREFsoci 41081994

CREF Stock Account CREFstok 41081995

TIAA Real Estate Account TIAAreal 41091375

TIAA-CREF Bond Fund (Retire-
ment)

TIDRX 4530828

TIAA-CREF Bond Index Fund
(Retirement)

TBIRX 20739662

TIAA-CREF Bond Plus Fund
(Retirement)

TCBRX 4530816
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Name Symbol bogus

TIAA-CREF Emerging Markets
Equity Fund (Retirement)

TEMSX 26176543

TIAA-CREF Emerging Markets
Equity Index Fund (Retirement)

TEQSX 26176547

TIAA-CREF Equity Index Fund
(Retirement)

TIQRX 4530786

TIAA-CREF Global Natural Re-
sources Fund (Retirement)

TNRRX 39444919

TIAA-CREF Growth & Income
Fund (Retirement)

TRGIX 312536

TIAA-CREF High Yield Fund
(Retirement)

TIHRX 4530821

TIAA-CREF Inflation-Linked
Bond Fund (Retirement)

TIKRX 4530829

TIAA-CREF International Equity
Fund (Retirement)

TRERX 302323

TIAA-CREF International Equity
Index Fund (Retirement)

TRIEX 300269

TIAA-CREF Large-Cap Growth
Fund (Retirement)

TILRX 4530785

TIAA-CREF Large-Cap Growth
Index Fund (Retirement)

TRIRX 299525

TIAA-CREF Large-Cap Value
Fund (Retirement)

TRLCX 301332

TIAA-CREF Large-Cap Value In-
dex Fund (Retirement)

TRCVX 304333

TIAA-CREF Lifecycle 2010 Fund
(Retirement)

TCLEX 302817

TIAA-CREF Lifecycle 2015 Fund
(Retirement)

TCLIX 302393

TIAA-CREF Lifecycle 2020 Fund
(Retirement)

TCLTX 307774

TIAA-CREF Lifecycle 2025 Fund
(Retirement)

TCLFX 313994

TIAA-CREF Lifecycle 2030 Fund
(Retirement)

TCLNX 307240

TIAA-CREF Lifecycle 2035 Fund
(Retirement)

TCLRX 309003

TIAA-CREF Lifecycle 2040 Fund
(Retirement)

TCLOX 300959

TIAA-CREF Lifecycle 2045 Fund
(Retirement)

TTFRX 9467597

TIAA-CREF Lifecycle 2050 Fund
(Retirement)

TLFRX 9467596
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Name Symbol bogus

TIAA-CREF Lifecycle 2055 Fund
(Retirement)

TTRLX 34211330

TIAA-CREF Lifecycle Index
2010 Fund (Retirement)

TLTRX 21066482

TIAA-CREF Lifecycle Index
2015 Fund (Retirement)

TLGRX 21066496

TIAA-CREF Lifecycle Index
2020 Fund (Retirement)

TLWRX 21066479

TIAA-CREF Lifecycle Index
2025 Fund (Retirement)

TLQRX 21066485

TIAA-CREF Lifecycle Index
2030 Fund (Retirement)

TLHRX 21066435

TIAA-CREF Lifecycle Index
2035 Fund (Retirement)

TLYRX 21066475

TIAA-CREF Lifecycle Index
2040 Fund (Retirement)

TLZRX 21066473

TIAA-CREF Lifecycle Index
2045 Fund (Retirement)

TLMRX 21066488

TIAA-CREF Lifecycle Index
2050 Fund (Retirement)

TLLRX 21066490

TIAA-CREF Lifecycle Index
2055 Fund (Retirement)

TTIRX 34211328

TIAA-CREF Lifecycle Index Re-
tirement Income Fund (Retire-
ment)

TRCIX 21066468

TIAA-CREF Lifecycle Retire-
ment Income Fund (Retirement)

TLIRX 9467594

TIAA-CREF Lifestyle Aggres-
sive Growth Fund (Retirement)

TSARX 40508431

TIAA-CREF Lifestyle Conserva-
tive Fund (Retirement)

TSCTX 40508433

TIAA-CREF Lifestyle Growth
Fund (Retirement)

TSGRX 40508437

TIAA-CREF Lifestyle Income
Fund (Retirement)

TLSRX 40508427

TIAA-CREF Lifestyle Moderate
Fund (Retirement)

TSMTX 40508460

TIAA-CREF Managed Allocation
Fund (Retirement)

TITRX 4530825

TIAA-CREF Mid-Cap Growth
Fund (Retirement)

TRGMX 305499

TIAA-CREF Mid-Cap Value
Fund (Retirement)

TRVRX 315272
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Name Symbol bogus

TIAA-CREF Money Market Fund
(Retirement)

TIEXX 4530771

TIAA-CREF Real Estate Securi-
ties Fund (Retirement)

TRRSX 300081

TIAA-CREF S&P 500 Index
Fund (Retirement)

TRSPX 306105

TIAA-CREF Short-Term Bond
Fund (Retirement)

TISRX 4530818

TIAA-CREF Small-Cap Blend In-
dex Fund (Retirement)

TRBIX 314644

TIAA-CREF Small-Cap Equity
Fund (Retirement)

TRSEX 299968

TIAA-CREF Social Choice Equi-
ty Fund (Retirement)

TRSCX 300078

TIAA-CREF Bond Fund (Institu-
tional)

TIBDX 307276

TIAA-CREF Bond Index Fund
(Institutional)

TBIIX 20739664

TIAA-CREF Bond Plus Fund (In-
stitutional)

TIBFX 4530820

TIAA-CREF Emerging Markets
Equity Fund (Institutional)

TEMLX 26176540

TIAA-CREF Emerging Markets
Equity Index Fund (Institutional)

TEQLX 26176544

TIAA-CREF Enhanced Interna-
tional Equity Index Fund (Institu-
tional)

TFIIX 9467603

TIAA-CREF Enhanced Large-
Cap Growth Index Fund (Institu-
tional)

TLIIX 9467602

TIAA-CREF Enhanced Large-
Cap Value Index Fund (Institu-
tional)

TEVIX 9467606

TIAA-CREF Equity Index Fund
(Institutional)

TIEIX 301718

TIAA-CREF Global Natural Re-
sources Fund (Institutional)

TNRIX 39444916

TIAA-CREF Growth & Income
Fund (Institutional)

TIGRX 314719

TIAA-CREF High Yield Fund
(Institutional)

TIHYX 4530798

TIAA-CREF Inflation-Linked
Bond Fund (Institutional)

TIILX 316693
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Name Symbol bogus

TIAA-CREF International Equity
Fund (Institutional)

TIIEX 305980

TIAA-CREF International Equity
Index Fund (Institutional)

TCIEX 303673

TIAA-CREF Large-Cap Growth
Fund (Institutional)

TILGX 4530800

TIAA-CREF Large-Cap Growth
Index Fund (Institutional)

TILIX 297809

TIAA-CREF Large-Cap Value
Fund (Institutional)

TRLIX 300692

TIAA-CREF Large-Cap Value In-
dex Fund (Institutional)

TILVX 302308

TIAA-CREF Lifecycle 2010 Fund
(Institutional)

TCTIX 4912376

TIAA-CREF Lifecycle 2015 Fund
(Institutional)

TCNIX 4912355

TIAA-CREF Lifecycle 2020 Fund
(Institutional)

TCWIX 4912377

TIAA-CREF Lifecycle 2025 Fund
(Institutional)

TCYIX 4912384

TIAA-CREF Lifecycle 2030 Fund
(Institutional)

TCRIX 4912364

TIAA-CREF Lifecycle 2035 Fund
(Institutional)

TCIIX 4912375

TIAA-CREF Lifecycle 2040 Fund
(Institutional)

TCOIX 4912387

TIAA-CREF Lifecycle 2045 Fund
(Institutional)

TTFIX 9467607

TIAA-CREF Lifecycle 2050 Fund
(Institutional)

TFTIX 9467601

TIAA-CREF Lifecycle 2055 Fund
(Institutional)

TTRIX 34211329

TIAA-CREF Lifecycle Index
2010 Fund (Institutional)

TLTIX 21066484

TIAA-CREF Lifecycle Index
2015 Fund (Institutional)

TLFIX 21066498

TIAA-CREF Lifecycle Index
2020 Fund (Institutional)

TLWIX 21066480

TIAA-CREF Lifecycle Index
2025 Fund (Institutional)

TLQIX 21066486

TIAA-CREF Lifecycle Index
2030 Fund (Institutional)

TLHIX 21066495

TIAA-CREF Lifecycle Index
2035 Fund (Institutional)

TLYIX 21066477
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Name Symbol bogus

TIAA-CREF Lifecycle Index
2040 Fund (Institutional)

TLZIX 21066474

TIAA-CREF Lifecycle Index
2045 Fund (Institutional)

TLXIX 21066478

TIAA-CREF Lifecycle Index
2050 Fund (Institutional)

TLLIX 21066492

TIAA-CREF Lifecycle Index
2055 Fund (Institutional)

TTIIX 34211326

TIAA-CREF Lifecycle Index Re-
tirement Income Fund (Institu-
tional)

TRILX 21066463

TIAA-CREF Lifecycle Retire-
ment Income Fund (Institutional)

TLRIX 9467595

TIAA-CREF Lifestyle Aggres-
sive Growth Fund (Institutional)

TSAIX 40508428

TIAA-CREF Lifestyle Conserva-
tive Fund (Institutional)

TCSIX 40508425

TIAA-CREF Lifestyle Growth
Fund (Institutional)

TSGGX 40508434

TIAA-CREF Lifestyle Income
Fund (Institutional)

TSITX 40508450

TIAA-CREF Lifestyle Moderate
Fund (Institutional)

TSIMX 40508443

TIAA-CREF Managed Allocation
Fund (Institutional)

TIMIX 4530787

TIAA-CREF Mid-Cap Growth
Fund (Institutional)

TRPWX 297210

TIAA-CREF Mid-Cap Value
Fund (Institutional)

TIMVX 316178

TIAA-CREF Money Market Fund
(Institutional)

TCIXX 313650

TIAA-CREF Real Estate Securi-
ties Fund (Institutional)

TIREX 303475

TIAA-CREF S&P 500 Index
Fund (Institutional)

TISPX 306658

TIAA-CREF Short-Term Bond
Fund (Institutional)

TISIX 4530784

TIAA-CREF Small-Cap Blend In-
dex Fund (Institutional)

TISBX 309018

TIAA-CREF Small-Cap Equity
Fund (Institutional)

TISEX 301622

TIAA-CREF Social Choice Equi-
ty Fund (Institutional)

TISCX 301897
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Name Symbol bogus

TIAA-CREF Tax-Exempt Bond
Fund (Institutional)

TITIX 4530819

TIAA-CREF Bond Fund (Retail) TIORX 4530794

TIAA-CREF Bond Index Fund
(Retail)

TBILX 20739663

TIAA-CREF Bond Plus Fund
(Retail)

TCBPX 4530788

TIAA-CREF Emerging Markets
Equity Fund (Retail)

TEMRX 26176542

TIAA-CREF Emerging Markets
Equity Index Fund (Retail)

TEQKX 26176545

TIAA-CREF Equity Index Fund
(Retail)

TINRX 4530797

TIAA-CREF Global Natural Re-
sources Fund (Retail)

TNRLX 39444917

TIAA-CREF Growth & Income
Fund (Retail)

TIIRX 4530790

TIAA-CREF High Yield Fund
(Retail)

TIYRX 4530830

TIAA-CREF Inflation-Linked
Bond Fund (Retail)

TCILX 313727

TIAA-CREF International Equity
Fund (Retail)

TIERX 4530827

TIAA-CREF Large-Cap Growth
Fund (Retail)

TIRTX 4530791

TIAA-CREF Large-Cap Value
Fund (Retail)

TCLCX 302696

TIAA-CREF Lifecycle Retire-
ment Income Fund (Retail)

TLRRX 9467600

TIAA-CREF Lifestyle Aggres-
sive Growth Fund (Retail)

TSALX 40508429

TIAA-CREF Lifestyle Conserva-
tive Fund (Retail)

TSCLX 40508432

TIAA-CREF Lifestyle Growth
Fund (Retail)

TSGLX 40508435

TIAA-CREF Lifestyle Income
Fund (Retail)

TSILX 40508438

TIAA-CREF Lifestyle Moderate
Fund (Retail)

TSMLX 40508453

TIAA-CREF Managed Allocation
Fund (Retail)

TIMRX 4530817

TIAA-CREF Mid-Cap Growth
Fund (Retail)

TCMGX 305208
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Name Symbol bogus

TIAA-CREF Mid-Cap Value
Fund (Retail)

TCMVX 313995

TIAA-CREF Money Market Fund
(Retail)

TIRXX 4530775

TIAA-CREF Real Estate Securi-
ties Fund (Retail)

TCREX 309567

TIAA-CREF Short-Term Bond
Fund (Retail)

TCTRX 4530822

TIAA-CREF Small-Cap Equity
Fund (Retail)

TCSEX 297477

TIAA-CREF Social Choice Equi-
ty Fund (Retail)

TICRX 4530792

TIAA-CREF Tax-Exempt Bond
Fund (Retail)

TIXRX 4530793

TIAA-CREF Bond Fund (Pre-
mier)

TIDPX 21066506

TIAA-CREF Bond Index Fund
(Premier)

TBIPX 21066534

TIAA-CREF Bond Plus Fund
(Premier)

TBPPX 21066533

TIAA-CREF Emerging Markets
Equity Fund (Premier)

TEMPX 26176541

TIAA-CREF Emerging Markets
Equity Index Fund (Premier)

TEQPX 26176546

TIAA-CREF Equity Index Fund
(Premier)

TCEPX 21066530

TIAA-CREF Global Natural Re-
sources Fund (Premier)

TNRPX 39444918

TIAA-CREF Growth & Income
Fund (Premier)

TRPGX 21066461

TIAA-CREF High Yield Fund
(Premier)

TIHPX 21066501

TIAA-CREF Inflation-Linked
Bond Fund (Premier)

TIKPX 21066500

TIAA-CREF International Equity
Fund (Premier)

TREPX 21066466

TIAA-CREF International Equity
Index Fund (Premier)

TRIPX 21066462

TIAA-CREF Large-Cap Growth
Fund (Premier)

TILPX 21066499

TIAA-CREF Large-Cap Value
Fund (Premier)

TRCPX 21066467

TIAA-CREF Lifecycle 2010 Fund
(Premier)

TCTPX 21066521
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Name Symbol bogus

TIAA-CREF Lifecycle 2015 Fund
(Premier)

TCFPX 21066528

TIAA-CREF Lifecycle 2020 Fund
(Premier)

TCWPX 21066518

TIAA-CREF Lifecycle 2025 Fund
(Premier)

TCQPX 21066522

TIAA-CREF Lifecycle 2030 Fund
(Premier)

TCHPX 21066527

TIAA-CREF Lifecycle 2035 Fund
(Premier)

TCYPX 21066517

TIAA-CREF Lifecycle 2040 Fund
(Premier)

TCZPX 21066516

TIAA-CREF Lifecycle 2045 Fund
(Premier)

TTFPX 21066444

TIAA-CREF Lifecycle 2050 Fund
(Premier)

TCLPX 21066526

TIAA-CREF Lifecycle 2055 Fund
(Premier)

TTRPX 34211331

TIAA-CREF Lifecycle Index
2010 Fund (Premier)

TLTPX 21066483

TIAA-CREF Lifecycle Index
2015 Fund (Premier)

TLFPX 21066497

TIAA-CREF Lifecycle Index
2020 Fund (Premier)

TLWPX 21066434

TIAA-CREF Lifecycle Index
2025 Fund (Premier)

TLVPX 21066481

TIAA-CREF Lifecycle Index
2030 Fund (Premier)

TLHPX 21066494

TIAA-CREF Lifecycle Index
2035 Fund (Premier)

TLYPX 21066476

TIAA-CREF Lifecycle Index
2040 Fund (Premier)

TLPRX 21066487

TIAA-CREF Lifecycle Index
2045 Fund (Premier)

TLMPX 21066489

TIAA-CREF Lifecycle Index
2050 Fund (Premier)

TLLPX 21066491

TIAA-CREF Lifecycle Index
2055 Fund (Premier)

TTIPX 34211327

TIAA-CREF Lifecycle Index Re-
tirement Income Fund (Premier)

TLIPX 21066493

TIAA-CREF Lifecycle Retire-
ment Income Fund (Premier)

TPILX 21066470

TIAA-CREF Lifestyle Aggres-
sive Growth Fund (Premier)

TSAPX 40508430
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TIAA-CREF Lifestyle Conserva-
tive Fund (Premier)

TLSPX 40508426

TIAA-CREF Lifestyle Growth
Fund (Premier)

TSGPX 40508436

TIAA-CREF Lifestyle Income
Fund (Premier)

TSIPX 40508451

TIAA-CREF Lifestyle Moderate
Fund (Premier)

TSMPX 40508456

TIAA-CREF Mid-Cap Growth
Fund (Premier)

TRGPX 21066464

TIAA-CREF Mid-Cap Value
Fund (Premier)

TRVPX 21066455

TIAA-CREF Money Market Fund
(Premier)

TPPXX 21066469

TIAA-CREF Real Estate Securi-
ties Fund (Premier)

TRRPX 21066459

TIAA-CREF Short-Term Bond
Fund (Premier)

TSTPX 21066445

TIAA-CREF Small-Cap Equity
Fund (Premier)

TSRPX 21066446

TIAA-CREF Social Choice Equi-
ty Fund (Premier)

TRPSX 21066460

Source: Comments in https://rt.cpan.org/Ticket/Attachment/1121440/589997/Tiaacref.pm.zip
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Appendix B. GNU Free Documentation
License

Version 1.1, March 2000
Copyright © 2000 Free Software Foundation, Inc.

Free Software Foundation, Inc. 59 Temple Place,
        Suite 330, Boston, MA
        02111-1307  USA

Everyone is permitted to copy and distribute verbatim copies of this license document, but changing it
is not allowed.

0. PREAMBLE
The purpose of this License is to make a manual, textbook, or other written document “free” in the sense of
freedom: to assure everyone the effective freedom to copy and redistribute it, with or without modifying it,
either commercially or noncommercially. Secondarily, this License preserves for the author and publisher
a way to get credit for their work, while not being considered responsible for modifications made by others.

This License is a kind of “copyleft”, which means that derivative works of the document must themselves
be free in the same sense. It complements the GNU General Public License, which is a copyleft license
designed for free software.

We have designed this License in order to use it for manuals for free software, because free software
needs free documentation: a free program should come with manuals providing the same freedoms that
the software does. But this License is not limited to software manuals; it can be used for any textual work,
regardless of subject matter or whether it is published as a printed book. We recommend this License
principally for works whose purpose is instruction or reference.

1. APPLICABILITY AND DEFINITIONS
This License applies to any manual or other work that contains a notice placed by the copyright holder
saying it can be distributed under the terms of this License. The “Document”, below, refers to any such
manual or work. Any member of the public is a licensee, and is addressed as “you”.

A “Modified Version” of the Document means any work containing the Document or a portion of it, either
copied verbatim, or with modifications and/or translated into another language.

A “Secondary Section” is a named appendix or a front-matter section of the Document that deals exclu-
sively with the relationship of the publishers or authors of the Document to the Document’s overall sub-
ject (or to related matters) and contains nothing that could fall directly within that overall subject. (For
example, if the Document is in part a textbook of mathematics, a Secondary Section may not explain any
mathematics.) The relationship could be a matter of historical connection with the subject or with related
matters, or of legal, commercial, philosophical, ethical or political position regarding them.

The “Invariant Sections” are certain  Secondary Sections whose titles are designated, as being those of
Invariant Sections, in the notice that says that the Document is released under this License.

The “Cover Texts” are certain short passages of text that are listed, as Front-Cover Texts or Back-Cover
Texts, in the notice that says that the Document is released under this License.
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A “Transparent” copy of the  Document means a machine-readable copy, represented in a format whose
specification is available to the general public, whose contents can be viewed and edited directly and
straightforwardly with generic text editors or (for images composed of pixels) generic paint programs or
(for drawings) some widely available drawing editor, and that is suitable for input to text formatters or
for automatic translation to a variety of formats suitable for input to text formatters. A copy made in an
otherwise Transparent file format whose markup has been designed to thwart or discourage subsequent
modification by readers is not Transparent. A copy that is not “Transparent” is called “Opaque”.

Examples of suitable formats for Transparent copies include plain ASCII without markup, Texinfo input
format, LaTeX input format, SGML or XML using a publicly available DTD, and standard-conforming
simple HTML designed for human modification. Opaque formats include PostScript, PDF, proprietary
formats that can be read and edited only by proprietary word processors, SGML or XML for which the
DTD and/or processing tools are not generally available, and the machine-generated HTML produced by
some word processors for output purposes only.

The “Title Page” means, for a printed book, the title page itself, plus such following pages as are needed
to hold, legibly, the material this License requires to appear in the title page. For works in formats which
do not have any title page as such, “Title Page” means the text near the most prominent appearance of the
work’s title, preceding the beginning of the body of the text.

2. VERBATIM COPYING
You may copy and distribute the Document in any medium, either commercially or noncommercially,
provided that this License, the copyright notices, and the license notice saying this License applies to the
Document are reproduced in all copies, and that you add no other conditions whatsoever to those of this
License. You may not use technical measures to obstruct or control the reading or further copying of the
copies you make or distribute. However, you may accept compensation in exchange for copies. If you
distribute a large enough number of copies you must also follow the conditions in section 3.

You may also lend copies, under the same conditions stated above, and you may publicly display copies.

3. COPYING IN QUANTITY
If you publish printed copies of the Document numbering more than 100, and the Document’s license
notice requires Cover Texts, you must enclose the copies in covers that carry, clearly and legibly, all these
Cover Texts: Front-Cover Texts on the front cover, and Back-Cover Texts on the back cover. Both covers
must also clearly and legibly identify you as the publisher of these copies. The front cover must present
the full title with all words of the title equally prominent and visible. You may add other material on the
covers in addition. Copying with changes limited to the covers, as long as they preserve the title of the
Document and satisfy these conditions, can be treated as verbatim copying in other respects.

If the required texts for either cover are too voluminous to fit legibly, you should put the first ones listed
(as many as fit reasonably) on the actual cover, and continue the rest onto adjacent pages.

If you publish or distribute Opaque copies of the Document numbering more than 100, you must either in-
clude a machine-readable Transparent copy along with each Opaque copy, or state in or with each Opaque
copy a publicly-accessible computer-network location containing a complete Transparent copy of the Doc-
ument, free of added material, which the general network-using public has access to download anony-
mously at no charge using public-standard network protocols. If you use the latter option, you must take
reasonably prudent steps, when you begin distribution of Opaque copies in quantity, to ensure that this
Transparent copy will remain thus accessible at the stated location until at least one year after the last time
you distribute an Opaque copy (directly or through your agents or retailers) of that edition to the public.

It is requested, but not required, that you contact the authors of the Document well before redistributing
any large number of copies, to give them a chance to provide you with an updated version of the Document.
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4. MODIFICATIONS
You may copy and distribute a Modified Version of the Document under the conditions of sections 2 and
3 above, provided that you release the Modified Version under precisely this License, with the Modified
Version filling the role of the Document, thus licensing distribution and modification of the Modified
Version to whoever possesses a copy of it. In addition, you must do these things in the Modified Version:

• A. Use in the Title Page (and on the covers, if any) a title distinct from that of the Document, and
from those of previous versions (which should, if there were any, be listed in the History section of the
Document). You may use the same title as a previous version if the original publisher of that version
gives permission.

• B. List on the Title Page, as authors, one or more persons or entities responsible for authorship of
the modifications in the Modified Version, together with at least five of the principal authors of the
Document (all of its principal authors, if it has less than five).

• C. State on the Title Page the name of the publisher of the Modified Version, as the publisher.

• D. Preserve all the copyright notices of the Document.

• E. Add an appropriate copyright notice for your modifications adjacent to the other copyright notices.

• F. Include, immediately after the copyright notices, a license notice giving the public permission to
use the Modified Version under the terms of this License, in the form shown in the Addendum below.

• G. Preserve in that license notice the full lists of  Invariant Sections and required Cover Texts given
in the Document’s license notice.

• H. Include an unaltered copy of this License.

• I. Preserve the section entitled “History”, and its title, and add to it an item stating at least the title,
year, new authors, and publisher of the Modified Version as given on the Title Page. If there is no
section entitled “History” in the Document, create one stating the title, year, authors, and publisher of
the Document as given on its Title Page, then add an item describing the Modified Version as stated
in the previous sentence.

• J. Preserve the network location, if any, given in the Document for public access to a Transparent
copy of the Document, and likewise the network locations given in the Document for previous versions
it was based on. These may be placed in the “History” section. You may omit a network location for
a work that was published at least four years before the Document itself, or if the original publisher of
the version it refers to gives permission.

• K. In any section entitled “Acknowledgements” or “Dedications”, preserve the section’s title, and
preserve in the section all the substance and tone of each of the contributor acknowledgements and/or
dedications given therein.

• L. Preserve all the Invariant Sections of the Document, unaltered in their text and in their titles.
Section numbers or the equivalent are not considered part of the section titles.

• M. Delete any section entitled “Endorsements”. Such a section may not be included in the Modified
Version.

• N. Do not retitle any existing section as “Endorsements” or to conflict in title with any Invariant
Section.
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If the Modified Version includes new front-matter sections or appendices that qualify as Secondary Sec-
tions and contain no material copied from the Document, you may at your option designate some or all
of these sections as invariant. To do this, add their titles to the list of Invariant Sections in the Modified
Version’s license notice. These titles must be distinct from any other section titles.

You may add a section entitled “Endorsements”, provided it contains nothing but endorsements of your
Modified Version by various parties--for example, statements of peer review or that the text has been
approved by an organization as the authoritative definition of a standard.

You may add a passage of up to five words as a Front-Cover Text, and a passage of up to 25 words as
a Back-Cover Text, to the end of the list of Cover Texts in the Modified Version. Only one passage of
Front-Cover Text and one of Back-Cover Text may be added by (or through arrangements made by) any
one entity. If the Document already includes a cover text for the same cover, previously added by you or
by arrangement made by the same entity you are acting on behalf of, you may not add another; but you
may replace the old one, on explicit permission from the previous publisher that added the old one.

The author(s) and publisher(s) of the Document do not by this License give permission to use their names
for publicity for or to assert or imply endorsement of any Modified Version .

5. COMBINING DOCUMENTS
You may combine the Document with other documents released under this License, under the terms de-
fined in section 4 above for modified versions, provided that you include in the combination all of the
Invariant Sections of all of the original documents, unmodified, and list them all as Invariant Sections of
your combined work in its license notice.

The combined work need only contain one copy of this License, and multiple identical Invariant Sections
may be replaced with a single copy. If there are multiple Invariant Sections with the same name but dif-
ferent contents, make the title of each such section unique by adding at the end of it, in parentheses, the
name of the original author or publisher of that section if known, or else a unique number. Make the same
adjustment to the section titles in the list of Invariant Sections in the license notice of the combined work.

In the combination, you must combine any sections entitled “History” in the various original documents,
forming one section entitled “History”; likewise combine any sections entitled “Acknowledgements”, and
any sections entitled “Dedications”. You must delete all sections entitled “Endorsements.”

6. COLLECTIONS OF DOCUMENTS
You may make a collection consisting of the Document and other documents released under this License,
and replace the individual copies of this License in the various documents with a single copy that is included
in the collection, provided that you follow the rules of this License for verbatim copying of each of the
documents in all other respects.

You may extract a single document from such a collection, and dispbibute it individually under this Li-
cense, provided you insert a copy of this License into the extracted document, and follow this License in
all other respects regarding verbatim copying of that document.

7. AGGREGATION WITH INDEPENDENT
WORKS

A compilation of the Document or its derivatives with other separate and independent documents or works,
in or on a volume of a storage or distribution medium, does not as a whole count as a Modified Version
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of the Document, provided no compilation copyright is claimed for the compilation. Such a compilation
is called an “aggregate”, and this License does not apply to the other self-contained works thus compiled
with the Document , on account of their being thus compiled, if they are not themselves derivative works
of the Document. If the Cover Text requirement of section 3 is applicable to these copies of the Document,
then if the Document is less than one quarter of the entire aggregate, the Document’s Cover Texts may
be placed on covers that surround only the Document within the aggregate. Otherwise they must appear
on covers around the whole aggregate.

8. TRANSLATION
Translation is considered a kind of modification, so you may distribute translations of the Document under
the terms of section 4. Replacing  Invariant Sections with translations requires special permission from
their copyright holders, but you may include translations of some or all Invariant Sections in addition to
the original versions of these Invariant Sections. You may include a translation of this License provided
that you also include the original English version of this License. In case of a disagreement between the
translation and the original English version of this License, the original English version will prevail.

9. TERMINATION
You may not copy, modify, sublicense, or distribute the Document except as expressly provided for under
this License. Any other attempt to copy, modify, sublicense or distribute the Document is void, and will
automatically terminate your rights under this License. However, parties who have received copies, or
rights, from you under this License will not have their licenses terminated so long as such parties remain
in full compliance.

10. FUTURE REVISIONS OF THIS LICENSE
The Free Software Foundation [http://www.gnu.org/fsf/fsf.html] may publish new, revised versions of the
GNU Free Documentation License from time to time. Such new versions will be similar in spirit to the
present version, but may differ in detail to address new problems or concerns. See http://www.gnu.org/
copyleft/ [http://www.gnu.org/copyleft].

Each version of the License is given a distinguishing version number. If the Document specifies that a
particular numbered version of this License “or any later version” applies to it, you have the option of
following the terms and conditions either of that specified version or of any later version that has been
published (not as a draft) by the Free Software Foundation. If the Document does not specify a version
number of this License, you may choose any version ever published (not as a draft) by the Free Software
Foundation.

Addendum
To use this License in a document you have written, include a copy of the License in the document and
put the following copyright and license notices just after the title page:

Copyright YEAR YOUR NAME.

Permission is granted to copy, distribute and/or modify this document under the terms of
the GNU Free Documentation License, Version 1.1 or any later version published by the
Free Software Foundation; with the Invariant Sections being LIST THEIR TITLES, with
the Front-Cover Texts being LIST, and with the Back-Cover Texts being LIST. A copy
of the license is included in the section entitled “GNU Free Documentation License”.
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If you have no Invariant Sections, write “with no Invariant Sections” instead of saying which ones are
invariant. If you have no Front-Cover Texts, write “no Front-Cover Texts” instead of “Front-Cover Texts
being LIST”; likewise for Back-Cover Texts.

If your document contains nontrivial examples of program code, we recommend releasing these examples
in parallel under your choice of free software license, such as the GNU General Public License [https://
www.gnu.org/copyleft/gpl.html], to permit their use in free software.

263

https://www.gnu.org/copyleft/gpl.html
https://www.gnu.org/copyleft/gpl.html
https://www.gnu.org/copyleft/gpl.html

	GnuCash Manual
	Table of Contents
	About the Authors
	Chapter 1. Introduction to GnuCash
	Chapter 2. Using This Document & Getting Help
	Accessing Help
	GnuCash Tutorial and Concepts Guide
	GnuCash Wiki
	GnuCash Website
	GnuCash On-line Assistance

	Mouse Buttons

	Chapter 3. Getting Started
	The “Welcome to GnuCash!” Screen
	New Account Hierarchy Setup
	Import QIF Files
	The “Tip of The Day” Screen

	Chapter 4. GnuCash Windows & Menus
	GnuCash Main Windows Areas
	Account Tree Display
	Account Tree - Menus
	Account Tree - File Menu
	Account Tree - Edit Menu
	Account Tree - View Menu
	Account Tree - Actions Menu
	Account Tree - Business Menu
	Account Tree - Reports Menu
	Account Tree - Tools Menu
	Account Tree - Windows Menu
	Account Tree - Help Menu

	Account Tree - Toolbar Icons/Buttons
	Tab bar
	Main pane - Account tree
	Summarybar
	Statusbar

	Account Register/General Journal
	Account Register & General Journal Window
	Account Register Menus
	Account Register - File Menu
	Account Register - Edit Menu
	Account Register - View Menu
	Account Register - Transaction Menu
	Account Register - Actions Menu
	Account Register - Busines Menu
	Account Register - Reports Menu
	Account Register - Tools Menu
	Account Register - Windows Menu
	Account Register - Help Menu

	Account Register - Toolbar Icons/Buttons
	Tab Bar
	List of Transactions
	Summarybar
	Statusbar

	Report Window
	Report Display Window
	Report Menus
	Reports - File Menu
	Report - Edit Menu
	Report - View Menu
	Report - Actions Menu
	Report - Business Menu
	Report - Reports Menu
	Report - Tools Menu
	Report - Windows Menu
	Report - Help Menu

	Reports - Toolbar Icons/Buttons
	Tab Bar
	Report Main Display
	Summarybar
	Statusbar

	Reconcile Window
	Reconcile Display Window
	Reconcile - Window

	Reconcile - Menus
	Reconcile - Reconcile menu
	Reconcile - Account Menu
	Reconcile - Transaction Menu
	Reconcile - Help Menu

	Reconcile - Toolbar Icons/Buttons

	Schedule Transaction Window
	Scheduled Transactions Main Display Window
	Scheduled Transaction Main Window Components

	Scheduled Transactions Menu
	Scheduled Transactions - Scheduled Menu

	Scheduled Transactions - Toolbar Icons/Buttons

	Budget Window
	Budget Window Menus
	Budget Window - Edit menu
	Budget Window - Actions menu
	Budget Window - Reports menu

	Budget Window Toolbar, Icons/Buttons
	Budget Window Main Display
	Budget Options

	Business Windows
	Customers Overview
	Vendors Overview
	Employees Overview


	Chapter 5. Setting Up, Editing & Working with Accounts
	Types of GnuCash Accounts
	Creating a Chart of Accounts
	Editing a Chart of Accounts
	Creating a New Account
	General Information Tab
	Steps to enable Online Quotes updating
	Opening Balance tab

	Editing an Account
	Renumbering Subaccounts
	Deleting an Account
	Reconciling an Account to a Statement
	Reconciling Information
	Interest Payment

	Reconcile


	Chapter 6. Common Transaction Operations
	Transfer Funds Dialog Box
	Basic Information
	Transfer Accounts
	Currency Transfer
	Finishing Up

	Enter Transaction via register
	Entering Directly in the Register Window

	Associating an External File with a Transaction.
	Multiple Split Transactions
	Multiple Currency/Commodity Transactions
	Editing a Transaction
	Deleting a Transaction
	Add Reversing Transaction
	Removing Transaction Splits
	Copying a Transaction
	Setting the reconcile status (R field) of a transaction
	Jump to another Account Register
	Scheduling Transactions
	Scheduled Transactions Window

	Edit Scheduled Transaction Window
	Printing Checks
	Importing Transactions from Files
	Import Formats
	Import Preference
	Import QIF
	To import QIF files:

	Import OFX/QFX
	Import CSV
	Import several file formats with AQBanking
	Generic Transaction Import Matcher
	Introduction
	Import Formats
	Controls
	List of Controls
	List of downloaded transactions
	Import Status

	Assign a Destination Account to a Single Transaction
	Assign a Destination Account to Multiple Transactions
	Completing the Import

	Match Picker
	Import Match Editor

	Exporting Transactions
	Choose Export Settings
	Account Selection
	Choose File Name for export
	Export Now...
	Export Summary

	Online Actions ...
	Get Balance
	Get Transactions ...
	Issue Transaction
	Direct Debit

	General Journal

	Chapter 7. Business Features
	Initial Setup
	Account Setup
	Tax Tables
	Company Registration
	Counters
	Business Preferences
	Billing Terms

	Accounts Receivable
	Customers
	New
	Find and Edit

	Invoices
	New
	Edit
	Post
	Find
	Print
	Assign Starting Invoice Number

	Customer Jobs
	Process Invoice Payment
	Over Payments or Pre-Payments
	Partial Payments
	Writing Off a Bad Debt

	Changing the Invoice Appearance
	Accounts Payable
	Vendors
	New
	Find and Edit

	Bills
	New
	Edit
	Post
	Find

	Vendor Jobs
	Process Bill Payment
	Over Payments or Pre-Payments
	Partial Payments

	Employees
	New Employee
	Find and Edit
	New Expense Voucher/Credit Note
	Find Expense Voucher/Credit Note
	Edit


	Chapter 8. Tools & Assistants
	Find
	Find Transaction
	Explanations of the Criteria

	Find Customer, Invoice, Job, Vendor, Bill, Employee, Expense Voucher
	Search Criteria section
	Type of Search section
	The rest of the search dialog
	List of search criteria buttons


	Since Last Run Assistant
	Mortgage & Loan Repayment Assistant
	Recording a Stock Transaction
	Transaction Details Page
	Transaction Type Page
	Stock Amount Page
	Stock Value Page
	Cash Page
	Fees Page
	Dividend Page
	Capital Gains Page
	Finish Page

	The Online Banking Setup Assistant
	Price Editor
	Adding a stock price manually
	Configuring for use of the Get Quotes button

	Security Editor
	Adding or Editing a Commodity
	Configuring Securities/Currencies for On-Line Retrieval of Prices

	Loan Repayment Calculator
	Close Book
	Dialog Box Details
	How It Works
	What It Doesn’t Do
	Necessity
	Conclusion

	Lots in Account
	Lots for Security Capital Gains
	Screen Elements

	Lots for Business Features
	Introduction
	Screen Elements



	Chapter 9. Reports And Charts
	Introduction
	Saving a Report Configuration
	Working with Saved Report Configurations

	Configuring Reports and Charts
	Report Options Buttons
	Common Report Options

	Reports Listed By Class
	General Reports
	Account Summary
	Future Scheduled Transactions Summary
	Transaction Report
	Report Options
	Displaying Split Account Details


	Assets & Liabilities
	Business Reports
	Customer Report
	Customer Summary
	Easy Invoice
	Employee Report
	Fancy Invoice
	Job Report
	Payable Aging
	Report Options

	Printable Invoice
	Receivable Aging
	Report Options

	Tax Invoice
	Vendor Report

	Income & Expense
	Sample & Custom
	Sample Report
	Sample Graphs
	Average Balance
	Expenses vs. Day of Week
	Income vs. Day of Week

	Budget
	Budget Balance Sheet
	Budget Barchart
	Budget Flow
	Budget Income Statement
	Budget Profit & Loss
	Budget Report

	Country Specific Reports
	US: Tax Schedule Report and TXF Export
	DE: Steuer-Bericht und ElStEr Export


	Printing or Exporting Reports and Charts
	Creating or Modifying Reports and Charts
	Accessing the GnuCash Application Programming Interface (API)
	Report Rendering


	Chapter 10. Customizing GnuCash
	Account Display Options
	Setting Preferences
	Accounting Period
	Accounts
	Business
	General
	Import
	Numbers, Date, Time
	Online Banking
	Online Quotes
	Printing
	Register
	Register Defaults
	Reports
	Scheduled Transactions
	Windows

	Book Options
	Accounts Book Options Tab
	Use Trading Accounts
	Day Threshold for Read-Only Transactions
	Use Split Action Field for Number

	Budgeting Book Options Tab
	Business Book Options Tab
	Counters Book Options Tab

	Changing Style Sheets
	Default Style Sheet
	Colors Tab
	Fonts Tab
	General Tab
	Tables Tab

	Easy Style Sheet
	Colors
	Fonts
	General
	Images
	Tables

	Footer Style Sheet
	Colors
	Fonts
	General
	Images
	Tables

	Technicolor Style Sheet
	Colors
	Fonts
	General
	Images
	Tables


	Setting Tax Report Options
	TXF Export - Known Anomalies and Limitations
	Detailed TXF Category Descriptions

	Reset Warnings...
	Changing the Language or Region

	Chapter 11. Setting Up the Quote Retrieval
	Installing Perl
	Installing Finance::Quote
	Using gnucash-cli for Testing and Automation.
	Displaying the Finance::Quote Version and Supported Sources
	Displaying Quotes in a Terminal Window
	Updating Quotes Automatically with gnucash-cli


	Appendix A. GnuCash Tips and tidbits
	Finance::Quote Sources
	Finance::Quote Sources - Currency source
	Quote Sources - Individual sources
	Finance::Quote Sources - Multiple sources

	Yahoo Specifics
	TIAA-CREF Specifics

	Appendix B. GNU Free Documentation License
	0. PREAMBLE
	1. APPLICABILITY AND DEFINITIONS
	2. VERBATIM COPYING
	3. COPYING IN QUANTITY
	4. MODIFICATIONS
	5. COMBINING DOCUMENTS
	6. COLLECTIONS OF DOCUMENTS
	7. AGGREGATION WITH INDEPENDENT WORKS
	8. TRANSLATION
	9. TERMINATION
	10. FUTURE REVISIONS OF THIS LICENSE
	Addendum


